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Introduction

INTRODUCTION
HOW TO USE THIS MANUAL
Like any other manual, this manual is not intended to be read through from the first to the last
page; however, we hope that its internal logic may make you want to do just that.
Following this introduction, you can find these three chapters:


"What Is New in Déjà Vu X2 Professional?" on page 19—an overview of some of the
most outstanding new features of Déjà Vu X2 Professional.



"The Déjà Vu X2 Professional Interface" on page 21—an introduction to Déjà Vu X2
Professional’s user interface.

"Workflow" on page 77—a suggested workflow model for translation with Déjà Vu X2
Professional. The workflow chapter is followed by chapters that detail some of the features
discussed in the workflow chapter:


"Translation Features in Déjà Vu X2 Professional—The Details" on page 135



"Editing Features in Déjà Vu X2 Professional—The Details" on page 235



"Review Features in Déjà Vu X2 Professional—The Details" on page 249



"Teamwork Features in Déjà Vu X2 Professional—The Details" on page 257



"Security Features in Déjà Vu X2 Professional—The Details" on page 273



"Analysis Features in Déjà Vu X2 Professional—The Details" on page 277

Next comes a chapter dealing with how to work with different file formats, and one that
specifically discusses working with SGML/XML files:


"Working with Different File Formats" on page 289



"Creating and Maintaining SGML/XML Filter Files" on page 355

The next three chapters are concerned with the creation and maintenance of Déjà Vu X2
Professional’s databases:


"The Lexicon" on page 377



"Creating and Maintaining Translation Memories" on page 395



"Creating and Maintaining Termbases" on page 449
Déjà Vu X2
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Some of the more complex technical aspects for the very advanced user are discussed in the last
chapter


"Digging In—Advanced Topics" on page 505

The Appendix contains an overview, a listing of the menu commands, and a glossary.
Finally, there is a very comprehensive index at the end of the manual that is meant to be a
substantial aid in finding relevant topics. We encourage you to use it extensively.

WHERE DO I START?
Where you’ll start depends on who you are, what your goals for Déjà Vu X2 Professional are, and
how experienced you are with translation memory tools in general and Déjà Vu in particular.

THE BEGINNER—WHEN YOU’RE STARTING FROM SCRATCH
If you’re a new user who has never worked with computer-assisted translation tools (commonly
abbreviated as CAT tools), it would probably be a good idea to start with the Getting Started Guide
that came with your software (or you can find it in the installation directory in PDF format). Going
through the tutorial will give you a good place to start.
If you stumble on terms that you are not familiar with, turn to the "Glossary" on page 562.
When you feel familiar with the basic concepts, you can continue by looking at "Workflow" on
page 77 in this manual. There you can see which steps you may not be familiar with and read
about the relevant features in the details sections on pages p. 135-p. 289. To find specific topics in
these chapters, it may be a good idea to use the index at the end of this manual.
"Working with Different File Formats" on page 289 will familiarize you with the specific types of
files that you will be working with.
When you are comfortable with the general concepts of how to translate in Déjà Vu X2
Professional, you should then look into optimizing your databases in the database section, ranging
from pages p. 377-p. 505. Again, the index will help you to navigate through these sections.
Please be aware that there is no need to learn everything about this program. Imagine
Déjà Vu X2 Professional as a big tool box from which you can choose the tools that
make sense for your specific needs. Do not overload yourself with information that you
will not need later on.

If you are interested in more advanced features, refer to the section for the power user on page p.
12.

Déjà Vu X2
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THE CONVERT—WHEN YOU’RE NEW TO DÉJÀ VU X2 BUT FAMILIAR WITH
OTHER CAT TOOLS
First of all: we’re glad to have you reading this, and we feel confident that you’ll like what you see.
One thing you should be aware of is that Déjà Vu X2 Professional does things a little differently
from other tools, so you may need to try to free your mind as much as you can from what you
know about how other translation memory tools work.
The "Glossary" on page 562 should be helpful for you to familiarize yourself with how Déjà Vu X2
Professional refers to concepts that the creators of other tools named differently (or didn’t know
about!).
From there we would suggest the following learning path: Start with the Getting Started Guide that
came with your software (or you can find it in the installation directory in PDF format) and work
your way through the tutorial. This will give you a good idea of how Déjà Vu X2 Professional
works and how it’s unique.
When you feel confident with the basic concepts that you have learned, you can continue by
looking at "Workflow" on page 77 in this manual, see which steps you may not be familiar with,
and read more about them in the details sections on pages p. 135-p. 289. To find specific topics in
these chapters, it may be a good idea to use the index at the end of this manual.
More about the specific kinds of files you will be translating can be found in the corresponding
sections of "Working with Different File Formats" on page 289.
When you are comfortable with the general concepts of how to translate in Déjà Vu X2
Professional, you should then look into optimizing your databases in the database section, ranging
from pages p. 377-p. 505. Again, the index will help you to navigate through these sections. The
first of these chapters, "The Lexicon" on page 377, should be of particular interest because this is a
concept that is unique to Déjà Vu X2 Professional.
Please be aware that there is no need to learn everything about this program. Imagine
Déjà Vu X2 Professional as a big tool box from which you can choose the tools that
make sense for your specific needs. Do not overload yourself with information that you
will not need later on.

If you are interested in more advanced features, refer to the section for the power user on page p.
12.

THE UPGRADER—WHEN YOU’RE FAMILIAR WITH DÉJÀ VU X
Your first questions will probably be: What’s new and what’s different? The short answer: Quite a
bit. But we do have a special section just for you: "What Is New in Déjà Vu X2 Professional?" on
page 19.
Déjà Vu X2
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After reading this section, you will probably want to look up individual chapters on topics that
you’re not yet familiar with. You will find that the index in this manual is more extensive than
earlier manuals to give you a quick reference point on where to look.
If you are interested in more advanced features, refer to the section for the power user on page p.
12.

THE POWER USER—WHEN YOU WANT TO MAXIMIZE THE SOFTWARE’S POTENTIAL AND YOU’RE NOT AFRAID OF THE HAIRY STUFF
If you’re familiar with some of the advanced features of Déjà Vu 3, you know that there is hardly
anything you cannot do with Déjà Vu. Well, the best has gotten better.
After you have familiarized yourself with how the new Déjà Vu X2 Professional works and how it
differs from earlier versions, you can find some meaty stuff in the section "Digging In—Advanced
Topics" on page 505. Topics include customizing the HTML filter, working with SQL, or refining the
export filter.
Good luck!

Déjà Vu X2
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THE DIFFERENT VERSIONS OF DÉJÀ VU X2
Features

DVX2
Standard

DVX2
Professional

DVX2
Workgroup

X
X
√
√
√

√
√
√
√
√

√
√
√
√
√

1

5

unlimited

1
√

5
√

unlimited

X
X
√

√
√
√

√
√
√

X
√
√
X
√
√

√
√
√
√
√
√

√
√
√
√
√
√

√

√

√

X
X
X

√
X
X

√
√
√

X

√

√

√
X

√
√

√
√

Translation
AutoAssemble
AutoPropagate
AutoCheck
AutoSend
AutoSearch
Maximum TM(s) per language in
one project
Maximum TB(s) per language in
one project
Pretranslate
Pretranslate with Term checks
(Quality Assurance)
Pseudotranslation
Scan in TM and Lookup in TB
DeepMiner
Assemble
Propagate
Guaranteed Matches
Add to TM/TB
Send Lexicon to TM/TB
Translate Lexicon entries with
TM/TB
Translate Lexicon using
DeepMiner
Connect to TeaM Server
Use COM+ TM and TB
Connection to Machine
Translation (Google Translate)

√

Quality Assurance (QA)
TermCheck
TermCheck: with Numerals
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Features

DVX2
Standard

DVX2
Professional

DVX2
Workgroup

Number Check
Batch Term Check and QA
Check

X

√

√

X

√

√

Store SQL: for QA and batch QA

X

√
√

√

External View: export into RTF
for proofreading

X

(only if rows are non
empty or include a
comment)

√

√
√
√
√

√
√
√
√

√
√
√
√

X
X

√
√

√
√

√
√
√
√
√
X
X
X

√
√
√
√
√
X
√
X

√
√
√
√
√
√
√
√

X
X
X
X

X
X
X
X

√
√
√
√

X
√
√

X
√
√

√
√
√

Editing
AutoCorrect
AutoText
Join and Split Segments
Row Selector
Store SQL: for row selector
AutoWrite

Project Management
Project Creation
Project Explorer
Project Properties
Import Files into Project
Export Files from Project
Export Files from Satellite
Import External View
Export External View
External View: export to Trados
WB/HTML/RTF (for translation)
External View: export to XLIFF
Import and Export Satellite
Export TM/TB Subset
Security: configure in Project/
TM/TB
Security: use in Project/TM/TB
Word Count
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Features
Word Count: with separate
counts per file
Analysis
Analysis: with separate counts
per file
Import and Export Lexicon
Advanced Project Explorer

DVX2
Standard

DVX2
Professional

DVX2
Workgroup

X
√

√
√

√
√

X
√
X

√
√
√

√
√
√

X
X

√
X

√
√

√

√

√

√

√

√

X

√

√

√
X
X
√

√
√
√
√

√
√
√
√

√
X
√
√
√
√
√
X
√
√
X

√
√
√
√
√
√
√
√
√
√
√

√
√
√
√
√
√
√
√
√
√
√

Filters
EBU filter
ODBC Filter
Office, Office 2007, HTML (+
ASP, PHP, JSP)
TagEditor, Trados Workbench,
SDL XLIFF, ITD
All other filters (XML, InDesign,
FrameMaker MIF, etc.)

Other
Alignment
Select SQL (TM + TB)
Execute SQL
Convert TM/TB
Compact Project/TM/TB/
Alignment Project
Compact Filter
Repair Project/TM/TB
Open Translation Project
Open Satellite
Open Pack&Go
Open TM/TB
Open Filter
Open Alignment Project
Create TM/TB
Create Filter
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Features
Create Multi-file and multiformat alignment project
Create Project Templates

DVX2
Standard

DVX2
Professional

DVX2
Workgroup

X
X

√
√

√
√

CONVENTIONS USED IN THIS MANUAL
USER INTERFACE CONTROLS
All user interface controls, such as buttons, menus, tabs, or dialogs, are bolded.

MENU COMMANDS
Menu commands, such as Tools> Options> Font, are identified by the greater-than sign.

PATH NAMES AND SAMPLE TEXT
All path names and user-entered sample text are in Courier New.

TIPS
Tips contain useful additional information on maximizing a specific feature. They are
delineated by the light bulb symbol.

NOTES
Notes contain important information that you need to be aware of. They are delineated
by the thumbtack symbol.

SCREENSHOTS
The screenshots that are used in this documentation may not necessarily reflect the actual
appearance in the version of Déjà Vu X2 Professional that you are using.

Déjà Vu X2
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RELATED DOCUMENTATION
README
Please consult the Readme file after the installation of Déjà Vu X2 Professional for the latest
information on the product and any possible issues with the program along with their workarounds.

WEBSITE
On www.atril.com you can find information about training seminars, user support, new versions of
the product, and freely downloadable updates.

USER GROUPS
The Déjà Vu user group at http://groups.yahoo.com/group/dejavu-l is a highly supportive and
caring communities of worldwide Déjà Vu users. You are strongly encouraged to join this group.

Déjà Vu X2
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What Is New in Déjà Vu X2 Professional?

WHAT IS NEW IN DÉJÀ VU X2 PROFESSIONAL?
THE LOOK AND FEEL
Déjà Vu X2 provides a fresh, intuitive, and more functional overhaul of the interface users know
and love, with updated icons, new connections between the different panes and windows,
organized in an easier-to-use tabbed interface, a choice between different color schemes, newly
organized shortcut menus, an overhauled Project Explorer (formerly File Navigator), and updated
industry-standard terminology.

AUTOWRITE
Déjà Vu X2 offers a completely new feature that suggests content from your databases as you
type. The suggestions will be displayed right underneath your cursor. You only have to press the
Enter button to accept (only in Déjà Vu X2 Professional and Workgroup).

DEEPMINER
Déjà Vu X2’s unique DeepMiner analyzes the attached databases and comes up with subsegment matches to give you every last bit of information from the databases and allow you to
enhance Déjà Vu X’s fuzzy match repair (only in Déjà Vu X2 Professional and Workgroup).

MULTI-FILE, MULTI-FORMAT ALIGNMENT
You can now align as many files from as many formats as are supported by Déjà Vu X2 in one go
(only in Déjà Vu X2 Professional and Workgroup).

NEW EXTERNAL VIEW FORMATS
You can now output External View formats in XLIFF, the most common translation file exchange
format, so your translators or you can continue to work with third-party tools (only in Déjà Vu X2
Workgroup).

NEW QUALITY ASSURANCE FEATURES
You can now check for missing or additional spaces, filter all of your quality checks down to
segments with a pre-defined status and do all QA checks in one batch operation (batch features
only in Déjà Vu X2 Professional and Workgroup).

NEW MACHINE TRANSLATION FEATURE
The newly added machine translation feature, currently offered through Google Translate,
alternatively translates complete segments, fills in unknown terms in the assemble process, or
repairs fuzzy matches. (Only in Déjà Vu X2 Professional and Workgroup).

Déjà Vu X2
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FEATURE TO STORE AND REUSE SQL COMMANDS
Any SQL command for any of the components of Déjà Vu X2 can be stored and used at a later
point for the current database or project (only in Déjà Vu X2 Professional and Workgroup).

PROJECT TEMPLATES
Rather than recreating all the settings for a new project from scratch, including defining termbases,
translation memories, clients, subjects, and language combinations, you can now apply a
previously stored template with all those settings with one click (only in Déjà Vu X2 Professional
and Workgroup).

NEWLY SUPPORTED FILE TYPES
Déjà Vu X Professional had already set the bar high with its large number of supported file types;
now we’re supporting even more, including RESX files (with a very sophisticated heuristic model to
evaluate text for its translatability), Office 2007/2010, InDesign IDML, and XLIFF.

NEW ANALYSIS FEATURES
The analysis feature has been overhauled to allow the inclusion of other projects into the analysis
to find the amount of repetition between your current project and others (only in Déjà Vu X2
Professional and Workgroup).
Analysis and Word Count now also allow you to switch between the way that MS Word and Déjà
Vu X2 interpret words.

Déjà Vu X2
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THE DÉJÀ VU X2 PROFESSIONAL INTERFACE
Unlike its previous versions, Déjà Vu X2 Professional has only one interface from which you
create, open, and edit all necessary files. The seven Déjà Vu internal file types are:


Déjà Vu Project Files (.dvprj)—the files in which you import the files that need to be
translatDéjà Vued, translate them, and from which you export them into their original
formats. This file can contain only one source language but several target languages.



Déjà Vu Satellites Files (.dvsat)—the protected files which contain only one source and
one target language plus all the information needed by the translator. These files can be
exported from the main project and re-imported after translation.



Pack & Go Packages (.dvpng)—highly compressed exports from project files that are
ideal for the transmission of Déjà Vu X2 Professional data. Like the satellite files, Pack &
Go packages can be exported from the main project and re-imported after translation.



Déjà Vu Translation Memories (.dvmdb)—the files that store all previously translated
segments (sentences, headings, cell content, bullet points, etc.) in source and target. This
file is completely multilingual, i.e., it can have several target languages. You will notice
that in the folder where the .dvmdb is created, other files are also created—one with the
extension .<language>.dvmdi for each language used and one with the extension
.dvmdx. These files contain the index and language-specific material. You may not delete
or rename them.



Alignment Files (.dvapr)—intermediary database files in which data from already
translated files is paired up. Once the alignment is completed, this file is fed into a
translation memory.



Déjà Vu Termbases (.dvtdb)—the files that contain pairs of terms or short expressions
(source and target) which you have added. Each pair is associated by additional
information that is freely configurable. Like the translation memories, the termbase is
completely multilingual, i.e., it can have several target languages.



SGML/XML Filters (.dvflt)—files that you will only need and use when you translate files
that follow the SGML definition. There are many subgroups of SGML, one of which is
XML, a widely used standard for data exchange and storage. Because each SGML file or
group of SGML files is unique, you will have to create a unique filter for them. You can
do that by having Déjà Vu either analyze the SGML files or read the DTD file, an
associated file that contains all the relevant information.

You will notice that the toolbars and the menu bar change according to what kind of file you open.
All of the toolbars are completely reconfigurable, so you can set them according to the tasks that
you most often perform.

Déjà Vu X2
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THE PROJECT INTERFACE
Let’s first have a look at the default Déjà Vu X2 Professional’s appearance with an open project
file.

To switch the user interface language of Déjà Vu X2 Professional
1

Select Tools> User Interface Language.

2

The Select User Interface Language dialog appears, displaying the language that you selected
when you first started Déjà Vu X2 Professional.

3

If you want to switch that language, click on the dropdown arrow and select the language of
your choice. The available languages are:


English
Déjà Vu X2
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Dutch



German



French



Russian



Spanish



Italian

THE MENU BAR
As in most Windows applications, almost all of Déjà Vu X2 Professional’s functions are accessible
through the menu bar.

THE FILE MENU
The commands in the File menu are the standard Windows options for creating, opening, and
closing a file as well as several import and export options.
You can find a complete list of File menu commands as well as the available keyboard shortcuts
and toolbar icons in the Appendix under "The Menu Commands and Toolbar Icons" on page 547.

THE EDIT MENU
The commands in the Edit menu include the standard Windows options for copying, cutting,
pasting, searching, replacing, and selecting text, as well as for changing the case of selected text
and joining and splitting segments.
You can find a complete list of Edit menu commands as well as the available keyboard shortcuts
and toolbar icons in the Appendix under "The Menu Commands and Toolbar Icons" on page 547.

THE INSERT MENU
The Insert menu includes AutoText- and AutoCorrect-specific commands and commands to
populate (copy) text from source to target and to insert text from the databases.
You can find a complete list of Insert menu commands as well as the available keyboard shortcuts
in the Appendix under "The Menu Commands and Toolbar Icons" on page 547.

Déjà Vu X2
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THE VIEW MENU
The View menu lets you toggle the sorting order of your project and switch between the Advanced
Project Explorer and the Advanced Advanced Project Explorer.
You can find a complete list of View menu commands as well as the available toolbar icons in the
Appendix under "The Menu Commands and Toolbar Icons" on page 547.

THE TRANSLATION MENU
The Translation menu consists of commands to search and add to the databases, propagate
translations, and perform consistency checks between the source and target.
You can find a complete list of Translation menu commands as well as the available keyboard
shortcuts and toolbar icons in the Appendix under "The Menu Commands and Toolbar Icons" on
page 547.

THE QA MENU
The QA (quality assurance) menu commands give you access to the various quality assurance
check features that Déjà Vu X2 Professional offers. You can detect and/or unmark duplicates in
source and/or target segments and manage your quality assurance warnings.
You can find a complete list of QA menu commands as well as the available keyboard shortcuts
and toolbar icons in the Appendix under "The Menu Commands and Toolbar Icons" on page 547.

THE PROJECT MENU
The Project menu commands give you access to the Project Properties dialog, they allow you to
add the complete project to the translation memory, and provide access to SQL commands.
You can find a complete list of Project menu commands as well as the available keyboard shortcuts
and toolbar icons in the Appendix under "The Menu Commands and Toolbar Icons" on page 547.

THE LEXICON MENU
The commands in the Lexicon menu give you access to generate and maintain a lexicon.
You can find a complete list of Lexicon menu commands in the Appendix under "The Menu
Commands and Toolbar Icons" on page 547.

THE USERS MENU
In the Users menu, you can find commands to log in into your project and to log out of your
project.
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You can find a complete list of Users menu commands in the Appendix under "The Menu
Commands and Toolbar Icons" on page 547.

THE TOOLS MENU
In the Tools menu, you can find commands to access the spell checker, the word count and
analysis modules, different languages for the user interface, the Windows Character Map, the
Déjà Vu X2 Professional Options dialog, commands to convert databases from earlier versions of
Déjà Vu, to customize the look of Déjà Vu X2 Professional, and to repair or compact the project.
You can find a complete list of Tools menu commands as well as the available keyboard shortcuts
and toolbar icons in the Appendix under "The Menu Commands and Toolbar Icons" on page 547.

THE WINDOW MENU
The Window menu consists of the standard Windows commands that allow you to re-configure
the way in which Déjà Vu X2 Professional’s windows are displayed and to rearrange the icons.
You can find a complete list of Window menu commands as well as the available keyboard
shortcuts and toolbar icons in the Appendix under "The Menu Commands and Toolbar Icons" on
page 547.

THE HELP MENU
The commands in the Help menu give you access to the Help system, to product registration
options and information about the current version of Déjà Vu X2 Professional.
You can find a complete list of Help menu commands as well as the available keyboard shortcuts
and toolbar icons in the Appendix under "The Menu Commands and Toolbar Icons" on page 547.

KEYBOARD SHORTCUTS
It is a good practice to learn the keyboard shortcuts for the Déjà Vu X2 Professional functions you
use most often, since this will let you work faster and more efficiently. You will find the default
keyboard shortcut for each function (if there is one) beside the function’s name on the menu. An
additional expanded list can be found under "The Keyboard Shortcuts" on page 558.
However, all keyboard shortcuts can be customized to fit your particular preferences.
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To customize the keyboard shortcuts
To customize the keyboard shortcuts, select Tools> Customize and select the Keyboard tab in the
Customize dialog.

Select the relevant category and then the command. In the edit box under Press New Shortcut
Key, you can edit existing shortcuts or add shortcuts to commands that do not have an assigned
shortcut.
1

Position your cursor in the edit field and press the new key combination.

2

Click Assign and Close.
By clicking on Reset All, you can reset the keyboard shortcut values to the original
values.

THE TOOLBAR
The toolbar gives you access to the most often-used commands for each file type.
Here is an example of the Standard and the Project toolbar. (For an explanation of the buttons, see
"The Menu Commands and Toolbar Icons" on page 547.)
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Just like the shortcut keys, the toolbar is completely configurable as well.

To customize the toolbars
To customize the toolbars, select Tools> Customize and select the desired toolbars in the Toolbars
tab of the Customize dialog.

You can also create new toolbars by clicking on the New button.
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To customize existing toolbars
To customize existing toolbars, select Tools> Customize> Commands and drag the desired
commands out of or into the existing toolbars.

The final tab of the Customize dialog offers you several more options to customize your view of
the menus, toolbars, and other features.
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To customize currently displayed toolbars
You can customize currently displayed toolbars by the options described under "To customize
existing toolbars" on page 28, or you can click on the down arrow at the end of these toolbars.
This will open a menu with all default buttons.
You can select or deselect each one of them and activate your selection by clicking Reset Toolbar.
–Or–
You can select Customize to access the Customize dialog.

THE TRANSLATION GRID
The main module of Déjà Vu X2 Professional’s translation interface is the translation grid, the
interface in which you actually perform any translation activity.
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Translation activities are by default performed directly within the grid, which resizes itself
automatically to accommodate differing lengths of segments.

To help you find your current position within the open file or project, the current
segment is marked with a little blue arrow ( ) to the left of the source segment and is
surrounded with emphasized segment borders.
The colors of the translation grid lines can be changed to any color you prefer. For more
information on changing colors, see "To change the colors of the indicator bars" on page 42.

EDIT AND SELECTION MODES
There are two different modes in a Déjà Vu X2 Professional project: the edit and the selection
mode. The edit mode is the default mode that you work in as you translate and edit segments. In
that mode you can select text in the source and/or target of the current segment, but you cannot
select (highlight) the complete segment. To do that you will have to switch into the selection mode.

To switch into the selection mode
1

Make sure your cursor is in a specific segment.

2

Press the Esc or the Enter key.

3

You can see that the complete segment is now highlighted.
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To switch back into the edit mode
1

Press the Enter key or double-click the source or target segment.

2

You can see that the segment is not highlighted anymore.

TRANSLATING IN A SEPARATE TEXT AREA
Some translators prefer to work in a vertical manner, i.e., with source and target positioned on top
of each other. You can do that by selecting Tools> Options> Environment> Edit in separate text
area> Split text area vertically.
Other benefits of this display mode include a more obvious highlighting of the currently selected
segment and the fact that you never have to scroll to find the currently selected segment.

If you choose to work in this manner, the actual grid will automatically switch into
selection mode so that you cannot edit directly within the cells.
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THE PROJECT EXPLORER
The Project Explorer is presented in a small pane on the right of your screen. It displays all the files
and the lexicon in your project so you can easily switch from one file to the next. This is especially
helpful because in Déjà Vu X2 Professional projects you can import and process any file of any
file type that is supported by Déjà Vu X2 Professional from anywhere on your local machine or
network.
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THE AUTOSEARCH WINDOW
Below the Project Explorer, the AutoSearch window displays the relevant matches from the
translation memories, the termbases, and the lexicon. Each record is associated with a number,
which in combination with the Ctrl key copies the respective term to the target window. A color
signifies the origin of the term (by default: red=translation memory, blue=termbase,
white=lexicon).
As with all other colors, these colors can be changed under Tools> Options> Display.

At the bottom of the window, you can see related information, such as client, subject, date/time
stamp, and database origin of the selected term displayed.
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If you select an entry from a translation memory, you will see additional rows in which the
differences between the record in the translation memory and the original source segment are
highlighted.
You can find information on each of the cells in these additional rows under "Scanning
the Translation Memories" on page 140. The cells in the Scan Results window described
in that section have the same structure as the ones in the AutoSearch window.

To minimize the amount of mouse work, you can use the keyboard to navigate through the
AutoSearch window and to paste a selected portion into the target text box.

To navigate through the AutoSearch window
Press Ctrl+Shift+UpArrow to move to the previous portion.
–Or–
Press Ctrl+Shift+DownArrow to move to the next portion.

SPLITTING THE AUTOSEARCH WINDOW
By default, the AutoSearch window contains relevant matches from the translation memories, the
termbases, and the lexicon. Depending on the length of the source segments, the extent of your
databases and your personal preferences, you can split the AutoSearch window into an
AutoSearch - Portions and an AutoSearch - Segments window.

Déjà Vu X2

34

The Déjà Vu X2 Professional Interface

To split the AutoSearch window
1

Select Tools> Options> Environment> Show segments and portions in separate windows.

2

The former AutoSearch window has now become the AutoSearch - Portions window which
will only display matches from the termbase and the lexicon. If selected under Tools>
Options> Environment> Display portions from Translation Memory, portions from the
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translation memory and the new AutoSearch - Segments window with exact and fuzzy
matches from the translation memory is displayed at the bottom of the screen.
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To hide the column headers
To maximize some of the room for the displays in the AutoSearch windows, you can now
select Tools> Options> Environment> Hide column headers, to hide the column headers.

To navigate through the split AutoSearch windows
AutoSearch - Portions:
Press Ctrl+Shift+UpArrow to move to the previous portion.
–Or–
Press Ctrl+Shift+DownArrow to move to the next portion.
AutoSearch - Segments:
Press Alt+Shift+UpArrow to move to the previous segment.
–Or–
Press Alt+Shift+DownArrow to move to the next segment.

To access the AutoSearch context options
1

Right-click on any entry in the AutoSearch window.
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2

The context menu appears.

3

You are presented with the following options:


Edit—switches the selected segment in to the edit mode so that text becomes
editable.



Delete—deletes the current segment from the lexicon, termbase, or translation
memory.



Add Source/Target to Spelling Dictionary—adds the source or target segment of the
selected segment to the custom dictionary in the appropriate language so that the
spelling of this word will not be found as incorrect.



Refresh—refreshes the view of the AutoSearch window.

THE SELECTOR SEGMENT
Above the source and the target cells, you will find a segment with three boxes: text locator, rows
selector, and target language selector.

From left to right, you will find:


Text/Record Locator



Segment Selector



Language Selector

THE TEXT/RECORD LOCATOR
If your sort order is the default "natural" order—the order in which the segments appear in the
source document—you can use this segment to enter the number of the record project line you
would like to jump to.
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If your sort order is "alphabetical"—the alphabetical order of the segments in the source
document—you can type the first few letters of the first word of the line you want to jump to.

Generally you will want to translate in the natural order because it allows you to see
how each particular segment fits into the flow of the document.

To switch between natural and alphabetic order
1

To sort alphabetically, click the

button on the toolbar.

–Or–
To reset to the natural sort, click the

button on the toolbar.

When you switch from one mode to the other, Déjà Vu X2 Professional will keep the
same current record.

Déjà Vu X2

39

40

THE SEGMENT SELECTOR
You can choose to filter and display only certain kinds of rows, e.g., exact matches, fuzzy matches,
pending rows, etc. You can see that each status is associated with a colored status indicator bar
that matches the color indicator in the translated cells.
The available status filters are:


All Empty Segments



All Empty Except Locked Segments



All Segments



All Unpainted Segments (default grey indicator bar)



Multiple Exact Match Segments (indicator: blue, underlined font)



Exact Match Segments (default dark green indicator bar)



Guaranteed Exact Match Segments (default orange indicator bar)



Fuzzy Match Segments (default light green indicator bar)
Usually, fuzzy matches are not displayed with a solid light green bar, but with a split
green/grey bar that indicates the percentage of fuzziness.



Assembled Segments (default dark blue indicator bar)



Machine Translated Segments (default brown indicator bar)



Fuzzy Propagated Segments (default gold indicator bar)



Exact Propagated Segments (default light blue indicator bar)



Finished Segments (indicator symbol:



Locked Segments (indicator symbol: golden lock
for a guaranteed match lock)



Segments with Comments (indicator symbol: blue
inconsistent terminology: violet

)
for manual lock and ribbon

or, if combined with marker for

)
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Segments with Comments in Source (indicator symbol: blue

)



Segments with Comments in Target (indicator symbol: blue

or, if combined with

marker for inconsistent terminology: violet


)

Segments with Inconsistent Terminology (indicator symbol: red
comments: violet

or, if combined with

)



Wrong Codes Segments (indicator symbol:

)



Duplicate Segments (default indicator: grey vertical bar to the left of source)
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SQL Statement (opens the Select SQL dialog. For more information, see "To use the SQL
Statement view" on page 46.)

This dropdown box also provides an instant overview of the meaning of each of the
colors displayed in the status indicator bar in each segment.
Another helpful way of instantly reviewing the status of a certain segment is to place
your mouse cursor over the indicator bar section. A tooltip-like window will appear in which you
can review the status information of the current segment, the user who last modified it, the date
and timestamp of the last modification, as well as various other bits of information.

To change the colors of the indicator bars
1

Select Tools> Option> Display.

2

The Display tab in the Options dialog is displayed.
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3

Select the status segment whose indicator color you want to change.

4

Click the selector button (

) that appears to the right of the segment.
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5

The Color dialog appears.

6

Select the desired color and click OK.
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7

The selected segment is now displayed with the new color setting.

8

Click Apply and/or OK.

To remove the segment status indicators
To reset the segment status to the unpainted segment status, you can right-click the segment
in question and select Segment Status> Reset Segment Status.
–Or–
Press Ctrl+Shift+U.
This will remove all status indicators with the exception of Wrong Codes, Comments,
and Terminology Mismatch.
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To use the SQL Statement view
The idea of the SQL Statement view is to give you complete flexibility as to what subset of rows in
your project you would like to view.
1

Select SQL Statement from the Segment Selector dropdown list.

2

The Select SQL dialog appears.

3

If you are familiar enough with SQL and the database structure of Déjà Vu X2 Professional,
you can directly enter an SQL expression starting after the WHERE clause.
–Or–
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You can select Build Expression to open the Build Status Expression dialog.

4

In this dialog you can check (include) or uncheck (exclude) certain status criteria. The
Translation Status criteria are mutually exclusive and so are the criteria under Progress Status
(i.e., they have an OR relationship), but the criteria from the two different groups are
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combinable. For instance, if you want to view all rows that are empty or assembled and not
locked, you make the following selection:

5

Upon clicking OK, you will see the following expression entered into the Select SQL dialog:
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6

If you want to save this statement for later use, enter a name into the name field:

7

Press the Save button that is now enabled.
From now on you can access this saved filter in one of two ways:
As an additional option in the Segment Selector:

- Or -
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As one of the options under QA> Next Segment in SQL Filter if you want to jump to one of
those segments without filtering the project.

8

Selecting Apply will now display all rows that are either empty or assembled but not locked.
If you prefer to change this expression, you can easily modify it manually.

THE LANGUAGE SELECTOR
You can use the language selector to switch between the different target languages that you may
have in your project.

THE STATUS BAR
This is Déjà Vu X2 Professional’s status bar explained from left to right:
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six little shortcut buttons—
—which can be clicked to activate and
deactivate AutoWrite, AutoAssemble, AutoSearch, AutoPropagate, AutoSend, and
AutoCheck (in that order).



information about the position in the project and in the current segment. The numbers
in the screenshot above have the following significance:


there are 21 characters in the source segment (21),



the cursor is at position 23 of 28 in the target (23/28), and



the current record position is 2 of 5 (2/5) in the currently selected file.
Some of this information can be especially helpful when translating files in which the
target text is not supposed to be longer than the source.



to the right of the position information, the Current user will be displayed. The displayed
user name will be the user name that is selected in the security settings (see "Security
Features in Déjà Vu X2 Professional—The Details" on page 273) or—if the security
settings are not enabled—the default Windows logon name will be displayed.
Every entry into the databases will also be associated with the current user name.



the user under Last modified by is the user who has previously worked on this particular
segment (if applicable).



the date and time setting to the very right of the status bar refers to the date and time this
particular segment had been worked on before (if applicable).
If you are viewing the whole project instead of a single file (see "Selecting the Complete
Project" on page 59), you can also see the file name you are currently working on to the
very left of the lower status bar.

REARRANGING THE WINDOWS
Déjà Vu X2 Professional’s integrated development environment (IDE) has two types of windows,
tool windows and document windows.
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The tool windows—which include the Project Explorer, the AutoSearch window(s), the Properties
window, or any of the toolbars—are freely dockable. This means that you can place them
anywhere outside the main window on your desktop and use the standard docking features (see
"Docking the Tool Windows" on page 52).
The document windows have to stay within the main window. They can be minimized within the
main window and are subject to the commands in the Window menu (see "Window Menu" on
page 555).
This allows you to arrange the windows so they fit your particular work environment.

With this feature you can even work on more than one monitor.

DOCKING THE TOOL WINDOWS
Dockable windows are windows that align themselves with the edge of another interface element,
usually a window or a pane.
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To dock a tool window
1

Click the window title bar and keep the mouse button pressed.

2

Drag the selected window to another location in the main window.

3

Once you start dragging the window, you’ll be able to see placement indicators on which you
can place the window for the desired location.

If you want to move a window without the aid of the placement indicators, press the
Ctrl key while you drag the window.
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To arrange tool windows within the main window
1

If you choose to have your tool windows within your main window, you can stack them in a
tabbed interface.

2

You can bring underlying windows to the front by clicking the tabs at the bottom.
–Or–
You can close individual windows by clicking the

button on the title bar.
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MANAGING OPTION CATALOGS
In a number of dialogs within Déjà Vu X2 Professional, long lists of options go beyond the
dimensions of the dialog windows.
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You can scroll through these lists with the help of the scrollbar or the wheel mouse, or you can
minimize the option headings by double-clicking on them.

SETTING THE FONT
The default font setting that Déjà Vu X2 Professional comes with is Tahoma 10. You can change
both font and size information.
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To change the font setting
1

Click the Display tab to display the corresponding page.

2

Click the Language drop-down arrow and select a language.

3

Click the Window Type drop-down arrow and select a window type.
This option allows you to define different fonts or font sizes to the main project,
translation memory, or termbase view (the primary windows) and the AutoSearch,
lookup, or scan windows (the secondary windows).

4

Click Change.
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The Font dialog appears.

5

Select the font, style, and size you want Déjà Vu X2 Professional to use when displaying text
in this language.
You should be able to see the new font in the Sample area of the Font dialog.

6

Click OK to accept the font settings.
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MOVING AROUND
There are several ways to move around within Déjà Vu X2 Professional.

SELECTING INDIVIDUAL TRANSLATION FILES
You can select any of the imported files or the lexicon by double-clicking on the file name in the
Project Explorer or the Advanced Advanced Project Explorer. The file will be opened in the main
area of the Déjà Vu X2 Professional interface.

SELECTING THE COMPLETE PROJECT
One of the great strengths of Déjà Vu X2 Professional is batch processing. While it allows you to
work in individual files, it also allows you to view the complete project and work in it as if it were
one file. We call this the All Files view.
To view all files, double-click the name of the project in the Project Explorer pane.

As soon as you switch to the All Files view, the name of the file you are currently working on
appears in the status bar.
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SELECTING OPEN TRANSLATION FILES, PROJECTS, AND DATABASES
You can select already-opened files by clicking on the respective link right under the toolbars.

JUMPING TO A SPECIFIC RECORD IN THE PROJECT
You can enter the record number or the first few letters of the first word of the record you want to
jump to in the Text/Record Locator. For more information, see "The Text/Record Locator" on page
38.

SWITCHING LINES WITHIN A TRANSLATION FILE OR PROJECT
As you translate, there are a number of keystrokes that you may want to use to go from one
segment to the next:


Ctrl+DownArrow to go to the next segment.


If AutoSend is enabled, the segment pair is sent to the translation memory.



If AutoAssemble is enabled, Déjà Vu X2 Professional assembles a translation for the
next segment.



If AutoPropagate is enabled, the translation is propagated to segments with identical
source text.



If AutoCheck is enabled, the terms in the translated segments are automatically
verified against the lexicon, termbase, and/or translation memory.
Alt+Ctrl+DownArrow enables the same processes, with the addition that it will
overwrite any existing content in the target cells, regardless of its content and status
(Ctrl+DownArrow only adds content to empty or propagated target cells).



Alt+DownArrow to go to the next untranslated segment. AutoPropagate, AutoSend, and
AutoAssemble are launched if enabled.



Ctrl+UpArrow to go to the previous segment.



Alt+UpArrow to go to the previous untranslated segment.



Alt+RightArrow to go to the next segment. The segment status will not be changed and
none of the automated features will be enabled.
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Alt+LeftArrow to go to the previous segment. The segment status will not
be changed and none of the automated features will be enabled.
If you select Tools> Options> Lock vertical scrolling in project view, your segment
selection will always be in the same relative position in the project table, i.e., if you
have selected a segment in the middle of the project table, moving to the next segment
will shift the table instead of your position in the table.

If you want to move to different sections of your current file, you can do that with the help of
keystrokes by switching into the selection mode (see "Edit and Selection Modes" on page 30).

To jump to different sections of the open file in the selection mode
The following keystrokes are available:


Ctrl+PgUp to go to the beginning of the file



Ctrl+PgDown to go to the end of the file.
The scrollbar also offers a convenient way to quickly change position within your
current file or project either in selection or edit mode. Clicking on the up and down
arrows on the top and bottom of the scroll bar will scroll one segment up or down in
your project, or you can drag the selection button in the scroll bar to anywhere in your
project. You can also right-click the scrollbar and select one of the following options:

SELECTING SEGMENTS
SELECTING SEGMENTS IN THE SELECTION MODE
You can select a segment in a Déjà Vu X2 Professional project file by switching into the selection
mode. You can find more information about this under "To switch into the selection mode" on
page 30.
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If you press the control key, you can select several rows at a time, and pressing Ctrl+Shift allows
you to select a range of rows.

Other segment selection keyboard shortcuts in combination with a mouse selection include:


Shift+Home (or Shift+Ctrl+Home) to select all the rows from the current selection up to
the beginning of the current file (or project in the All Files view)



Shift+End (or Shift+Ctrl+End) to select all the rows from the current selection down to
the end of the current file (or project in the All Files view)



Shift+PgUp (or Shift+Ctrl+PgUp) to select all the rows from the current selection up to
the top of the current screen



Shift+PgDown (or Shift+Ctrl+PgDown) to select all the rows from the current selection
down to the bottom of the current screen

SELECTING SEGMENTS BY STATUS
As described under "The Segment Selector" on page 40, Déjà Vu X2 Professional allows you to
select any number of rows according to their status.

SELECTING SEGMENTS BY FILTERING
You can display only those rows that contain a certain word or phrase, either in source or in target.
This will allow you to concentrate on a subset of your project if, for example, you are having a
problem with that particular word or phrase.
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To filter the project on a word or phrase
1

Select the desired text in the source and/or target cell.
If you select text in the source and target, all segment pairs that contain both selections
will be displayed.

2

Right-click the selection and select Filter> Source (Target) Selection.

3

Only rows that contain that particular word or phrase will be displayed.

To clear the filter
Right-click the source box or the target box and click Filter> Unfilter (or again on Filter > Source
(Target) Selection). The highlight on the Source (Target) Selection option will disappear and all rows
will be displayed again.
This feature is also extremely valuable for editing work because it allows the editor to
quickly view the translation of a certain word or phrase in all occurrences within the
project.

THE ADVANCED PROJECT EXPLORER
The Advanced Project Explorer is the Windows Explorer-like interface within Déjà Vu X2
Professional that allows you to manage your files within a project. You can use the Advanced
Project Explorer to import and export files into a project and to delete files out of a project.
It is important to learn the difference between the Project Explorer and the Advanced
Project Explorer. While the Project Explorer allows you to navigate within your existing
project, the Advanced Project Explorer allows you to explore the folder structure of
your local and network drives to build your project.

To access the Advanced Project Explorer
1

Select Advanced Project Explorer from the View menu.
-OrRight-click the project icon in the Project Explorer window and select Advanced Project
Explorer.
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2

The Advanced Project Explorer view appears.

To import files with the Advanced Project Explorer
1

In the upper left-hand pane, select the directory where you have saved the file that you want
to have translated.
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2

Click the file and drag it over to the lower right-hand pane.

3

Select the file name and set the format-specific properties in the Properties window to the
right of the Advanced Project Explorer. For more information on this, see "To apply specific
import options" on page 295.
You can select several items by pressing the Ctrl key as you select them, or a range of
items by pressing Ctrl+Shift as you select the first and the last item in that range.
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4

Right-click the file name and select Import.

5

When the import is finished, close the Advanced Project Explorer by clicking on the
symbol in the upper right-hand corner of the Explorer window.
If you notice that the segmentation of the source files is not adequate, i.e., individual
segments are not being split in the desired manner, this can have two reasons: the
original file may been formatted badly (e.g., soft or hard returns may have been used to
force line breaks) or your segmentation rules may have to be adjusted. Depending on
the situation, it may be advisable to either go to the source files and correct some of the poor
formatting or adjust your segmentation rules (see "Sentence Delimitation" on page 215) and
reimport the files.
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You are returned to the Project Explorer, in which you can see both files displayed.
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To import folders with the Advanced Project Explorer
1

In the upper left-hand pane, select the directory where you have saved the folder that
contains all the translatable files.

2

Click the file and drag it over to the lower right-hand pane.

3

The Add Folder dialog is displayed.
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4

Check the Only add files with the following extensions check box if you would like to exclude
certain file types from translation.
You do not have to worry about files that are not translatable within Déjà Vu X2
Professional, such as graphics files. These files will automatically be excluded.

If you check the check box, you can enter any file name and/or extension to which you
would like to limit your import. You will have to use a semicolon if you use several file names/
extensions and it is possible to use wildcards. As an example,
*.ht*;c*.txt
would include all files with an extension starting with .ht (such as .htm or .html) and all
.txt files with a file name starting with c (such as correction.txt or cd.txt).
Check the Include subfolders check box if you would like to include all subfolders in the
exact same structure as the original.

5

Select OK.
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6

You are returned to the Advanced Project Explorer.

7

You can now see that serval folders were brought over into the lower part of the Advanced
Project Explorer, as well as only files adhering to the extension definition.

8

Select the folder and set the available properties in the Properties window to the right of the
Advanced Project Explorer.
It is possible to change the default import properties for each extension/specific file format.
For more information on this, see "To apply specific import options" on page 295 and "To
apply global or project-wide import options for each file extension" on page 296.
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9

Right-click the folder name and select Import.

10 The import progress is displayed in the Import Progress dialog.

11

When the import is finished, close the Advanced Project Explorer by clicking on the
symbol in the upper right-hand corner of the Explorer window.
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You are returned to the Project Explorer, in which you can see all the files displayed.

To export files with the Advanced Project Explorer
1

In the lower right-hand pane, select the file(s) or the folder(s) that you want to export.
You can select several items by pressing the Ctrl key as you select them, or a range of
items by pressing Ctrl+Shift as you select the first and the last item in that range.
You can also select an entire folder for export. If you do that, Déjà Vu X2 Professional
will export all translated files within that folder and all of its subfolders with the default export
options.
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2

Right-click the file or folder name(s) and select Export.
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3

The Export Options dialog appears.

4

Under Destination, select the folder to which you want your files to be exported.

5

Under Languages, select the languages you want to export.

6

If applicable, you can define filter-specific options for the files within your project. For
information about these options, see the corresponding sections in "Working with Different
File Formats" on page 289.
If you have selected more than one file type with filter-specific export options, both sets of
options will be listed and you will have to make sure that you set all available options.

7

Select OK.

8

Déjà Vu X2 Professional will verify if there are any discrepancies


in embedded codes (see p. 206) and/or
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spaces at the end of segments.
If Déjà Vu X2 Professional finds a discrepancy in spaces following periods, question
marks, or exclamation marks, it will offer to automatically fix that discrepancy.

9

For each language you are exporting, Déjà Vu X2 Professional will create a subfolder inside
the export folder, named after the code for the specific locale of that target language. For
example, if you were translating the file into German (Germany), the new folder would be
called C:\My Projects\DE_DE.
If you have exported a complete folder, Déjà Vu X2 Professional will recreate the structure
of that folder with all of its subfolders, containing all the files you have translated.

10 Once the export is finished, close the Advanced Project Explorer by clicking on the
in the upper right-hand corner of the Explorer window.

symbol

11 You are returned to the Project Explorer.

To delete files with the Advanced Project Explorer
1

Select any file(s) or folder(s) listed in the Advanced Project Explorer and press the delete key.
–Or–
Right-click on any file(s) or folder(s) listed in the Advanced Project Explorer and select Delete.

2

A confirmation dialog appears.
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3

Select Yes.

4

Once the deletion is completed, close the Advanced Project Explorer by clicking on the
symbol in the upper right-hand corner of the Explorer window.
You are returned to the Project Explorer, in which you can see that the files are deleted from
the project.

How to view file details in the Advanced Project Explorer
You can view details for each file in your project in the Details fields in the Advanced Project
ExplorerProject Explorer.
You may have to scroll to the right to see some of the otherwise hidden fields.

The available fields are:


Name



Size



Type



Date Modified



Source Path



Date Last Imported



Export Path



Date Last Exported
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WORKFLOW
The following is a simplified suggested workflow model for translation. The lightly shaded parts are
optional and/or will be not used for every project you work on.
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You will notice that the workflow chart is segmented in several phases. In the following sections
you can find detailed information about each of the activities in the different phases.
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PHASE I: PREPARATION
The preparation phase consists of preparing the memory and termbases by optionally importing
existing material into them (see "Import of Existing Third-Party Databases into the Translation
Memory" on page 78, "Import of Existing Translations into the Translation Memory" on page 79,
and "Import of Existing Third-Party Glossaries into the Termbase" on page 79), as well as selecting
the source files for import (see "Source Files" on page 80).

IMPORT OF EXISTING THIRD-PARTY DATABASES INTO THE TRANSLATION MEMORY
This component is optional and will not have to be performed every time you work on a
translation project. Situations where you may want to import existing databases could include the
following:


you have received external databases from your client



you own existing databases in other formats



you are sharing databases with fellow translators

The formats of these databases can vary widely, including:


Déjà Vu X2 Translation Memory—for merging other Déjà Vu X2 translation
memories into the existing one.



Déjà Vu 2.x/3.x Memory Database—for importing memory databases of earlier
versions of Déjà Vu.



Text—for importing delimited text files (tab, comma, etc.).



Access 9x/2000/XP—for importing databases from various versions of Microsoft
Access.



Excel 9x/2000/XP—for importing databases from various versions of Microsoft Excel.



Trados Workbench Databases—for importing translation memories from the Trados
Workbench .txt format.



SDLX or IBM TM—for importing translation memories from the SDLX or IBM TM2
formats.



TMX—for importing databases from the Translation Memory EXchange format, an
XML-based exchange format between different CAT tools.

For more information on importing external databases, see "Importing External Data" on page 409.
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IMPORT OF EXISTING TRANSLATIONS INTO THE TRANSLATION MEMORY
The alignment module in Déjà Vu X2 Professional allows you to take the source and the target
texts of an existing translation and create a translation memory from them.
As a rule of thumb, it’s a good idea to primarily rely on building databases by actually
doing translation within the Déjà Vu X2 Professional translation environment. But the
alignment feature can be a very powerful tool when translating documents for which
you have very similar file pairs..

IMPORT OF EXISTING THIRD-PARTY GLOSSARIES INTO THE TERMBASE
As with the option of importing external databases into the translation memories, this component
is optional and will not have to be performed every time you work on a translation project.
Situations where you may want to import existing glossaries would include the following:


you have received external glossaries from your client



you own existing glossaries in other formats



you are sharing glossaries with fellow translators

The formats of these glossaries can vary widely, including:


Plain text (delimited by any ASCII character)



Excel



Access



MultiTerm 5.5



Déjà Vu X2 Professional termbases



Déjà Vu 2 or 3 termbases

When importing external glossaries, make sure that these glossaries are useful in Déjà
Vu’s workflow. Glossaries of most other tools are mere dictionaries, but in Déjà Vu X2
Professional’s case they are active entities that automatically insert text into segments.
That means that if you have two different translations in one target field, Déjà Vu X2
Professional would insert both of them.

For more information on importing external glossaries, see "Importing External Data" on page 474.
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SOURCE FILES
Déjà Vu can import a great variety of source files, including:


tagged formats (SGML/XML, HTML, ASP)



word processing, presentation, and spreadsheet formats (Microsoft Word, Microsoft
PowerPoint, Microsoft Excel, and the corresponding formats from the OpenOffice suite)



exchange formats (RTF, TMX)



desktop publishing formats (Adobe FrameMaker, Adobe PageMaker, Adobe InDesign,
Interleaf/Quicksilver, QuarkXPress)



database formats (Microsoft Access)



Help formats (WinHelp RTF, Help content files)



software development formats (Resource files, C/C++/Java source files, Java Properties,
VBScript, JavaScript, GNU gettext, RESX)



preprocessed files from other TM tools (Trados Workbench RTF, Trados TTX, Trados BIF,
IBM TranslationManager)
For more information on each of these file formats, see "Working with Different File
Formats" on page 289.

The unique power of Déjà Vu X2 Professional is that you can take any number of files of any
variety of the above-listed formats from any location of your computer or network and import
them into one project!
From a file management perspective, it may still make sense to have the files located in
one folder or group of subfolders.
In most cases you do not need the originating applications installed on your machine.
That means you can process QuarkXPress, PageMaker, or FrameMaker files without actually having
to have the actual (and very expensive!) applications. However, there are exceptions that include
Word, Excel, and PowerPoint. If you are planning to process any files that originate from these
applications, you will have to have them installed.
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PHASE II: PROJECT BUILDING
The project building phase consists of selecting an existing project file (see "Selecting an Existing
Project File" on page 81) or creating a new project file ("Creating a New Project File" on page 85)—
which includes importing the source files and associating the file with translation memories and
termbases—as well as building the lexicon (see "Generating the Lexicon" on page 97).

SELECTING AN EXISTING PROJECT FILE
The source files for a large translation project are rarely delivered in one batch. Typically they
come in one large batch and several later ones.

To import many files into existing projects
1

Open the project file.

2

Select View> Advanced Project Explorer.
-OrRight-click the project icon in the Project Explorer window and select Advanced Project
Explorer.
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3

Select the file that you would like to import in the upper half of the window (Explorer) and
drag it into the lower half (Project).

4

Select the file name and set the format-specific properties in the Properties window to the
right of the Advanced Project Explorer. For more information on this, see "To apply specific
import options" on page 295.
You can also select an entire folder for import. For more information on this, see "To
import folders with the Advanced Project Explorer" on page 68.

5

Right-click the file or folder name and select Import.
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6

The file or folder is imported into the project.

To import one file or several files from a single location into existing projects
1

Open the project file.

2

Select Project> Add.

3

The Add submenu appears.

4

You can select between the import of a single or any number of files from one location, a
folder with any number of files, or you can create a new folder within the Project Explorer to
add files into.

5

Select Source File.
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6

A selection dialog appears.

7

Select the source file and click Open.

8

The file appears in the Project Explorer grayed out and with no status percentage indicator.

9

Select the file in the Project Explorer and select Project> Import to import the file.
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CREATING A NEW PROJECT FILE
To create a new project file, Déjà Vu X2 Professional assists you with a powerful wizard that
allows you to create a project file and associate it with existing databases and/or new databases.

To create a new project file
1

Open Déjà Vu X2 Professional.

2

Click the

button on the toolbar.

The New File dialog appears.

Double-click Project or select Project and click OK.
-OrSelect File> New> Project.
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3

The New Project Wizard appears.

4

In the steps that follow, the wizard will guide you through the process of creating a project file
by


specifying a project name and file,
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selecting the languages,

You will notice that there are a great number of languages and sub-languages.
Déjà Vu X2 Professional ranks the sub-languages hierarchically. If the program finds a
perfect or an equally fuzzy match with the same subject and client properties and the
same source sub-language (English (United States), for instance) in the translation
memory, it will choose it over another with a different source sub-language (English (United States)
vs. English (United Kingdom), for instance). Further, it will prefer that constellation (different source
sub-languages, equal target sub-languages) to a constellation where the source sub-languages are
equal but the target sub-languages are different (French (Standard) vs. French (Belgian)). For more
information on the matching hierarchy, see "Clients and Subjects" on page 174.
The list of displayed languages changes dynamically to display the last chosen languages at the top
of the list.
If you cannot find certain languages in that list, such as Cyrillic, right-to-left, or East Asian languages,
it is possible that your operating system does not support these languages. If you cannot find them
you may need to enable support for these languages within Windows in Regional and Language
Options under Start> Settings> Control Panel.
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selecting or creating the associated main translation memory,



selecting or creating the associated main termbase,
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selecting the source files,

You can access specific import properties (see p. 295) for each individual or all files by
selecting Properties in this dialog. The default settings in the wizard are activated
segmentation (i.e., all current segmentation rules are turned on) and all other formatspecific options are turned off. For information on format-specific import options, see
"Working with Different File Formats" on page 289.
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and selecting a subject and a client.

5

Click Next and select the files that need to be translated.

6

When you have made your selections click Next and Finish.
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7

The Project Explorer is opened, displaying the imported files.

8

To start the translation, double-click on either of the file names or on the project name.

CREATING A NEW PROJECT FILE ON THE BASIS OF A TEMPLATE
Rather than having to create every new project from scratch, Déjà Vu X2 Professional allows you
to create a new project file on the basis of the template of a previous project.
For this to happen, you’ll need to save the settings of a previous project.

To save the settings of a project in a settings file
1

Select Project> Properties> Templates (in the lower left-hand corner of the Project
Properties dialog) in the previous project.
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2

The Project Templates dialog appears.

3

Click on Save.
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4

You are prompted to enter a new template name or accept the existing one.

5

Click OK when you have made your selection.
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6

7

The following settings are saved:


source and target languages



translation memories



termbases



client



subject

Click OK.

Once a template is saved, you can now create a project on the basis of those settings.

To create a project on the basis of a template
1

Open Déjà Vu X2 Professional.
Click the

button on the toolbar.

The New File dialog appears.

Double-click Project From Template or select Project From Template and click OK.
-OrSelect File> New> Project from Template.
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2

The New Project Wizard appears.

3

Select the template you want to assign to your project and click Next.

4

Click on Create to select a name and location for your project.
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5

Click Next and select the files that need to be translated.

6

When you have made your settings, click Finish.

7

The Project Explorer is opened, displaying the imported files.

8

To start the translation, double-click on either of the file names or on the project name.
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GENERATING THE LEXICON
The project’s lexicon is a list of all the source language words or phrases present in the project—in
other words, an index of all terms and phrases. Once you have created this index, you can
translate the terms that seem relevant to you, batch delete all other terms (for instance, terms like
"the" or "to" in the image below), and Déjà Vu X2 Professional will use what remains as the
primary glossary for your project.

Clients will often ask you to provide them with a glossary for a project you’ve translated
for them; this will help them keep a record of the terminology used, ensuring that the
same terminology is used in future projects. With Déjà Vu X2 Professional, creating a
glossary for your client is as simple as exporting the lexicon to a text file.

The lexicon is a very useful tool, but as indicated in the light shading in the workflow chart on page
p. 77, it is an optional component.

To create the lexicon
1

Select Lexicon> Build Lexicon.

Déjà Vu X2

97

98

2

The Build Lexicon dialog appears.

3

You are offered the following options:


Specify the maximum number of words for a lexicon entry.

Generally you will want to select 2 or 3 for this option. Higher numbers tend to result in
a great deal of useless entries. Déjà Vu X2 Professional does not linguistically evaluate
the words; it simply lists all occurrences in all combinations. For example, "The cat is
black" with a maximum number of 4 would be listed as "The," "cat," "is," "black," "The
cat," "cat is," "is black," "The cat is," "cat is black," and "The cat is black." Of those entries, only "cat,"
"black," and arguably "cat is black" would be useful entries in the lexicon.

4



Specify whether Déjà Vu X2 Professional should try to translate the lexicon entries
as it creates them, using the termbases and translation memories for the project.



Specify whether you want a lexicon for the current or all files.

Select the options you want, and click OK.
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Depending on the size of the project, building the lexicon may take some time because
Déjà Vu X2 Professional has to process each segment in the project a number of times. While
Déjà Vu X2 Professional is working on creating the lexicon, you will see a progress indicator in
the Build Lexicon dialog.

Once Déjà Vu X2 Professional has finished building the lexicon, you can view it by doubleclicking on Lexicon from the Project Explorer.

The first column on the table, with the heading Words Freq, shows the number of words in the
lexicon entry, and the frequency, i.e., the number of times it appears in the project.

To translate the lexicon
There are several ways to translate a lexicon:


As you generate the lexicon, you can choose to Automatically resolve lexicon with
databases (see p. 98).



Once the lexicon is generated, you can select Project> Resolve with Translation
Memory/Termbase/Deep Miner to leverage the content of your databases against the
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lexicon. For more information on this, see "Resolving the Lexicon with the Databases" on
page 379.


You can manually translate it by entering the translation into the target column.

Either way, you will want to translate only those terms that are helpful for you to have in the
lexicon and delete the remaining lexicon entries.

To remove rows from the lexicon
To avoid a large number of useless entries in the lexicon, you will probably want to delete the
lexicon entries that only appear rarely in the project, or those that contain a very large number of
words.
Déjà Vu X2 Professional will only use translated rows in its translation processes, so it
is possible to skip this step.

1

Select Lexicon> Remove Entries.

2

The Remove lexicon rows dialog appears.

3

You are offered the following options:


Remove the entire lexicon.



Remove those lexicon entries for which you have not entered a translation.
This is useful when you have finished translating the useful entries in the lexicon and
want to remove the rest, or when you want to export the relevant entries in the lexicon
to send to your client as a glossary.
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Remove lexicon entries based on the number of words they contain and/or their
frequency. You can also specify whether to remove those entries that satisfy these
conditions and have not been translated, thereby preserving any special entries you
decided to keep. The selection in the image above instructs Déjà Vu X2
Professional to delete all rows with three or more words in the source field and ten
or fewer occurrences.
This kind of setting may make sense for a very large project where you have some
occurrences of several hundred.

4

Select the options you want and click OK.

When you are done building your lexicon, you have completed the project building phase.
For more information about the lexicon, see "The Lexicon" on page 377.

PHASE III: PRETRANSLATION
The third phase of a translation project in Déjà Vu X2 Professional is pretranslation. Pretranslation
allows you to batch leverage the content of your databases—translation memory(s), termbase(s),
and (optionally) the lexicon—against your source files.
While you could leverage on a segment-by-segment level as you translate (see "Phase
IV: Translation" on page 104), pretranslation has the advantage of giving you a better
idea of what to expect, i.e., how much actually needs to be translated.

To pretranslate a project
1

On the Translation menu, click Pretranslate.
–Or–
Press Ctrl+P.
–Or–
Click the

button on the toolbar.
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2

The Pretranslate dialog appears.

3

Set the different options as shown above and click OK.


By unchecking Accept only exact matches, you instruct Déjà Vu X2 Professional to
scan the translation memory for perfect matches; if it cannot find perfect matches, it
will look for fuzzy matches.
You can set the degree of fuzzi> ness under ToolsOptions> General.



By checking Assemble from portions, you instruct Déjà Vu X2 Professional to fill in
portions (i.e., single words or short phrases) from the translation memory(s), the
termbase(s), and (if available) the lexicon. Déjà Vu X2 Professional will also try to
turn fuzzy matches into perfect ones by supplying missing terms in whole segments
from the translation memory with segments from the termbase(s) and the lexicon.



The options under the Assemble option include Use DeepMiner Engine to include
subsegments and their combinations from the translation memory(s), Use Machine
Translation to enter machine translation where no other matches are found, and
Insert source text for failed portions to copy over portions that are not found in any
of the databases.
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4



The options under Overwriting allow you to pretranslate segments that have already
been processed and have either an exact, fuzzy, or assembled status. Though these
options are not relevant for our particular aim that we hope to achieve with
pretranslating, they may be helpful when you receive a Déjà Vu X2 Professional
project file that has already been translated, but you feel that your own database(s)
has a greater amount of and more accurate project-specific terminology.



Checking the option Check for inconsistent terminology will activate Déjà Vu X2
Professional’s automated terminology check even during the pretranslate process.
With this feature, Déjà Vu X2 Professional will check any of the pretranslated
material to inconsistencies in any other of the attached databases and warn you
with a red exclamation mark if it finds any. For more information on the
inconsistency checks, see "Terminology Consistency Checks" on page 114.



Limit to current record selection may be helpful if you only wish to pretranslate a
section of a file that you are displaying through filtering or the segment selector (see
"Selecting Segments by Filtering" on page 62 and "Selecting Segments by Status" on
page 62).

Once the pretranslation is finished, a status report will be displayed at the bottom of the
Pretranslate dialog, informing you of how many segments have been processed at what
status.
At this point you can also generate a more detailed report on the word count by
selecting Tools> Word Count.
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You will notice a colored status indicator to the left of the translations. By default, every
guaranteed match has an orange indicator, every perfect match has a dark green indicator, every
fuzzy match has a light green indicator, and so forth. All of these display options are configurable
under Tools> Options> Display.
Even if the pretranslation inserts an exact match, it is a good practice to check the
translation for any mistakes (you might have translated it wrong in the past or translated
it in an entirely different context).
If the actual match is blue and has an underline, it is an exact match for which several perfect
matches have been found in the database. Right-clicking on each of these records opens a context
menu in which the other translation options are displayed. If you choose one of those over the
existing one, you can select it by clicking on it. To jump to the next multiple exact match line, you
can press Ctrl+F3. You are strongly encouraged to check each of these matches.
If you have checked all multiple matches and would like to delete the underline and blue
coloriing, you can right-click in the target field and select Accept all Multiple Matches.
Guaranteed matches, however, are matches for which Déjà Vu X2 Professional has automatically
checked the context for you.

PHASE IV: TRANSLATION
Although Déjà Vu X2 Professional may have done a great deal of your translation work for you,
there will usually still be translation work left for you to do.
Translation—much like pretranslation—is a process where the translation work in the project file is
greatly enhanced by the associated databases and the lexicon. You can manually access
information in all these files and use it as a reference, but you can also let Déjà Vu X2
Professional do the work for you.
Essentially, there are two processes during the translation phase: leveraging from the databases, a
process that can be largely automated in Déjà Vu (see "Automatically Communicating with the
Databases" on page 105); and feeding to the databases (see "Feeding the Databases" on page 111).
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AUTOMATICALLY COMMUNICATING WITH THE DATABASES
1

Before you start to translate, select Tools> Options> Environment.

You can see that there are several "Auto-Features" available:


AutoWrite (see p. 166)



AutoAssemble (see p. 106),



AutoPropagate (see p. 198),



AutoCheck (see p. 118),



AutoSend (see p. 111), and
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AutoSearch (see p. 107)
For AutoCorrect, see "AutoCorrect" on page 225, and for AutoText, see "AutoText" on
page 220.

AUTOWRITE
You can instruct Déjà Vu X2 Professional to automatically suggest matches it finds in the
subsegments of the associated translation memory(s) and/or termbase. These matches will be
shown as you type your translation and you can accept them by clicking on them.

To activate AutoWrite
1

On the Environment tab in the Options dialog, click Enable AutoWrite.
-OrClick

on Déjà Vu X2 Professional’s status bar.

AUTOASSEMBLE
You can instruct Déjà Vu X2 Professional to automatically insert a match from the translation
memory or to assemble a translation from smaller pieces that can be found in the project lexicon,
termbase, and translation memory (in this order).

To activate AutoAssemble
1

On the Environment tab in the Options dialog, click Enable AutoAssemble.
-OrClick

2

on Déjà Vu X2 Professional’s status bar.

The next time you jump from one segment to the next by pressing Ctrl+DownArrow (or to
the next translatable segment by jumping Alt+DownArrow), Déjà Vu X2 Professional will
automatically assemble the segment for you.
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3

You can recognize assembled segments by their status indicator. The default color is dark
blue.
Other options of AutoAssemble include specifications for how entries from the
translation memory will be handled (First scan for whole segments, Accept only exact
matches when scanning), whether source text should be copied over when no matches
are found (Insert source text for failed portions), and whether the segments may
contain commas (Allow portions containing commas). Be aware that this last option may slow the
process of AutoAssemble considerably.

For more information on the Assemble function, see "Assemble" on page 149.

AUTOSEARCH
By activating AutoSearch, you can make Déjà Vu X2 StandardProfessionalWorkgroup
automatically scan (search) the translation memory for the current segment, and search the
translation memories, termbases and the project lexicon for any portions of the segment.

To activate AutoSearch
1

On the Environment tab in the Options dialog, click Enable AutoSearch.
-OrClick

on Déjà Vu X2 ProfessionalWorkgroup’s status bar.
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2

The AutoSearch window appears in the lower right-hand corner of the screen.

At the bottom of the window, you can see related information, such as client, subject, date/time
stamp, and database origin of the selected term displayed.
If you prefer to view segments and portions displayed in two separate windows, you
can activate this by selecting Tools> Options> Evironment> Show segments and
portions in separate windows. For more information on this, see "Splitting the
AutoSearch window" on page 34.

If you select an entry from a translation memory, you will see additional rows in which the
differences between the record in the translation memory and the original source segment are
highlighted.
You can find information on each of the cells in these additional rows under "Scanning
the Translation Memories" on page 140. The cells in the Scan Results window described
in that section have the same structure as the ones in the AutoSearch window.

The AutoSearch window will also display matches that have been turned from fuzzy to perfect
matches with the help of Déjà Vu X2 Professional’s advanced leverage technology. In these cases,
the upper portion of the AutoSearch window will display the "fixed" segment rather than the
original segment of the source. Any change you make to the translation of that string in the
AutoSearch window would be considered a new entry to the translation memory instead of a
change to the existing segment pair.
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To navigate through the AutoSearch window
Press Ctrl+Shift+UpArrow to move to the previous portion.
–Or–
Press Ctrl+Shift+DownArrow to move to the next portion.

To copy a term from the AutoSearch window into the target column
1

Press Ctrl+1 (or whichever number is associated with that entry).
If you press Ctrl+Shift+1 (or whichever number is associated with that entry), you can
copy the respective term into the target field by overwriting the existing content.

-OrDouble-click that entry.
-OrPress Ctrl+R to copy the currently selected entry from the AutoSearch window into the target
cell (Ctrl+E for the AutoSearch - Segments window).
If you press Ctrl+Shift+R (or Ctrl+Shift+E for the AutoSearch - Segments window),
you can copy the respective term into the target field by overwriting the existing
content.
The underlying color of the number indicates the source of the segment (blue=termbase,
white=lexicon, and red=translation memory). As with all other colors, these colors can be
changed under Tools> Options> Display.

2

As soon as you move to a new segment in your project, Déjà Vu X2 ProfessionalWorkgroup
will begin searching the lexicon and the databases and display any matches.
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To adjust the AutoSearch settings
1

Select Tools> Options> Environment.

2

The options under AutoSearch include:


Enable AutoSearch—see "To activate AutoSearch" on page 107.



Require Ctrl-key to Insert AutoSearch portions—Controls whether matches form the
AutoSearch window can be inserted from the numbers on the keypad with or
without the Control key being pressed.



Display portions from Translation Memory—Controls whether matches found in the
translation memory(s) are also displayed, and whether or not the translation
memory(s) will be used when performing terminology checks (for terminology
checks, see "Terminology Consistency Checks" on page 114).
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Hide embedded codes—Removes any embedded codes present in text retrieved
from the databases before displaying it.



Display all subportions—Controls whether parts of portions should be displayed
when larger portions are found.



Show segments and portions in separate windows—Controls whether one or two
AutoSearch segments will be displayed. For more information, see "Splitting the
AutoSearch window" on page 34.



Hide column headers—Controls whether the AutoSearch language column headers
are hidden to gain some additional user interface estate. For more information, see
"To hide the column headers" on page 37.



Cache expiry period—Determines how often to clear the cache that holds
information on matches that Déjà Vu X2 Professional has displayed in the past XX
seconds. This speeds up the AutoSearch process because Déjà Vu X2 Professional
will not have to look in the databases again.
If you prefer not to use the cache expiry period, do not enter 0 into the text field as this
will cause the cache never to expire. Instead, enter a low number such as 1.

FEEDING THE DATABASES
As you can see, the databases allow you to greatly enhance your translation process; however,
they can only do that because you feed them the information that they use to help you in the
translation.
There are several ways to feed the databases. One is to create and translate a lexicon (see
"Generating the Lexicon" on page 97), another is to feed the translation memory with the
AutoSend feature (see "AutoSend" on page 111) and the manual feeding of the termbase (see
"Adding Terms to the Termbase" on page 112).

AUTOSEND
If you want to automatically send segments to the translation memory when you are finished with
their translation, you can activate the AutoSend feature.

To activate AutoSend
1

On the General tab in the Options dialog, click AutoSend to translation memory.
-Or-

Déjà Vu X2

111

112

Click
2

on Déjà Vu X2 Professional’s status bar.

The next time you jump from one segment to the next by pressing Ctrl+DownArrow (or to
the next translatable segment by jumping Alt+DownArrow), Déjà Vu X2 Professional will
automatically send the current segment pair to the translation memory.
Because you can simultaneously have twoseveral translation memories assigned in
Déjà Vu X2 Professional, make sure that under Project> Properties> Database you
assign the write attribute to the database(s) that is to contain all new material from the
current project.
If you choose not to use the AutoSend feature, you can send individual segment pairs (or only
highlighted selections of those) to the translation memory. To do that, click Add Pair to Translation
Memory on the Translation menu, click F12, or click the

button on the toolbar.

ADDING TERMS TO THE TERMBASE
While it makes sense to automate the process of sending data to the translation memory, the
termbase cannot be built automatically: you will have to teach the termbase which word or phrase
in your translation corresponds to which term or phrase in the source. While entering terms into
the termbase is probably the most manual process in Déjà Vu X2 Professional, it is still very easy
and we encourage you to use it as much as possible.

To add terms to the termbase
1

Highlight a term or phrase in the source segment and the corresponding term or phrase in the
target segment with your mouse.

2

Send the highlighted terms to the termbase.
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3

On the Translation menu, click Add Pair to Termbase.
–Or–
Press F11.
–Or–
Click the

4

button on the toolbar.

Add any specifications, including grammatical information (part of speech, gender, or
number) and semantical definition (such as context information, subject, or client).
Minimize your entry time by entering only the information that will be relevant for you
or your co-workers later on. For instance, it obviously would not make sense to enter
gender information if your language does not have a grammatical gender, or if any
skilled translator or editor would be familiar with this kind of information anyway.
If you are certain that you do not need to enter any additional information (aside from the standard
user and date/time information), you can also send the highlighted terms or phrases to the
termbase by pressing Shift+F11 or by right-clicking and selecting Add Pair to Termbase (No
Prompt). This method will not prompt you to enter any additional information.
This way of entering term pairs into your termbase is especially beneficial for terms that are
completely unspecific to project, subject, or client, such as "and" or "or."
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5

Click Add.
For other ways to send information to the databases, see "Sending Text to the
Databases" on page 169.

PHASE V: EDITING AND QUALITY ASSURANCE
The editing and quality assurance phase consists of employing Déjà Vu X2 Professional’s
advanced integrated quality assurance features ("Déjà Vu X2 Professional’s Integrated Quality
Assurance Features" on page 114) and editing the project by reading it through


on a hard copy ("Exporting into the Original Format for Proofing" on page 129),



in the External View format ("Proofing within the External View Format" on page 129),
and/or



within Déjà Vu X2 Professional’s own environment ("Proofing within Déjà Vu X2
Professional" on page 129).

DÉJÀ VU X2 PROFESSIONAL’S INTEGRATED QUALITY ASSURANCE FEATURES
Déjà Vu X2 Professional uses several methods to assure the quality of the translation project.
These include:


several levels of consistency checks between source and target and different targets



spell check

TERMINOLOGY CONSISTENCY CHECKS
Déjà Vu X2 Professional provides for a number of different terminology consistency checks:


a batch check once the translation is finished,



an automated check that can be used during the translation ("AutoCheck"),



a terminology check that selects the next available discrepancy, and



a consistency check during pretranslation (see p. 103).

On the General tab in the Options dialog, you can define what databases will be considered
during the different terminology consistency checks.
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1

Select Tools> Options> General.

2

Under Terminology Checks you can specify whether numbers should be included in the
checks and whether the checks should be performed against data in the


lexicon,



termbases, and/or



translation memories.
It is important to realize that any of the terminology consistency checks will also point
out words or phrases that are identical with existing terms in any of the databases but
are now part of compound words in the target. The best way to avoid this is to enter as
many compound works in any of the databases as you can.
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To perform a batch terminology validation
1

Once you are finished with the translation or at any point during the translation, select QA>
Batch Terminology Validation.

2

The Batch Terminology Validation dialog appears.

3

Select whether you want the current or all languages checked; the current or all files; from the
beginning of the file/project or from the current position; and whether you want to have only
those rows checked that you are displaying through filtering or the segment selector (see
"Selecting Segments by Filtering" on page 62 and "Selecting Segments by Status" on page 62).

4

Select OK.

5

A process indicator shows you the progress of the validation.
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6

Once the validation is finished, every segment with a discrepancy displays a red exclamation
mark (or a light violet exclamation mark if there is already a target comment on that segment).

7

If you select the segment, you can see that the source terms for which inconsistencies were
found are painted red. If you hold your mouse cursor over one of the exclamation marks, you
can see what kind of inconsistencies were found and in what kind of database they were
found.

To ease the process of finding the rows with inconsistencies in your project,
you can filter the project to display only rows with inconsistencies by selecting
Segments with Inconsistent Terminology in the Segment Selector.

8

When you have reviewed that information and decided to make changes or leave the
translation as originally intended, the exclamation mark will disappear (or become light blue if
there is a comment in that segment) after you hit Ctrl+DownArrow.

9

To jump to the next segment and mark the segment as Finished, hit Ctrl+DownArrow again.
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10 Once you are done reviewing all rows, you can right-click in the target area and select Delete
all Terminology Warnings.

To use the automated terminology check
If you would like to automatically check your translation for consistency with any of your
databases as you translate, you can activate the AutoCheck function.
1

Select Tools> Options> Environment> AutoCheck and select Apply and/or OK.

–Or–
Click
2

on Déjà Vu X2 Professional’s status bar.

When you press Ctrl+DownArrow after translating a segment with inconsistent terminology,
you will not jump to the next available segment. Instead, you will be notified with a red
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exclamation mark (or a light violet exclamation mark if there is already a target comment on
that segment) that there is a potential problem in that segment.

3

The source terms for which inconsistencies were found are painted red. If you hold your
mouse cursor over the exclamation marks, you can see the inconsistencies and in what kind
of database they were found.

4

After you have reviewed the information and decided to make changes or leave the
translation as originally intended, the exclamation mark will disappear (or become light blue if
there is a comment in that segment) after you hit Ctrl+DownArrow.

5

To jump to the next segment and finally mark the segment as Finished, hit Ctrl+DownArrow
again.

To check the current segment for a terminology mismatch
1

Press Ctrl+Shift+T.

2

Déjà Vu X2 Professional will check whether there is a terminology discrepancy and will
display a red exclamation mark in that segment (or a light violet exclamation mark if there is
already a target comment on that segment).

3

The source terms for which inconsistencies were found are painted red. If you hold your
mouse cursor over the exclamation mark, you can see what kind of inconsistencies were
found and in what kind of database they were found.
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4

After you review the information and decide to make changes or leave the translation as
originally intended, the exclamation mark will disappear (or become light blue if there is a
comment in that segment) when you hit Ctrl+DownArrow.

5

To jump to the next segment and mark the segment as Finished, hit Ctrl+DownArrow again.

To find the next terminology mismatch
1

Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open
file or project (see "Selecting Segments in the Selection Mode" on page 61).

2

On the QA menu, click Check Terminology.
–Or–
Press Ctrl+F7.

3

Déjà Vu X2 Professional will find the next terminology discrepancy and will display a red
exclamation mark in that segment (or a light violet exclamation mark if there is already a
target comment on that segment).

4

The source terms for which inconsistencies were found are painted red. If you hold your
mouse cursor over the exclamation mark, you can see what kind of inconsistencies were
found and in what kind of database they were found.

5

After you review the information and decide to make changes or leave the translation as
originally intended, the exclamation mark will disappear (or become light blue if there is a
comment in that segment) when you hit Ctrl+DownArrow.

6

To jump to the next segment and mark the segment as Finished, hit Ctrl+DownArrow again.

NUMERAL CONSISTENCY CHECKS
To find the next numeral discrepancy
1

Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open
file or project (see "Selecting Segments in the Selection Mode" on page 61)
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2

On the QA menu, click Check Numerals.
–Or–
Press Ctrl+Shift+F7.

3

Déjà Vu X2 Professional will find the next numeral discrepancy and display a red
exclamation mark in that segment (or a light violet exclamation mark if there is already a
target comment on that segment).

4

The inconsistent target and source numbers are painted red. If you hold your mouse cursor
over the exclamation mark, you can see a further description of the inconsistencies.

5

When you have reviewed the information and decided to make changes or leave the
numbers as originally intended, the exclamation mark will disappear (or become light blue if
there is a comment in that segment) after you hit Ctrl+DownArrow.

6

To jump to the next segment and mark the segment as Finished, hit Ctrl+DownArrow again.
Déjà Vu X2 Professional will not mark discrepancies between numbers caused by
Déjà Vu’s automatic decimal conversion feature (see "Conversions" on page 211).
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7

Continue to check for number errors and, if appropriate, fix them until you reach the end of
the open file or project.
You can also check for discrepancies in numerals as you check for discrepancies in the
terminology (see "Terminology Consistency Checks" on page 114). To do this, you will
have to activate Also check numerals under Tools> Options> General> Terminology
Checks as you check the terminology.

MISSING SPACES CHECK
To check whether there are any discrepancies between the spaces at the end of a segment in
source and target
1

Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open
file or project (see "Selecting Segments in the Selection Mode" on page 61).

2

On the QA menu, click Check Missing Spaces.
–Or–
Press Ctrl+Shift+F8.

3

Déjà Vu X2 Professional will jump to the next occurrence of a discrepancy between spaces
at the end of a segment in source and target.

4

Make sure to fix any discrepancies.

CODE CONSISTENCY CHECKS
To check whether there are any discrepancies between embedded codes in source and target
1

Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open
file or project (see "Selecting Segments in the Selection Mode" on page 61).

2

On the QA menu, click Check Embedded Codes.
–Or–
Press Ctrl+Shift+F8.

3

Déjà Vu X2 Professional will jump to the next occurrence of a discrepancy between
embedded codes in source and target.
Discrepancies include:


missing or additional codes,
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codes that are in a different order than in the source segment, and



codes at the very beginning or the very end of the source segment that have
something before or after them in the target segment.

4

You can quickly fix the codes by pressing Ctrl+F8. This will copy all missing codes to the end
of the current target segment.

5

Make sure that the codes are now located in the correct position.

6

Continue to check for code errors and fix them until you reach the end of the open file or
project.
For more information about embedded codes, see "Embedded Codes" on page 202.

TRANSLATION CONSISTENCY CHECKS
To check whether there are any discrepancies in the translations of the same source
1

Select Project> Find Duplicate Segments.

2

The Find Duplicate Segments dialog appears.

3

Select whether you want to Find (all) sets of duplicate source segments.
–Or–
Find sets of duplicate source segments with different translations.

4

If you select the second option, you will also have to select the target language.

5

Make the appropriate selections under Miscellaneous:
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Ignore case—With this option, THIS SENTENCE would be considered a duplicate
of this sentence.



Ignore numerals—With this option, A 100 m dash would be a duplicate of A 50
m dash.



Ignore embedded codes—With this option, This {101}sentence{102} would
be a duplicate of This sentence.

6

Click OK.

7

All duplicates are indicated with a grey indicator to the left of the source sentence.

The colors of the duplication indicator can be changed to any color you prefer. For
more information on changing colors, see "To change the colors of the indicator bars"
on page 42.

8

To view duplicates and their differing translations (provided that you have selected that
option) side by side, you can select Duplicate Segments in the Segment Selector.

–And/Or–
Highlight the source in question, right-click, and select Filter> Filter on Source Selection.
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9

The duplicated rows with different translations are now displayed on top of each other.

10 You can now enter your correction if necessary.
11 Display all rows by selecting All Rows from the Segment Selector.
–And/Or–
Right-click in the source column and select Filter> Unfilter.

To unmark duplicate segments
To remove the indicator in duplicate segments, select Project> Unmark Duplicate Segments.

SPELL CHECKING
Integrated spell checking by Déjà Vu X2 Professional is available for the following languages:


Danish



Dutch



English (U.S.)



English (U.K.)



English (Canada)



Finnish



French



German



Italian



Norwegian (Bokmål)



Spanish



Swedish
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Portuguese (Brazil)



Portuguese (Portugal)
Other languages can be spell checked through the Microsoft Word spell checker if your
version of Word provides the appropriate dictionary. For more information on this, see
"To spell check an open file or project with Microsoft Office’s spell checker" on page
127.

To spell check an open file or project with Déjà Vu X2 Professional’s integrated spell checker
1

Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open
file or project (see "Selecting Segments in the Selection Mode" on page 61).

2

On the Tools menu, click Spelling.
–Or–
Press F7.

3

At the next occurrence of a misspelled or unrecognized word, the Check Spelling dialog
opens.

4

The misspelled or unrecognized word is displayed in the Not in Dictionary box. The word is
considered misspelled because it could not be located in any of the open dictionaries.

5

You have the following options:
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Change the word by selecting the correct word under Suggestions or entering the correct
spelling in Change To box and clicking the Change button (Change All changes all
occurrences of this word in the current file or project).
–Or–
Enter a correction into the Not in Dictionary box and click the Suggest button to see whether
the spell checker recognizes this alternative. If it does, click Change (or Change All) to change
the word in the current file or project.
–Or–
Skip it by clicking the Ignore button (Ignore All skips all of the occurrences of this word during
this session of the spell checker).
–Or–
Add it to the dictionary that is selected under Add words to by clicking the Add button (for
more information on dictionaries, see "Dictionaries" on page 238).
6

According to the selection you made, the word is changed or remains unaltered and at the
occurrence of the next misspelled or unrecognized word the Check Spelling dialog opens
again.

For an in-depth discussion on spell checking options, see "Spelling Options" on page 235.
For languages that do not have a spell checking option in Déjà Vu X2 Professional, you also have
the option to use Microsoft Word’s spell checking option.
To use this option, you will have to have Word 2000 or higher as well as the
appropriate Word spell checker installed on your computer.

To spell check an open file or project with Microsoft Office’s spell checker
1

Select Tools> Options> Spelling.
–Or–
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Click on Options in the Check Spelling dialog.

2

Select Use the Microsoft Office Spell Checker.

3

When you continue with spell checking, Déjà Vu X2 Professional will automatically use the
dictionaries of the Microsoft Office spell checker for that particular language.

Loading the Microsoft Office spell checker
The very first time you started Déjà Vu X2 Professional, all the available Office spell checkers
were loaded. To avoid the rather time-consuming process of having to reload them during each
startup, they are stored. If you change your configuration of Office spell checkers (e.g., update,
add, or delete languages), these changes will not be automatically reflected within Déjà Vu X2
Professional until you select the Reload Office Proofing Tools button on the Spelling tab.
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EDITING AND PROOFING
While the previous section described ways to use the integrated proofing tools that Déjà Vu X2
Professional provides, translators typically want to edit and proof their translations manually as
well. There are several ways of doing this.

EXPORTING INTO THE ORIGINAL FORMAT FOR PROOFING
Some translators/editors prefer to see the translated text in its original format for proofing
purposes.
To do this, you can export an intermediary copy of your document(s) to use for proofing. If you
choose this option, you should be aware that:


it is important to apply all changes to the Déjà Vu project file rather than the exported
file. This is the only way to make sure that your modifications will be reflected in your
translation memory and that you will be able to benefit from that later on.
To locate segments that need to be modified, you can use the search function (select
Edit> Find, press Ctrl+F or click

).



there is certain text that you will not be able to see on the screen or in a printout copy,
including index markers or text within scripts.



this process applies more to print and desktop publishing formats than online, database,
or resource formats.

PROOFING WITHIN THE EXTERNAL VIEW FORMAT
The External View format is a format specifically created for proofing or checking unresolved issues
outside of Déjà Vu X2 Professional. This allows you to export translated and commented rows
into a tabular Word or HTML format in which proofing can be performed and outstanding
questions can be answered.
The main benefit of these formats is that they can be used across platforms and thus even by
people who could not install a copy of Déjà Vu X2 Professional. For more information on the
External View format, see "External Views" on page 262.

PROOFING WITHIN DÉJÀ VU X2 PROFESSIONAL
Many translators and editors feel that the most efficient and safe way to edit and proof a document
is directly in the Déjà Vu environment.
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Here are some of the benefits:


All translated text is visible.



All codes are protected (for more information on codes, see "Embedded Codes" on page
202).



All text is organized in the tabular database view of Déjà Vu X2 Professional that can be
viewed, sorted, and edited in all possible configurations:


You can choose to only display rows with a certain status (see "Selecting Segments
by Status" on page 62).



You can choose to display all rows alphabetically (see "To switch between natural
and alphabetic order" on page 39).



You can sort on a specific phrase or word to see the use of this phrase or word in the
entire project (see "Selecting Segments by Filtering" on page 62).



Text can be marked and displayed as pending (see "Marking Segments as Pending" on
page 251).



You can do entire database scans for a certain word if you are not sure about its use (see
"Searching the Databases" on page 139).



You can make sure that your changes are being implemented in all identical rows
through the Propagate function (see "Propagate" on page 197).

PHASE VI: EXPORT
When you are finished translating and editing your files, you will want to export them into their
original format. Déjà Vu X2 Professional offers you three different ways to do that:


you can export the complete project via the menu command Project> Export Translated
Project,



you can export single files or folders through a right-click command from within the
Project Explorer or by selecting the file or folder within the Project Explorer and selecting
Project> Export, or



you can export single files or any subset of files from the Advanced Project Explorer.

For information on exporting with the Advanced Project Explorer, see "To export files with the
Advanced Project Explorer" on page 72.
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To export files with the menu command
1

Select File> Export> Translated Project.

2

The Export Options dialog appears.

3

Under Destination, select the folder to which you want your files to be exported.

4

Under Languages, select the languages you want to export.

5

If applicable, you can define filter-specific options for the files within your project under
Filter-specific Options. For information about these options, see the respective sections in
"Working with Different File Formats" on page 289.
If your project contains several file types with filter-specific export options, all sets of options
will be listed and you will have to make sure that you set all available options.

6

Select OK.

7

Déjà Vu X2 Professional will verify if there are any discrepancies


in embedded codes (see p. 206) and/or
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spaces at the end of segments.
If Déjà Vu X2 Professional finds a discrepancy in spaces following periods, question
marks, or exclamation marks, it will offer to automatically fix that discrepancy.

8

For each language you are exporting, Déjà Vu X2 Professional will create a subfolder inside
the export folder, named after the code for the specific locale of that target language. For
example, if you were translating the file into German (Germany), the new folder would be
called C:\My Projects\DE_DE.

To export files with the right-click command in the Project Explorer
1

Right-click on any single file or folder or the complete project in the Project Explorer.

2

Select Export Translated File.
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3

The Export Options dialog appears.

4

Under Destination, select the folder to which you want your files to be exported.

5

Under Languages, select the languages you want to export.

6

If applicable, you can define filter-specific options for the files within your project under
Filter-specific Options. For information about these options, see the respective sections in
"Working with Different File Formats" on page 289.

7

Select OK.

8

Déjà Vu X2 Professional will verify if there are any discrepancies


in embedded codes (see p. 206) and/or

Déjà Vu X2

133

134



spaces at the end of segments.
If Déjà Vu X2 Professional finds a discrepancy in spaces following periods, question
marks, or exclamation marks, it will offer to automatically fix that discrepancy.

9

For each language you are exporting, Déjà Vu X2 Professional will create a subfolder inside
the export folder, named after the code for the specific locale of that target language. For
example, if you were translating the file into German (Germany), the new folder would be
called C:\My Projects\DE_DE.
If your project contained a complete folder, Déjà Vu X2 Professional will recreate the
structure of that folder with all of its subfolders, containing all the files you have translated.
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TRANSLATION FEATURES IN DÉJÀ VU X2 PROFESSIONAL—THE DETAILS
While many of Déjà Vu X2 Professional’s features were discussed or mentioned in the previous
two chapters ("The Déjà Vu X2 Professional Interface" on page 21 and "Workflow" on page 77),
these and other features are presented in this resource chapter in more in-depth manner:


Database Performance on page 135



Searching the Databases on page 139



Assemble on page 149



The DeepMiner Engine on page 152



AutoWrite on page 166



Machine Translation on page 160Sending Text to the Databases on page 169



Clients and Subjects on page 174



Propagate on page 197



Pseudotranslation on page 200



Embedded Codes on page 202



Context View on page 210



Conversions on page 211



Copying and Populate on page 213



Sentence Delimitation on page 215



AutoText on page 220



AutoCorrect on page 225



Common Windows Functions on page 229

DATABASE PERFORMANCE
It is important to understand that all the different file formats that you can create and work in with
Déjà Vu X2 Professional are databases that are based on Microsoft’s Jet database engine version
4.0.
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This is important for several reasons:


The databases are accessible with standard SQL (Structured Query Language)
commands. This means that the only limitation to the way you can modify databases is
your own creativity (and SQL knowledge).



The data exchange between the Déjà Vu X2 Professional databases and other formats is
very advanced. You can import and export into many of the formats supported by the Jet
engine as well as a number of translation-specific formats (Trados Workbench, TMX).



Because each of the files, including the Déjà Vu project files, are databases, a great
variety of sorting, filtering, and batch processing options are available.



Many of the standard Jet engine utilities such as Compact Database and Repair Database
are available for each of the components, as well as a great number of third-party
utilities.

REPAIRING AND COMPACTING FILES
Each of the file types that are supported by Déjà Vu X2 Professional (project and satellite files,
termbases and translation memories, as well as SGML/XML filters) can be compacted, and almost
all can be repaired.

To compact a file
Because Microsoft’s Jet engine handles data by allocating unnecessary disk space, any of the files
in question can grow very large. To save disk space and increase performance, it is advisable to
compact the files at regular intervals. The result can be very impressive as files can be shrunk to a
third or more of their original size. It specifically makes sense to compact a database, after you
have performed the following actions:


deleted a large number of examples from an SGML/XML file



deleted a large number of lexicon entries from a project file



deleted one or several files from a project



added a large amount of data to any file



deleted any subset of data from a termbase or translation memory

1

Select Tools> Compact> Project/Translation Memory/Termbase/Filter from anywhere within
Déjà Vu X2 Professional.

2

Select the project/satellite/translation memory/termbase/SGML filter file and click Open.
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3

The compact process will start and Déjà Vu X2 Professional will notify you upon completion.
Depending on the size of the original file, this process can take several minutes.
When compacting a file, data will be written to a new temporary file which is then
copied back to the original file. This means that to successfully compact files, you need
to have the necessary disk space for the temporary file.

To repair a corrupted file
Repairing is necessary when a database file has become corrupted, probably because of an
abnormal program ending caused by a power outage or by hardware problems.
1

Select Tools> Repair> Project/Translation Memory/Termbase from anywhere within
Déjà Vu X2 Professional.

2

Select the project/translation memory/termbase file and click Open.

3

The repair process will start and Déjà Vu X2 Professional will notify you upon completion.
This procedure involves time-consuming processes such as re-indexing the complete
database and removing invalid entries. Depending on the size of the original file, this
process can take a significant amount of time.
When repairing a file, data will be written to a new temporary file which is then copied back to the
original file. This means that to successfully repair files, you need to have the necessary disk space
for the temporary file.

FUZZINESS SETTING
It is important for you to be able to control the level at which you want the databases to interact
with your translation project. This level is generally called fuzziness, i.e., the degree of similarity of
a database match to the original.
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To set the fuzziness setting
1

Select Tools> Options> General.

Under Database Lookups, you can determine


how you want to sort your matches:

by the order of the translation memories and termbases that you have set under
Project> Properties> Databases.
–Or–
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by the age of your database entries (i.e., whether older or newer database matches are
preferred),
This setting only comes into effect when all other settings are of identical match quality,
including sub-languages, client, and subject. If one match has the same fuzziness but a
better matching sub-language, client, or subject, it will be preferred over the others
regardless of their ages or database origin.


whether the search operations for partial matches (single words or phrases that are
displayed in the AutoSearch window or inserted in the Assemble features) are also
be performed with a fuzzy index, and



what kind of Minimum Score (i.e., degree of fuzziness as a percentage) the matches
are supposed to have to be used.
The setting under Minimum Score will depend on your personal preference and the
quality and extent of your databases. While the default setting is 75%, many users with
extensive translation memories prefer a higher setting, while others try to benefit as
much as possible from whatever they have in their translation memories.

2

Make the desired settings and click Apply and/or OK.

SEARCHING THE DATABASES
There are several ways to search for a segment in your memory and termbases. Déjà Vu X2
Professional uses the terms scan for searching the translation memories and lookup for searching
the termbases.
Typically, you pull data from your databases on the fly, i.e., as you translate. In the previous
chapter you were introduced to:


Pretranslation (see "Phase III: Pretranslation" on page 101)—the process of batch
leveraging data from your databases against your project.



AutoAssemble (see "AutoAssemble" on page 106)—the process of automatically inserting
applicable data from your databases as you go from one segment to the next.



AutoSearch (see "AutoSearch" on page 107)—the process of automatically displaying all
applicable data from your databases in the AutoSearch window and making this data
easily accessible with mouse clicks or shortcut keys.

There are times, however, when none of the above options is applicable or you want to
concordance search for only one subset of a segment.
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SCANNING THE TRANSLATION MEMORIES
To manually scan the translation memory(s)
1

If you want to scan for a part of a segment, select the text you want to search for in the source
segment. If you want to scan for the whole segment, do not select any text.

2

On the Translation menu, click Scan.
–Or–
Press Ctrl+S.
–Or–
Click the

3

button on the toolbar.

If Déjà Vu X2 Professional finds any matches in the translation memory, the Scan Results
dialog appears.

The Scan Results dialog consists of the following elements:
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Sought Source—The source language segment (or portion) you were searching for. Any words
that are different from the match in the translation memory will be marked red.
Proposed Translation—The target language segment found in the translation memory with
any changes that Déjà Vu X2 Professional has applied to it. This field can be edited.segment
Found Source—The source language segment (or portion) that was found in the translation
memory. Any words that are different from the segment you are looking for will be crossed
out.
Found Target—The target language segment found in the translation memory.
Matches—A list containing all the matches found by Déjà Vu X2 Professional, with their
corresponding translations. The matches are sorted primarily by their fuzziness percentage
and secondarily by other criteria (subject, client, date, etc.). If you would like to review other
matches, you can navigate through the list of matches by using the table’s scrollbar or the
following keystrokes:


Ctrl+PageDown to go to the end of the list.



Ctrl+PageUp to go to the beginning of the list.



Ctrl+DownArrow to go to the next match.



Ctrl+UpArrow to go to the previous match.

Under the Matches list you can see information about the currently selected match, including
Score (the percentage of fuzziness), Subject, Client, Database (origin of match), Date (date
and time the record was entered into translation memory), and User (who entered the term
into the translation memory).
The buttons to the right have the following function:


Replace—Replaces the text in the current target cell with the proposed translation.



Close—Closes the dialog without any changes.



Insert <<—Inserts the proposed translation to the left of any existing text in the
current target cell (this button is only displayed if there is some text in the current
target cell).



Insert >>—Inserts the proposed translation to the right of any existing text in the
current target cell (this button is only displayed if there is some text in the current
target cell).



Copy—Copies the proposed translation to the Windows clipboard.
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Power Scan—Launches the Power Scan feature that will do another deeper search
in the translation memory. The regular Scan feature saves time by not displaying
fuzzy matches when an exact match is found. Power Scan will perform a new scan,
resulting in matches in which single words will be displayed in context even if exact
matches are found. The total number of matches that can be shown is not limited in
this case.
The Power Scan feature is especially helpful when scanning for single words or short
phrases.

4

Review the proposed translation, considering the information from the Sought Source and
Found Source fields and, if applicable, scroll down the list of matches and select a different
match.

5

Make any necessary changes in the Proposed Translation text box and select the appropriate
insertion button.
If you have searched for a complete segment and found a match for that, you will
probably want to select the Replace button. If you have searched for only a part of the
segment, it would probably be a better choice to insert the match to the left or right of
the current target, or copy it to the clipboard to paste it into the target with one of the
standard paste features.

6

The dialog closes and the match is inserted into the current target cell.

To scan with wildcards
To widen the scope of your searches, you can use wildcards at the end of text you are looking for.
The wildcards you can use to build search patterns are:


* — zero or more characters



? — one character



# — one digit



[a-m] — one character in the specified range



[!a-m] — one character outside the specified range

Examples:
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Kind of Match

Pattern

Match

No Match

Multiple characters

a*a

aa, aBa, aBBBa

aBC

Multiple characters

*ab*

abc, AABB, Xab

aZb, bac

Multiple characters

ab*

abcdefg, abc

cab, aab

Special character

a[*]a

a*a

aaa

Single character

a?a

aaa, a3a, aBa

aBBBa

Single digit

a#a

a0a, a1a, a2a

aaa, a10a

Range of characters

[a-z]

f, p, j

2, &

Outside a range

[!a-z]

9, &, %

b, a

Not a digit

[!0-9]

A, a, &, ~

0, 1, 9

Combined

a[!b-m]#

An9, az0, a99

abc, aj0

1

Select a part of the text that you would like to search for.

2

Right-click on the selection and select Scan with Wildcards.
–Or–
Press Ctrl+Shift+S.
–Or–
Select Translation> Scan with Wildcards.

3

The Enter Search Expression dialog appears, displaying the selected text.

4

Enter the wildcard(s).
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5

Click OK.

6

The Scan Results dialog appears with all matches that Déjà Vu X2 Professional has found in
the associated translation memories.

7

For information on how to insert a match, see "To manually scan the translation memory(s)"
on page 140.

Scan is one of the most helpful and frequently used functions in Déjà Vu X2 Professional.
The Scan Results dialog will also display matches that have been turned from fuzzy to
perfect matches with the help of Déjà Vu X2 Professional’s DeepMiner fuzzy repair
feature.

LOOKUP IN THE TERMBASES
To lookup a term in the termbases
In the same way that you can scan the translation memories for a segment or a part of a segment,
you can search the termbases for data.
1

Select the term you want to look up.
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2

On the Translation menu, click Lookup.
–Or–
Press Ctrl+L.
–Or–
Click the

3

button on the toolbar.

If Déjà Vu X2 Professional finds any matches in the termbases, the Terminology Lookup
dialog appears.

The Terminology Lookup dialog consists of the following elements:
Source—The source language terms you were searching for.
Target—The target language term found in the termbases.
Source Attributes—A list of all attributes that were entered for the source term.
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Target Attributes—A list of all attributes that were entered for the target term.
For information on how to set up attributes, please see "Templates" on page 456.

If you would like to review other matches, you can navigate through the list of matches by
using the table’s scrollbar or the DownArrow and UpArrow keys.
Under the Attributes you can see information about the currently selected match, including
Date (date and time the record was entered into termbase), Subject, Client, Database (origin
of match), and User (who entered the term into the termbase).
The buttons to the right have the following function:


Insert—Replaces the text in the current target cell with the proposed translation.



Close—Closes the dialog without any changes.



Insert <<—Inserts the proposed translation to the left of any existing text in the
current target cell (this button is only displayed if there is some text in the current
target cell).



Insert >>—Inserts the proposed translation to the right of any existing text in the
current target cell (this button is only displayed if there is some text in the current
target cell).



Copy—Copies the proposed translation to the Windows clipboard.

4

Review the proposed translation and, if applicable, scroll down the list of matches and select
a different match.

5

Select the appropriate insertion button.

6

The dialog closes and the match is inserted into the current target cell.

To lookup with wildcards
To widen the scope of your searches, you can use wildcards at the end of text you are looking for.
The wildcards you can use to build search patterns are:


* — zero or more characters



? — one character
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# — one digit



[a-m] — one character in the specified range



[!a-m] — one character outside the specified range

Examples:

Kind of Match

Pattern

Match

No Match

Multiple characters

a*a

aa, aBa, aBBBa

aBC

Multiple characters

*ab*

abc, AABB, Xab

aZb, bac

Multiple characters

ab*

abcdefg, abc

cab, aab

Special character

a[*]a

a*a

aaa

Single character

a?a

aaa, a3a, aBa

aBBBa

Single digit

a#a

a0a, a1a, a2a

aaa, a10a

Range of characters

[a-z]

f, p, j

2, &

Outside a range

[!a-z]

9, &, %

b, a

Not a digit

[!0-9]

A, a, &, ~

0, 1, 9

Combined

a[!b-m]#

An9, az0, a99

abc, aj0

1

Select a part of the text that you would like to search for.

2

Right-click on the selection and select Lookup with Wildcards.
–Or–
Press Ctrl+Shift+L.
–Or–
Select Translation> Lookup with Wildcards.

3

The Enter Search Expression dialog appears, displaying the selected text.
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4

Enter the wildcard(s).
.

5

Click OK.

6

The Terminology Lookup dialog appears with all matches that Déjà Vu X2 Professional has
found in the associated termbases.

7

For information on how to insert a match, see "To lookup a term in the termbases" on page
144.
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ASSEMBLE
When scanning (see "To manually scan the translation memory(s)" on page 140) does not find a
match, you can ask Déjà Vu X2 Professional to assemble a translation from smaller pieces that
can be found in the project lexicon, termbases, and the translation memories (in this order if the
similarity and other properties are equal).
Unlike with AutoAssemble (see "AutoAssemble" on page 106) or the assemble process during
pretranslation ("To pretranslate a project" on page 101), this process is started manually.

To manually assemble a translation for a single segment
1

Select the segment you want to assemble a translation for.
On the Translation menu, click Assemble.
–Or–
Press Ctrl+A.

2

Déjà Vu X2 Professional will insert all relevant portions into the target segment along with a
blue status indicator to signify that this segment has been assembled.

3

If Déjà Vu X2 Professional finds more than one match for any of the portions in the source, it
will fill in the match with the highest fuzziness rate and underline and color-code it.
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4

Right-clicking that portion will display a context menu with the other possibilities.

5

You can choose to accept Déjà Vu X2 Professional’s choice or select one of the other
choices by selecting it in the context menu.
Déjà Vu X2 Professional will also attempt to copy embedded codes from the source to
the target segment, particularly when it finds those at the beginning and/or end of the
segment or around portions that it "knows" from any of the databases.

To adjust the assemble settings
1

Select Tools> Options> General.
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2

The General tab in the Options dialog is displayed.

The options under Assemble include:


First scan for whole segment—Instructs Déjà Vu X2 Professional to first look for a
match for the complete segment in the translation memory before it assembles the
segment. In general, this option should be enabled.



Accept only exact matches when scanning—Instructs Déjà Vu X2 Professional to
reject fuzzy matches from the translation memory(s) because assembling from
portions is expected to yield better results. In general, this option should be
disabled.



Use Machine Translation for whole segments—Instructs Déjà Vu X2 Professional to
use Machine Translation instead of assemble.
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For Portions Not Found in Databases: Use DeepMiner Engine—For the DeepMiner
function see p. 152.



For Portions Not Found in Databases: Use Machine Translation—For the machine
translation function see p. 160.



For Portions Not Found in Databases: Insert Source Text—This will make
Déjà Vu X2 Professional insert unknown words into the target as they appear in the
source text. This option should be enabled if your text contains a great amount of
non-translatable words such as product names or if you prefer to overtype text as
you translate.



Allow portions containing commas—With this option enabled, Déjà Vu X2
Professional will also consider portions with commas in its assemble processes. This
option will slow down the assemble process.

Make the desired settings and click Apply and/or OK.

To quickly change the order of words
If a segment is assembled from a great number of portions, the word order may need to be
changed. Déjà Vu X2 Professional offers several keyboard shortcuts to quickly change the word
order.
1

Select the word or phrase which you would like to move to another position within the
segment.

2

Press Ctrl+Shift+N to move the selected word or phrase forward one word at a time.
Pressing Ctrl+Shift+N will continue to move the selected word or phrase forward.
–Or–
Press Ctrl+Shift+B to move the selected word or phrase one word backward. Pressing
Ctrl+Shift+B again will continue to move the selected word or phrase backward.

THE DEEPMINER ENGINE
Déjà Vu X2 Professional’s DeepMiner engine allows you to unearth content from your translation
memories that would otherwise be hidden.
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A translation memory in its simplest form is nothing more than a collection of translated segments
that occur most typically in sentence form. Some kinds of texts have a fairly high degree of
repetition, including instructional text, legal boiler plates, and certain medical phrasing, but the
repetition in the majority of texts does not happen on the sentence level. To get to that deeper
kind of content, the DeepMiner engine processes the translation memories that are attached to a
project to "discover" and present you with parts of segments that you can use for your translations.
How does it do that? In the simplest form: by using mathematical calculations!
The engine is able to isolate a certain phrase or word within a source segment if that word or
phrase is also used in other segments.
There are various uses for this feature within Déjà Vu X2 Professional:


Repairing of fuzzy matches during translation or pretranslation



Assemble matches during translation or pretranslation



Extension of suggestion with the AutoWrite feature (see "AutoWrite" on page 166)

REPARING OF FUZZY MATCHES
This is our source document:

It’s not a very weighty text, but it has no repetition on a segment level though it does contain
repeated terminology (black, cat, brown).
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Since there is no content in our translation memory or termbase, we need to start translating from
scratch. For the first few segments we might get some help from AutoWrite (see "AutoWrite" on
page 166), but the translation memory does not bear much automated help:

However when we come to the last segment—which is a fuzzy match—we can see that the fuzzy
match was automatically "corrected" and turned into a perfect match (even though the status
indicator to the left of the target segment still displays it as a fuzzy match):
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What happened?
Since both black and brown and their translations were repeated at least twice in the previous
segments and then all sent to the translation memory, Déjà Vu X2 Professional’s DeepMiner
engine was able to determine which term was to be deleted from the fuzzy match ("schwarz") and
which term it should be replaced with (braun). While this might not sound special at first, think
about it: only four segments ago, Déjà Vu X2 Professional "knew" nothing about the source and
target languages; now it has "figured" out the translation of these two terms even though the user
has never specifically entered that information (only indirectly as part of a segment).
In earlier versions of Déjà Vu, this self-repairing feature relied on what was entered into the
termbases or lexicon; now the information is also generated from the translation memories.

ASSEMBLE AND THE DEEPMINER ENGINE
We can take the use of the DeepMiner engine one step further, though. Let’s imagine this
document has an additional segment:
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We can see that there is no fuzzy match that can be "repaired," but by using the Assemble features
(see "Assemble" on page 149) we are still getting to the content in the TM even though nothing is
shown in the AutoSearch window:

To enable the assemble feature of the DeepMiner feature, see p. 159.
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To activate the DeepMiner engine for fuzzy match repair
1

Select Tools> Options> General.

2

Select Use DeepMiner engine under For Fuzzy Match Repair.

3

Click Apply and/or OK.

To activate the DeepMiner engine for fuzzy match repair during pretranslation
1

On the Translation menu, click Pretranslate.
–Or–
Press Ctrl+P.
–Or–
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Click the

button on the toolbar.

2

The Pretranslate dialog appears.

3

Unselect Accept only exact matches.

4

Select Use DeepMiner engine.

5

Click OK.
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To activate the DeepMiner engine for assembling matches
1

Select Tools> Options> General.

2

Select Use DeepMiner engine under For Portions Not Found in Databases.

3

Click Apply and/or OK.

To activate the DeepMiner engine for assemble during pretranslation
1

On the Translation menu, click Pretranslate.
–Or–
Press Ctrl+P.
–Or–
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Click the

button on the toolbar.

2

The Pretranslate dialog appears.

3

Unselect Accept only exact matches.

4

Select Assemble from Portions> Use DeepMiner engine.

5

Click OK.

MACHINE TRANSLATION
The demand for a machine translation feature within Déjà Vu X2 Professional has seen a
significant rise. At the same time, the availability and quality of machine translation output has
increased. The quality of the output of some machine translation engines is at a point that some
professional translators find it helpful for some language combinations and subject matters as a first
gist translation that will have to be post edited.
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Also, due to some of Déjà Vu X2 Professional’s unique features, such as assemble and fuzzy
match repair, there are particular usage cases for machine translation in Déjà Vu X2 Professional
that might make its use a real productivity gain.
Independent of the machine translation engine you might want to use, please
remember that results vary greatly according to language combination. While some
language combination might have some usefulness others will not.
Google Translate in its present form supports more than 60 languages and through the use of
"bridge languages" close to 4000 language pairs, but only a small group of those may prove to be
useful for the professional translator.
Lastly, you also need to be aware that some clients might not permit the use of online-based
machine translation engines such as Google Translate because of the potential security risk: every
text segment that is sent to these engines stays in their possession.

There are three different kinds of usage cases for machine translation in Déjà Vu X2 Professional:


Machine translation of individual segments



Machine translation to repair fuzzy matches



Machine translation as part of the assemble process

To translate individual segments with the help of machine translation
1

While you are in the segment you want to machine translate, press Ctrl+G
- Or Select Translation> Translate with Google Translate.

2

The machine translation is entered into the target segment and the status indicator changes to
auburn.
This options overwrites any other possible translations or fragments you might gain from
your own databases, so make sure to use this option only if you know that you will
benefit more from the machine-translated content than from your own materials.
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To activate machine translation for fuzzy match repair
The fuzzy match repair feature allows you to fill in parts of a segment that cannot be translated by
your own resources (translation memory, termbase, lexicon) with the help of machine translation.
In any of the fuzzy repair options, you also have the opportunity to activate the
DeepMiner engine. If there are DeepMiner results available they will always take
preference over the machine translation results.

1

To activate, select Tools> Options> General.

2

Select Use Machine Translation under For Fuzzy Match Repair.
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3

Click Apply and/or OK.
If you also check the DeepMiner engine in this dialog, it will take preference over the
machine translation function if there are DeepMiner results available.

To activate machine translation for fuzzy match repair during pretranslation
1

On the Translation menu, click Pretranslate.
–Or–
Press Ctrl+P.
–Or–
Click the

button on the toolbar.

2

The Pretranslate dialog appears.

3

Unselect Accept only exact matches.

4

Select Use Machine Translation.
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5

Click OK.

To activate machine translation for assembling matches
1

Select Tools> Options> General.

2

Select Use Machine Translation under For Portions Not Found in Databases.

3

Click Apply and/or OK.
You can also use machine translation as the primary translate option. To do that, select
Use Machine Translation for whole segments.
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To activate machine translation for assemble during pretranslation
1

On the Translation menu, click Pretranslate.
–Or–
Press Ctrl+P.
–Or–
Click the

button on the toolbar.

2

The Pretranslate dialog appears.

3

Unselect Accept only exact matches.

4

Select Assemble from Portions> Use Machine Translation.

5

Click OK.
You can also use machine translation as the primary translate option. To do that, select
Use Machine Translation for whole segments.
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AUTOWRITE
Déjà Vu X2 Professional’s AutoWrite feature serves two purposes: as a productivity boost and as a
feature to increase consistency within your translation.
Much like the AutoComplete feature from Microsoft Excel or the address bar of your browser,
AutoWrite predicts the text you are entering based on the first couple of keystrokes. The difference
is that it does not just base the prediction on the current project but on the associated translation
memories, termbases, and the lexicon.
In suggesting the list of AutoWrite suggestions, Déjà Vu X2 Professional looks at the following
criteria and accordingly gives them a preferential treatment:


occurrence in the current project



similarity of subject



client match



occurrence in a database (preferred order: lexicon, termbase, translation memory)



age of record



DeepMiner results
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The suggestions will come up right underneath your cursor as you type. You can select them by
going down the list with the down-arrow key or with the mouse and enter them by pressing the
Enter button.

If none of the suggestions is helpful, or if you decide that it’s faster to type rather than enter any of
the suggestions, you can keep on typing. The AutoWrite suggestion will continue to change and be
further filtered down with every additional keystroke you make:
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If you have the DeepMiner engine enabled, you will receive a greater number of suggestions
based on the parameters with which it extracts additional and deeper lying data from the
translation memories.

To enable AutoWrite
1

Select Tools> Options> Environment> AutoWrite.

- Or 2

Click on the AutoWrite button

in the status bar.
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SENDING TEXT TO THE DATABASES
SENDING INFORMATION TO THE TRANSLATION MEMORY
If you send information to the translation memory(s), your records not only contain source and
target text, but also a date/time stamp, subject and client (if enabled), and user name, as well as
various other project-specific data.
By default, Déjà Vu X2 Professional will only store unique segment pairs in the translation
memory to allow for a smaller size of the translation memory.
There are several options for sending records to the translation memory within Déjà Vu X2
Professional:


automatically during the translation with the AutoSend option (see "AutoSend" on
page 111).

–Or–


manually for every single segment or in a batch process.

MANUALLY SENDING SEGMENT PAIRS TO THE TRANSLATION MEMORY
To send a segment pair to the translation memory
After you have translated and/or edited a segment in Déjà Vu X2 Professional, click Add Pair
to Translation Memory on the Translation menu.
–Or–
Press F12.
–Or–
Click the

button on the toolbar.

If you send a segment pair to the translation memory multiple times, earlier instances of
that specific segment pair will be overwritten. If you prefer to have two different
translations in your translation memory instead of only the most current one, you can
highlight the source and target segment and then send it. That way it will not overwrite
earlier entries.
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To send only a portion of the segment pair to the translation memory
1

Select the portion of the source segment and the portion of the target segment that you want
to send to the translation memory.

2

On the Translation menu, click Add Pair to Translation Memory.
–Or–
Press F12.
–Or–
Click the

button on the toolbar.

To send the whole project to the translation memory
1

On the Project menu, click Add Project to Translation Memory.
–Or–
Press Alt+F12.
–Or–
Click the

button on the toolbar.
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2

The Send Project to Translation Memory dialog appears, offering you the following options:



Select whether you want to send the currently selected language or all the target
languages for the project.



Select whether you want to send any segment with a status other than the default
options Finished Segments or Unmarked manual translation.



Limit to current record selection allows you to select a certain section of a file to
send to the memory database. For more information on how to select a certain
subset of rows, see "Selecting Segments" on page 61.



Delete all pairs previously sent from this project deletes everything in the translation
memory that has been sent from the current project at an earlier time. You will not
need to use this option if you just resend your project to the translation memory as
all updated lines will overwrite earlier instances by default.
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3

Click OK.
If you send a project/file to the translation memory, earlier instances of the segment
pairs within that project/file you have already sent will be overwritten. Déjà Vu X2
Professional is able to recognize earlier instances by assigning unique project, file, and
segment IDs to each segment pair in the translation memory. If a file within a project is
deleted and a new file is imported, the same project, file, and segment IDs could be assigned to
the new file, resulting in the deletion of anything sent from the earlier file to the associated
translation memory. To avoid this, you should create new projects for your newly translatable files.

To prevent a segment from being sent to the translation memory
1

If you would like to single out certain rows (for instance, rows that contain code information)
that you do not want to be sent to your translation memory, you can right-click the segment
or the selection of segments you do not want in the translation memory and click Do Not
Send.
–Or–
Press Ctrl+Shift+D.

2

The Do Not Send symbol (

) appears in the target cell.

To remove the Do Not Send status
1

Select the segment you want to mark as normal.

2

Right-click the segment table and click Do Not Send.
–Or–
Press Ctrl+Shift+D.

3

The

symbol disappears.

SENDING INFORMATION TO THE TERMBASE
For more information on sending terms to the termbase, see "Adding Terms to the Termbase" on
page 112.

SENDING INFORMATION TO THE LEXICON
For more information on sending terms to the lexicon, see "To manually add entries to the lexicon"
on page 379.
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LOCKING SEGMENTS
It is possible to lock rows in the project so that you cannot accidentally change their target text.

To lock a group of segments
1

Select the segment(s) you want to lock.
For information on how to select rows, see "Selecting Segments in the Selection Mode"
on page 61.

2

Right-click the selection and select Segment Status> Locked (

).

–Or–
Press Ctrl+Shift+K.

To unlock a group of segments
1

Select the segment(s) you want to unlock.

2

Right-click the selection and remove the checkmark from Segment Status> Locked (
clicking on it.

) by

–Or–
Press Ctrl+Shift+K.
Target text in locked rows is protected against any modification.
This feature can be very helpful if you want to exclude a certain subset of rows for your
view. You can lock these rows and then select All Except Locked Segments in the
Segment Selector (see "The Segment Selector" on page 40).

MODIFYING AND DELETING DATABASE RECORDS IN THE AUTOSEARCH WINDOW
The primary use of the AutoSearch window is to give you a view of and easy access to the relevant
contents of your databases (see "The AutoSearch Window" on page 33). However, as you view
your database records you will often notice mistakes that need to be corrected or records that
need to be deleted altogether.
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To modify database records in the AutoSearch window
1

Select the record in the AutoSearch window that needs to be modified and switch into edit
mode by pressing the Enter key.

2

Make the necessary modifications.

3

Leave the edit mode by hitting the Esc key.

To delete database records in the AutoSearch window
1

Select the record in the AutoSearch window that needs to be deleted.

2

Press the Delete key.
–Or–
Select Edit> Delete.
–Or–
Click the

button on the toolbar.

–Or–
Right-click on the record and select Delete.

CLIENTS AND SUBJECTS
Déjà Vu X2 Professional has several ways to add additional information to the source and target
segments in the termbase and translation memory. While some of that additional information is
completely configurable for the termbases (see "Templates" on page 456), there is only a limited
and pre-defined number of fields that can be added to the translation memories.
These include:


User—the name or nickname of the user who entered that record into the translation
memory.



Date/Time stamp—the date and time the record was entered into the translation
memory or termbase.



Project ID—the preassigned 7-digit project ID of every project file that accompanies
every record that is entered from that project into the translation memory.



File ID—the name of the file that the translation originated from.

Déjà Vu X2

174

Translation Features in Déjà Vu X2 Professional—The Details


Subject—the user-assigned subject, or topic, of a record. This can be entered into the
translation memories and termbases through the subject of a current project or manually.



Client—the user-assigned client of a record. This can be entered into the translation
memories and termbases through the client of a current project or manually.

This additional information provides you with helpful data about each of these records when they
are displayed in any of the database views, it allows you to specify subsets of your databases for
exporting purposes, and it allows Déjà Vu X2 Professional to make choices when determining
what match to use in any of its automated translation processes.
First and foremost, Déjà Vu X2 Professional will use similarity, or the degree of fuzziness, to
decide which match to choose over another. However, with large databases, Déjà Vu X2
Professional will often encounter situations where there are two or more different perfect matches
or matches of the same fuzziness. In these situations, the program will use sophisticated algorithms
to decide which of these matches to choose.
The hierarchy in which Déjà Vu X2 Professional will decide on the match is as follows:
1

fuzziness

2

target sub-language (see p. 87)

3

client

4

subject

5

source sub-language (see p. 87)

6

case similarity (Atril vs. atril vs. ATRIL)

7

age (see p. 139)

The logic follows an exclusionary scheme: If the fuzziness of one match is of a higher percentage
than that of another, the more identical match will be preferred, regardless of any other setting. If
the match quality of the two matches is identical, and one has the same target sub-language as the
source segment but the other has a differing sub-language (French (Standard) vs. French (Belgian),
for instance), the one with identical target sub-languages would be preferred, regardless of any
other setting, and so on.
Regardless of Déjà Vu X2 Professional’s choice for a match, the other matches are
always available in case you want to override Déjà Vu X2 Professional’s decision.
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STORING THE CLIENT AND SUBJECT SETTINGS
The client and subject settings, along with settings for AutoText, AutoCorrect, and segment
delimitation (see p. 220, p. 225, and p. 215), are automatically stored in the settings.dvset file. In
the default setting, this file is located in the Déjà Vu X2 Professional installation folder (on an
English Windows system typically at C:\Program Files\ATRIL\Deja Vu X).
If you work with other users over a network on the same file and/or databases, you should save
this file to an accessible point on the network and have the different Déjà Vu X2 Professional
installations access that file by selecting Tools> Options> General.

Clicking on Shared settings location under Miscellaneous displays an activated file selector with
which you can select a path to the new location.

Déjà Vu X2

176

Translation Features in Déjà Vu X2 Professional—The Details

WORKING WITH CLIENTS
Under Tools> Options> Clients, you will see a sample list of clients that are associated with
individual numeric codes.

You can also assign non-numeric codes to clients.

You can assign clients directly to database records during import and align processes or to
individual records in the termbase or translation memory view, but most commonly you assign
them to records through your project files. Every language pair record that you send to the
databases from your project will by default have the client that you assigned in the project.

To assign clients to a project file
1

In the open project file, select Project> Properties> General.
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–Or–
Right-click the project icon in the Project Explorer and select Properties.
2

The General tab of the Project Properties dialog appears.

You can see that the project name (the name of the project file), the Type of Project (whether
it is a normal or a satellite project), and the Project ID are automatically filled in. You will have
to select Client and Subject.
3

Click on the down arrow in the Client line.
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4

The list of clients opens.

5

Select the client of your project and do the same with the Subject field.

6

Click OK.

To add clients to the list of clients
1

Enter a new code into the Code field.
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2

Enter a name into the Name field.

3

Click the Add button which is now activated.
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4

The new client has been added to the list.

5

Click Apply.

To import clients from Déjà Vu 3
1

Select Import in the lower left corner of the Options dialog.
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2

The Import DV3 Settings dialog appears.

3

Under Clients, you can select to import clients by either deleting or overwriting existing
clients (if applicable).

4

Click OK.

To modify clients in the list of clients
1

Highlight the record that you want to modify.
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2

Change the name in the Name field.

3

Click the Replace button which is now activated.
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4

The changed client now appears in the list.

5

Click Apply.

To delete clients from the list of clients
1

Highlight the record that you want to delete.

2

Click Delete.

3

The record is deleted from the list.

4

Click Apply.

To find a client in the list of clients
1

Enter any digit that is contained in the code or any character that is contained in the client
name into the Filter field.
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2

The records that match the find sequence are displayed

You can use wildcards when looking for clients (for more information on wildcards, see
"To scan with wildcards" on page 142).
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Managing Clients—Tips and Tricks
The most important rule about clients is to apply them to every translation project and each other
entry in the databases.
If you work within a large organization, instead of "company clients" it may make sense for you to
use "department clients," or any other category that makes sense for your particular situation.
If you work as a freelancer, you should always use the end client (i.e., the company that the
translation is actually produced for), even if that differs from the organization that you are directly
performing your services for (a translation vendor, for instance). If you are performing legal,
medical, and technical translations for one translation vendor, the client field becomes useless and
potentially distorting if you use the name of the translation vendor rather than the end client’s
name.
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Under Tools> Options> Subject, you will see that each of the listed subjects is associated with a
numeric code. These codes are organized in a hierarchical structure of main topics and subtopics.
You can also assign non-numeric codes to subjects, but this will result in the loss of the
hierarchical structure.
The preset subjects and clients that come with Déjà Vu X2 Professional represent the
UDC list. UDC stands for "Universal Decimal Classifications" and is the most commonly used
bibliographic system. For more information about UDC, see www.udcc.org.

The code 6, for instance, is the code for Applied sciences. Medicine. Technology, of which 61,
Medical sciences, is a subcategory, of which 611, Anatomy. Human and comparative anatomy, is
yet another subcategory.
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Déjà Vu X2 Professional’s matching algorithms would recognize that a record with the associated
code 611 is closer to the code 61 (of which it is a subcategory) than for instance to 62 (of which it
is not a subcategory) or even to 6 (of which it is only a subcategory of a subcategory). 611 is more
closely related to 61, 62, or 6 than, for instance, to 7 (The Arts).
This means that the more sophisticated your system of classification is, the more precise
the matches will be that Déjà Vu X2 Professional will be using.

You can assign subjects directly to database records during import and align processes or to
individual records in the termbase or translation memory view, but most commonly you assign
them to records through your project files. Every language pair record that you send to the
databases from your project will by default have the subject that you assigned in the project.

To assign subjects to a project file
1

In the open project file, select Project> Properties> General.
–Or–
Right-click the project icon in the Project Explorer and select Properties.
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2

The General tab of the Project Properties dialog appears.

You can see that the project name (the name of the project file), the Type of Project (whether
it is a normal or a satellite project), and the Project ID are automatically filled in. You will have
to select Client and Subject.
3

Click on the down arrow in the Subject line.
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4

The list of subjects opens.

5

Select the subject of your project and do the same with the Client field.

6

Click OK.

To add subjects to the list of subjects
1

Enter a new code into the Code field.
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2

Enter a description into the Description field.

3

Click the Add button which is now activated.
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4

The new category, in this case a subcategory to 611, Anatomy, has been added to the list.

5

Click Apply.

To import subjects from Déjà Vu 3
1

Select Import in the lower left corner of the Options dialog.
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2

The Import DV3 Settings dialog appears.

3

Under Subjects, you can select to import subjects by either deleting or overwriting existing
subjects.

4

Click OK.

To modify subjects in the list of subjects
1

Highlight the record that you want to modify.
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2

Change the description in the Description field.

3

Click the Replace button which is now activated.
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4

The changed category now appears in the list.

5

Click Apply.

To delete subjects from the list of subjects
1

Highlight the record that you want to delete.

2

Click Delete.

3

The record is deleted from the list.

4

Click Apply.

To find a subject in the list of subjects
1

Enter any digit that is contained in the code or any character that is contained in the subject
description into the Filter field.
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2

The records that match the find sequence are displayed

You can use wildcards when looking for subjects (for more information on wildcards,
see "To scan with wildcards" on page 142).
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Managing Subjects—Tips and Tricks
The most important rule about subjects is to apply them to every translation project and each other
entry in the databases.
The next most important consideration is how to set them up. Essentially, there are two ways to do
that. You can
use the existing list of subjects and either try to find subjects that are relevant to your projects or set
them up within the preassigned order, or
delete the list of subjects and build your own list with its own hierarchical structure from scratch.
While the second option may give you more flexibility in defining your choices (if, for instance, you
only work with legal translation and you would like to fine-tune the whole range of subject codes
to legal topics), only the first option allows you to effectively exchange Déjà Vu databases with
other translators without having to redefine their structure.
No matter which way you choose to go, you should take your time to define (or fit) your subject
structure as thoroughly as you can. Many translators find it helpful to do this planning on a piece of
paper and then later transfer it into Déjà Vu X2 Professional.

PROPAGATE
Once you have translated a segment, you can apply this translation to the same or similar
segments within Déjà Vu X2 Professional. This process is called Propagation.
When searching for cells to propagate to, Déjà Vu X2 Professional only looks for linguistic
matches and assumes that digits and embedded codes are not to be changed between source and
target languages. This means that the samples in the following screenshot are all considered to be
perfect matches, even though the number and codes differ from each other.

There are several ways to propagate a segment with Déjà Vu X2 Professional:
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AutoPropagate allows you to automatically propagate your segments throughout your
current project.



The manual propagate option allows you to either propagate in your current file or
throughout the project.



The overwrite option (see "To manually propagate a translation to all files in the project"
on page 200) allow you to overwrite any existing translation, regardless of its status.

There are differences between these three options in terms of how segments are being
overwritten:


AutoPropagate overwrites any empty, fuzzy match or assembled segment but does not
do any fuzzy propagation.



Manual propagate overwrites any empty, fuzzy match or assembled segment and
prompts for confirmation when it finds a fuzzy match.



The overwrite option overwrites anything, including perfect and guaranteed matches
and unmarked empty rows (i.e., manually translated rows), except finished and locked
rows.

AUTOPROPAGATE
By activating AutoPropagate, you instruct Déjà Vu X2 Professional to automatically insert the
translation you have just entered in the current segment into all targets where the sources are
identical.

To activate AutoPropagate
1

Under Tools> Options> Environment, click AutoPropagate.
-OrClick

2

on Déjà Vu X2 Professional’s status bar.

The next time you jump from one segment to the next by pressing Ctrl+DownArrow (or to
the next translatable segment by jumping Alt+DownArrow), Déjà Vu X2 Professional will
automatically propagate the current segment into all other identical segments for you.
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3

You can recognize autopropagated segments by their status indicator. The default color is light
blue.
Make sure that you review all AutoPropagated segments. Even though one segment
may be identical to another, the context may require a completely different translation.
If your text tends to have the same segment appear in different contexts, it may not
always be an appropriate choice to activate AutoPropagate.

The advantage of AutoPropagate is that you don’t have to do anything but activate the option—
Déjà Vu X2 Professional does the rest for you. Because it does not ask for any user intervention, it
would never propagate anything to a fuzzy match segment, i.e., a segment that is not completely
identical. To do this you will have to use the manual propagation procedures.

To manually propagate a translation in the current file
1

Select the segment with the translation you want to propagate.

2

On the Translation menu, click Propagate In Current File.
–Or–
Press Shift+F9.
–Or–
Click the

button on the toolbar.

3

After propagating to identical source rows, Déjà Vu X2 Professional will look for rows where
the source text is only similar to the one being propagated. If any such rows are found,
Déjà Vu X2 Professional will display the segment in question and the fuzzy match in the
Confirm Fuzzy Propagation dialog.

4

Make any corrections in the Confirm Fuzzy Propagation dialog.

Déjà Vu X2

199

200

5

Click Yes, and the match will be inserted into the target segment.

You can see that Déjà Vu X2 Professional automatically placed the corrected codes
into the target and gave that segment a different status indicator.

To manually propagate a translation to all files in the project
1

Select the segment with the translation you want to propagate.

2

On the Translation menu, click Propagate To All Files.
–Or–
Press Alt+Shift+F9.
–Or–
Click the

3

button on the toolbar.

After propagating to identical source rows, Déjà Vu X2 Professional will look for rows where
the source text is only similar to the one being propagated. If any such rows are found,
Déjà Vu X2 Professional will display the segment in question and the fuzzy match in the
Confirm Fuzzy Propagation dialog. For more information on this, see the description under
"To manually propagate a translation in the current file" on page 199.

PSEUDOTRANSLATION
Pseudotranslation is a rather specialized process in which a "dummy" translation with targetlanguage-specific characters is performed and the length of the target text is increased by about
20% of the source.
Asian double-byte languages (Chinese, Japanese, Korean) are excluded from this text
expansion because these languages usually do not experience text expansion in the
process of translation. In these cases, Déjà Vu X2 Professional replaces each word (or
double-byte character) with one double-byte character.

There are two main uses for this feature:
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You can export the "dummy" file to verify that the special characters of the target
language can be displayed appropriately in the original file format.



You can export the "dummy" file to verify whether the usual text expansion can be
accommodated in the resulting original format files (this is especially useful for software
development files, such as .rc files).

The groups of supported languages for which codepage-specific characters are used include:
Arabic, Armenian, Baltic, Bengali, Burmese, Central European, Chinese (Simplified), Chinese
(Traditional), Cyrillic, Devanagari, Ethiopic, Georgian, Greek, Gujarati, Gurmukhi, Hebrew,
Japanese, Kannada, Khmer, Korean, Lao, Malayalam, Mongolian, Oriya, Sinhala, Syriac, Tamil,
Telugu, Thaana, Thai, Tibetan, Turkish, Vietnamese, and Western European.
Some of these languages—for instance, Vietnamese and Thai—may not be supported
on a non-native version of Windows 98 or ME.

To translate a text with the pseudotranslate feature
1

Select Translation> Pseudotranslation.

2

The Pseudotranslate dialog appears.

3

Select whether you want to translate the current or all languages, the current or all files,
whether you would like to limit the pseudotranslation to the current selection (if applicable),
and where you would like the translation to start. Under Type you can select whether you
would just like to have the source copied over to target or whether you would like to

Déjà Vu X2

201

202

Generate random strings. By selecting the latter, you would get results like the following (from
left to right: German, Greek, and Thai):

Though none of the "translations" makes any linguistic sense, they can now be used for
functionality testing.

EMBEDDED CODES
It is important for anyone working with Déjà Vu X2 Professional to understand what
"embedded codes" are. They are arguably one of Déjà Vu X2 Professional’s most
powerful features because they protect the integrity of your documents and allow you
to leverage your translation across many formats—to a much greater degree than most
other CAT tools.

When you work with file types other than plain text, Déjà Vu X2 Professional only displays
translatable text—everything else is hidden. However, in formats such as HTML, FrameMaker, or
Word, formatting information is often embedded within a segment, such as a particular word in
bold, cursive, or small caps. Since Déjà Vu X2 Professional cannot automatically decide which
formatting belongs to which word, it leaves the decision on where to place this formatting
information to the translator. These are "embedded codes." If you have created a Déjà Vu X2
Professional project for, say, HTML, you will probably have noticed that many segments contain
embedded codes such as {142} or {835}.
Consider the following example:

You can see that the translator chose to place the codes in the target around the corresponding
word in the translation.
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In most cases you don’t need to worry about what the embedded codes really contain, but it’s
clear that—whatever effect they have—they must be placed before and after the word gewartet
(the German translation of waited).
Take a look at the original text:

You can see that each of the instances of "waited" was formatted differently. Not only did this not
make a difference to Déjà Vu X2 Professional when it processed the document (or the translators
as they translated the document), but as indicated by the light blue status indicator, Déjà Vu X2
Professional even allowed the translator to only translate the first instance of that line and to
propagate that translation to the other lines as perfect matches (for more information on
propagation, including why the numbers are automatically copied over, see "Propagate" on page
197).
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After the export of the translated document, all the formatting is retained at the appropriate
positions:

Though Déjà Vu X2 Professional stores the "meaning" of each code within a project—so that the
correct formatting can be applied when you export the document—it treats the codes as mere
placeholders when it propagates them or when it stores them in the translation memories or
termbases. The effect of this is that Déjà Vu X2 Professional can be used across all file formats and
internal format differences. Not only does
I waited for 8 hours
represent a perfect match to
I waited for 16 hours
within Word, but also to
I waited for 24 hours
within an HTML or FrameMaker file.
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RELATIVE POSITIONING OF EMBEDDED CODES AROUND TEXT
It is important to maintain the order of the codes relative to each segment in the source because
each embedded code in the Déjà Vu X2 Professional project stores specific formatting
information.
Here are a few examples where this becomes relevant. Assume that
I waited for 8 hours
from an HTML file (in HTML code: I <b>waited<\b> for 8 hours) is displayed in
Déjà Vu X2 Professional as:
I {446}waited{447} for 8 hours.
The placement of codes in the translation can only be like this:
Ich habe 8 Stunden {446}gewartet{447}.
If the codes were reversed in the translation:
Ich habe 8 Stunden {447}gewartet{446}
the resulting text would be corrupted because the tag that determines the beginning of the bold
formatting (in our HTML example: <b>) would be preceded by the tag that closes it (in our HTML
example: <\b>), with the result that the rest of the document would be in bold.

RELATIVE POSITIONING OF EMBEDDED CODES IN SHIFTED SYNTAX
Another thing to consider is the placement of codes when the syntax of the target language
requires a re-arrangement of codes. Assuming that
I waited for 8 hours
from an HTML file (in HTML code: I <b>waited<\b> for 8 <i>hours<\i>) is displayed
in Déjà Vu X2 Professional as:
I {446}waited{447} for 8 {448}hours{449},
the placement of codes in the translation can only be like this:
Ich habe 8 {448}Stunden{449} {446}gewartet{447}.
If the codes were reversed in the translation:
Ich habe 8 {446}Stunden{447} {448}gewartet{449},
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the resulting text after the export would have a reversed formatting:
Ich habe 8 Stunden gewartet.

COPYING AND MOVING EMBEDDED CODES
When you are translating a segment that contains embedded codes, you must make sure that the
target segment contains the same embedded codes, or Déjà Vu X2 Professional will not be able
to export the project files properly.
In fact, Déjà Vu X2 Professional has several measures implemented to guarantee that the codes
are not overlooked or deleted.


It marks rows with a warning symbol (
source and target.

) where it finds a discrepancy in codes between



It allows you to jump to rows with inconsistencies in embedded codes through the
selection of Translation> Check Embedded Codes.
–Or–

Pressing Ctrl+Shift+F8.


It write-protects codes in the target cells and marks them by painting them in a light gray.



It allows for several ways to quickly insert embedded codes into the target.



It warns when exporting documents with corrupted codes.
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To automatically copy the next embedded code
1

Place your cursor in the target cell on the position you want the next available code to be
copied to, and click Copy Next Code.
–Or–
Press F8 (or Ctrl+D).

2

Déjà Vu X2 Professional will insert the first embedded code that is in the current source
segment and not already in the target segment at the position of the cursor.

To automatically copy all embedded codes
1

Right-click the target box, and click Copy All Codes.
–Or–
Press Alt+F8.

2

Embedded codes found in the current source segment will be inserted at the cursor position
in the current target segment.
You should only use this option when you prefer to first copy the codes and then type
around them. Just copying the codes into the segment will disable the warning features
in Déjà Vu X2 Professional, but it will not guarantee the correct placement of the
embedded codes and the subsequent export of the file.

To automatically fix all embedded codes
1

Select the segment for which you want to fix the embedded codes and select Translation> Fix
Embedded Codes.
–Or–
Press Ctrl+F8.

2

Embedded codes found in the current source segment will be inserted at the end of the
current target segment.
You should only use this option when you prefer to first copy the codes and then type
around them. Just copying the codes at the end of a segment will disable the warning
features in Déjà Vu X2 Professional, but it will not guarantee the correct placement of
the embedded codes and the subsequent export of the file.
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To manually copy an embedded code from source to target
1

Double-click the desired code in the source segment.

2

Drag the selected code to the target box, hold down the Ctrl key (otherwise the code will be
moved rather than copied), and release the mouse button at the position where you want the
code to be inserted.
–Or–
Press Ctrl+C (or Ctrl+Ins) and position the cursor in the appropriate position in the target cell
and press Ctrl+V (or Shift+Ins).
–Or–
Right-click, select Copy, position the cursor in the appropriate position in the target cell, rightclick, and select Paste.

To move an embedded code in the target cell
1

Double-click the code you want to move.

2

Use drag and drop to move the selected code to the desired position.

DELETING EMBEDDED CODES
In some cases, you may want to temporarily delete the embedded codes from the target segment.

To delete a single embedded code
1

Select the entire code (double-clicking on a code will select it).

2

Press Ctrl+X (or Shift+Del).

To delete all embedded codes in a segment
1

Right-click the target text box to bring up the context menu, and click Delete Codes.
–Or–
Press Ctrl+Space.
You can also select Delete Codes and Text or press Ctrl+Space twice to delete the
whole segment.

Déjà Vu X2

208

Translation Features in Déjà Vu X2 Professional—The Details

MODIFYING EMBEDDED CODES
Embedded codes are protected in such a way that it is difficult to tamper with them. If you were to
delete even only one, the export function might not be able to reconstruct a valid DTP file. It is
possible, however, to modify the contents of a code in a target segment.

To modify the contents of an embedded code
1

Right-click anywhere on the code and select Display Code from the shortcut menu.
–Or–
Highlight the code and press Shift+F6.

2

The Embedded Code dialog appears with the embedded code being displayed.
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3

Enter your changes in the target box.

4

Click Accept.
You should only change the contents of embedded codes when absolutely necessary
and when you are very familiar with the coding of the file format you are working in.

CONTEXT VIEW
In some cases, it is helpful to have a more thorough context view than Déjà Vu X2 Professional
offers in its project view. For these cases, Déjà Vu X2 Professional offers you the See in Context
view.

To see text in context
1

Select the segment for which you would like to see the context.

2

Select Edit> See in Context.
–Or–
Press F6.
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3

The Source Segment in Context dialog appears.

4

You can see the source segment of your current selection in red and the surrounding text and
code in black.
The context view is not the same as you would see in a particular viewer, such as
Internet Explorer or Microsoft Word; instead it is the view of the underlying code, in
this case HTML.
File formats for which this view is not available include Access, Excel, PowerPoint, and Trados RTF.

CONVERSIONS
Whenever Déjà Vu X2 Professional inserts a match into a translation, it automatically performs
certain conversions, including:


embedded codes (see "Embedded Codes" on page 202).



acronyms—Déjà Vu X2 Professional will assume that any word of two or less characters
is an acronym that does not need to be translated and will thus take it over from source
to target. For double-byte languages, this feature will only work with one-character
words.
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numbers—the assumption is made that numbers will not be translated and will be taken
over from the source to the target, regardless of what is found in the databases.
While the acronym and number conversions are extremely helpful features, it is wise to
verify any of these conversions. Examples of where an automatic conversion may not
be successful would include toll-free telephone numbers that are valid for the region of
the source language but not for the region of the target language.

Other conversion features are not performed automatically but are dependent on your settings.

To control the conversion features
1

Select Tools> Options> General.

2

The General tab of the Options dialog is displayed.

Under Conversion, you can enable the following conversion processes:
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3



Control leading and trailing symbols—Enables Déjà Vu X2 Professional to
automatically fill in symbols such as punctuation marks or spaces at the beginning or
end of a segment. This is a helpful setting if the punctuation systems of your
languages match each other. Between English and Japanese, for example, this would
not be a very helpful setting.



Allow decimal conversion—If enabled, Déjà Vu X2 Professional will automatically
convert numbers, such as 1,000,000.00 (American English) to 1.000.000,00
(Spanish) to 1 000 000,00 (French).



Allow case conversion—If enabled, Déjà Vu X2 Professional will automatically
convert the case of a word in the target to the case of the source. While this is a
helpful setting between languages of a similar capitalization system, it would not be
a helpful setting between English and German, for instance.

Make the desired settings and click Apply and/or OK.

COPYING AND POPULATE
Déjà Vu X2 Professional employs the standard Windows commands and paths to copy, cut, and
paste text. You can copy, cut, and paste text by:
Selecting the text and pressing Ctrl+C (or Ctrl+Ins) for Copy, Ctrl+X (or Ctrl+Ins) for Cut, or
Ctrl+V (or Shift+Ins) for Paste.
–Or–
Selecting the text and selecting Edit> Copy, Edit> Cut, or Edit> Paste.
–Or–
Selecting the text and clicking on

(Copy), or

(Cut), or

(Paste) on the toolbar.

–Or–
Selecting the text and pressing the Ctrl key while dragging and dropping the text elsewhere.
However, there are a number of copy functions available that are specific to Déjà Vu X2
Professional. These are called "Populate."
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POPULATING SINGLE SEGMENTS
Populating single segments can be especially helpful when you have a segment with a
lot of untranslatable text, such as product names, proper names, addresses, or codes.

To copy the current source to the current target
1

Select the segment you want.

2

On the Insert menu, select Populate> Current Segment.
–Or–
Press F5.
You can also copy the content of several rows into the target with this command by
selecting the desired rows in the selection mode (see "Selecting Segments in the
Selection Mode" on page 61).

To insert the current target with the current source
1

Select the segment you want.

2

Press Ctrl+F5.

3

The source segment is inserted to the beginning of the existing target segment.
You can also copy the content of several rows into the target with this command by
selecting the desired rows in the selection mode (see "Selecting Segments in the
Selection Mode" on page 61).

To populate all the target columns for the current target language
On the Insert menu, select Populate> Current Language
–Or–
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Press Alt+F5.
You can also populate all target languages in the project by pressing Ctrl+Alt+F5.
You should be careful with this option because it can be difficult to batch delete a
certain subgroup of segments again. The possibilities that Déjà Vu X2 Professional
readily offers are to delete all translations, all assembled translations, and all fuzzy match
translations.
One significant difference between populating only one segment and all the segments of a
language is that only in the first option are the contents of the segment in question overwritten. In
the second option, only the empty rows are filled in.

SENTENCE DELIMITATION
Sentence delimitation rules are the rules by which Déjà Vu X2 Professional determines how text
in a specific language should be segmented. You can change or add the default delimitation rules
so that it corresponds to your specific language and the style of the author of your source
documents. The delimitation rules allow you to specify for each language what rules are to be used
as well as the exceptions to these rules.
Déjà Vu X2 Professional’s default rules are the most common rules for most languages. It
segments text when it sees one of the following punctuation marks:


period,



question mark,



explanation mark,



colon, or



semi-colon

followed by a white space. For periods, questions marks, and explanation marks, Déjà Vu X2
Professional also defines that they may not be followed by a lower-case letter.
Though these are good rules, in many cases they may only provide a starting point for your
particular delimitation rules. Examples include the following:


Certain frequently occurring abbreviations in your source language, such as "P.O. Box,"
would be considered to be splittable by these rules.
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Certain languages may make very heavy use of some punctuation marks, such as the
semi-colon, which then should probably be deleted as a delimitation rule for that
language.



Certain languages may not make use of any of these rules because they use a completely
different set of punctuation marks. That would include languages such as Chinese and
Japanese.

In these cases you will have to define new rules.

To modify sentence delimitation rules
1

Select Tools> Options> Delimiters.

2

The Delimiters tab is displayed with the source language of your current project.

3

In the left part of the tab you can see the Rules, and in the right part the Exceptions to the
rules.
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To define rules you can use any actual character plus these symbols:

Symbol

Meaning

^w

white space

^#

a digit (1, 2, 3...)

^$

a letter (upper-case, lower-case, or any case)

^a

a lower-case letter

^A

an upper-case letter

^?

any character

^^

the caret character (^) itself

The character string .^w would thus mean a period followed by a white space, or e.g.,^w
would mean (the abbreviation) "e.g.," followed by a white space.
4

Select the desired language

5

Type the desired character and symbols in the Before Split and After Split fields.
–Or–
Type the desired character. To enter the desired symbols, right-click and select the symbols
from the shortcut menu.

6

Once you have entered or modified your rule, click Add.

To remove a rule or exception
1

Click the desired row on the table to select it.

2

Click Delete.
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To import sentence delimitation rules from Déjà Vu 3
1

Select Import in the left-hand lower corner of the Options dialog.

2

Though the resulting Import DV3 settings dialog does not contain any option that is specific to
sentence delimitation, if you start the import process by clicking OK, all custom delimitation
rules for all languages will be imported.
In cases where several sub-languages have replaced a single language in Déjà Vu 3—
e.g., German in Déjà Vu 3 is now German (Standard), German (Austria), German
(Liechtenstein), German (Luxemburg), and German (Switzerland)—the rules for the
main language will be imported to all sub-languages.

Tips and Tricks on Sentence Delimitation:
For languages that do not use any of the typical punctuation marks, such as Chinese, you can
delete all the existing rules and add new rules by typing the appropriate characters and the symbols
that Déjà Vu X2 Professional uses. For Chinese, for instance, you can add "º" to have Déjà Vu X2
Professional split segments every time that character is used in the document. Because typically
spaces are not used after that character (or any other punctuation mark in Chinese), you would not
have to add "^w."
The sentence delimitation settings are stored in the settings.dvset file. For more information, see
"Storing the Client and Subject Settings" on page 176.

SPLITTING AND JOINING SEGMENTS
After importing, it is possible that you may find that a segment has been incorrectly split.
Déjà Vu X2 Professional splits the source text into segments using the rules and exceptions you
set for the project’s source language (see "Sentence Delimitation" on page 215). However, even
with the most carefully built set of rules and exceptions, there may be errors in the way
Déjà Vu X2 Professional breaks text into sentences. The most common reasons for these errors
are


uncommon abbreviations that are not included in your list of exceptions (see "To modify
sentence delimitation rules" on page 216), and

Déjà Vu X2

218

Translation Features in Déjà Vu X2 Professional—The Details


incorrectly placed soft or hard returns added by the author for formatting purposes.
In some formats (such as PowerPoint, where this is an extremely typical error),
Déjà Vu X2 Professional automatically ignores soft returns. There is no case, however,
where hard returns can be ignored.

You can correct such errors by:


editing the source file.



adding a new exception rule and importing the file(s) again.



manually splitting a segment at a certain point.



manually joining two segments together.

To split a segment
1

Place the insertion caret to the position in the source segment where you want to split the
segment.

2

Select Split Segment from the Edit menu.
–Or–
Click the

button on the toolbar.

–Or–
Press Ctrl+I.
3

The segment should now be split.

To join two segments
1

Click the segment that you want to have joined with the next segment.

2

Select Join Segments from the Edit menu.
–Or–
Click the

button on the toolbar.

–Or–
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Press Ctrl+J.
3

The segments are now joined.
Depending on what is between the segments in the source file, Déjà Vu X2
Professional may or may not add an embedded code. If the undesired split is due to an
incorrectly set sentence delimitation rule, Déjà Vu X2 Professional will typically not
add an embedded code. If it is because of an incorrectly set soft or hard return,
Déjà Vu X2 Professional will place an embedded code between the segments.
In general, it is not possible to join segments in certain file formats, including Excel, Trados,
PowerPoint, and Access.

AUTOTEXT
AutoText is comparable to the AutoText option of Microsoft Word. Its purpose is to save typing
effort by expanding abbreviations into longer text (for instance, "DV" to "Déjà Vu").
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To add new AutoText entries
1

Select Tools> Options> AutoText.

2

Select the language for which you would like to add AutoText entries and whether this new
entry should be valid for this (Current project’s entries) or for all projects (Global entries).

3

Type an abbreviated form under Token and the expanded form under Replace with.

4

Click Add.

To add new AutoText entries as you translate
1

Highlight the term that you would like to add as an AutoText entry.
You can also choose to send the complete target segment as an AutoText entry. To do
that, you don’t have to select anything.
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2

Right-click on the selection and select Add Selection to AutoText from the context menu.
–Or–
Select Insert> AutoText> Add Selection to AutoText.

3

The AutoText entry dialog appears with your selection already displayed under Token.

4

Enter the expanded form under Replace with.

5

Select whether this is supposed to be valid for all projects (Global entry) or only for the
current project.

6

Click OK.

To delete AutoText entries
1

Select the AutoText entry you would like to delete.

2

Click Delete.

To modify AutoText entries
1

Select the AutoText entry you would like to modify.
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2

Make the necessary modifications under Replace with.

3

Click Replace.

To expand AutoText entries
1

Type the token you have defined on the AutoText tab into the target field of the appropriate
language

2

Press Ctrl+Shift+F3.

3

The expanded form appears.

To import AutoText entries
You can import AutoText entries from two sources:


Microsoft Word
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To start the import process from Microsoft Word, you will have to select Import from Word on
the AutoText tab.
You should only choose to import from Word if you already have a significant number
of custom AutoText entries. Some of the predefined AutoText entries in Word are very
specific to Microsoft Word and may not be too useful.
Note also that Word does not define language-specific AutoText entries, i.e., you should only
import AutoText entries into the language in which you added most of your AutoText entries in
Word, if applicable.


Déjà Vu 3

To start the import process from Déjà Vu 3, click Import in the left-hand corner of the dialog.

Select Import as AutoText under AutoText, and select whether you would like to have your
existing AutoText entries overwritten or appended to.
In Déjà Vu 3, "AutoText" was a function that combined the AutoText and AutoCorrect
functions. You should thus only import AutoText entries into the Déjà Vu X2 AutoText
feature if they contain a significant number of AutoText-like entries. For information on
AutoCorrect, see "AutoCorrect" on page 225.
The AutoText settings are stored in the settings.dvset file. For more information, see "Storing the
Client and Subject Settings" on page 176.
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AUTOCORRECT
AutoCorrect is comparable to the AutoCorrect option of Microsoft Word. Its purpose is to correct
common spelling mistakes (for instance, "segement" to "segment" or "Deja Vu" to "Déjà Vu"). Unlike
AutoText, it is an automated function that can either be enabled or disabled.

To add new AutoCorrect entries
1

Select Tools> Options> AutoCorrect.

2

Select the language for which you would like to add AutoCorrect entries, and whether this
new entry should be valid for this (Current Project’s entries) or for all projects (Global entries).

3

Type the misspelled form under Token, and the correct form under Replace with.

4

Click Add.
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To add new AutoCorrect entries as you translate
1

Highlight the misspelled term that you would like to add as an AutoCorrect entry.
You can also choose to send the complete target segment as an AutoCorrect entry. To
do that, you don’t have to select anything.

2

Right-click on the selection and select Add Selection to AutoCorrect from the context menu.
–Or–
Select Insert> AutoText> Add Selection to AutoCorrect.

3

Select Add Selection to AutoCorrect from the context menu.

4

The AutoCorrect entry dialog appears with your selection already displayed under Token.

5

Enter the corrected form under Replace with.

6

Select whether this is supposed to be valid for all projects (Global entry) or only for the
current project.

7

Click OK.

To delete AutoCorrect entries
1

Select the AutoCorrect entry you would like to delete.

2

Click Delete.

To modify AutoCorrect entries
1

Select the AutoCorrect entry you would like to modify.
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2

Make the necessary modifications under Replace with.

3

Click Replace.

To use AutoCorrect
1

Make sure that you activate AutoCorrect enabled on the AutoCorrect tab.

2

Every time you now enter a token—i.e., an incorrectly spelled form that you have defined on
the AutoCorrect tab—into the target field of the appropriate language, and hit the space bar,
the correct form will appear.

To import AutoCorrect entries
You can import AutoCorrect entries from two sources:


Microsoft Word
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To start the import process from Microsoft Word, you will have to select Import from Word on
the AutoCorrect tab.
Note that Word defines language-specific AutoCorrect entries, i.e., it will only import
AutoCorrect entries if Word actually contains an AutoCorrect list for that specific
language.


Déjà Vu 3

To start the import process from Déjà Vu 3, click Import in the left-hand corner of the dialog.

Select Import as AutoCorrect under AutoText and select whether you would like to have your
existing AutoCorrect entries overwritten or appended to.
In Déjà Vu 3, "AutoText" was a function that combined the AutoText and AutoCorrect
functions. For information on AutoText in Déjà Vu X, see "AutoText" on page 220.
The sentence delimitation settings are stored in the settings.dvset file. For more
information, see "Storing the Client and Subject Settings" on page 176.
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COMMON WINDOWS FUNCTIONS
CHARACTER MAP
You can press Ctrl+K or select Tools> Character Map to display the Windows Character Map—a
convenient way to enter special characters that you cannot type with your keyboard or whose
ANSI code you don’t remember.

To enter characters with the Windows Character Map
1

Select a font and the character you want to enter.

2

Click Select and Copy.

3

The character is now on your clipboard and you can paste it into any position within your
open file by placing your cursor at the appropriate location and
pressing Ctrl+V (or Shift+Ins)
–Or–
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selecting Edit> Paste
–Or–
clicking on

on the toolbar.

SEARCH AND REPLACE FEATURES
If you are looking for a specific term, you can use the standard Windows Find features to find it. If
you want to replace the term, you can use the standard "search and replace" features to locate and
replace it.

To use the Find feature
1

On the Edit menu, click Find.
–Or–
Press Ctrl+F.
–Or–
Click the

button on the toolbar.

2

The Find dialog appears.

3

Select whether you want to search the Source Text or the Target Text and/or the Current File
or All Files by checking the appropriate check boxes.

4

In the Find box, enter the text you want to search for.
By default, the text that you last entered will be displayed. You can also use the
dropdown list to select any text you searched for recently, or you can highlight the text
you want to search for and then open the Find dialog.
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5

If you want to only search for complete words, check Find whole word only. If this option is
not selected, words that begin with the search text will also be found.

6

If you want to only search for words with capitalization identical to what you entered, check
Match case.

7

Click Find Next.

8

The next segment that contains the search word will be selected.

9

To continue searching for that word, you can continually click Find Next.
–Or–
Close the Find dialog and press F3 (or Shift+F4).
–Or–
Close the Find dialog and click

on the toolbar.

10 The next segment that contains the search word will be selected.

To use the search and replace feature
1

Press Ctrl+H.
–Or–
Select Edit> Replace.
–Or–
Within the Find dialog, click Replace.

2

The Replace dialog appears.
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3

Select whether you want to replace text in the Source Text or the Target Text and/or the
Current File or All Files by checking the appropriate check boxes.

4

Enter the text you are looking for into the Find box and the text you want to replace it with
into the Replace With field.
By default, the text that you last entered will be displayed. You can also use the
dropdown lists to select any text you searched for and replaced recently, or you can
highlight the text you want to search for and then open the Replace dialog.

5

If you want to only replace complete words, check Find whole word only. If this option is not
selected, words that begin with the search text will also be replaced.

6

If you want to only replace words with capitalization that is identical to what you entered,
check Match case.

7

Click Find Next.

8

The next segment that contains the search word will be selected.

9

If you want to replace the word that has been found, click Replace. If you want to have all
occurrences of this word replaced, click Replace All.

REDO AND UNDO FEATURES
Déjà Vu X2 Professional supports an unlimited number of redo and undo actions.

To undo an action
Press Ctrl+Z.
–Or–
Select Edit> Undo.
–Or–
Click

on the toolbar.

To redo an action
Press Ctrl+Y.
–Or–
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Select Edit> Redo.
–Or–
Click

on the toolbar.

SAVING THE PROJECT
One of the great benefits of working in a database environment is that the database saves itself
automatically when a new cell is selected or the database is closed. Because even the Déjà Vu
project file is a database, there is no need to ever save your project!

CHANGE CASE
You can either change the case (capitalization) of a certain selection within a target segment or for
the content of a whole target segment.

To change the case for a selection
1

Select the text whose case you want to have changed.

2

Press Shift+F3.
–Or–
Select Edit> Change Case.
–Or–
Click

3

on the toolbar.

The case will change in the following cycle:


first letter uppercase, the rest lowercase



all lowercase



all uppercase

To change the case for the content of target cell
1

Select the segment for which you want to have the case changed for all the source text.

2

Press Shift+F3.
–Or–
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Select Edit> Change Case.
–Or–
Click
3

on the toolbar.

The case will change in the following cycle:


first letter uppercase, the rest lowercase



all lowercase



all uppercase
The change of case does not affect numbers and symbols. On a U.S. English keyboard
layout, for instance, a single quote (’) will not change to a double quote (").
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EDITING FEATURES IN DÉJÀ VU X2 PROFESSIONAL—THE DETAILS
Déjà Vu X2 Professional includes a multitude of editing and quality assurance features, most of
which are described in the workflow chapters (p. p. 77). These include:


Terminological consistency check



Numeral consistency check



Embedded code check



Missing spaces check



Spell check

Below you will find an in-depth description of the spelling module of Déjà Vu X2 Professional.

SPELLING OPTIONS
There are several spelling options in Déjà Vu X2 Professional.

To access the spelling options
1

Select Tools> Options> Spelling.
–Or–
Click on Options in the Check Spelling dialog (see "Spell checking" on page 125).

Déjà Vu X2

235

236

2

The Spelling tab in the Options dialog is displayed.

Going from top to bottom, you will find the following options:


General> Use the Microsoft Office Spell Checker—When this option is enabled, the
dictionaries of the Microsoft Office spell checker are used rather than Déjà Vu X2
Professional’s own spell checking dictionaries.

unselected.

This option is particularly helpful for spell checking languages without a native spell
checker in Déjà Vu X2 Professional, but it does tend to slow the spell checking
process. If you are translating into a language that includes a spell checking dictionary
in Déjà Vu X2 Professional, you may work more efficiently if you leave this option

Enabling this option disables all other options.
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General> Allow accented capital—When this option is enabled, words with accented
capitals, such as ESPAÑA, are accepted. This option is selected by default.



General> Case sensitive—When this option is enabled, any word that does not match
the exact case in the dictionary will be reported. This would, for example, include
"canada," "CANADA," or "cANADA," whereas "Canada" would be considered correct.



Report> Doubled words—When this option is enabled, any word appearing twice in a
segment is reported in the Check Spelling dialog.



Report> Uncapitalized words—When this option is enabled, any word that does not
match the capitalization in the dictionary will be reported in the Check Spelling dialog.
For example, “canada” is considered different from "Canada," so "canada" would be
reported as a misspelling. "CANADA," however, would not be reported (see p. 237).



Report> Words with embedded capital letters—When this option is enabled, any word
in which a capital letter is embedded is reported in the Check Spelling dialog. Examples
would include DejaVu or QuarkXPress. This option is selected by default.



Report> Words with digits—When this option is enabled, any word that contains digits
is reported in the Check Spelling dialog. Examples would include Win2000 or B2B.



Ignore> Words in capitals—When this option is enabled, any words containing all
capital letters are ignored (i.e., are skipped without being checked).



Ignore> Words that begin with a capital letter—When this option is enabled, any words
beginning with a capital letter are ignored (i.e., are skipped over without being checked).



Ignore> Words with embedded capital letters—When this option is enabled, any word
with a capital letter in the middle is ignored. Examples would include DejaVu or
QuarkXPress.



Ignore> Words with digits—When this option is enabled, any word that contains digits is
ignored. Examples would include Win2000 or B2B.



Ignore> Numbers—When this option is enabled, any number—such as 255.255.255.0
or 1-800-255-1212—is ignored. This option is selected by default.



Ignore> Internet addresses—When this option is enabled, any Internet address—such as
http://www.atril.com—is ignored. This option is selected by default.



Split> Contracted words—When this option is enabled, contracted words are split.
Examples include words such as the Italian "quell’anno" into "quell anno."
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Split> Hyphenated words—When this option is enabled, hyphenated words are split.
Examples include words such as "self-control" into "self control" or "log-on" into "log on."
This option is selected by default.



Split> Compound words—When this option is enabled, compound words are split.
Examples include words such as "logon" into "log on" or "toolbar" into "tool bar."



Split> Strip possessives—When this option is enabled, possessives are stripped.
Examples include "Emilio’s" into "Emilio" or "Déjà Vu X2’s" into "Déjà Vu X2." This
option is selected by default.



Suggestions> Phonetic—When enabled, suggestions are made based on phonetic
similarity as well as typographical similarity. This option tends to improve suggestions for
badly misspelled words. Enabling this option will increase the time required to locate
suggestions.



Suggestions> Typographical—When enabled, suggestions are made only based on
typographical similarity. You will have to choose between phonetic and typographical
suggestions.



Suggestions> Suggest split words—When this option is enabled, two separate words will
be suggested as a replacement for a misspelling containing two joined words. For
example, "is the" would be suggested as a replacement for "isthe."

Set the appropriate options for each language you are working in.
The spelling options you check in this dialog also take effect in any spelling you may
perform in your translation memories or termbases. For more information on this, see
"Spell Checking the Translation Memory" on page 432 and "Spell Checking the
Termbase" on page 503.

DICTIONARIES
Dictionaries are customized lists of words that you want to have automatically or conditionally
changed, ignored, or excluded.
Though Déjà Vu X2 Professional is pre-equipped with extensive dictionaries for the languages
with supported spell check engines, there will always be words that you encounter during spell
checks which are not included. You can choose to include those in your custom dictionaries.
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To add words to user dictionaries
1

If a correctly spelled word is displayed in the Not in Dictionary box on the Check Spelling
dialog (see "Spell checking" on page 125), the word should be added to a user dictionary.

2

Select the desired dictionary under Add words to and click Add.

3

The word is added to the dictionary with the default setting of Ignore, and will no longer be
marked as misspelled.
You can choose to send the word to the userdic.tlx, which is a general-purpose user
dictionary. We recommend that you select this user dictionary in the Add Words To list
so words will be added to it when you click the Add button in the Check Spelling
dialog.
You can also add words to the spelling dictionary from the AutoSearch window (see "To access the
AutoSearch context options" on page 37) or by highlighting any target term, right-clicking, and
selecting Add to Spelling Dictionary.

To add words to the custom dictionaries with settings other than Ignore
1

On the Check Spelling dialog, click Dictionaries.
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2

The Dictionaries dialog appears.

The Dictionaries dialog allows you to add and remove user dictionaries and edit the contents
of any added user dictionary.
3

Open the drop-down list under Dictionaries.
Here you can see a list of all associated user dictionaries for that language. The default
dictionary is userdic.tlx.
For information on how to create other dictionaries, see "To create a new dictionary" on
page 242.

In our case we would like to add Wotr to our German user dictionary with the setting
Automatic Change to Wort.
4

Enter "Wotr" under Words and Wort under Replace with.

5

Open the drop-down list under Action and select Automatic Change.
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6

Click on Add Word.

7

Click Close. The next time you encounter Wotr in your German spell check, it will
automatically be changed to Wort.
You can also delete or edit words in the same dialog.

Other possible settings include:


Automatic change - preserve case—This automatically changes the word while
preserving the case of the original (in our case, "wotr" would have been changed to
"wort").



Conditional change—This option prompts the defined correction in the Change to
field in the Check Spelling dialog.



Conditional change - preserve case—This option prompts the defined correction in
the Change to field in the Check Spelling dialog while preserving the case of the
original.



Exclude (always treat as misspelled)—This option always treats that word as
misspelled.



Ignore—This option, which is the default setting, always ignores the word during
spell checks.
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To create a new dictionary
1

On the Check Spelling dialog, click Dictionaries.

2

The Dictionaries dialog appears.

3

Click on New File in the Dictionaries dialog.

4

The New Dictionary dialog appears.

5

Click Browse and select a name and path for your new dictionary.
The default path for dictionaries is C:\ProgramData\Atril\Deja Vu
X\Spelling\<LanguageCode> (on an English Windows 7 installation) but you are
free to save it elsewhere.

6

Select a language from the drop-down list under Language.

7

Click OK.
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8

You are returned to the Dictionaries dialog. If you select the drop-down list under
Dictionaries, you can now see the added dictionary.

Situations where it may be useful to add dictionaries may include projects where you
have a very specific vocabulary that may not be valid for other projects.

To add existing dictionaries
1

On the Check Spelling dialog, click Dictionaries.

2

The Dictionaries dialog appears.

3

Click on Add File in the Dictionaries dialog.
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4

The Select Name and Location of the User Dictionary dialog appears.

5

Select name and location of the new dictionary and click Open.

6

The dictionary is added.
While it is possible to simply add the existing user dictionaries of the "ignore" type of an
earlier version of Déjà Vu, you should be aware that this will automatically change the
internal file format which makes them unusable for Déjà Vu 2 or 3 installations. A
better way of adding these would be to import them into existing Déjà Vu X2
Professional user dictionaries (see "To import a dictionary" on page 244).

To import a dictionary
It is possible to import


existing .tlx dictionaries from earlier versions of Déjà Vu or other programs that use
the same spell checker,



simple text files (with words listed in a simple column format), or
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external .dic files (such as from an Office installation).
To find the installation path of your Microsoft Office dictionary, open Word, select
Tools> Options> Spelling & Grammar, and click Dictionaries or Custom Dictionaries.
In the resulting dialog, you can see the full path of your custom dictionary files:

While words from the .dic files and text files can only be included in the "ignore" property, words
from existing .tlx dictionaries will retain the property they had previously (automatic or conditional
change, ignore, or exclude).
1

On the Check Spelling dialog, click Dictionaries.

2

The Dictionaries dialog appears.

3

Make sure that the dictionary you want to import into is selected under Dictionaries.

4

Click on Import.
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5

A file selector dialog appears. Select the dictionary that you would like to import.
Make sure that you select a dictionary for the correct language!

6

Click Save.

7

Depending on the size of the dictionary, the import process can take several minutes.
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8

Once it is finished, you can see the imported entries in the Dictionary dialog.

9

Note that the imported entry was correctly interpreted as an Automatic change entry.

10 Click Close.

To export a dictionary
The dictionary export function of Déjà Vu X2 Professional converts the user dictionary files into
mere text files.
1

On the Check Spelling dialog, click Dictionaries.

2

The Dictionaries dialog appears.

3

Make sure that the dictionary you want to export is selected under Dictionaries.

4

Select Export.

5

Select the folder path and the name of the text file.

6

Select Open.
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REVIEW FEATURES IN DÉJÀ VU X2 PROFESSIONAL—THE DETAILS
Translators often encounter passages that are difficult to translate. The more you think about them,
the harder they become to translate. The best way to deal with this would probably be to forget
about it for a while, continue translating, and come back to it when your mind is fresh. If you
cannot come up with a good solution even then or you are still not certain about your solution,
Déjà Vu X2 Professional provides tools to highlight these rows for an editor or another translator.

BOOKMARKING A SEGMENT
Déjà Vu X2 Professional allows you to set a "bookmark" to mark a position in a project. All the
bookmark commands are available through the Bookmarks submenu within the Files menu:

Bookmarks help you to select sentences on the fly that you can later easily locate.

To set a bookmark
1

Select the segment where you want to set a bookmark.

2

Select Edit> Bookmarks> Toggle Bookmark.
–Or–
Press Ctrl+B (or Ctrl+F2).
–Or–
Right-click on the segment and select Toggle from the shortcut menu.

3

A Bookmark icon

will appear to the left of the segment.

To remove a single bookmark
1

Select the segment in which you have previously set a bookmark.

2

Select Edit> Bookmarks> Toggle Bookmark.
–Or–
Press Ctrl+B (or Ctrl+F2).
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–Or–
Right-click on the segment and select Toggle from the shortcut menu.
3

The Bookmark icon

at the left of the segment will disappear.

To remove all bookmarks
1

Select Edit> Bookmarks> Clear All Bookmarks.

2

All Bookmark icons

will disappear.

To move to the next bookmark after the currently selected segment
1

Select Edit> Bookmarks> Next Bookmark.
–Or–
Press F2.

2

If there are only bookmarks above your current position, the following dialog is displayed:

To move to the previous bookmark before the currently selected segment
1

Select Edit> Bookmarks> Previous Bookmark.
–Or–
Press Shift+F2.
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2

If there are only bookmarks below your current position, the following dialog is displayed:

MARKING SEGMENTS AS PENDING
Déjà Vu X2 Professional allows you to mark questionable rows as "pending" so that you or
someone else can come back at a later time to finish or review these rows.

To mark a segment as pending
1

Right-click the sentence you want to mark as pending and click Segment Status> Pending.
–Or–
Press Ctrl+Shift+P.

2

The Pending symbol (

) appears in the target cell.

To remove the pending status
1

Select the sentence you want to mark as normal (non-pending).

2

Right-click the sentence table and click Segment Status> Pending.

3

The Pending symbol disappears.
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To view all your pending segments
Select Pending Segments from the Segment Selector. For more information, see "The Segment
Selector" on page 40.

ADDING COMMENTS
It is often important to add notes to aid your own memory about a certain translation or to
communicate something to other translators or editors who work with you.

To add a comment
1

Right-click on the source or the target section of a segment to which you want to add a
comment and select Comments> Add Comment from the context menu.
–Or–
Place your cursor in the source and target section and press Ctrl+M.
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2

The Add Comment dialog appears. Here you can enter any appropriate comment.

3

Select Apply.

4

The light blue Comment icon appears to the left of the source or the target section of the
segment.
In case the target section already contains an inconsistency mark (see "Terminology
Consistency Checks" on page 114), the exclamation mark will be light violet.
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To view all rows with comments
Select Segments with Comments, Segments with Comments in Source, or Segments with
Comments in Targets from the Segment Selector. For more information, see "The Segment
Selector" on page 40.

To review a comment
1

The easiest way to review a comment is to place your cursor over the left section of the
source or target section of the segment.

2

A tooltip-like window will appear in which you can review the comment.
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To edit a comment
1

Right-click on the segment that contains a comment.

2

Select Comments> Edit Comment from the context menu.

3

The Edit Comment dialog appears. Here you can edit the existing comment or add a
response to the comment.

4

Select Apply.

To delete a comment
Right-click on the segment that contains a comment and select Comments> Delete
Comment from the context menu.
–Or–
Press Ctrl+Shift+M.

To delete all comments
Right-click on the segment that contains a comment and select Comments> Delete All
Comments from the context menu.
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TEAMWORK FEATURES IN DÉJÀ VU X2 PROFESSIONAL—THE DETAILS
Déjà Vu X2 Professional provides several ways to create sub-projects and databases to pass on to
team members—translators, editors, reviewers, or project managers.
There are many benefits to these files:


much smaller size resulting in faster transmission speed



added security by limiting the work of translators/editors to their specific language
combination (satellites only)



added control by limiting database sharing to the necessary data



greater speed in local area networks by being able to split up files and have translators
work on their local computers



possibility of cross-platform work (External View only)

PACK & GO PACKAGES
Pack & Go packages are highly compressed exports from project files that are ideal for the
transmission of Déjà Vu X2 Professional data. The Pack & Go feature is available as a stand-alone
feature for the transfer of complete projects, or as part of the satellite creation for the transfer of
even smaller bilingual satellite projects (for more information on satellites, see "Satellite Files" on
page 262).
Opening a Pack & Go package will start the Pack & Go Wizard, which will allow you to define
where you want to have your new project stored. When the translation of the project is finished,
you can once again export it into the Pack & Go format to transmit it back to the project owner.

To create a Pack & Go project
1

Open the project that you would like to export into a Pack & Go package.

2

Select File> Export> Pack & Go.
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3

The Select Location of "New Pack & Go Package" dialog appears.

4

Click on Save after you have selected the folder where you want this file to be stored and
have named the file.

5

The Pack & Go Export Progress dialog appears.

6

When the export is finished, a new file with the extension .dvpng will have been placed in the
specified folder. You will notice that the size of the .dvpng file is significantly smaller than the
originating project file:

To open a Pack & Go package
1

Select File> Open.
–Or–
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Click

.

2

In the Open dialog, navigate to the location of your Pack & Go Package, select All DejaVu X2
Files or Pack & Go Projects, and select the .dvpng file.

3

Click Open.
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4

The Pack & Go Import Wizard starts.

5

Click Next and create a project to host your Pack & Go package.

6

Select Next.
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7

The wizard displays the current settings.

8

Click Finish. The wizard shows you the import progress.

9

Déjà Vu X2 Professional displays the open project.

To translate a project created from a Pack & Go package
Once the file is open, you can start to work in it right away. It may be a good idea, however, to first
re-adjust the settings of the current project.
1

Select Project> Properties.

2

On the General tab, make sure that the client and subject setting is set to match the
configuration of your subjects and clients.
For more information on subjects and client, see "Clients and Subjects" on page 174.

3

On the Databases tab, make sure that the project is mapped to databases on your computer
or network.
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To return a Pack & Go package
When you are done with your work on the project file, you can create a new Pack & Go package
(see "To create a Pack & Go project" on page 257) and return it to the project owner.

SATELLITE FILES
A satellite file contains only one source and one target language (as opposed to a full project file,
which typically consists of the source language plus a number of target languages) with all the
information needed by the translator. This information can exclude the formatting and image
code, thus significantly reducing the file size and making it easier to transmit.
A satellite file contains a number of automatic restrictions. It is not possible to:


delete files,



split/join rows,



edit the source, or



lock/unlock rows.

If the security options for the originating project file are enabled(for information on security, see
"Security Features in Déjà Vu X2 Professional—The Details" on page 273), users of the satellite
files will have to log in with a user name and password. This will give them access to a predefined
security level, which in turn will either permit or prohibit the overwriting of translation entered by
other users or the project owner.

Once the translation of a satellite is finished, it can be sent back to the project owner who can
import it into its parent project file.

EXTERNAL VIEWS
The External View format is a format specifically created for proofing or checking unresolved issues
outside of the Déjà Vu X2 Professional environment. You can export translated and commented
rows into several formats in which proofing can be performed and outstanding questions can be
answered.
The available formats are


RTF



HTML

These format have two major purposes:
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They allow for proofing outside of Déjà Vu X2 Professional with the subsequent reimport back into Déjà Vu X2 Professional.



The RTF and HTML formats allow for the review of comments and questions that the
translator, editor, or project manager may have in platform- and application-independent
formats.

To create an External View
1

Open the project file from which you would like to export an External View file.

2

Select File> Export> External View.

3

The Export External View dialog appears.

4

Make the following selections:


Under Format, select whether the output format.
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Under Files, select whether you want to export the Lexicon (if applicable), the
currently selected file (this option is grayed out if the All Files view is selected in the
project), or all files.



Under Selection, you have a number of different options.

You can select whether you are going to export only rows with empty targets (i.e.,
commented rows that are not translated yet and for which further clarifications is
needed), only rows with non-empty targets (i.e., translations that need to be reviewed),
or all rows (i.e., all rows with comments and translations). These options are mutually
exclusive.
Furthermore you can define your selection by suppressing (i.e., ignoring) certain rows.
These include duplicate rows (so that duplicated rows are exported only once), locked
rows, exact matches, and guaranteed matches.


Under Sorting, you can select, whether the rows should be exported alphabetically
or naturally (i.e., in the order in which they appear in the source text).



Under Miscellaneous, you can select whether embedded codes are to be
suppressed or exported (this option is grayed out when the segment ID export is
activated), whether segment IDs are to be included (these are necessary for the reimport!), whether the segment status is to be included, if so, whether it should be
displayed as a color and/or number, and whether you want the name of the
originating file to be included.
It is imperative that you include the segment ID if you are planning to re-import the
project (as you would after proofreading or editing), and instruct your proofreader not
to change these.
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Under Colors you can assign colors to Pending and Locked rows, which in the main
grid view do not have any associated colors. For any of the other segment types, the
colors that are defined under Tools> Options> Display will be used.
If you are exporting locked rows, the complete segment, rather than just the
appropriate field in the Status column, will be underlied with the appropriate color to
emphasize the fact that this segment should not be touched.

To export only rows with comments
1

First, let’s create an External View in HTML format with two comments in the project file that
need to be resolved.
To be able to export only these two rows, you will have to make sure that these are the
only empty rows in the project.
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2

Make the following selection.
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3

Click OK.
For any non-commented empty target segment, a dialog will be displayed in which you
can enter a comment so that segment can also be exported.

4

When the status bar shows you that the export process is finished and the Cancel button is no
longer displayed, click on Close.

5

Yon can now send the HTML file to the person who is going to answer your comments.

6

Because this file does not have to be edited, it can be opened in a web browser. You can see
several columns:



Segment ID
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Source



Target (empty)



Comments

The comments can be reviewed and answers can be sent back to you.

To export all translated rows
1

Let us now create an External View in Word format with all the translated rows that may need
editing or proofreading.
You will need Microsoft Word installed on your computer to be able to export and reimport the External View in Word format.

2

Make the following selection.
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3

Click OK.
For any non-commented populated target segment, a dialog will be displayed in which
you can enter a comment so that segment can also be exported.

4

When the status bar shows that the export process is finished and the Cancel button is no
longer displayed, click on Close.

5

You can now send the Word file for review to the proofreader or editor.

6

When the file opens in Word or any other compatible program, you can see five different
columns:



ID
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Source



Target



Comments (if applicable)



Status (if applicable) (for the color selection of the status segment, see "To change
the colors of the indicator bars" on page 42)

The target column of the file can now be edited in your word processor.
Aside from not changing any of the other columns, it is important for your editor to not
change the tabular structure of the file, to not add any soft or hard returns into the
target cells, and to understand the concept of embedded codes and sentence
delimitation. If you would like to have a handout with instructions that your
proofreaders can download, go to the Documentation section of www.atril.com.

Once the file is proofread and sent back to you, you can re-import it into your Déjà Vu X2
Professional project.
8

Select File> Import> External View in your open Déjà Vu X2 Professional project.

9

The Import External View dialog appears.

10 Select the folder in which your .doc file is stored and the target language of that file.

11 Click OK.

Déjà Vu X2

270

Teamwork Features in Déjà Vu X2 Professional—The Details

12 The Merge External View Data dialog appears.

13 In the main window of the dialog you can find all rows listed that have been changed. Any
discrepancy between Existing Source/Target (i.e., the source and target sentences of your
Déjà Vu X2 Professional project) and New Source/Target are displayed with a strikethrough
(Existing) and red formatting (New).
You can choose to individually review and accept the changes by checking each of the check
boxes in the Accept column, or you can accept or reject them all by selecting Accept All or
Accept None in the lower part of the dialog.
The other buttons on this dialog have the following functions:


Previous Difference/Next Difference—highlights the previous or next segment with
differences.
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Show All Segments/Show Only Differences—shows rows with or without
differences.

14 Make the appropriate selections and click OK.
You are returned to your Déjà Vu X2 Professional project, where you can see that the changes
from the External View have replaced the original text, and the status value(s) from the External
View have been reimported.
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SECURITY FEATURES IN DÉJÀ VU X2 PROFESSIONAL—THE DETAILS
Déjà Vu X2 Professional’s most basic user-based security feature, i.e., the tracking of any user’s
activities, is enabled by default. Every process that any user performs in Déjà Vu X2 Professional
will be associated with his or her computer or login name.
In a Déjà Vu X2 Professional project created in a version of Déjà Vu X2 Workgroup where the
project owner has enabled the advanced security features, additional security features will be set
up. With these in play, translation users can be limited to working in only one language
combination and will not be allowed to perform any of the following activities:


delete files from the project



split/join rows in the project



edit the source in the project



lock/unlock rows and files in the project



merge segments in the translation memories and termbases



execute SQL statements



access the project/database configuration (the Project/Translation Memory/
Termbase Properties dialogs)

Each translation user in a project, translation memory, or termbase with the enabled advanced
security features has one of nine different stages of permission levels. Users with the highest
security clearance can overwrite anything from users of the other eight levels; users with the lowest
level are unable to overwrite anything from any user except one with the same level.
Furthermore, the ability to import and/or export data in and out of projects, translation memories,
or termbases has to be individually assigned to each translation user.
If you work in a project with advanced security features, you will have to log yourself into that
project with the user name and password provided by the project owner.

To log into a project, translation memory, or termbase
1

Select Users> Login.
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2

The User Login dialog appears.

3

Enter your user name and password and click OK.

4

Every record that you edit or translate will now be associated with that user name


in the status bar of the project:

–Or–


in the translation memory or termbase:

and be protected by your particular set of rights.
Because the login will not notify you if your profile is not part of this project or
database, it may be a good idea to try logging in again if you are blocked from activities
that your security clearance should enable you to do.
To repeat a login, you do not have to first log out.

To log out from a project, translation memory, or termbase
1

Select Users> Logout.
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2

You are now logged out of the project.
You do not have to log out of a file to log into that file with a different logon. The
function of the logout feature is merely a security feature that, for instance, allows an
administrator to work on someone else’s computer, log in with the administrative
password, and simply log out when the task is finished.
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ANALYSIS FEATURES IN DÉJÀ VU X2 PROFESSIONAL—THE DETAILS
Déjà Vu X2 Professional offers two different project analysis features that allow you


to count words, characters, and embedded codes in a number of different configurations
and



to analyze the repetition within your project and the number of exact and fuzzy matches
from your existing translation memory(s).

THE COUNT FEATURE
Because of the different attributes that Déjà Vu X2 Professional applies to every segment within a
project, word counts can be a very complex matter. While some attributes are mutually exclusive
(e.g., a segment cannot be a fuzzy and a perfect match at the same time, or a segment cannot be
simultaneously locked and pending), the combination of other attributes makes sense and may be
of interest to the user (e.g., a segment can be an exact match and be finished). To satisfy the need
for an accurate overall word count as well as detailed word counts of all attributes and possible
combinations, Déjà Vu X2 Professional offers two different count modes (Simple and Full) that
use three different groups of categories.




The first mutually exclusive group is that of the flagged categories:


Finished (

),



Locked (

),



Pending (

),



Unmarked (i.e., the non-flagged translation status).

The second mutually exclusive group is that of mutually exclusive translation status
categories:


Empty (default grey indicator bar),



Manual (default grey indicator bar),



Exact (default dark green indicator bar),



Guaranteed Exact (default orange indicator bar),



Fuzzy (default light green indicator bar),
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Assembled (default dark blue indicator bar),



Machine Translated (default auburn indicator bar),



Exact Propagated (default light blue indicator bar), and



Fuzzy Propagated (default gold indicator bar).

The third group consists of several unrelated categories that are counted by Déjà Vu X2
Professional independently of the preceding categories (and are counted independently
of the total count):


Multiple Matches (indicator: blue, underlined font),



Renumbered Matches (i.e., exact matches in which either embedded codes or
numerical values were renumbered)



Stopped (



Wrong Codes (



Duplicates (i.e., duplicated source segments in a file or project)

)
)

What does all of this mean in practice?
Here is the simplest word count module (Current Language, All Files, Simple):
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In this count, the flagged categories (Unmarked, Finished, Locked, and Pending) are the main
categories that make up the Total, and the status categories are treated as sub-categories of the
Unmarked category.
All other categories are counted independently of the Total.
This count is most suitable for a quick overview of the dimensions of the project.
Following is the same word count module for the same project in Full mode:

In this count, the status categories are the main categories that make up the Total, and the flagged
categories (Unmarked, Finished, Locked, or Pending) are treated as sub-categories to the status
categories.

To count the words and characters in a single file, for each individual file, or the whole project
1

In an open project, select Tools> Word Count.
–Or–
Press Ctrl+W.
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2

The Word Count dialog appears with individual tabs to display counts for Words, Characters,
and (Embedded) Codes.
If you only want to count the words in a single file, you will have to make sure that you
view only that file. If you want to count words in the whole project, you can either
choose the single file view or the project view.

3

Make your selections from the following options:
Language—View the counts for the current language (the language combination that you are
currently viewing) or all languages.
Files—View the counts for the currently displayed file (this option is disabled if you are using
the All Segments view), for each file, or for all files.
Word Count—Decide whether you want to perform a word count according to Déjà Vu X2
Professional’s internal logic or in line with MS Word’s logic (see p. 283).
Output—View simple or full counts (see p. 277).
Miscellaneous—Check whether you would like to have the words, characters, and codes in
duplicate rows counted.

4

Select Calculate.
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5

The desired word count is displayed.

6

To view the corresponding character count, select the Character tab.
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7

To view the corresponding count of embedded codes, select the Codes tab.

To save the results in an external file format
1

Select Copy in the Word Count dialog.

2

Open a text editor or word processor.

3

Paste the text into a new document.
–Or–

1

Select Save in the Word Count dialog.

2

A file selector dialog appears.

3

Choose the folder in which the file is going to be saved, name the file, and select whether
your want to save it as a text file or as a comma-separated value (.csv) file.

4

Click Save.

Déjà Vu X2

282

Analysis Features in Déjà Vu X2 Professional—The Details

If you selected CSV as the output type and have Microsoft Excel installed on your computer,
this file will open by default in Excel.

You can see that numbers—including words, characters, and codes—are displayed in the
external file format.

USING THE WORD COUNT ACCORDING TO MS WORD
Under the option Word Count you can select to count according to Déjà Vu X2 Professional’s
internal word count logic or using the same parameters that MS Word is using.
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While both word counts are internally logic and consistent, the benefit of the MS Word word
count logic is that this is the way many clients count, providing a good way to avoid potential
conflict.

THE ANALYSIS FEATURE
The analysis feature allows you to analyze


the number of matches from your translation memory(s) in a variety of degrees of
fuzziness,



the repetition within your project (intra-project) and



the repetition between your project and other projects (inter-project).

To analyze the repetition of segments in a project
1

In a newly-created project, select Tools> Analysis.
–Or–
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Press Ctrl+Shift+W.
You can perform the Analysis function at any point during the translation of your
project (before pre-translation or well into the translation), but you will probably gain
the best overview and the most benefit from the analysis if you do this before you start
your actual translation work.

2

The Analysis dialog appears.

3

Make your selections from the following options:
Language—View the analysis for the current language (the language combination that you are
currently viewing) or all languages.
Files—View the counts for the currently displayed file, for each file, or for all files.
Word Count—Decide whether you want to perform an analysis according to Déjà Vu X2
Professional’s internal logic or in line with MS Word’s logic (see the description under p. 283).
Translation Memories—Select which translation memory(s) you want to base the analysis on.
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Additional Options—Select whether you want to perform an analysis based on the current
project only (Intra-project Analysis) or based on other projects to take potentially increased
duplication into consideration (Inter-project Analysis).
If you want to see repetition both within the current and between the current projects
and other projects, you will have to check both options.

The other of the Additional Options allows you to count (or exclude) locked segments. This is
helpful when you have a great number of locked segments due to guaranteed matching or
manual locking and you want to make sure that these don’t distort your analysis.
Projects—This option is enabled when the Inter-project Analysis is selected so that you can
select other projects to include in the analysis.
Once your options are selected, this dialog gives you access to an analysis of the following
data for each language at the current state of the project:


number of guaranteed and exact matches from the translation memory(s);



duplicates within the project;



number of fuzzy matches in various levels (percentages) of fuzziness from the
translation memory(s);



total number of (source) words in the project;



total number of matches;



internal repetition of portions in percentage.
The internal repetition percentage will give you a good idea of how useful features such
as Assemble and the Lexicon will be!
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4

Select the language for which you want to perform the analysis and click Analyze.

To save the results in an external file format
1

Select Copy in the Analysis dialog.

2

Open a text editor or word processor.

3

Paste the text into a new document.
–Or–

1

Select Save in the Analysis dialog.

2

A file selector dialog appears.

3

Choose the folder in which the file is going to be saved, name the file, and select whether
your want to save it as a text file or as a comma-separated value (.csv) file.

4

Click Save.
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WORKING WITH DIFFERENT FILE FORMATS
One of Déjà Vu X2 Professional’s distinctive advantages is that you have the possibility of working
with a wide range of file formats. Whatever type of file you work with, Déjà Vu X2 Professional
presents you with a uniform interface, displaying only translatable text, so you can work
comfortably without having to worry about overwriting formatting and layout information.
Déjà Vu X2 Professional has built-in filters that allow you to work with:


Microsoft Word up to version 2003 (see p. 300)



RTF (see p. 305)



Microsoft PowerPoint up to version 2003 (see p. 306)



Microsoft Excel up to version 2003 (see p. 307)



Microsoft Office 2007/2010 (see p. 309)



OpenOffice/StarOffice (see p. 310)



Microsoft Access (see p. 311)



FrameMaker (see p. 313)



PageMaker (see p. 320)



QuarkXPress (see p. 324)



InDesign (see p. 327)



Interleaf/Quicksilver (see p. 331)



Plain Text (see p. 332)



Help Content (.cnt) (see p. 332)



HTML (including scripts and ASP) (see p. 333)



SGML/XML (for more information on SGML, see p. 338)



Java Properties (see p. 342)



RC (see p. 342)



C/C++/Java source files (see p. 344)
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RESX files (see p. 345)



GNU gettext files (see p. 346)



IBM TranslationManager (see p. 347)



Trados Word/RTF (see p. 349)



Trados TagEditor (see p. 351)



TMX (see p. 353)



XLIFF (see p. 352)

All of these formats are recognized by their appropriate extensions but can be reconfigured.

To reconfigure the default relationship between file format and file extension
1

If you need to change the default association between file format and file extension, select
Project> Properties> Filters to change it for the current project
–Or–
Select Tools> Options> Filters to change it for all.
An example of when this may become necessary would include situations where you
continuously have to work with Interleaf or Trados documents, both of which have the
.doc extension, which by default is assigned to Word.
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2

The Filters tab appears.
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3

Select the extension for which you want to have the association changed.
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4

Select a new association from the drop-down list at the bottom of the screen.
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5

Click Replace.

6

Click Apply and/or OK.

7

A new default extension-filter association has been created. Now during the import process,
the Interleaf filter will be applied to every .doc file.

To reconfigure the individual relationship between file format and file extension
When importing files, the default extension-filter association can be changed on an individual file
basis.
1

When importing a file through the New Project Wizard, select Properties when you select the
files that you are going to import.
–Or–
When importing selecting a file for import in the Advanced Project Explorer, the default
extension-filter association is displayed in a pane labeled Properties on the right side of the
screen.
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2

Click the drop-down arrow that appears when you select the Filter segment, and select the
desired filter for this specific file.

3

The new filter will be applied to this file during the import process.

To apply specific import options
All of the file formats have file-specific import options that you can select and apply to the import
process.
1

When importing a file through the New Project Wizard, select Properties when you select the
files that you are going to import.
–Or–
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When selecting a specific file or several files of the same format in the Advanced Project
Explorer, the import options for that format will be automatically displayed in a pane labeled
Properties on the right side of the screen.

2

Make the appropriate selections by checking the check boxes.

3

Right-click the file name and select Import from the context menu.

4

The file is being imported with the options you specified.

To apply global or project-wide import options for each file extension
Rather than specifying the format-specific import options for single or small numbers of files, it can
be helpful to change the default option on a project-wide or even global basis.
You can change the options on the basis of the file extension. This means that although .htm files
may be of the same format as .html files, they could have different import options.
1

Select Project> Properties> Filters to change the options for the current project.
–Or–
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Select Tools> Options> Filters to change the import options globally.
2

The Filters tab appears.
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3

Select the extension for which you want to change the default import option for the current
project.

4

Select the selector button (

5

The Filter Options dialog appears where you can make the desired changes.

6

Click OK.

7

Click Apply and/or OK.

) to the right of the filter options in the lower part of the dialog.
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8

The default filter options for every file with the extension .htm have been created.

GLOBAL IMPORT OPTIONS
Prevent Segmentation
There is one option that is common to all file formats: Prevent Segmentation. In fact, if you choose
to import several files of more than one file format with the Advanced Project Explorer, this option
will still be displayed in the Properties window.

By checking this option, you override all segmentation rules that you set under Tools> Options>
Delimiters. For more information on setting up segmentation rules, see "Sentence Delimitation" on
page 215.
The only segmentation rules that will still be followed when this option is checked are


hard returns or their equivalents,



the end of cells (such as in tables or in Excel), or



the end of other already-marked segments (such as in Trados or IBM TM files).
You should use this option sparingly. As a rule of thumb, the larger your translation
segments become, the more difficult it will be for your translation memory to come up
with good matches. Situations where this option may prove to be helpful could include
software source files (RC, C/C++, Java) where existing glossaries often contain
complete strings that encompass several segments, documents that are to be translated very freely
(across source segment levels), or documents that are imported into Déjà Vu X2 Professional for
the purpose of editing or proofreading.

Encoding
Encoding is an import and export option for a variety of formats.
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Clicking on the down-arrow at the end of the encoding line allows you to define a code page for
the file(s) you are importing and/or exporting.

If a selection is not made during the import, Déjà Vu X2 Professional will select the code page
that it recognizes in the source file (i.e., a Unicode UTF-8 file will be imported with that code
page).
If you do not make a selection during the export, Déjà Vu X2 Professional will select the best
code page based on the following information:


code page of the source file



the target language



the actual text found in the target file



the file format

MICROSOFT WORD 2003 AND BELOW
Déjà Vu X2 Professional includes support for Microsoft Word documents (.doc files). No special
procedure is required to translate them; however, you must have Microsoft Word installed on your
computer. Déjà Vu X2 Professional supports Word 6.0, 95 (7.0), 97 (8.0), 2000 (9.0), XP (2002 or
10.0), and 2003 (11.0).
It is recommended that you use Word 97 or higher due to limitations in previous
versions.
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WORD-SPECIFIC IMPORT OPTIONS

Ignore Hidden Text
This option controls whether hidden text in a Word document will be displayed in Déjà Vu X2
Professional.
Situations where this is a very helpful option include:


documents where you want to translate only a certain section and in which you can
choose to hide the sections that are not translatable;



documents that contain hidden code, including WinHelp source files that contain
hidden text defining "jumps" within the Help (see graphic below).

Import Field Results
This option refers to the rare situation where the result of a field needs to be translated.
Non-translatable Notes
The option for non-translatable notes refers strictly to WinHelp source files that contain footnotes,
some of which are translatable and others which are not.
If you do not translate Help files, you do not have to worry about modifying this setting.
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In the following example of a WinHelp file, you can see both the hidden text and the markers for
the footnotes.

WORD-SPECIFIC EXPORT OPTIONS
When you export a Word document, you will be presented with the following filter-specific
options:
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Export source comments as Office comments—allows the export of source comments to Microsoft
Word comments.
Export target comments as Office comments—allows the export of target comments to Microsoft
Word comments.
Highlight text in exported files—allows the highlighting of text according to the translation status in
Déjà Vu X2 Professional.
Selecting the Highlight text option activates two more options:
Highlight options—lets you access a dialog that allows you to select what kind of rows should be
highlighted in what manner.
Highlight order of preference—lets you choose whether rows with Translation Status (pending,
locked, etc.) or Match Type (exact, fuzzy, assembled, etc.) should take preference.
Clicking on the file selector button on the Highlight options row (the file selector only becomes
activated when you actually select the row) brings up the Segment Highlight Options dialog.
Clicking Add lets you select individual formatting options (including any combinations of bold,
italics, underline, strikethrough, text color, or underlying color) for as many different Segment
Types as you like.

Déjà Vu X2

303

304

When you are done with your selection, click OK.
Assuming that the Word file in the following Déjà Vu X2 Professional project had one pending
line and one comment—

—and the user chooses to display comments in Word and highlight pending segments in bright
magenta, the exported file would look like this:

Tips and Tricks with Word
When importing Word documents, Déjà Vu X2 Professional will run macros in the Word program
that you have installed. If your version is Word 2000 or higher, you will have to set the security
settings (Tools> Macro> Security) in Word to Medium or Low to be able to import and export
Word files.
If character spacing was used in your document, it is advisable to take it out before importing the
document into Déjà Vu X2 Professional. You can do this by selecting the complete document
(Ctrl+A) and then selecting Format> Font> Character Spacing> Spacing> Normal.
If you have used the Track Changes or the Comments function in Word, make sure that you accept
all changes and delete all comments before you process the Word document. Otherwise, you will
see both options (before and after edit) as well as the text of the comments displayed in
Déjà Vu X2 Professional.
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If you import a Word document from Word 97 or any higher version that contains text boxes, the
text in these will be duplicated in the Déjà Vu X2 Professional project. The Word document
contains duplicates of the text boxes to guarantee the compatibility with earlier versions.
Finally, it is possible to make good use of Word’s AutoFormat option. It’s not possible to add
formatting that is not contained in the source documents to your Word documents directly within
Déjà Vu X2 Professional, but you can enclose words with certain characters (such as _these_ for
italics and *these* for bold formatting) and use Word’s AutoFormat feature (Tools> AutoFormat) to
apply the desired formatting. Here are the preconfigured AutoFormat options that Word offers:

RTF (RICH TEXT FORMAT)
The options for RTF files are almost identical to that of Word (see "Microsoft Word 2003 and
below" on page 300), only that there is no need to have an installation of Word on your computer
and therefore the security settings in Word have no influence on the import process.
Déjà Vu X2 Professional adheres strictly to the Microsoft RTF standard of Word 2002
and lower, and will process any files that follow that standard. There are several nonMicrosoft applications that export RTF files; in some situations, these applications may
export RTF files that do not conform to the standard. In such cases, it is possible that
Déjà Vu X2 Professional may not be able to correctly import those RTF files.
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MICROSOFT POWERPOINT 2003 AND BELOW
As is the case with Word files, no special procedure is required to translate PowerPoint .ppt files.
However, you must have Microsoft PowerPoint 97 (or later) installed on your computer.
Because of the way in which Déjà Vu X2 Professional works with PowerPoint files,
once a translation is finished and ready to be exported, the original, unaltered .ppt file
must be in the location from which it was imported. This is essential, because any slight
modification to the file may prevent Déjà Vu X2 Professional from being able to
export the final translation.

POWERPOINT-SPECIFIC IMPORT OPTIONS

Process Notes
This option controls whether PowerPoint notes are included in the translation project. To see
whether you have notes in your project, open the PPT file in PowerPoint and select View> Notes
Page.
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Process Slide Master
This option controls whether the Slide Master that contains formatting information is to be
included in the translation project. Typically you do not need to translate the information on the
Slide Master.

Tips and Tricks with PowerPoint
PowerPoint files are often written by people who are inexperienced in formatting documents.
Instead of using styles and correctly sized text boxes, they tend to use soft returns and hard returns
to force line breaks. Déjà Vu X2 Professional will ignore soft returns by default, but it will break a
segment in which a hard return occurs. To avoid that, it is a good practice to go through the
PowerPoint document and replace all the unnecessary hard returns with soft returns.
PowerPoint files often contain graphics that at first sight look just like text. If there is a whole slide or
a part of a slide that has not been imported into Déjà Vu X2 Professional, make sure that this is
not a graphic or another non-translatable object. To do that, you can right-click that specific area in
the open PowerPoint file. If one of the options is either Format Picture or Format Object, chances
are that you will not be able to use Déjà Vu X2 Professional for the translation of this.

MICROSOFT EXCEL 2003 AND BELOW
As with Word files, no special procedure is required to translate Excel .xls files. However, you must
have Microsoft Excel 97 (or later) installed on your computer.
Because of the way in which Déjà Vu X2 Professional works with Excel files, once a translation is
finished and ready to be exported, the original, unaltered .xls file must be in the location from
which it was imported. This is essential, since any slight modification to the file may prevent
Déjà Vu X2 Professional from being able to export the final translation.

EXCEL-SPECIFIC IMPORT OPTIONS
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Ignore Red Text
Excel files often contain both translatable information and other information that you do not want
to have translated. Instead of having to go through an imported Excel file and manually sorting out
the information that needs to be translated, you can open the file in Excel, highlight the cells that
do not have to be translated, and paint them red by selecting Format> Cells> Font> Color.

Déjà Vu X2 Professional will now ignore text in these cells when it imports the file. When the file
has been translated and exported, you can remove the red formatting.

Tips and Tricks with Excel
It is not possible to join lines in Excel files between segments. However, you will be able to join two
segments that originate from the same cell.
In situations where a target column has to be added to a source column (rather than overwriting
the existing source), you can duplicate the source column within Excel and paint the first of the
columns red. If you then enable Ignore Red Text during the import into Déjà Vu X2 Professional,
the first column will not be imported and thus not be changed, and the second column will be
imported and translated.
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MICROSOFT OFFICE 2007 AND 2010 (OPEN XML)
The formats between MS Office 2003 and later versions have dramatically changed. No matter
whether it is Excel, PowerPoint, or Word documents or templates, they are all based on XML and
can all be processed with one filter. The supported file extensions include docm, docx, dotm,
dotx, potm, potx, pptm, pptx, xlsm, xlsx, xltm, and xltx.

MS OFFICE 2007/2010-SPECIFIC IMPORT OPTIONS

The only filter-specific option is to ignore hidden text. If you need some of the more advanced
filter options available for earlier versions of MS Office files, you have the option of saving the file
to an earlier version of MS Office. To do that, press F12 within MS Office 2007 and 2010.
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OPENOFFICE/STAROFFICE/OPEN DOCUMENT
Déjà Vu X2 Professional supports the files of OpenOffice 1 and StarOffice 6 with the OpenOffice
filter. The supported file types include word processing (.sxw), spreadsheets (.sxc), and
presentations (.sci).
Later version of OpenOffice and LibreOffice are supported with the OpenDocument filter. The
supported file extensions for this filter include odc, odf, odg, odi, odm, odp, ods, odt, otc, otf, otg,
oti, otp, ots, ott.

Tips and Tricks with OpenOffice/StarOffice files
If you have used the Record Changes or the Notes function in an OpenOffice document, make
sure that you accept all changes and delete all comments before you process the document.
Otherwise, you will see the corrected option displayed at the beginning of the document as well as
the text of the notes displayed in Déjà Vu X2 Professional.
Like in Word, it is possible to make good use of OpenOffice/StarOffice’s AutoFormat option. It’s
not possible to add formatting that is not contained in the source documents to your .sxw
documents directly within Déjà Vu X2 Professional, but you can enclose words with certain
characters (such as _these_ for underline and *these* for bold formatting) and use OpenOffice/
StarOffice’s AutoFormat feature (Tools> AutoCorrect/AutoFormat) to apply the desired formatting.
Here are the preconfigured AutoFormat options that OpenOffice/StarOffice offers:
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MICROSOFT ACCESS
Though the translation of database content has become very important, it still presents a great
challenge to translation memory tools.


Typically, only a small part of the database—often only one field (of many hundred
existing ones)—needs to be translated.



By overwriting the content of the translatable field, relationships may get lost.



The records may contain a variety of text—including HTML, RTF, and SGML, to only
name a few—for which other specified filters are necessary.

Déjà Vu X2 Professional has found creative ways to deal with these challenges, and it supports
Access97, 2000, and XP (2002) files.

ACCESS-SPECIFIC IMPORT OPTIONS
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When you select the Custom field, an ellipsis button appears to the right of that line. If you click
that button, the ODBC Import Options dialog appears.

In this dialog, you can see the tables of the database in question (under Tables), the fields or
columns in each of the tables (under Columns), and you can see samples of the content of the
fields on the right side of the dialog. By default, all fields are selected as non-translatable; indeed,
in this example, only one field, "s_content," needs to be translated.
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By selecting that field, checking the Translate check box, specifying the type of text that needs to
be translated (in this example Plain Text), and specifying that the translation should be sent to the
field "t_content" under Send translation to field, you can easily set up the translation of the relevant
content of this database.

For options to define the code page during export and import, see "Encoding" on page 299.

ADOBE FRAMEMAKER
Déjà Vu X2 Professional includes support for Adobe FrameMaker 5-10 MIF files.
Déjà Vu X2 Professional cannot import FrameMaker binary FM files; if you have an
FM file that you want to translate in Déjà Vu X2 Professional, you must convert it to
MIF format.
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To convert an FM file to MIF format
1

Open the file you want to convert in Adobe FrameMaker 5-10.

2

On the File menu, click Save As.

3

The Save Document dialog appears.

4

Select the path you want to save the document to.

5

Click the Save as type dropdown list and select MIF (*.mif).
If available, you should save as a MIF 10.0 rather than a MIF 7.0 file, since only the
former is fully Unicode compliant.

6

Click Save.
If you do not own a copy of FrameMaker, you should ask your client to send
FrameMaker files in MIF format.
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FRAMEMAKER-SPECIFIC IMPORT OPTIONS

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

Exposable Markers
The default setting for exposable markers is 2 (index markers). This is a setting that you probably
do not want to change, as index markers usually are the only translatable markers.

Ignore Variable Definitions
If checked, Déjà Vu X2 Professional will ignore all variable definitions, such as the book title.

Ignore Automatic Numbering
If checked, Déjà Vu X2 Professional will ignore all automatically generated automatic numbering
information, such as Section 1.1.1.1 or Table 1.1.1.1.

Ignore Cross-Reference Definitions
If checked, Déjà Vu X2 Professional will ignore all automatically generated cross-reference format
texts, such as See XX on page XX, etc.

Ignore Text on Master Page
If checked, Déjà Vu X2 Professional will ignore all text on the master page, including all nonvariable information in the header and footer.

Convert Hard Spaces to Soft Spaces
If checked, Déjà Vu X2 Professional will convert all non-breaking spaces (inserted into the
FrameMaker document with the key combination Ctrl+Space) to regular spaces. If unchecked,
Déjà Vu X2 Professional will embed all non-breaking spaces with an embedded code. Generally,
this option should be enabled.
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FONT MAPPING
It may be necessary to change the fonts for translations into languages that use a completely
different font system from your source language (i.e., from English to Chinese, or from Japanese to
German).
To access the MIF Font Mapping tab, select Project> Properties> MIF Font Mapping.

You can now see a list of all fonts and their properties used in the FrameMaker files within your
project.
To make changes to the individual fonts, select a different font by clicking the down arrow to the
right of the Map to row and making the other appropriate changes in each of the other rows
(Angle: regular or italic; Weight: regular or bold; Variant: regular, oblique, narrow, or condensed;
Size; and—in the case of Japanese—Tsume: to move a character closer to the next).
When you are done with your changes, click Apply and/or OK.
You can also change the fonts globally by selecting Global Replacement and selecting a different
font by clicking the down arrow to the right of the Map to row in the Global Font Replacement
dialog.
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By using the up and down arrows to the right of the Size delta rows, you can make proportional
adjustments to the size of the fonts.

FRAMEMAKER-SPECIFIC EXPORT OPTIONS
When you export a FrameMaker document, you will be presented with the following filter-specific
options:

Export source comments as conditional text—allows the export of source comments to the
DVXSourceComments condition.
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Export target comments as conditional text—allows the export of target comments to the
DVXTargetComments condition.
Highlight text in exported files—allows the highlighting of text according to the translation status in
Déjà Vu X2 Professional.
Selecting the Highlight text option activates two more options:
Highlight options—lets you access a dialog that allows you to select what kind of rows should be
highlighted in what manner.
Highlight order of preference—lets you choose whether rows with Translation Status (pending,
locked, etc.) or Match Type (exact, fuzzy, assembled, etc.) should take preference.
Clicking on the file selector button on the Highlight options row (the file selector only becomes
activated when you actually select the row) brings up the Segment Highlighting Options dialog.
Clicking Add lets you select individual formatting options (including any combinations of bold,
italics, underline, strikethrough, or text color) for as many different Segment Types as you like.

When you are done with your selection, click OK.

Déjà Vu X2

318

Working with Different File Formats

Assuming that the FrameMaker file in the following Déjà Vu X2 Professional project had one
pending line and one comment—

—and the user chooses to display target comments in FrameMaker and highlight pending rows in
bright magenta, the exported file would look like this:

You can choose to display or hide conditions in FrameMaker with the command
Special> Conditional Text> Show/Hide.
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Tips and Tricks with FrameMaker
If all files of your FrameMaker book follow one or possibly two sets of formats, you can avoid a
large amount of repetition in your project by doing the following: Uncheck all the special "Ignore"
options for one representative file and check them for all other files. Once you have exported all of
your files, you can import the formats of the representative file to all other files (in FrameMaker,
select, File> Import> Formats).
Make sure that your FrameMaker files do not contain any change bars (markers that indicate
changes to the file). To delete existing change bars, select Format> Document> Change Bars>
Clear All Change Bars.
To re-import a file that has already been exported as a MIF file from a Déjà Vu X2 Professional
project, you will have to open that file in FrameMaker, save it as an FM file, close and re-open that
FM file in FrameMaker, and save it as MIF.

ADOBE PAGEMAKER
Déjà Vu X2 Professional includes support for Adobe PageMaker 6.5 and 7 files.
To process Adobe PageMaker documents, you must first save the text you want to translate as a
"tagged text" file.

To export a story
1

Open the file you want to process in PageMaker.

2

In Layout view, click anywhere on the story you want to export.

3

Select Edit> Edit Story.

4

The story appears as editable text.

5

Select File> Export> Text.
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6

The Export Document dialog appears.

7

Select the correct export location.

8

Accept the default name or enter a name for the export file.

9

Click the Save as type dropdown list and select Tagged text.

10 Make sure the options Entire story and Export tags are selected.
11 Click Save.
You can either repeat this procedure for each text chain (which constitutes a story) in the
PageMaker document, or you can combine and export all stories within one document.

To combine and export stories
1

Open the PageMaker document from which you want to combine and export stories.

2

Select File> Save As.

3

Save the document as A copy in 6.0 format (PageMaker 7: A copy in 6.5 format).

4

Open a new PageMaker publication by selecting File>New.
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5

In the Document Setup dialog, adjust the settings to match the settings from the original.

6

Select File>Place, select the formerly saved document, and then click OK.

7

The Place PageMaker Stories dialog appears, listing every story in the publication in the order
in which they were placed.

8

If necessary, enter 1 into the characters field to include all stories and click Relist.

9

Click Select All to combine all stories in the document, or hold down the Shift key while
clicking on the stories you want to combine, and then click OK.

10 The pointer changes to a loaded icon (

).

11 Click the loaded icon. All the stories are pasted into the new document as one story.
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12 To export this story into a text file, see "To export a story" on page 320.
This procedure will not copy any non-text items (such as graphics) into the new
document, so you will have to either manually paste those into the new document or
revert to exporting each story individually in the old document.

When you have imported, translated, and exported the tagged TXT file in Déjà Vu X2
Professional, you have to replace the text into the PageMaker document.

To re-import the story
1

Make a copy of the original file from which you exported the tagged text file.

2

Open the copy in PageMaker.

3

In Layout view, click anywhere on the original story you want to replace.

4

On the Edit menu, click Edit story.

5

On the File menu, click Place.

6

The Import to Story Editor dialog appears.
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7

Select the TXT file which Déjà Vu X2 Professional has exported (the one containing the final
translation).

8

Make sure that the following options are selected:

9



In the Place option group: Replacing entire story.



In the Options option group: Retain format, Convert quotes, and Read tags.

Click Open.

10 The translation is being imported.

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.
Because PageMaker does not support Unicode, none of the Unicode code pages is offered. If you
use the default encoding option, Déjà Vu X2 Professional will select the code page that is used in
the file (import) or select one according to the target language (export).

Tips and Tricks with PageMaker
PageMaker files are often delivered in Mac format. Though it is usually no problem to open these
files on a PC, your client may not want you to convert these files to PC files. To avoid problems
with special characters in the original or translated TXT files, you will have to change the code page
of the tagged file between Mac and Windows. Do this by selecting a Mac code page during the
import and export processes.
Double-byte PageMaker files (Chinese, Japanese, Korean) can only be opened and processed on a
native (Chinese, Japanese, or Korean) version of PageMaker.

QUARKXPRESS
Déjà Vu X2 Professional includes support for QuarkXPress 4 and higher.
To process QuarkXPress documents, you must first save the text you want to translate as an XPress
Tag file.

To export text as an XTG file
1

Open the file you want to process in QuarkXPress.
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2

Make sure that the Content tool (

) is selected. If it is not displayed, press F8.

3

Click the text box that contains the beginning of the text chain you want to export.

4

Select File> Save Text.

5

The Save Text dialog appears.

6

Select the correct export location.

7

Enter a name for the export file.

8

Click the Save as type dropdown list and select XPress Tags.

9

Make sure the option Entire Story is selected.

10 Click Save.
For each text chain (which constitutes a story) in the XPress document, you will have to
repeat this procedure because QuarkXPress does not provide an automated way of
exporting all the stories together.

After you have imported, translated, and exported the .xtg file in Déjà Vu X2 Professional, you
have to replace the text into the QuarkXPress document.

To re-import the XTG file
1

Make a copy of the original file from which you exported the .xtg file.

2

Open the copy in QuarkXPress.

3

Click the text box containing the beginning of the story you exported.
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4

Select File> Get Text.

5

The Get Text dialog appears.

6

Select the XTG file which Déjà Vu X2 Professional has exported (the one containing the final
translation).

7

Make sure that the Include Style Sheets option is selected.

8

Click Open.

9

The translation is being imported.

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.
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As QuarkXPress before version 7 did not support Unicode, none of the Unicode code pages are
offered for those versions. If you use the default encoding option, Déjà Vu X2 Professional will
select the code page which is used in the file (import) or select one according to the target
language (export).

Tips and Tricks with QuarkXPress
For jobs that contain a large number of stories, we recommend that you obtain a copy of CopyFlow
Gold for Quark. These allow you to export text from all the stories in the document to a single TTG
file, a format that can be read by the XTG filter (for more information, see napsys.com).
Quark files are often delivered in Mac format. Though it is usually no problem to open these files
on a PC, your client may not want you to convert these files to PC files. To avoid problems with
special characters in the original or translated TXT files, you will have to change the code page of
the tagged file between Mac and Windows. Do this by selecting a Mac code page during the
import and export processes.

INDESIGN
Déjà Vu X2 Professional includes support for various versions of InDesign with different filters


InDesign 2 and CS with the Adobe InDesign Tagged Text filter



InDesign CS2 through CS4 with the Adobe InDesign INX filter



InDesign CS4 and higher with the Adobe InDesign IDML filter

INDESIGN 2 AND CS
To process Adobe InDesign documents, you must first save the text you want to translate as a
"tagged text" file.

To export a story
1

Open the file you want to process in InDesign.

2

Select the Type tool (

3

Select File> Export.

) and click in the story you want to export.
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4

The Export dialog appears.

5

Specify a name and location for the exported story, and select Adobe InDesign Tagged Text
under Save as Type.

6

Click Save.

7

The Adobe InDesign Tagged Text Export Options dialog appears.

8

Select Verbose under Tag Form and the correct encoding under Encoding.
Make sure that you select Unicode if you are translating into or from any non-Western
language.

9

Click OK.

When you have imported, translated, and exported the tagged .txt file in Déjà Vu X2
Professional, you have to replace the text into the InDesign document.
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To re-import the story
1

Open the .indd file in InDesign.

2

Select the Type tool (

3

Select File> Place.

4

The Place dialog appears.

5

Select Convert Quotes, Retain Format, and Replace Selected Items and navigate to the
location of your translated file.

6

Select the file and click Open.

7

The translation is being imported.

) and click in the story you want to import.

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.
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THERE IS NO NEED TO DEFINE A CODE PAGE FOR THE IMPORT BECAUSE
DÉJÀ VU X2 PROFESSIONAL WILL TAKE THAT INFORMATION FROM THE HEADER
OF EACH INDESIGN FILE. THE POSSIBLE EXPORT CODE PAGES INCLUDE ANSII,
ASCII, UNICODE, SHIFTJIS, AND BIG5. IF YOU USE THE DEFAULT ENCODING
OPTION, DÉJÀ VU X2 PROFESSIONAL WILL SELECT THE CODE PAGE ACCORDING
TO THE TARGET LANGUAGE (EXPORT).
INDESIGN CS2 THROUGH CS4
Starting with InDesign CS2, Adobe introduced the exchange format INX, which is XML-based and
allows you to export all stories into one file. To save an InDesign .indd file as an .inx file, select
File> Export in InDesign, select InDesign Interchange under Save as Type, and save the file in an
appropriate location under Save as Type.

ONCE THE TRANSLATION IS FINISHED, AND THE .INX FILE EXPORTED OUT OF
DÉJÀ VU X2 PROFESSIONAL, YOU CAN OPEN IT UP IN INDESIGN WITH THE
COMMAND FILE> OPEN AND SAVE AS A .INDD FILE.
INDESIGN CS4 AND HIGHER
Starting with InDesign CS4, Adobe introduced yet another exchange format. It’s called IDML and
allows for an even more seamless conversion between different tools, including CAT tools.
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To save an InDesign .indd file as an .idml file, select File> Export in InDesign, select InDesign
Markup under Save as Type and save the file in an appropriate location under Save as Type.

ONCE THE TRANSLATION IS FINISHED, AND THE .INX FILE IS EXPORTED OUT OF
DÉJÀ VU X2 PROFESSIONAL, YOU CAN OPEN IT UP IN INDESIGN WITH THE
COMMAND FILE> OPEN AND SAVE IT AS AN .INDD FILE.

INTERLEAF/QUICKSILVER
Déjà Vu X2 Professional can process Interleaf/Quicksilver ASCII files exported with Interleaf 6 or
later. Binary Interleaf/Quicksilver files are not supported, so make sure that you save the Interleaf/
Quicksilver documents as ASCII, or ask your client to do so if you do not own a copy of Interleaf/
Quicksilver.

To save an Interleaf document in ASCII format
1

Open the document in Interleaf/Quicksilver.

2

On the File menu, click Save As.
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3

The Save As dialog appears.

4

Select the correct folder and enter the name of the file you want to save to.

5

Click the Save as type dropdown list and select ASCII (*.doc).

6

Click Save.

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

PLAIN TEXT
Déjà Vu X2 Professional can, of course, process plain text files. For general options to define the
code page during export and import, see "Encoding" on page 299.
All code pages that are supported by Windows can be selected for the export or import. If none is
selected for the import, Déjà Vu X2 Professional will detect the code page in the file or choose
the code page best suited for the language in the source file. If no code page is selected for the
export, Déjà Vu X2 Professional will choose the best suitable code page for the target language
and/or the actual content, with a preference to Unicode (UTF-16).

HELP CONTENT
Help content files are simple text files that automatically create the table of contents in a WinHelp
file.
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View of a Help Contents .cnt file in a text editor:

Déjà Vu X2 Professional will ignore the non-translatable content following the equal signs and the
numbers when importing these files.

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

HTML AND SCRIPT-BASED FILES
Déjà Vu X2 Professional includes extended support for HTML and script-based files.

HTML-SPECIFIC IMPORT OPTIONS
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Ignore Strings in Script
This option controls whether translatable text in scripts such as JavaScript or VBScript should be
translated or excluded.
Unless you know that there is no translatable text within any script, you should not
enable this option.

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.
Déjà Vu X2 Professional will usually be able to separate translatable from non-translatable
content in HTML files and display the translatable content correctly. Because of the nature of
customizable and regularly re-defined scripting languages, there may be situations where some
text is imported that should not be translated. You can choose to copy this text from the source to
the target column and possibly lock those rows, but Déjà Vu X2 Professional also allows you to
write simple regular expression files that would exclude these lines. For more information on this,
see "Creating Customized HTML Import Files" on page 505.
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HTML-SPECIFIC EXPORT OPTIONS
When you export a file that adheres to the HTML specification, you will be presented with the
following filter-specific options:

Encoding—Regardless of the format of the imported file, you can choose to export the files in any
of the code pages that are supported by Windows. When exporting the file, Déjà Vu X2
Professional will not only change the actual code page but also the corresponding META tag.
In the above example of a Simplified Chinese file, after the export the meta tag will read:
<META http-equiv=Content-Type content="text/html; charset=gb2312">
If no code page is selected, Déjà Vu X2 Professional will select a code page suitable to
the target language and actual language used, with a preference to the same code page
used during the import.

Export special characters as entities—If you select this option, special characters will be exported
in the appropriate code (© will, for instance, be exported as &copy;). If you select Export as they
are, they will not be converted (© will stay ©).
Export source comments as pop-up text—allows the export of source comments to text in HTML
pop-ups.
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Export target comments as pop-up text—allows the export of target comments to text in HTML
pop-ups.
Highlight text in exported files—allows the highlighting of text according to the translation status in
Déjà Vu X2 Professional.
Selecting the Highlight text option activates two more options:
Highlight options—lets you access a dialog that allows you to select what kind of rows should be
highlighted in what manner.
Highlight order of preference—lets you choose whether rows with Translation Status (pending,
locked, etc.) or Match Type (exact, fuzzy, assembled, etc.) should take preference.
Clicking on the file selector button on the Highlight options row (the file selector only becomes
activated when you actually select the row) brings up the Segment Highlight Options dialog.
Clicking Add lets you select individual formatting options (including any combinations of bold,
italics, underline, strikethrough, or text color) for as many different Segment Types as you like.

When you are done with your selection, click OK.

Déjà Vu X2

336

Working with Different File Formats

Assuming that the HTML file in the following Déjà Vu X2 Professional project had one pending
line and one comment—
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—and the user chooses to display target comments in HTML and highlight pending rows in bright
magenta, the exported file would look like this:

Tips and Tricks with HTML and Script-Based Files
When you translate a website that you have copied to your hard drive, and export it to a different
path than the original files, the HTML files will look different than the original files because of
missing graphic files. To display the images correctly in the webpages, you will have to copy the
image folder(s) to the exact same relative position that they held in the folder structure of the
source files (for instance, as a subfolder to the root of the website).
If you translate HTML files and need to open and save them in an application other than
Déjà Vu X2 Professional or an Internet browser, make sure that you only open them in a simple
text editor, an HTML editor that does not add any additional coding, or the HTML editor the files
were originally created in. Otherwise you will run the risk of corrupting the files.

SGML/XML
SGML stands for Standardized General Markup Language, which is not a file type but a
metalanguage used to define markup languages. These definitions are called Document Type
Definitions or DTDs. Each set of SGML documents has its DTD, which means that—unlike with
Word, Excel, or FrameMaker—you will have to teach Déjà Vu X2 Professional how to interpret
these files. You can do this by creating a specific SGML/XML filter for each SGML/XML project you
work on. For more information on how to build an SGML/XML filter, see "Creating and
Maintaining SGML/XML Filter Files" on page 355.
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Déjà Vu X2 Professional includes support for all documents that follow the SGML standard.
Because SGML and XML are widely used in all kinds of applications of data storage and data
exchange, the use of the SGML filter goes far beyond the translation of files that have the default
.sgml, .sgm, or .xml extension.
A good way to determine whether files can be imported with the SGML/XML filter is to
open the file in question in a text editor and verify that it follows the basic structure of:
<TAG ATTRIBUTE1="translatable" ATTRIBUTE2="not translatable">translatable
text</TAG>

SGML/XML-SPECIFIC IMPORT OPTIONS

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

Filter Definition File
In the SGML filter, you will have to select a project-specific filter definition file (for information
about creating these files, see "Creating and Maintaining SGML/XML Filter Files" on page 355).
1

When you select the Filter Definition File line, a file selector button (
of the line.

2

Click

) appears at the right

.
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3

The Select Name and Location of Filter File dialog appears.

4

Select your filter definition file and click Open.

5

You can see that the filter is now selected.

Once you have selected the filter file, the import process is the same as with any other file.
For options to define the code page during import, see "Encoding" on page 299.
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SGML/XML-SPECIFIC EXPORT OPTIONS
When you export a file that adheres to the SGML/XML specification, you will be presented with
the following filter-specific options:

Special Characters—If you select Export as Entities, special characters will be exported in the
appropriate code (© will, for instance, be exported as &copy;). If you select Export as they are,
they will not be converted (© will stay ©).
Encoding—Regardless of the format of the imported file, you can choose to export the files in any
of the code pages that is supported by Windows.
If no code page is selected, Déjà Vu X2 Professional will select a code page suitable to the target
language and actual language used, with a preference to the same code page used during the
import.

Tips and Tricks with SGML/XML
A good way to determine whether your settings for the SGML/XML filter file are correct is to import
a few sample files and see whether you are satisfied with the segmentation. If not, determine
where the problem occurs, fix the SGML/XML filter file, and import your files again.
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JAVA PROPERTIES
Java Properties files are simple text files that are used in Java applications.
View of a Java Properties file in a text editor:

Déjà Vu X2 Professional will ignore the non-translatable content preceding the equal signs as well
as all text preceded by the number sign (#), and it will use an HTML sub-filter to interpret the
HTML coding in the file.

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

RC (RESOURCE)
RC files are simple text files that are compiled into binary files such as .exe’s and .dll’s.
To create an RC file from an .exe or .dll file, you will have to save the file in your development
environment as an RC file.
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View of an RC file in a text editor:

Déjà Vu X2 Professional will ignore all non-translatable content. This includes everything outside
quotation marks, with the exception of the copyright note (which is in quotation marks but should
not be translated).

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

Tips and Tricks with RC Files
Because the syntax of RC files uses the quotation mark as a functional character, it requires a
duplicated quotation mark ("") for every linguistic quotation mark ("Click on ""Next"" to
continue"). To make the translation process easier, Déjà Vu X2 Professional will display every
duplicated quotation mark ("") as a single quotation mark ("), and then replace those instances with
a required duplicated quotation mark ("") during the export of the file.
RC files often have a limitation for the length of a string (for instance, a string may not be longer
than 255 characters). For these situations, the current record position indicator on the status bar
(see p. 51) is very helpful.
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C/C++/JAVA
C/C++ and Java files are simple text source files that are compiled into C/C++ and Java
applications.
View of a .cpp file in a text editor:

Déjà Vu X2 Professional will ignore all non-translatable content. This includes everything outside
quotation marks.
File types that are supported by this filter by default include .cpp, .c, .h, and .hpp files.

C/C++/JAVA-SPECIFIC IMPORT OPTIONS

Ignore Text in Single Quotes
This option allows you to specify whether you would like to have text in ’single quotes’ treated the
same as text in "double quotes" or ignored.

Déjà Vu X2

344

Working with Different File Formats

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

RESX FILES
RESX files are simple XML-based text source files that are used as resource files for .NET
applications.
Déjà Vu X2 Professional will ignore all non-translatable content.

RESX-SPECIFIC IMPORT OPTIONS

Exclude/Lock Strings Heuristically
Outwardly RESX files follow a simple structure: everything surrounded by <value> tags has to be
translated. In many cases this rule is more complicated because many of these text strings, while
following that basic rule, should in fact not be translated.
Déjà Vu X2 Professional uses a heuristic system to evaluate which of these segments have to be
translated. It allows you to specify whether you would like to have those strings excluded or
included, but with the original text copied over and locked to give you a chance to evaluate
whether they should in fact not be translated.
The following file has been imported with the Lock feature in place:
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And here is the same file with the Exclude feature activated:

Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

GNU GETTEXT
GNU gettext PO and POT files are the translatable language resource files used in the free GNU
gettext concept for translating software and documentation (from docbook or XML). GNU gettext
is the de-facto standard in many open source projects, and it works with a large variety of
programming languages.
PO files are typically translated or pretranslated files, whereas POT files are the translatable
templates.
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View of a pretranslated POT file in a text editor:

Déjà Vu X2 Professional imports the pretranslated bilingual file that you can now edit and (where
applicable) translate. View of the same passage in Déjà Vu X2 Professional:

When the translation is finished, the file will be exported back into its legal code page, Unicode
(UTF-8).

IBM TRANSLATIONMANAGER
Déjà Vu X2 Professional can process IBM untranslated segments files.
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To obtain the untranslated segments file for a particular file
1

Run IBM TranslationManager.

2

Locate your folder in TranslationManager's Folder List.

3

Double-click it to open its list of files.

4

Right-click the desired file. Select Analyze.

5

Check the Create file containing untranslated segments box.

6

Click Analyze.

To translate IBM TranslationManager files
1

Analyze the IBM TranslationManager documents to obtain the "untranslated segments" files.

2

Import these "untranslated segments" files into a Déjà Vu X2 Professional project.

3

Translate in Déjà Vu X2 Professional.

4

Export the finished translation from Déjà Vu X2 Professional.

5

Import the resulting files into the IBM TM translation memory.

6

Re-analyze the IBM TranslationManager documents. This will yield a fully translated
document.

7

Return the IBM TranslationManager folder to your client. The folder contains all translated
documents and a translation memory with all the material you have translated.
It is not possible to split and join segments from IBM TranslationManager.

To export a translation memory from IBM TM
1

Display TM's Translation Memory List.

2

Right-click the desired database. Select Export.

3

Select the External format.

4

Specify the destination file.

5

Click Export.
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Encoding
For general options to define the code page during export and import, see "Encoding" on page
299.

TRADOS RTF/WORD FILES
To process Trados Workbench 2.3, 3, 5, or 5.5 files, you need Microsoft Word 97 or
later installed on your computer; however, you do not need an installation of Trados.

Déjà Vu X2 Professional is able to import pre-processed Trados Word or RTF files and export
them after the translation into the original Trados format.

TRADOS-SPECIFIC IMPORT OPTIONS

Ignore Exact Matches
This options allows you to not import any exact matches. This is a helpful option if you are
specifically instructed by your client not to edit any of the existing exact matches in the Trados file.
Even if you do not select this option, Déjà Vu X2 Professional is still able to interpret the perfect
and fuzzy match setting from Trados and apply that to its own project:
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View of pre-processed Trados file within Word (note the numbers between the
segments that describe the level of fuzziness):



View of the same file in Déjà Vu X2 Professional (note the indicator bars for the
fuzzy and the perfect match):

Déjà Vu X2

350

Working with Different File Formats

Because of the way in which Déjà Vu X2 Professional works with Trados files, after a translation is
finished and ready to be exported, the original, unaltered Trados file must be in the location from
which it was imported. This is essential, because any slight modification to the file may prevent
Déjà Vu X2 Professional from being able to export the final translation.

Tips and Tricks with Trados RTF/Word Files
Make sure that during the Trados processing, the Trados setting Tools> Translate> Segment
Unknown Sentences is checked. Otherwise, not all segments will be imported into Déjà Vu X2
Professional.
Because Trados files typically have the extension .doc or .rtf, you should not import Trados files
with the Import Wizard unless you have changed the default association for .doc or .rtf files (see "To
reconfigure the default relationship between file format and file extension" on page 290). Import
Trados files through the Advanced Project Explorer and change the association on an individual file
level instead (see "To reconfigure the individual relationship between file format and file extension"
on page 294).
It is not possible to split and join segments from a Trados Workbench file.

TRADOS TAGEDITOR FILES
Déjà Vu X2 Professional is able to import pre-processed Trados TagEditor BIF and TTX files and
export them after the translation into the original BIF and TTX formats.
As with Trados Word files (see "Trados RTF/Word Files" on page 349), Déjà Vu X2 Professional is
able to interpret the perfect and fuzzy match setting from Trados and apply that to its own project.
The protected XTranslated or PerfectMach units from the BIF and TTX documents will
be imported as guaranteed matches.
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TAGEDITOR-SPECIFIC IMPORT OPTIONS

Language Mapping
When importing a BIF or TTX file, Déjà Vu X2 Professional will recognize the languages that are
present in the importable file(s) but will prompt you to map each language extension from the BIF
file to one of the languages that are defined within Déjà Vu X2 Professional.
You will notice that in most cases Déjà Vu X2 Professional has already made the
correct choice for you.

TAGEDITOR-SPECIFIC EXPORT OPTIONS
The options under Encoding are the three possible code pages for BIF and TTX files: US-ASCII,
Unicode, and Unicode (UTF-8). For more information on the options defining the code page
during export and import, see "Encoding" on page 299.

XLIFF FILES
Déjà Vu X2 Professional is able to import XLIFF files and export them after the translation into the
original XLIFF format.
XLIFF is the most widely used exchange format for translation files. Many of Déjà Vu X2
Professional’s competitors use this format as an internal format (including Trados Studio with the
.sdlxliff format) or as an interim exchange format. Déjà Vu X2 Professional allows you to translate
these files within its environment and continue to use them within the environment of other CAT
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TMX FILES
You can translate TMX files in Déjà Vu X2 Professional. TMX (Translation Memory eXchange) is
widely used as an interchange format between different translation memory formats. This means
that with this format filter you are able to translate TMX translation memories of any tool that
supports this format and apply that translated translation memory in its original, native
environment.
Because of the multi-lingual nature of TMX files, Déjà Vu X2 Professional will import source and,
where applicable, target(s). You are free to edit or overwrite the target segments.

TMX-SPECIFIC IMPORT OPTIONS

Language Mapping
When importing a TMX file, Déjà Vu X2 Professional will recognize the languages that are present
in the importable file(s) but will prompt you to map each language extension from the TMX file to
one of the languages that are defined within Déjà Vu X2 Professional.
You will notice that in most cases Déjà Vu X2 Professional has already made the
correct choice for you.
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TMX-SPECIFIC EXPORT OPTIONS
Because TMX files can have several target languages, Déjà Vu X2 Professional allows you to
export individual bilingual files for every target language in your project, or one TMX file with
several target languages.

If you want all target languages in one TMX file, you can leave the selection as presented in the
Export Options dialog. If you prefer individual TMX files or any combination of languages, you can
select the respective languages and make the appropriate choices under Export each language to a
separate file.
The options under Encoding are the three possible code pages for TMX files: US-ASCII, Unicode,
and Unicode (UTF-8). For more information on the options defining the code page during export
and import, see "Encoding" on page 299.
If you choose to export more than one target language, Déjà Vu X2 Professional will
export the file(s) into a subfolder named according to the source language rather than
the usual target language naming convention.
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CREATING AND MAINTAINING SGML/XML FILTER FILES
Unlike other file formats (FrameMaker, Word, Excel, etc.), SGML (Standardized General Markup
Language) and XML (eXtensible Markup Language) are not real file formats; they are a standard for
tagging files, and for defining those tags. Since every set of SGML/XML files uses a different set of
tags, an SGML/XML filter must be created for every set of SGML/XML files.
SGML defines a standard for creating DTDs (Document Type Definition). For example, the World
Wide Consortium (W3C) has DTDs for the various specifications of HTML; this means that HTML
is a markup language defined according to SGML rules. You will probably be somewhat familiar
with the structure and tags in HTML, so we will use it as an example in our explanations.

TAGS AND ATTRIBUTES
SGML files are text files that encode formatting, layout, and image information using tags. Tags are
in the format of:
<TAGNAME ATTRIBUTE1="VALUE1" ATTRIBUTE2="VALUE2">
A tag can contain attributes that further define a value of the tag.
Because Déjà Vu X2 Professional does not need to interpret tags and keys, there are only two
pieces of information that you must provide:


Embeddable tags—An embeddable tag is one that can appear in the middle of a
segment, and Déjà Vu should not split the segment before or after this tag. For example,
the <B> and <I> tags in HTML (which specify bold and italic attributes) are
embeddable, while the <P> tag (which specifies a paragraph change) is not.



Extractable text between tags—It is possible to define whether text between certain tags
is extractable (default) or not extractable, i.e., not translatable. For example, if text
between certain tags always contains dates or numbers that may not need to be
translated, you can choose to embed that text.
If you define a text between tags with nested subtags (for example, <tag1> text
<tag2> text </tag2></tag1>) as non-extractable, text between the nested
subtags will not be extracted either.

However, attributes (see below), are not affected by a choice to not extract text between tags (for
example, the attributetext in: <tag1 attribute="attributetext"> text </
tag1> would be extracted if so defined, even though the text of tag1 may be defined as not
extractable).


Extractable attributes—Certain tags may contain attributes whose values are translatable,
and must therefore be extracted. For example, the <IMG> tag in HTML (which inserts an
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image into the text) has the ALT=“[alternate text for the image]” attribute,
which specifies the text to display if the browser cannot load the image. This text should
be translated, so the attribute is extractable.
Déjà Vu X2 Professional offers two combinable possibilities for creating an SGML filter file:


from the DTD file



directly from the SGML/XML files
In general, it is advisable to combine the methods to allow for greater accuracy of the
SGML filter.

To create an SGML filter from SGML/XML files
1

Open Déjà Vu X2 Professional.

2

Click the

button on the toolbar.

The New File dialog appears.

Double-click SGML/XML Filter, or select it and click OK.
–Or–
On the File menu, click New> SGML/XML Filter.
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3

The New SGML/XML Filter Wizard appears.

4

Click Next.

5

The wizard prompts you to create an SGML/XML filter.
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6

Click Create, select a folder in which you want to have the SGML/XML filter saved, and type a
name for the filter.

7

Click Open.
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8

Click Next. The wizard prompts you to either specify a DTD file or to generate the SGML/
XML filter directly from an SGML/XML file.

9

For this exercise we will use an XML file. Click Next.
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10 Click the Add button.

11 Select your SGML/XML file(s) and click Open.

12 Click Next.
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13

The New SGML/XML Filter Wizard displays the current settings.

14 Click Finish.
15 The wizard displays the import progress.

16 Click Finish after the import process has finished.
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17 The Tags and Attributes tab is displayed.
The newly created SGML filter has made the following definitions:


all the tags of the imported SGML/XML file(s) are interpreted as embaddable (by
having the ...<>... column in the Tags field unchecked),



all text between tags is defined as extractable (by having the <>...<> column in
the Tags field checked), and



all attributes are defined as embeddable (by not having the <=...> column in the
Attributes field checked).

18 You will have to review each of these tags and attributes and decide whether the default
setting is appropriate or not. To ease that process, Déjà Vu X2 Professional displays examples
from the occurrences of the tags and attributes in the respective file(s) under and to the right
of Examples.
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Typically, the vast majority of tags should not be embedded. Below is an example of
tags that could be embedded; the ...<>... column in the Tags fields is therefore
checked:
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Typically, the majority of text between tags should be extracted. Below are examples
of text that should probably not be extracted; the <>...<> column in the Tags field
is therefore unchecked:



Most of the attributes will only contain internal, non-translatable information.
Leaving the checkboxes in the <=...> column in the Attributes field unchecked
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ensures that they will not be extracted, i.e., displayed in the Déjà Vu X2
Professional project. For those that should be translated, add a check mark.

19 When you are finished defining the tags and attributes, you can reduce the size of your
SGML/XML filter by deleting all the examples.
This is especially helpful when you have imported a great number of SGML or XML
files, which can blow up the size of the filter to several hundred megabytes.

20 Select Edit> Delete All Examples.

Other SGML/XML-specific options include the deletion of all tags and attributes and all
entities. These options are only used on very rare occasions.
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21 Select the Entities and Characters tab.

Here you can find definitions of the Begin Tag and the End Tag as well as for the Begin Entity
and the End Entity. These settings are the standard settings and typically do not have to be
changed.
On this tab you can also find a great number of pre-defined special characters. The definition
of each will determine how Déjà Vu X2 Professional will display the character and export it
again. The copyright sign (©), for instance, will be displayed as &copy; in the SGML file
before and after the translation, but as © in the project file.
22 In the process of generating the SGML/XML filter file below, Déjà Vu X2 Professional has
detected one character, a y with an accent (ý), that is not in its predefined lists of special
characters. With the appropriate Unicode sequence, you can now define how you want this
character to be handled.
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23 Type the appropriate Unicode sequence into the field to the right of U+. The correct
character will now be displayed in the adjacent field.

24 Click Replace.

25 The new entity will now be displayed correctly as ý in Déjà Vu X2 Professional, but as
&yac; when exported.
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To create an SGML filter from the DTD file
1

Open Déjà Vu X2 Professional

2

Click the

button on the toolbar.

The New File dialog appears.

Double-click SGML/XML Filter, or select it and click OK.
–Or–
On the File menu, click New> SGML/XML Filter.
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3

The New SGML/XML Filter Wizard appears.

4

Click Next.

5

The wizard prompts you to create an SGML/XML filter.
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6

Click Create, select a folder in which you want to have the SGML/XML filter saved, and type a
name for the filter.

7

Click Open.
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8

Click Next. The wizard prompts you to either specify a DTD file or to generate the SGML/
XML filter directly from an SGML/XML file.

9

For this exercise, we will use an existing DTD file. Click Select and select your DTD file.
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10 Click Open. The wizard displays the current settings.

11 Click Next.
12 The wizard prompts you to specify the location of your SGML/XML files.

13 Click Next.
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14 The New SGML/XML Filter Wizard displays the current settings.

15 Click Finish.
16 The Tags and Attributes tab is displayed.
The newly created SGML filter has made the following definitions:


most of the tags that are listed in the DTD file are interpreted as extractable (by
having the ...<>... column in the Tags fields unchecked),



all text between tags is defined as extractable (by having the <>...<> column in
the Tags field checked), and
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all attributes are defined as extractable (by having the <=...> column in the
Attributes field checked).

17 You can now choose to review each of these tags and attributes and decide whether the
default setting is appropriate or not.
To ease this process, it is advisable to combine the DTD import with the import of some
representative SGML/XML files. Déjà Vu X2 Professional will then display examples
from the occurrences of the tags and attributes in the respective file(s) under and to the
right of Examples. For information on how to import SGML/XML files, see "To create an
SGML filter from SGML/XML files" on page 356.

For further information on how to decide how to treat the different tags and attributes, see p.
362.
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To add data to the SGML filter
1

If you want to add data at a later point from an existing SGML filter or other SGML files, you
can do that by selecting File> Import> Data from SGML File (or: Data from Another Filter).

2

Select the SGML file or the filter file and click Open.

3

The new data will be imported into your existing filter.

To import from a Déjà Vu 2/3 filter file
You can convert Déjà Vu 2/3 SGML filters to Déjà Vu X2 Professional SGML/XML
filters. If you do, you should be aware that certain properties in Déjà Vu X2
Professional SGML/XML filters were not available in Déjà Vu 2/3 SGML filters, such as
non-extractable text or predefined special characters. After the conversion it may be a
good idea to verify that all settings are appropriate.

1

Select File> Import> Data from DV v.2.x/3.x Filter.
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2

The Select Name and Location of Deja Vu v.2.x/3.x Filter dialog appears.

3

Select the location and name of a .dvt file you would like to import and click Open.

4

The data is being imported.
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THE LEXICON
If you are not familiar with Déjà Vu’s lexicon concept, get ready for something completely
different and new.
You probably have a relatively good understanding of how the termbase and the translation
memory work. Both are project-unspecific, external databases that contain segments, phrases, and
terms from a large variety of subjects, clients, and projects. While the translation memory is
primarily used for segment matching, the termbase provides the individual components of a
segment when no match is found in the translation memory.
So how does the lexicon fit in?
The project’s lexicon is a list of all the source language words or phrases present in the project—in
other words, an index of all terms and phrases. Once you have created this index, you can
translate the terms that seem relevant to you, batch delete all other terms (for instance, terms like
"the" or "to" in the image below), and Déjà Vu X2 Professional will use what remains as the
primary glossary for your project.

While creating this index, the lexicon also provides you with the number of occurrences of the
individual terms or segments (see the Freq column in the image above), thus giving you a pretty
good idea of what terms are central to your project. And even though the same terms may reside
in your termbase, chances are that there will be several translations for many terms in the
database. The word "cat," for instance, could be a feline animal, a piece of heavy equipment, or
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"computer-assisted translation." Each of these meanings will have a different translation in different
languages, making it difficult for Déjà Vu X2 Professional to know which one to choose over the
other. By providing the one correct translation in the project-specific internal lexicon, Déjà Vu X2
Professional will always choose that over any other translation.
Clients will often ask you to provide them with a glossary for a project you’ve translated
for them; this will help them keep a record of the terminology used, ensuring that the
same terminology is used in future projects. With Déjà Vu X2 Professional, creating a
glossary for your client is as simple as exporting the lexicon to a text file.

WORKING WITH THE LEXICON
You can access the different functions and aspects of the lexicon through the Lexicon menu.
For information on how to create and translate a lexicon and how to remove rows from a lexicon,
please see "Generating the Lexicon" on page 97.

To change the lexicon sorting
As with normal files in a project, you can change the order in which the lexicon entries appear.
1

Click the

button on the toolbar.

2

The Sort Lexicon dialog appears.
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3

You can sort alphabetically, by number of words, by frequency, or by any combination of the
three in either descending or ascending order.
You will generally want to choose the settings shown in the image above.

4

Click OK.

To manually add entries to the lexicon
1

If you want to add a selection, select the corresponding portions in the source and target cells.

2

On the Translation menu, click Add Pair to Lexicon.
–Or–
Press F10.

3

At the bottom of the screen, you will be able to see: Pair added to the Lexicon.
There could be two reasons why you may want to add to the lexicon and not to the
termbase. Because Déjà Vu X2 Professional treats the lexicon as the most relevant
database in its assemble processes, it is helpful to add to the lexicon as you translate.
This will overwrite anything you may have in the project-unspecific termbase.
Furthermore, there are entries that are so project-specific that you may not want to have them in
your termbase, but they may be very helpful in the lexicon.

To modify or delete lexicon entries as you translate
See "To modify database records in the AutoSearch window" on page 174

RESOLVING THE LEXICON WITH THE DATABASES
After the lexicon has been built and you have added and removed those entries you considered
necessary, you should translate it. You can do this manually, but you can also decide to use the
content in your databases.
The resolve options are also available during the lexicon build process (see "To create
the lexicon" on page 97).
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To resolve the lexicon with the translation memory(s)
1

Select Lexicon> Resolve with Translation Memory.

2

The Resolve Lexicon dialog appears and shows how many entries have been processed.

This process is comparable to a pretranslation; i.e., it finds both exact and fuzzy
matches in the translation memory.

To resolve the lexicon with the termbase(s)
1

Select Lexicon> Resolve with Termbase.

2

The Resolve Lexicon dialog appears and shows how many entries have been processed.

Both of the resolve processes are done with the currently selected target language. If
there is more than one language in the project, you can choose which one to display by
selecting a language from the Language Selector (see "The Language Selector" on page
50).
It is advisable to check the translations generated by the "resolve" procedures.

SENDING THE LEXICON TO A DATABASE
After expanding, translating, and correcting the lexicon, you can send it to the termbase or the
translation memory so that the data in the lexicon will also be available for later projects.
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To send the lexicon to the translation memory
1

If you only want to send a portion of the lexicon, select the respective records (for more
information on how to select records, see "Selecting Segments" on page 61).

2

Select Lexicon> Add Lexicon to Translation Memory.

3

The Send Lexicon to Translation Memory dialog appears.

4

Select whether you want to send the Current Language or All Languages, any rows with a
status other than the default options Finished Segments or Unmarked manual translation, and
whether you want to send all of the lexicon or only a previously selected subset.

5

Click OK.

6

At the bottom of the dialog, you will be able to see how many entries have been sent.

7

Click Close.

To send the lexicon to the termbase
1

If you only want to send a portion of the lexicon, select the respective records (for more
information on how to select records, see "Selecting Segments" on page 61).

2

Select Lexicon> Add Lexicon to Termbase.
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3

The Send Lexicon to Termbase dialog appears.

4

Select whether you want to send the Current Language or All Languages, any rows with a
status other than the default options Finished Segments or Unmarked manual translation, and
whether you want to send all of the lexicon or only a previously selected subset.

5

Click OK.

6

At the bottom of the dialog, you will be able to see how many entries have been sent.

7

Click Close.

EXPORTING THE LEXICON
Once you have processed the lexicon, you may want to export it to send it to your client, to have
it translated outside of Déjà Vu X2 Professional, or to import it into another Déjà Vu project.
Déjà Vu X2 Professional can create a text or an Excel file with the lexicon entries from the source
language and any number of target languages.

To export the lexicon
1

In an open project with an existing lexicon, select File> Export> Lexicon.
–Or–
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Right-click on the lexicon icon and select Export.
2

The Lexicon Export Wizard opens.

3

Select Next and choose the format you would like to export into. Supported formats include
various versions of Excel and Text. For this example, we are going to select Text.
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4

Select Next, choose the folder where the file is supposed to be saved, name the file, and
select Save.

5

The wizard displays the current settings to you.

6

Select Next and choose the target languages you are intending to export.
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7

Select Next and choose how the records should be separated from each other (Delimiter),
whether you want column headings in the exported file (First Segment Contains Field
Names), and the codepage. Because one of our export languages is a non-Western
language—Greek— Unicode may be a good choice as a codepage.
You will not be presented with these choices if you use Excel as an export format.
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8

Click Next. The wizard displays the current settings to you.

9

Click Finish. After the export process is finished, the wizard displays the number of exported
records.

10 Select Close.
Déjà Vu X2

386

The Lexicon

PREPARING A LEXICON FOR TRANSLATION OUTSIDE OF DÉJÀ VU X2 PROFESSIONAL
If you are planning to prepare a lexicon for translation outside of Déjà Vu X2 Professional, you
can follow these steps.
1

Determine which terms or phrase are helpful, copy them over from source to target, and
select the desired rows.

2

On the Insert menu, select Populate> Current Segment.
–Or–
Press F5.
You can also copy the content of several rows into the target with this command by
selecting the desired rows in the selection mode (see "Selecting Segments in the
Selection Mode" on page 61).

3

Select Lexicon> Remove Entries.

4

The Remove lexicon rows dialog appears.

5

Select All rows with empty targets.

6

Click OK.

7

You can now export the remaining entries into a text or Excel file (see "Exporting the Lexicon"
on page 382), translate the file outside of Déjà Vu X2 Professional by overwriting the target
segments and, once the translation is finished, re-import the file into the lexicon.
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IMPORTING INTO THE LEXICON
The option to import a lexicon can prove to be helpful in a variety of situations, including the
following:


the lexicon has been translated, edited, or proofread outside of Déjà Vu X2 Professional
and needs to be reimported into the project,



you would like to transfer the lexicon from an earlier project to the current project, or



a project-specific glossary has to be imported into the project’s lexicon.
The last item is arguably the most important one. As mentioned before, the lexicon is
used as the primary glossary for the project, so it is very helpful to import a projectspecific glossary into the lexicon rather than the generic termbase.

To import an external file into the lexicon
1

In an open project with or without an existing lexicon, select File> Import> Lexicon.
–Or–
With an existing lexicon, right-click on the lexicon icon and select Import.

2

The Lexicon Import Wizard appears.
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3

Click Next and select the format of the file you would like to import. The supported formats
include Text, Excel, and Access. For this example we are going to select Access.

4

Select Next, choose the folder where the file is located, name the file, and select Save.

5

The wizard displays the current settings to you.
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6

Select Next and select the database table which contains the material that needs to be
imported.
You will not be presented with these choices for Excel or text.
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7

Select Next, specify which of the available fields needs to be imported, and map it to the
appropriate language and code page.

8

Select Next and choose whether you want the entries in the glossary to overwrite any existing
similar entries in the current lexicon and whether you want to recalculate the frequencies
(i.e., add the existing number of occurrences to the one in the new glossary).
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9

Click Next. The wizard displays the current settings to you.

10 Click Finish. After the import process is finished, the wizard displays the number of imported
records.
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11 Click Close. If you now open the lexicon in your project, you will be able to see the imported
entries.
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CREATING AND MAINTAINING TRANSLATION MEMORIES
THE TRANSLATION MEMORY INTERFACE

The translation exit memory interface consists of a number of elements.


Source Language—though you can only view one source language at a time, the
multilingual nature of Déjà Vu X2 Professional’s translation memories makes it possible
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to select a different source language from the Source Language dropdown list and have
the present source language become a target language:



Target Language—allows you to view each individual target language or—as in the
examples above—all target languages.



Locate Segment—this field allows you to enter the first few letters of the first word in the
target segment you are searching for to have Déjà Vu X2 Professional jump to a
matching entry.
Even though you can use this feature in any mode, it is particularly useful in
alphabetical order. To switch to alphabetical order, select View> Toggle Sorting.
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Filter—allows you to enter any full word (partial word or wildcard searches are not
possible). By clicking the Filter button to the right of the text box, the translation memory
displays all records where the source contains that word.



Add—clicking this button in either the source or target column will open a new field in
which you can enter a new segment or term.
If you have all All Languages selected under Target Language, the Add button in the
target column will be disabled as the selection under Target Language determines the
languages of the segment that is going to be added.



Remove—clicking these buttons will remove the source or target segment.
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Merge—this option allows you to merge two identical source segments with translations
into different languages. Highlight two source segments by clicking on them while
holding down the Ctrl key.

Select Merge.



All Segments—the standard view that displays all source segments with their associated
target segments.
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Duplicates Only—displays all source rows.
A more powerful option for managing duplicates is to select Database> Find Duplicate
Segments.
The Find Duplicate Segments dialog gives you a wide variety of options for finding sets
of duplicates, sets of duplicates with identical translations, or sets of duplicates with different
translations for all possible language combinations. It also allows you to delete duplicates if both
source and target are identical.



SQL—this option opens the Select SQL dialog in which you can enter any SQL
statement to view a certain subset of the translation memory.
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OPENING TRANSLATION MEMORIES
1

On the File menu, click Open.
–Or–
Press Ctrl+O.
–Or–
Click the

button on the toolbar.

2

The Open dialog appears.

3

Select Memory Databases under Files of type, select the database you want to open, and click
Open.

CREATING TRANSLATION MEMORIES
There are two different ways to create a translation memory:


you can create one during the process of creating a Déjà Vu X2 Professional project file
(see "Creating a New Project File" on page 85), or



you can create a translation memory as a stand-alone file.
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By creating a termbase as a stand-alone file (which you can later associate with project files), a
creation wizard allows you to select several customized options.

To create a translation memory as a stand-alone file
1

Open Déjà Vu X2 Professional.

2

Click the

button on the toolbar.

The New File dialog appears.

Double-click Translation Memory, or select it and click OK.
–Or–
On the File menu, click New> Translation Memory.
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3

The New Translation Memory Wizard appears.

4

Click Next.

5

The wizard prompts you to create a translation memory.
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6

Click Create, select a folder in which you want to have the translation memory saved, and
type a name for the translation memory.

7

Click Open.
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8

Click Next. The New Translation Memory Wizard displays the current settings.

9

Click Finish. Déjà Vu X2 Professional displays an empty translation memory.
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ASSOCIATING TRANSLATION MEMORIES WITH A PROJECT
Translation memories can be associated with your project during the creation of a project (see p.
88) or at a later point.

To associate translation memories with projects
1

In an open project, select Project> Properties> Databases.

2

If you would like to disassociate the existing translation memory from the project, select
Remove in the Translation Memories section.

3

If you would like to add an additional translation memory, select Add in the Translation
Memories section.
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4

A file selector dialog appears.
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5

Select the additional database which can be located on a drive of your local computer or
anywhere in your network and click Open.

6

Click Apply and/or OK.

TRANSLATION MEMORY STATISTICS
It is possible to obtain statistical data about your translation memory, such as number of records
and languages in the translation memory.

To view translation memory statistics
1

In an open translation memory, select Database> Properties> Statistics.
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2

The Statistics tab in the Translation Memory Properties dialog is displayed.
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3

Click Calculate.

4

The statistics for the current translation memory are displayed.

IMPORTING EXTERNAL DATA
You add records to your translation memory as you translate (see "Sending Information to the
Translation Memory" on page 169), but Déjà Vu X2 Professional also enables you to import
external data into translation memories. For example, this allows you to convert data you have
accumulated with other translation memory software, or even from data found on the Internet.

To import data
1

With an open translation memory, click File> Import> External Data.
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2

The Translation Memory Import Wizard appears.

3

Click Next.

4

The wizard prompts you to specify an import format. The supported formats are:
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Déjà Vu X2 Translation Memory—for merging translation memories



Déjà Vu 2.x/3.x Memory Database—for importing memory databases of earlier
versions of Déjà Vu
You can also convert Déjà Vu 2.x/3.x memory databases into new Déjà Vu X2
Professional translation memories. For more information on this, see "To convert Déjà
Vu 2.x/3.x memory databases" on page 417).



Text—for importing delimited text files (tab, comma, etc.)



Access 9x/2000/XP—for importing databases from various versions of Microsoft
Access



Excel 9x/2000/XP—for importing databases from various versions of Microsoft Excel



Trados WB Databases—for importing databases from translation memories from the
Trados Workbench .txt format



IBM TM2—for importing databases from translation memories from the IBM TM2
or OpenTM2 .exp format



TMX—for importing databases from the Translation Memory EXchange format, an
XML-based exchange format between different CAT tools



SDLX TM—for importing databases from translation memories from the SDLX .mdb
format

For this example, we will select Text to import a multilingual comma-separated value file
(.csv).
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5

Select Text and click Next.

6

Select the text file you want to import and click Open. The wizard displays the current
settings.
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7

Click Next. The wizard displays the data of the file and allows you to adjust the delimiter
settings.

8

Select the delimiter of your original file (in this case Comma), and check the appropriate
option if the first row contains field names.
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9

Click Next. The wizard now allows you to specify the field information for the fields of your
original file.

The available standard fields are:


Main Segment (typically the source language)



Translation



Date



User ID



Subject



Client
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10 Select Main Segment and the appropriate language and code page settings for the source
language, and Translation and the appropriate language and code page settings for the target
languages.

11 Click Next.
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12 The wizard displays the current settings. Click Next.

13 The wizard displays the import progress; when it is finished, it shows how many records have
been added.
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14 Click Close and you are returned to your translation memory view. If you now look for one of
the imported segments, you will find that it has been imported with English as the source
language and the different specified languages as target languages:

To convert Déjà Vu 2.x/3.x memory databases
1

Select Tools> Convert> DV 2.x/3.x Memory Database.

2

The Convert v2.x/3.x Memory Database dialog appears.

3

Click Select and select the memory database you would like to convert.

Déjà Vu X2 Professional will automatically recognize the language setting of the old database
and will propose a new translation memory with the same name, in the same folder, with a
new extension.
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4

If necessary, change the language setting and/or the name or path of the new translation
memory.

5

Click OK.

6

Déjà Vu X2 Professional will show you the import process.

7

Once the import is finished, Déjà Vu X2 Professional will show you how many records have
been added.

8

Click Close.
If you open the new database, you will be able to see that not only source and target terms
have been imported, but also all other information that was present in the old memory
database, including subject, client, datestamp, user, project ID, etc.
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ALIGNING EXISTING FILES
Alignment is the process in which pairs of already translated files that were translated in a
monolingual environment (i.e., outside a translation memory tool) are paired up to become part of
an existing or a new translation memory. The process of pairing up these files is done in an
intermediary alignment file, a .dvapr file; once the alignment is completed, this file is fed into the
translation memory.
Though this feature can be very powerful, especially for users who start without any
existing bilingual material, you should be cautious of blindly feeding existing material
into your translation memory, just to "make it grow." In our experience, the best
procedure for alignment is to choose very carefully what kind of textual material you
will benefit from most, or align in a specific situation when you have to translate a file and you have
a set of very similar, already translated files that are not yet contained in the translation memory.

Déjà Vu X2 Professional’s advanced concept of using placeholders for embedded codes in the
translation memory allows for:


aligning of different file types (i.e., you can align an HTML file in language A with a Word
document in language B), or



using the translation memory that you built up from aligning from files of type A to
translate files of type B.

In the latest edition of Déjà Vu X2 Professional it is also possible to have an unlimited number of
files or differing file formats in one alignment process.

To align several pairs of files
1

Open Déjà Vu X2 Professional.

2

Click the

button on the toolbar.
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The New File dialog appears.

Double-click Alignment Workfile, or select it and click OK.
–Or–
On the File menu, click New> Alignment Workfile.
Alternatively, you can also align from within an existing translation memory. To do that,
open the translation memory that you would like to align new material into and select
File> Import> Align.
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3

The Alignment Wizard appears.

4

Select Next.

5

Click Select.
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6

Give the new alignment file a name and choose a folder in which to save it.

7

Select Save.

8

Select Next.
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9

Make the following selections:


choose the source and target files by clicking on the Add buttons;



change the order of the source and target files so that they are listed in the same
order by using the up and down arrows;



choose the language for the files from the dropdown list; and



change any properties for the import process of individual files by highlighting them
and clicking on the Properties buttons.

Note that you can mix and match any file type that is supported by Déjà Vu X2
Professional within one alignment project.
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10 Select Next. The wizard shows the progress of the import process.

11 Select Next.

12 Select the appropriate client and subject for this alignment project and click Next.
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13 In the following screen you will have to adjust the alignment.

You can resize this window by dragging the resizing corner in the bottom right corner.
The next time you open this screen, Déjà Vu X2 Professional will have "remembered"
your earlier sizing adjustments.

You can make adjustments in source or target by selecting one or several rows in either source
and target (press Ctrl while selecting several rows or Ctrl+Shift while selecting a range) and
using one of the following options to adjust the alignment:
You can recognize whether your selection is in the source or the target column by the
yellow dotted line that surrounds your selection.



Joining the current segment with the next or joining all selected segments by clicking
one of the Join buttons.



Splitting the current segment at the cursor’s location by clicking one of the Split
buttons.



Deleting the current segment or all selected segments by clicking one of the Delete
buttons.



Moving the current segment or all selected segments up by clicking one of the Move
Up buttons.
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Moving the current segment or all selected segments down by clicking one of the
Move Down buttons.



Sending term pairs to the termbase by highlighting them in source and target and
clicking Add to TB. (The first time you do this, you are prompted to select a
termbase. Once you have selected a termbase for one alignment project, you will
not have to select it again.)

The most common adjustments that you will have to make are due to


soft or hard returns that were set for formatting purposes (as in the first two lines in
both source and target in the example above);



differences in the segment structure; or



differences in the use of segment delimiters.

If you see great differences in how sentences are delimited because of delimitation
rules, it may be advisable to discard the current alignment workfile, change the
delimitation rules for one or both languages, and import the files again into a new
alignment project. For more information on sentence delimitation, see "Sentence
Delimitation" on page 215.
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When you are finished with your adjustments, all the rows should be aligned perfectly.
The following step of selecting or creating a translation memory is omitted if you are
aligning through the Import> Align command within an existing translation memory.

Déjà Vu X2

427

428

14 Create a translation memory that the alignment file can be entered into by clicking Create, or
select an existing one by clicking Select.

15 Select Next.
16 The wizard displays the current settings.
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17 Select Finish.
18 The wizard shows you the progress of sending the segment pairs into your translation memory
and eventually the numbers of segments that have been sent.

19 Select Close.

To open an existing alignment file
1

On the File menu, click Open.
–Or–
Press Ctrl+O.
–Or–
Click the

button on the toolbar.
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2

The Open dialog appears.

3

Select Alignment Workfiles under Files of type, select the alignment workfile you want to
open, and click Open.
Alternatively, you can also open an alignment file from within an existing translation
memory. To do that, open the translation memory that you would like to align new
material into and select File> Import> Align.
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4

The Alignment Wizard appears.

5

Select Next.

6

Select Open existing alignment workfile and click Next.
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7

The wizard displays the last created alignment workfile. If you would like to select another
file, click Select. If you would like to open the currently displayed file, click Next.

8

The alignment workfile is displayed.

SPELL CHECKING THE TRANSLATION MEMORY
To activate spell checking
1

Select Tools> Spelling.
–Or–
Press F7.

2

The Spell Checking Options dialog appears.
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3

Under Language, you can choose to check any language present in the project, including the
source language.
It is a good practice to include the source language in your spell checks. Any misspelling
in the source is unlikely to occur a second time in later texts, but it will prevent
Déjà Vu X2 Professional from finding perfect matches.

4

Under Scope, you can choose to check all entries in that language or just those that have not
been checked before.
Limiting the spell check to records that have not been checked is an efficient way to
avoid duplicating your work.

5

The Check Spelling dialog appears.

6

For more information on spelling, see "Spell checking" on page 125.
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EXPORTING DATA FROM TRANSLATION MEMORIES
There are various situations where it may be very helpful to export parts or all of your translation
memories, the most obvious being:


storing a translation memory in a compact format, or



sharing translation memory content with co-workers or teammates.

To export data
1

With an open translation memory, click File> Export> External Data.

2

The Translation Memory Export Wizard appears.
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3

Click Next.

4

The wizard prompts you to specify an export format. The supported formats are:


Text—for exporting delimited text files (tab, comma, etc.)



Access 9x/2000/XP—for exporting databases into various versions of Microsoft
Access
Access 9x does not support Unicode. Depending on your languages, this may be an
important consideration in choosing the right format for you.



Excel 9x/2000/XP—for exporting databases into various versions of Microsoft Excel
Excel 97 made an end to Excel 95’s limitation of 255 characters per cell (they upped it
to 32,000) and 16,384 rows in a worksheet (extended to more than 65,000). This is an
important consideration when choosing the correct Excel format. Another important
consideration may be that anything before Excel 2000 does not support Unicode.



Trados WB Databases—for exporting databases into translation memories of the
Trados Workbench .txt format
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TMX—for exporting databases into the Translation Memory EXchange format, an
XML-based exchange format between different CAT tools



TeaM Server—for exporting databases onto a TeaM Server

In the following two examples, we will first select TMX and then Excel as the export format.

To continue the export process with TMX as the data format
The export process into the Trados WB database text format is similar to the one into
TMX.

1

Select TMX.
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2

Click Select.

3

Select the desired export path, give the file an appropriate name, and click Save. The wizard
displays the current settings.

4

Click Next.

5

The wizard displays the languages in your translation memory.
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6

Copy the desired languages over the Export languages field by selecting them and clicking on
Add.
A TMX file can be multilingual, so you can select as many languages as you like.

7

Click Next.

8

The wizard prompts you to enter any filtering condition, i.e., criteria by which you want to
filter the export of your database.
Unless you are very familiar with the underlying structure of the databases, you should
probably resort to using and modifying the provided samples in the Advanced Topics
chapter (see "Sample Regular Expressions for Export from Translation Memory and
Termbase" on page 529).

9

If you choose to enter an expression, verify it by clicking the Validate button. If the expression
proves to be valid, select Next.
–Or–
If you choose not to enter an expression, select Next.
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10 The wizard gives you a choice of the three possible ways to encode a TMX file (Unicode UTF16, Unicode UTF-8, and US-ASCII) and lets you select what other information besides source
and target should be exported.
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11 Make the appropriate choices and select Next.
The export into the Trados WB database format differs in this step. Instead of selecting
the correct encoding, you will have to select the Trados-specific language specifier for
each language.
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12 The wizard displays the current settings.

13 Click Finish.
14 The wizard displays the import progress; when it is finished, it shows how many records have
been added.
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15 Click Close and you are returned to your translation memory view.

To continue the export process with Excel as the data format
The export process into Access or text formats is similar to the procedure for Excel.

1

Select Excel 97/2000/XP.
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2

Click Select.

3

Select the desired export path, give the file an appropriate name, and click Save. The wizard
displays the current settings.

4

Click Next.
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5

The wizard prompts you to specify the fields you are planning to export.

6

Click Add and specify for each exportable field the Field Type, Language, and the column
header in the Excel file (Export As).
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7

Continue until you have selected and specified all necessary fields.

You can move the fields with the up and the down arrows to the right of the selection
field.
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8

The wizard prompts you to enter any filtering condition, i.e., criteria by which you want to
filter the export of your database.
Unless you are very familiar with the underlying structure of the databases, you should
probably resort to using and modifying the provided samples in the Advanced Topics
chapter (see "Sample Regular Expressions for Export from Translation Memory and
Termbase" on page 529).

9

If you choose to enter an expression, verify it by clicking the Validate button. If the expression
proves to be valid, select Next.
–Or–
If you choose not to enter an expression, select Next.
If you are exporting to text or Access 97, the wizard prompts you to select the encoding
of the resulting data.

10 Give the worksheet within the Excel spreadsheet the desired name or leave the default name
(Segments).
11 Click Next.
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12 The wizard displays the current settings.

13 Click Finish.
14 The wizard displays the import progress; when it is finished, it shows how many records have
been added.
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15 Click Close and you are returned to your translation memory view.

Déjà Vu X2

448

Creating and Maintaining Termbases

CREATING AND MAINTAINING TERMBASES
OPENING A TERMBASE
1

On the File menu, click Open.
–Or–
Press Ctrl+O.
–Or–
Click the

button on the toolbar.

2

The Open dialog appears.

3

Select Termbases under Files of type, select the database you want to open, and click Open.

TERMBASE STATISTICS
It is possible to obtain statistical data about your termbase, such as number of records and
languages in the termbase.
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To view termbase statistics
1

In an open termbase, select Database> Properties> Statistics.

2

The Statistics tab in the Terminolgy Database Properties dialog is displayed.
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3

Click Calculate.

4

The statistics for the current termbase are displayed.

CREATING TERMBASES
There are two different ways to create a termbase:


you can create one during the process of creating a Déjà Vu X2 Professional project file,
or



you can create a termbase as a stand-alone file.

If you create a termbase in the process of creating a project file, Déjà Vu X2 Professional will
create a basic termbase with a default template that you should refine at a later point.
By creating a termbase as a stand-alone file (which you can later associate with project files), a
creation wizard allows you to select several customized options.

To create a termbase as a stand-alone file
1

Open Déjà Vu X2 Professional.
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2

Click the

button on the toolbar.

The New File dialog appears.

Double-click Termbase or select it and click OK.
–Or–
On the File menu, click New> Termbase.
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3

The New Termbase Wizard appears.

4

Click Next.

5

The wizard prompts you to create a termbase.
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6

Click Create, select a folder in which you want to have the termbase saved, and type a name
for the termbase.

7

Click Open.
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8

Click Next and select the template to define relationships and attributes that you would like
to associate with your termbase. For more information on templates, see "Templates" on page
456.

9

Click Next. The New Termbase Wizard displays the current settings.
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10 Click Finish. Déjà Vu X2 Professional displays an empty termbase.

TEMPLATES
Templates are small files in XML format with the extension .dvtdt (Déjà Vu termbase template) that
are located in the \Templates folder within your Déjà Vu X2 Professional installation folder (by
default C:\Program Files\Atril\Deja Vu X\Templates on an English Windows
installation). These files define what kind of relations, attributes, and categories your termbase will
have—in short, how your termbase is going to behave.
In the default installation of Déjà Vu X2 Professional, there are several preset templates:
Template Name

Organization

No. of
Attr.

No of
Rel.

ATRIL
Déjà Vu X

ATRIL

5

3

Eurodicautom

European
Commission

11

3

TIS

Council of the
EU

9

3

Reference URL

http://europa.eu.int/
eurodicautom/login.jsp
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Template Name

Organization

No. of
Attr.

No of
Rel.

Reference URL

Criter

Corpus du
Réseau Interministériel de
Terminologie

13

4

http://www.culture.fr/culture/dglf/
garde.htm

IIF

Interval Project

14

2

http://www.computing.surrey.
ac.uk/ai/new_interval/

Vintars

UN at Vienna

21

3

https://cms.unov.org/
vintars/VINTARSDefault.aspx

Unterm

UN at New York

6

2

http://unterm.un.org/

Termite

International
Telecomm.
Union

7

2

http://www.itu.int/
terminology/index.html

ILOTerm

International
Labour
Organization

8

2

http://www.ilo.org/iloterm/

CILF

Conseil
international de
la langue
française

8

2

http://www.cilf.org/bt.fr.html

SilvaTerm

International
Union of
Forestry
Research
Organization

8

2

http://www.iufro.org/
science/special/silvavoc/
silvaterm/

TBX

LISA

23

69

http://en.wikipedia.org/wiki/
Translation_memory#TBX

When creating a new termbase, Déjà Vu X2 Professional will by default assign the minimal
template that only contains the relation "translation." You can easily assign a different template, or
you can create your own custom templates from scratch or on the basis of existing templates.

To assign a different template
1

While you have a termbase open, select Database> Properties.
–Or–
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Click the

button on the toolbar.

2

Click Templates.

3

The Termbase Templates dialog appears.

4

Select a different template and click OK.

5

The new template has now been assigned to your termbase.

To create a custom template
1

While you have a termbase open, select Database> Properties.
–Or–
Click the

2

button on the toolbar.

Click Templates.
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3

The Termbase Templates dialog appears.

4

Select the existing template on which you would like to base a new template and click Save.

5

The Template Name dialog appears.

6

Type in the name you want the new template to have. For this sample, we want to create a
template that will not hold any grammatical information, so we call it No Grammar.

7

Click OK.
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8

You are returned to the Termbase Templates dialog. Note that the new template No
Grammar has already been added.

9

Make sure that the new template is highlighted and click OK.
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10 The Termbase Properties dialog appears again. Click the General tab if it is not already
displayed.

11 Enter an internal name for the template, enter a description, and select whether the subject
and client information from the project should automatically be entered for each of the
records that you add to the termbase.
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12 Select the Relations tab.

13 The default settings—which are taken over from the ATRIL Déjà Vu X2 template—have
three different relations: Translation, Synonym (a word with the same or similar meaning),
and Antonym (a word with the opposite meaning). Each relation is defined by a number of
properties.
Name—the internal name of the relation.
Caption—the name of the relation as it appears in the list on the left in other views of the
termbase.
Scope—a dropdown field from which you can choose whether this is an interlanguage
relation, i.e., a relation between different languages, or an intralanguage relation, i.e., a
relation within one language.

Déjà Vu X2

462

Creating and Maintaining Termbases

Reflexive, symmetric, and transitive—the three most basic relationships in a relational
database model that describe the relationship of an element to itself (reflexive), to one other
element (symmetric), or to several others (transitive).

opposite.

Reflexive—A reflexive relationship is a relationship that is valid for itself. For example, a
translation relation cannot be reflexive, because a term cannot be translated with itself.
A synonym relation is reflexive, however, because every term is also a synonym of itself.
An antonym by definition cannot be reflexive, because a term cannot be its own

Symmetric—In a symmetric relationship, the relationship of A to B is also true of B to A. This is the
classical translation relationship: if term A is the translation of term B, then term B is also the
translation of term A. Synonym and antonym relations are symmetric relationships as well.
Transitive—In a transitive relationship, the relationship from A to B and A to C is the same as that of
B to C. Translations from language A to B are not transitive (the German translation of the English
term "file" can be either "Datei" or "Akte"; however, "Datei" is not the translation of "Akte"), nor are
synonyms (though "square" is the synonym for both "four-sided figure" and "plaza," "plaza" is not a
synonym for "four-sided figure") or—by the same logic—antonyms.

A
A

A

B
B

Reflexivity

Symmetry

C
Transitivity

14 Click Add to define a new relation, or Delete to delete an existing relation.
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15 Click the Attributes tab.

16 On the left-hand side, you can see the default grammatical Attributes (Part of Speech (=word
class), Gender, and Number); their Properties are on the right-hand side (Name, Caption, and
Type).
17 In our case we want to delete all existing grammatical attributes, so we click the Remove
button until there are no more attributes listed.
18 Now we decide to add a new category, "Style."
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19 Click the Add button, change the Caption and the Name to Style, and select Category
under Type.

Déjà Vu X2

465

466

20

Click the Categories tab and select Style in the Attribute dropdown list.

21 Add as many appropriate attributes as you would like and click Apply and OK.
22 You are returned to the termbase view.
23 To verify that your new settings have taken effect, click Add.
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24 The Add Term dialog appears. Click the dropdown list next to the newly created attribute
Style, and you can see that all the new categories are listed.

ASSOCIATING TERMBASES WITH A PROJECT
Termbases can be associated with your project during the creation of a project (see p. 88) or at a
later point.
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To associate termbases with projects
1

In an open project, select Project> Properties> Databases.

2

If you would like to disassociate the existing termbase from the project, select Remove in the
Termbases section.

3

If you would like to add an additional termbase, select Add in the Termbases section.
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4

A file selector dialog appears.
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5

Select the additional database which can be located on a drive of your local computer or
anywhere in your network and click Open.

6

Click Apply and/or OK.

ADDING RECORDS
Just as Déjà Vu X2 Professional offers you the possibility of adding term pairs of different relations
(see "Templates" on page 456), there are different ways to enter them. Naturally, the emphasis is on
adding translation records (see "Adding Translation Records" on page 470), for which there are a
variety of different methods, but there are also ways in which you can add terms of other relations
(see "Adding Non-Translation Records" on page 484).

ADDING TRANSLATION RECORDS
There are three ways to add translation records to a termbase:


Manually in the termbase view



Manually as you translate your project



Manually as you align files
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Automatically through import processes

Though Déjà Vu X2 Professional provides the opportunity to manually add entries in the
termbase view (see p. 466), this is a rarely used and rather tedious way to enter translation
information.
A much more efficient way to enter single term pairs to the terminology is during the actual
translation process.

To manually add term pairs during the translation process
1

While you have a project open, highlight a term or phrase in the source segment and the
corresponding term or phrase in the target segment with your mouse.

2

Send the highlighted terms to the termbase:
On the Translation menu, click Add Pair to Termbase.
–Or–
Press F11.
–Or–
Click the

button on the toolbar.

Déjà Vu X2

471

472

3

The Add Term Pair dialog appears.

4

You can see that several entries are already filled in, including the actual terms (under Lemma,
a term for word or phrase), as well as the languages.
The subject and client are automatically filled in if the appropriate options in the
Termbase Properties dialog are selected (see p. 461).

The attributes that are listed as well as their categories depend on the template you have
chosen or created for your termbase. In this example we have chosen the ATRIL Déjà Vu X2
template. For more information on termbase templates, see "Templates" on page 456.
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5

Add any specifications, including grammatical information (part of speech (=word class),
gender, or number) and semantical definition (such as definition information, subject, or
client).
Note that for most of the attributes there are predefined categories which you can
select. Some fields, including the Definition field, are text fields in which you can freely
enter all appropriate information.

6

You may use the Copy button to copy any of the selections from the first to the second
column.
Be as judicious and at the same time as thorough as you can by only entering the
information that will be relevant for you or your co-workers later on. For instance, it
obviously would not make sense to enter gender information if your language does not
have a grammatical gender, or if any translator or editor should be familiar with this kind
of information. On the other hand, it may very well be worthwhile to spend some time entering
information into the Definition field to give yourself or your co-workers necessary context
information.

7

Click Add.
Because you can simultaneously have several termbases assigned in Déjà Vu X2
Professional, make sure that under Project> Properties> Database you assign the
correct database as the destination database, i.e., the database that is to contain all new
material from the current project.
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8

Your term pair is now entered into your termbase and can be accessed through the standard
searching and assemble functions.

IMPORTING EXTERNAL DATA
You add records to your termbases as you translate (see "Adding Translation Records" on page
470), but Déjà Vu X2 Professional also enables you to import external data into termbases. For
example, this allows you to convert data you have accumulated in other glossaries or even from
data found on the Internet.

To import data
1

With an open termbase, click File> Import> External Data.

2

The Termbase Import Wizard appears.
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3

Click Next.

4

The wizard prompts you to specify an import format. The supported formats are:


Déjà Vu 2.x/3.x Termbase—for importing termbases of earlier versions of Déjà Vu
You can also convert Déjà Vu 2.x/3.x termbases into new Déjà Vu X2 Professional
termbases. For more information on this, see "To convert Déjà Vu 2.x/3.x termbases" on
page 482).



Text—for importing delimited text files (tab, comma, etc.)



Access 9x/2000/XP—for importing databases from various versions of Microsoft
Access



Excel 9x/2000/XP—for importing databases from various versions of Microsoft Excel



MultiTerm 5.5—for importing termbases in the exported text format from MultiTerm
5.5

For this example, we will select Text to import a multilingual comma-separated value file
(.csv).
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5

Select Text and click Next.

6

Select the text file you want to import and click Open. The wizard displays the current
settings.
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7

Click Next. The wizard displays the data of the file and allows you to adjust the delimiter
settings.

8

Select the delimiter of your original file (in this case Comma), and check the appropriate
option if the first row contains field names.
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9

Click Next. The wizard now allows you to specify the field information for the fields of your
original file.

The available standard fields depend on the template you have assigned to that database. If
you have attached the default ATRIL Déjà Vu X2 template you will see the following
relations:


Main Lemma (typically the source term)



Translation



Synonym



Antonym
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New Relation...
Selecting New Relation will open the New Relation dialog in which you can create a
new relation and assign it to the template of the termbase.

and the following attributes:


Part of Speech



Gender



Number



Definition



Subject



Client



New Attribute...
Selecting New Attribute will open the New Attribute dialog in which you can create a
new attribute and assign it to the template of the termbase.
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10 Select Main Lemma and the appropriate language and code page settings for the source
language, and Translation, the appropriate language, relation, and code page settings for the
target languages.

11 Click Next.
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12 The wizard displays the current settings. Click Finish.

13 The wizard displays the import progress; when it is finished, it shows how many records have
been added.
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14 Click Close and you are returned to your termbase view. If you now look for one of the
imported segments, you will find that all languages have been imported.

To convert Déjà Vu 2.x/3.x termbases
1

Select Tools> Convert> DV 2.x/3.x Termbase.

2

The Convert v2.x/3.x Termbase dialog appears.

3

Click Select and select the termbase you would like to convert.

Déjà Vu X2 Professional will automatically recognize the language setting of the old database
and will propose a new termbase with the same name, in the same folder, with a new
extension.
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4

If necessary, change the language setting and/or the name or path of the new termbase.

5

Click OK.

6

Déjà Vu X2 Professional will show you the import process.

7

Once the import is finished, Déjà Vu X2 Professional will show you how many records have
been added.

8

Click Close.
If you open the new database, you will be able to see that not only source and target terms
have been imported, but also all other information that was present in the old termbase,
including subject, client, datestamp, grammatical information, user, etc.
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ADDING NON-TRANSLATION RECORDS
1

Open the termbase to which you want to enter term pairs of non-translation relations. In this
example we are going to add a synonym for a term.

2

Locate the term for which you would like to add a synonym.
Enter the term in the Locate Term text field.
–Or–
Search for the term with the common search function (see "Search and Replace Features" on
page 230).
If you want to add a completely new term, you can do that by clicking Add in the
Source Language section of the window.

3

Click Add in the Related Terms section of the window.
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4

The Add Relation dialog appears.

5

Under Relation Type, select Synonym.

6

Under Language, select the same language as the source language.

7

Under Locate Term, enter the synonym or select one from the list of terms.
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8

Click Add Term and modify or enter any attributes.

9

Click Add.
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10 You are returned to the Add Relation dialog.

11 Click Add and Close. You are returned to the termbase view.
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12 If you select All under Related Terms and All under Target Languages, you can see that there is
now an entry under Translation and under Synonym.

EXPORTING DATA FROM TERMBASES
There are various situations where it may be very helpful to export parts or all of your termbases,
the most obvious being:


storing a termbase in a compact format, or



sharing termbase content with co-workers or teammates.

To export data
1

With an open termbase, click File> Export> External Data.
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2

The Terminology Export Wizard appears.

3

Click Next.

4

The wizard prompts you to specify an export format. The supported formats are:
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Text—for exporting delimited text files (tab, comma, etc.)



Access 95/97 and Access 2000/XP—for exporting databases into various versions of
Microsoft Access
Access 9x does not support Unicode. Depending on your languages, this may be an
important consideration in choosing the right format for you.



Excel 3.0/4.0/5.0/9x/2000/XP—for exporting databases into various versions of
Microsoft Excel
Excel 97 made an end to Excel 95’s limitation of 255 characters per cell (they upped it
to 32,000) and 16,384 rows in a worksheet (extended to more than 65,000). This is an
important consideration when choosing the correct Excel format. Another important
consideration may be that anything before Excel 2000 does not support Unicode.



TeaM Server—for exporting termbases onto a TeaM Server.

In the following example, we will select Excel as the export format.
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To continue the export process with Excel as the data format
The export process into Access or text formats is similar to the procedure for Excel.

1

Select Excel 97/2000/XP.
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2

Click Select.

3

Select the desired export path, give the file an appropriate name, and click Save. The wizard
displays the current settings.

4

Click Next.
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5

The wizard prompts you to specify the fields you are planning to export.

6

Click Add.
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7

Specify for each exportable field the Field Type, Language, the column header in the Excel file
(Export As), and the relation to other selected fields.
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8

Continue until you have selected and specified all necessary fields.

You can move the fields with the up and the down arrows to the right of the selection
field.
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9

The wizard prompts you to enter any filtering condition, i.e., criteria by which you want to
filter the export of your database.
Unless you are very familiar with the underlying structure of the databases, you should
probably resort to using and modifying the provided samples in the Advanced Topics
chapter (see "Sample Regular Expressions for Export from Translation Memory and
Termbase" on page 529).

10 If you choose to enter an expression, verify it by clicking the Validate button. If the expression
proves to be valid, select Next.
–Or–
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If you choose not to enter an expression, select Next.
If you are exporting to text, or Access 97, the wizard prompts you to select the
encoding of the resulting data. In the case of text, it will also prompt you to enter
delimitation information:
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11 Give the worksheet within the Excel spreadsheet the desired name or leave the default name
(Terms).

12 Click Next.
13 The wizard displays the current settings.
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14 Click Finish.
15 The wizard displays the import progress; when it is finished, it shows how many records have
been added.

16 Click Close and you are returned to your termbase view.

EDITING THE TERMBASE
To locate a particular term
In the termbase, terms are either sorted naturally (the order in which they were entered) or
alphabetically.
You can change the sorting order by selecting View> Toggle Sorting.
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You can enter the term that you are looking for in the Locate Term text box, or you can search for
the term with the common search function (see "Search and Replace Features" on page 230).
You can also search and replace within a termbase with the common Search & Replace
features.

When you locate the term by entering it in the Locate term text field, Déjà Vu X2 Professional
will reposition to the first record that begins with the letters you have typed so far. This action is
artificially delayed so that you will have time to type in a few letters before the repositioning
occurs.

MODIFYING A PARTICULAR TERM
Once you have located the term that you want to modify, you can:


edit the attributes of the term or the term itself,



delete that term, or



merge that term with several other source terms.

To edit a term
1

Select the source term or (one of) the related term(s).

2

Click on Edit in the Source Language section to edit the source term.
–Or–
Click on Edit in the Related Terms section to edit the source term.
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3

The Edit Terms dialog appears.

4

Change the term or the attributes as necessary.

5

Click OK.

To delete a term
1

Select the source term or (one of) the related term(s).

2

Click Delete in the Source Language section to delete the source term and all related terms.
–Or–
Click on Delete in the Related Terms section to delete the source term.

To merge several source terms
1

Select several identical or nearly identical source terms.

2

Press the Ctrl key while selecting individual records.
–Or–
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Press the Shift key while selecting a range of records.

3

Click Merge.

4

The source records are merged into one record with several related terms.

Only the attributes of the first of the selected source terms are preserved.
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To view all rows or certain subsets of rows
All Segments is the standard view that displays all source segments with their associated target
segments.
If you want to view only a subset of terms, you can select SQL. This option opens the Select SQL
dialog in which you can enter any SQL statement to view a certain subset of the termbase.

SPELL CHECKING THE TERMBASE
To activate spell checking
1

Select Tools> Spelling.
–Or–
Press F7.

2

The Spell Checking Options dialog appears.
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3

Under Language, you can choose to check any language present in the project, including the
source language.
It is a good practice to include the source language in your spell checks. Any misspelling
in the source is unlikely to occur a second time in later texts, but it will prevent
Déjà Vu X2 Professional from finding perfect matches.

4

Under Scope, you can choose to check all entries in that language or just those that have not
been checked before.
Limiting the spell check to records that have not been checked is an efficient way to
avoid duplicating your work.

5

The Check Spelling dialog appears.

6

For more information on spelling, see "Spell checking" on page 125.
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DIGGING IN—ADVANCED TOPICS
CREATING CUSTOMIZED HTML IMPORT FILES
Déjà Vu X2 Professional will usually be able to separate translatable from non-translatable
content in HTML files and display the translatable content correctly. Because of the nature of
customizable and regularly re-defined scripting languages, there may be situations where some
text is imported that should not be translated. You can choose to copy this text from the source to
the target column and possibly lock those rows, but Déjà Vu X2 Professional also allows you to
write simple regular expression files that would exclude these lines.
There are three different customizations that can be performed. These include the conditional
extraction of attributes in HTML tags, hiding pieces of text that match specific patterns, and
preventing line breaks in script text.

CONDITIONAL EXTRACTION OF ATTRIBUTES IN HTML TAGS
Déjà Vu X2 Professional includes a hard-coded list of which attributes are translatable for each
tag:

Tag

Attribute

A

TITLE

A

ONMOUSEOVER

A

ONMOUSEOUT

A

ONCLICK

APPLET

ALT

AREA

ALT

IMG

ALT

INPUT

VALUE

ISINDEX

PROMPT

META

CONTENT

OBJECT

STANDBY

OBJECT

TITLE

OPTGROUP

LABEL
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Tag

Attribute

OPTION

LABEL

OPTION

VALUE

PARAM

VALUE

TABLE

SUMMARY

TD

ABBR

TD

ONMOUSEOVER

TD

ONMOUSEOUT

TD

ONCLICK

TH

ABBR

You may wish to conditionally override items on this list. For example, you may wish to hide the
contents of CONTENT in the META tag when NAME contains GENERATOR as in: <META
NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">.
You can specify these exceptions in a file called HTMExcept.txt. If this is used, it must be saved in
the directory in which the project file is saved. This file contains five columns separated by tabs,
following this pattern:
Ordinal Tagname KeyToHideWhen ReferenceKey ReferenceKeyPattern
Each line in the file instructs Déjà Vu X2 Professional to hide the contents of
KeyToHideWhen if the contents of ReferenceKey match
ReferenceKeyPattern when processing a tag whose name is Tagname.
The first item is a number used to distinguish between otherwise equal Tagname/
KeyToHideWhen/ReferenceKey 3-tuples. It must be used always, even if there is no
ambiguity.

Lines beginning with a hash mark (#) are ignored.
ReferenceKeyPattern can either be a pattern or constant text.

The following lines
1 PARAM VALUE NAME [A-Z]+[a-z]+[A-Z]+.*
2 PARAM VALUE NAME id
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1 META CONTENT NAME GENERATOR
would exclude the value from these lines:
<PARAM NAME=BgColor VALUE=WHITE>
<PARAM NAME=id VALUE=num1>
and the content from:
<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">
For specifications on regular expression in VBScript, see the MSDN library at http://
msdn.microsoft.com/library.

If you don't use the HTMExcept.txt file, Déjà Vu X2 Professional will default to the following
exceptions:
1 META CONTENT NAME GENERATOR
2 META CONTENT NAME Generator
3 META CONTENT http-equiv Content-Type
4 META CONTENT http-equiv Pragma

HIDING PIECES OF TEXT THAT MATCH SPECIFIC PATTERNS
It is possible to force Déjà Vu X2 Professional to hide pieces of text that match certain patterns,
and depending on what comes before or after the strings. You can place a file called HTMHide.txt
in the directory in which the project file is saved and add lines to that file that instruct Déjà Vu X2
Professional how to deal with strings. You will have to follow this structure (each of the entries is
separated by a tab character):
Pre StringstoHide Post StringsToDisplay


Example 1:

\WSession\("

"\) (User1|User2)

would be interpreted by Déjà Vu X2 Professional as:


a non-word character, followed by the word Session, followed by an opening
parenthesis and a double quote (Pre);
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followed by any string (StringstoHide);



followed by a double quote and closing parenthesis (Post);



followed by the strings User1 or User2 (and not User3 or UserName)
(StringsToDisplay)

resulting in displaying User2 in Session("User2") but not User7 in
Session("User7").


Example 2:

\WRedirect(\W)*"

"\W

would be interpreted by Déjà Vu X2 Professional as:


a non-word character, followed by the word Redirect, followed by a non-word
character appearing zero or more times, followed by a double quote (Pre);



followed by any string (StringstoHide);



followed by a double quote and a non-word character (Post) with no strings to
display (StringsToDisplay) (i.e., hide any strings that appear surrounded by Pre and
Post)

resulting in not displaying www.atril.com/default.asp in Response.Redirect "http:/
/www.atril.com/default.asp"


Example 3:

*[a-z]+[A-Z]+.*
would be interpreted by Déjà Vu X2 Professional as:


any string (Pre);



followed by any number of characters, followed by a lowercase letter appearing one
or more times, followed by an uppercase letter appearing one or more times,
followed by any number of characters (StringsToHide);



followed by any string (Post)



with no strings to display (StringsToDisplay)
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resulting in not displaying retValue.
Items are separated by tabs.
Lines beginning with a hash mark (#) are ignored.
Any items may be empty, but the three tabs must be present.
Pre is a pattern that describes the characters before the string in questions; if empty, Déjà Vu X2
Professional will ignore it.
StringsToHide is a pattern that describes the string itself; if empty, Déjà Vu X2 Professional
assumes "any string."
Post is a pattern that describes the characters after the string; if empty, Déjà Vu X2 Professional
will ignore it.
You can use StringsToDisplay rather than StringsToHide. If you do, StringsToDisplay is a pattern that
describes the strings that must be displayed. All other strings will be hidden. To specify a list of
strings in StringsToDisplay, separate them with '|' and enclose the list in parentheses, as in the first
example below.
If StringsToHide is not empty, then StringsToDisplay will be ignored.
All rows must contain exactly three tab characters even if not all the items are used.
For specifications on regular expression in VBScript, see the MSDN library at http://
msdn.microsoft.com/library.

PREVENTING LINE BREAKS IN SCRIPT TEXT
Bits of text found in scripts will normally go to a new segment in the Déjà Vu X2 Professional
project. For example, in
+ "(client has " + Trim(CStr(PrevCopies)) + " copies of D&eacute;j&agrave;Vu X2 Professional)"
the two pieces of text will end up in two different Déjà Vu rows, unless you tell Déjà Vu X2
Professional that
" + Trim(CStr(PrevCopies)) + "
is a pattern that does not force a segment change.
You can place a file called ASPNoBreaks.txt in the directory in which the project file is, each of
whose lines contains one pattern. The following two lines:
" *(\+|&) *" *
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" *(\+|&) *(\w|\.)*[(]*(\w|\.)*[)]* +(\+|&) *" *
would mean that whenever any of the following pattern occurs:


double quote, followed by any number of spaces, followed by a plus sign or
ampersand, followed by any number of spaces, followed by a double quote, and
any number of spaces (for example: " + ")



double quote, followed by any number of spaces, followed by a plus sign or
ampersand, followed by any number of spaces, followed by a word character or dot
appearing zero or more times, followed by any number of open parentheses,
followed by a word character or dot appearing zero or more times, followed by any
number of close parentheses, followed by at least one space, followed by a plus sign
or ampersand, followed by any number of spaces, followed by double quote,
followed by any number of spaces (for example: " +
Trim(CStr(PrevCopies)) + ")

the line would not break.
For specifications on regular expression in VBScript, see the MSDN library at http://
msdn.microsoft.com/library.
The above mechanisms also work when you are aligning any files. The only difference
is that you will have to save HTMExcept.txt, HTMHide.txt, or ASPNoBreaks.txt in Déjà Vu X2
Professional's installation directory rather than in the project's common source directory.

USING STRUCTURED QUERY LANGUAGE AND SAMPLE SQL STATEMENTS
Before executing any SQL command, make sure that your files are backed up. There is
no undo function!

Déjà Vu X2 Professional provides for several ways to use standard SQL commands to update or
modify project files, translation memories, and termbases—all of which are database files.


In project files, you can enter a SELECT command with the help if an Expression Builder
(see "To use the SQL Statement view" on page 46)



In project files, you can enter a full SQL statement under Project> Execute SQL.



In translation memories and termbases, you can enter a full SQL statement under
Databases> Execute SQL.
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Due to the more complicated nature of the database structure of Déjà Vu X2 Professional than
the one in earlier version of Déjà Vu 3, we will give some samples of SQL statements that you can
use, and if applicable, alter to your specific needs.
If there are several commands listed under one heading, you will have to make sure
that you enter all of them in successive order. To omit one of them may leave the
database file in an unstable condition.
If you need help with more complex SQL statements, please contact Atril support at
support@atril.com, to discuss ways in which we can help you.

COMMANDS TO DELETE DATA FROM THE TRANSLATION MEMORY
After executing any DELETE command for the translation memory, you will have to
make that you select Tools> Repair> Translation Memory to repair the translation
memory. This is necessary to keep the index congruent with the information in the
database.

Delete project 1234567 from translation memory
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE
PrjID=1234567)
DELETE FROM Translations WHERE PrjID=1234567

Delete translation memory records with client "ABC"
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE
Client='ABC')
DELETE FROM Translations WHERE Client='ABC'

Delete translation memory records with subject "123"
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE
Subject='123')
DELETE FROM Translations WHERE Subject='123'

Delete translation memory records with client "ABC" and with subject "123"
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE
Client='ABC' AND Subject='123')
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DELETE FROM Translations WHERE Client='ABC' AND Subject='123'

Delete translation memory records where the source is shorter than 4 characters
Replace ConditionOnSentence with: Len(Sentence)<4 AND IsSource
DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
ConditionOnSentence)
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
ConditionOnSentence)

Delete translation memory records where American English records contain "ß" or "ä" or
"ö" or "ü"
Replace ConditionOnSentence with: Lang = 9 AND SubLang = 1 AND
(Sentence LIKE '*ß*' OR Sentence LIKE '*ä*' OR Sentence LIKE '*ö*' OR
Sentence LIKE '*ü*')
DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
ConditionOnSentence)
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
ConditionOnSentence)

Delete translation memory records with FileID "987" from translation memory
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE
FileID=987)
DELETE FROM Translations WHERE FileID=987

Delete translation memory records entered on December 31, 2010
DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
Datestamp >= #12/31/2009# AND Datestamp<#1/1/2010#)
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
Datestamp >= #12/31/2009# AND Datestamp<#1/1/2010#)
You need the lower and upper boundaries for the date field because the same field also
contains the time value.
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Delete translation memory records entered on or after December 31, 2009
DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
Datestamp >= #12/31/2009#)
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
Datestamp >= #12/31/2009#)
If you surround the date with #, you will have to use the format mm/dd/yy or mm/dd/
yyyy. It is also possible to use the Datevalue function in combination with date in the
format currently specified in the Windows Regional Options (under Start> Settings>
Control Panel> Regional Options> Date), e.g., Datestamp >= Datevalue('31/12/
2009') for the default German setting.

Delete translation memory records entered between January 1, 2010, and January 31,
2010
DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
Datestamp >= #1/1/2010# and Datestamp<#2/1/2010#)
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
Datestamp >= #1/1/2010# and Datestamp<#2/1/2010#)
You need the lower and upper boundaries for the date field because the same field also
contains the time value.

Delete translation memory records entered on January 1, 2010, between 11 am and 3
pm
You need the lower and upper boundaries for the date field because the same field also
contains the time value.

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
Datestamp >= #1/1/2010 11:00# and Datestamp<#1/1/2010 15:00#)
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
Datestamp >= #1/1/2010 11:00# and Datestamp<#1/1/2010 15:00#)
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Delete all translation memory records in U.S. English starting with "ABC"
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*')
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*')

Delete all translation memory records in U.S. English containing "ABC"
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
Lang = 9 AND SubLang = 1 AND Sentence LIKE '*ABC*')
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
Lang = 9 AND SubLang = 1 AND Sentence LIKE '*ABC*')

Delete all translation memory records from User "Joe"
DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE
UserNick = 'Joe')
DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE
UserNick = 'Joe')

Delete all translation memory records where U.S. English is equal to Standard Spanish
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

From Translations table:
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DELETE FROM Translations WHERE ID IN (SELECT S1.ID FROM Sentences AS
S1 INNER JOIN Sentences AS S2 ON S1.ID = S2.ID WHERE S1.Sentence =
S2.Sentence AND S1.Lang=9 AND S1.SubLang = 1 AND S2.Lang = 10 AND
S2.SubLang = 1))
From Sentences table:
DELETE FROM Sentences WHERE ID IN (SELECT S1.ID FROM Sentences AS S1
INNER JOIN Sentences AS S2 ON S1.ID = S2.ID WHERE S1.Sentence =
S2.Sentence AND S1.Lang=9 AND S1.SubLang = 1 AND S2.Lang = 10 AND
S2.SubLang = 1))

COMMANDS TO DELETE DATA FROM THE TERMBASE

Delete termbase records with client "ABC
Before you execute this command, you will have to verify what AttrTypeID "client" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents client. In this example we
assume that this code is 6, but this will not necessarily be the case for your database.

DELETE FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE
AttrTypeID=6 AND Textvalue='ABC')
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT LemmaID FROM
Attributes WHERE AttrTypeID=6 AND Textvalue='ABC')
DELETE FROM Attributes WHERE AttrTypeID=6 AND Textvalue='ABC'

Delete termbase records with subject "123"
Before you execute this command, you will have to verify what AttrTypeID "subject" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents subject. In this example we
assume that this code is 5, but this will not necessarily be the case for your database.

DELETE FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE
AttrTypeID=5 AND Textvalue='123')
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT LemmaID FROM
Attributes WHERE AttrTypeID=5 AND Textvalue='123')
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DELETE FROM Relations WHERE DstLemmaID IN (SELECT LemmaID FROM
Attributes WHERE AttrTypeID=5 AND Textvalue='123')
DELETE FROM Attributes WHERE AttrTypeID=5 AND Textvalue='123'

Delete termbase records with client "ABC" and with subject "123"
Before you execute this command, you will have to verify what AttrTypeID "client" and
"subject" have in your termbase. You can do that by opening the AttrTypes table within
the termbase with Microsoft Access. Look for the ID that represents client. In this
example we assume that this code is 5 and 6, but this will not necessarily be the case
for your database.

DELETE FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE
AttrTypeID=6 AND Textvalue='ABC') AND ID IN (SELECT LemmaID FROM
Attributes WHERE AttrTypeID=5 AND Textvalue='123')
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT LemmaID FROM
Attributes WHERE AttrTypeID=6 AND Textvalue='ABC') AND OrgLemmaID IN
(SELECT LemmaID FROM Attributes WHERE AttrTypeID=5 AND
Textvalue='123')
DELETE FROM Relations WHERE DstLemmaID IN (SELECT LemmaID FROM
Attributes WHERE AttrTypeID=6 AND Textvalue='ABC') AND DstLemmaID IN
(SELECT LemmaID FROM Attributes WHERE AttrTypeID=5 AND
Textvalue='123')
DELETE FROM Attributes WHERE LemmaID IN (SELECT LemmaID FROM
Attributes WHERE AttrTypeID=6 AND Textvalue='ABC') AND LemmaID IN
(SELECT LemmaID FROM Attributes WHERE AttrTypeID=5 AND
Textvalue='123')

Remove the association between termbase records entered on or after December 31,
2009
DELETE FROM Relations WHERE Datestamp >= #12/31/2009#
This command removes the association but leaves the actual terms in the database.
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Remove the termbase records entered on or after December 31, 2009
DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM
Relations WHERE Datestamp >= #12/31/2009#) OR LemmaID IN (SELECT
DstLemmaID FROM Relations WHERE Datestamp >= #12/31/2009#)
DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations
WHERE Datestamp >= #12/31/2009#) OR ID IN (SELECT DstLemmaID FROM
Relations WHERE Datestamp >= #12/31/2009#)
DELETE FROM Relations WHERE Datestamp >= #12/31/2009#

Remove the association between termbase records entered on December 31, 2009
DELETE FROM Relations WHERE Datestamp >= #12/31/2009# and
Datestamp<#1/1/2010#
This command removes the association but leaves the actual terms in the database.

Delete the termbase records entered on December 31, 2009
DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM
Relations WHERE Datestamp >= #12/31/2009# and Datestamp<#1/1/2010#)
OR LemmaID IN (SELECT DstLemmaID FROM Relations WHERE Datestamp >=
#12/31/2009# and Datestamp<#1/1/2010#)
You need the lower and upper boundaries for the date field because the same field also
contains the time value.

DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations
WHERE Datestamp >= #12/31/2009#) OR ID IN (SELECT DstLemmaID FROM
Relations WHERE Datestamp >= #12/31/2009# and Datestamp<#1/1/2010#)
DELETE FROM Relations WHERE Datestamp >= #12/31/2009# and
Datestamp<#1/1/2010#
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Remove the association between termbase records entered between January 1, 2010,
and January 31, 2010
DELETE FROM Relations WHERE Datestamp >= #1/1/2010# AND Datestamp<#2/
1/2010#
This command removes the association but leaves the actual terms in the database.

Delete the termbase records entered between January 1, 2010, and January 31, 2010
DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM
Relations WHERE Datestamp >= #1/1/2010# and Datestamp<#2/1/2010#) OR
LemmaID IN (SELECT DstLemmaID FROM Relations WHERE Datestamp >= #1/1/
2010# and Datestamp<#2/1/2010#)
DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations
WHERE Datestamp >= #1/1/2010# and Datestamp<#2/1/2010#) OR ID IN
(SELECT DstLemmaID FROM Relations WHERE Datestamp >= #1/1/2010# and
Datestamp<#2/1/2010#)
DELETE FROM Relations WHERE Datestamp >= #1/1/2010# AND Datestamp<#2/
1/2010#

Remove the association between termbase records entered on January 1, 2010,
between 11 am and 3 pm
DELETE FROM Relations WHERE Datestamp >= #1/1/2010 11:00# AND
Datestamp<#1/1/2010 15:00#
This command removes the association but leaves the actual terms in the database.

Delete termbase records entered on January 1, 2010, between 11 am and 3 pm
DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM
Relations WHERE Datestamp >= #1/1/2010 11:00# AND Datestamp<#1/1/2010
15:00#) OR LemmaID IN (SELECT DstLemmaID FROM Relations WHERE
Datestamp >= #1/1/2010 11:00# AND Datestamp<#1/1/2010 15:00#)
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DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations
WHERE Datestamp >= #1/1/2010 11:00# AND Datestamp<#1/1/2010 15:00#)
OR ID IN (SELECT DstLemmaID FROM Relations WHERE Datestamp >= #1/1/
2010 11:00# AND Datestamp<#1/1/2010 15:00#)
DELETE FROM Relations WHERE Datestamp >= #1/1/2010 11:00# AND
Datestamp<#1/1/2010 15:00#

Delete termbase records in U.S. English starting with "ABC"
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

The terms (including attributes, relations, and lemmas):
DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE
Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*')
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas
WHERE Condition) OR DstLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9
AND SubLang = 1 Lemma LIKE 'ABC*')
DELETE FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*'
Related lemmas:
DELETE FROM Lemmas WHERE (ID IN (SELECT OrgLemmaID FROM Relations
WHERE DstLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang =
1 Lemma LIKE 'ABC*')) OR ID IN (SELECT DstLemmaID FROM Relations
WHERE OrgLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang =
1 Lemma LIKE 'ABC*')))
Break relations:
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas
WHERE Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*') OR DstLemmaID IN
(SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE
'ABC*')))
Related attributes:
DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE
Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*')

Déjà Vu X2

519

520

Only the lemmas:
DELETE FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*'

Delete all termbase records in U.S. English containing "ABC"
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

The terms (including attributes, relations, and lemmas):
DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE
ConditionOnLemma)
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas
WHERE Condition) OR DstLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9
AND SubLang = 1 Lemma LIKE '*ABC*')
DELETE FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*'
Related lemmas:
DELETE FROM Lemmas WHERE (ID IN (SELECT OrgLemmaID FROM Relations
WHERE DstLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang =
1 Lemma LIKE '*ABC*')) OR ID IN (SELECT DstLemmaID FROM Relations
WHERE OrgLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang =
1 Lemma LIKE '*ABC*')))
Break relations:
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas
WHERE Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*') OR DstLemmaID IN
(SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE
'*ABC*')))
Only the lemmas:
DELETE FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*'

Delete all termbase records from User "Joe"
Just removing the connection between related terms without deleting the terms from the
termbase:
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DELETE FROM Relations WHERE UserNick = 'Joe'
Removing the terms (including attributes, relations, and lemmas):
DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM
Relations WHERE UserNick = 'Joe') OR LemmaID IN (SELECT DstLemmaID
FROM Relations WHERE UserNick = 'Joe')
DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations
WHERE UserNick = 'Joe') OR ID IN (SELECT DstLemmaID FROM Relations
WHERE UserNick = 'Joe')
DELETE FROM Relations WHERE UserNick = 'Joe'

Delete all termbase translation records where U.S. English is equal to Standard Spanish
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

Deleting the attributes:
DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE
ID IN (SELECT L1.ID FROM Lemmas AS L1, Relations, Lemmas AS L2 WHERE
Relations.RelTypeID = 1 AND ((L1.ID = Relations.OrgLemmaID AND L2.ID
= Relations.DstLemmaID) OR (L2.ID = Relations.OrgLemmaID AND L1.ID =
Relations.DstLemmaID)) AND L1.Lemma = L2.Lemma AND ((L1.Lang=9 AND
L1.SubLang = 1 AND L2.Lang = 10 AND L2.SubLang = 1) OR (L2.Lang=9 AND
L2.SubLang = 1 AND L1.Lang = 10 AND L1.SubLang = 1))))
Deleting the terms:
DELETE FROM Lemmas WHERE ID IN (SELECT L1.ID FROM Lemmas AS L1,
Relations, Lemmas AS L2 WHERE Relations.RelTypeID = 1 AND ((L1.ID =
Relations.OrgLemmaID AND L2.ID = Relations.DstLemmaID) OR (L2.ID =
Relations.OrgLemmaID AND L1.ID = Relations.DstLemmaID)) AND L1.Lemma
= L2.Lemma AND ((L1.Lang=9 AND L1.SubLang = 1 AND L2.Lang = 10 AND
L2.SubLang = 1) OR (L2.Lang=9 AND L2.SubLang = 1 AND L1.Lang = 10 AND
L1.SubLang = 1)))

Delete termbase records where the source is longer than 255 characters
Replace ConditionOnLemma with: LEN(Lemma)>255
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DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE
ConditionOnLemma)
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas
WHERE ConditionOnLemma)
DELETE FROM Relations WHERE DstLemmaID IN (SELECT ID FROM Lemmas
WHERE ConditionOnLemma)
DELETE FROM Lemmas WHERE ConditionOnLemma

Delete termbase records where American English records contain "ß" or "ä" or "ö" or "ü"
Replace ConditionOnLemma with: Lang = 9 AND SubLang = 1 AND (Sentence
LIKE '*ß*' OR Sentence LIKE '*ä*' OR Sentence LIKE '*ö*' OR Sentence
LIKE '*ü*')
DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE
ConditionOnLemma)
DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas
WHERE ConditionOnLemma)
DELETE FROM Relations WHERE DstLemmaID IN (SELECT ID FROM Lemmas
WHERE ConditionOnLemma)
DELETE FROM Lemmas WHERE ConditionOnLemma

COMMANDS TO UPDATE RECORDS IN THE TRANSLATION MEMORY

Change client to "DEF" in translation memory
UPDATE Translations SET Client = 'DEF'

Change translation memory records with client "ABC" in to client "DEF"
UPDATE Translations SET Client='DEF' WHERE Client='ABC'

Change translation memory records with subject "123" in to subject "456"
UPDATE Translations SET Subject='456' WHERE Subject='123'
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Change translation memory records marked as American English to British English
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

UPDATE Sentences SET SubLang=2 WHERE Lang = 9 AND SubLang = 1
After executing a command of this type for the main language (rather than the
sublanguage), you will have to make that you select Tools> Repair> Translation
Memory to repair the translation memory.

Change client to "1234" for translation memory records entered on December 31, 2009
UPDATE TRANSLATIONS SET Client='1234' WHERE ID IN (SELECT ID FROM
SENTENCES WHERE Datestamp >= #12/31/2009# AND Datestamp<#1/1/2010#)

Change user to "Joe" for translation memory records with client "1234"
UPDATE Sentences SET UserNick = 'Joe' WHERE ID IN (SELECT ID FROM
Translations WHERE Client = '1234')

COMMANDS TO UPDATE RECORDS IN THE TERMBASE

Change client to "DEF" in termbase
Before you execute this command, you will have to verify what AttrTypeID "client" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents client. In this example we
assume that this code is 6, but this will not necessarily be the case for your database.

DELETE FROM Attributes WHERE AttrTypeID = 6
INSERT INTO Attributes SELECT 'DEF' AS TextValue, 6 as AttrTypeID, ID
AS LemmaID FROM Lemmas
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Change client to "DEF" in termbase for records entered on December 31, 2009
Before you execute this command, you will have to verify what AttrTypeID "client" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents client. In this example we
assume that this code is 6, but this will not necessarily be the case for your database.

DELETE FROM Attributes WHERE AttrTypeID = 6 AND LemmaID IN (SELECT ID
FROM Lemmas WHERE Datestamp >= #12/31/2009# AND Datestamp<#1/1/2010#)
INSERT INTO Attributes SELECT 'DEF' AS TextValue, 6 as AttrTypeID, ID
AS LemmaID FROM Lemmas WHERE Datestamp >= #12/31/2009# AND
Datestamp<#1/1/2010#

Change client to "DEF" in translation memory for records with subject "9876"
UPDATE TRANSLATIONS SET Client='DEF' WHERE Subject = '9876'

Change client to "DEF" in termbase for records with subject "9876"
Before you execute this command, you will have to verify what AttrTypeID "client" and
"subject" have in your termbase. You can do that by opening the AttrTypes table within
the termbase with Microsoft Access. Look for the IDs that represent client and subject.
In this example we assume that the code for client is 6 and for subject 5, but this will
not necessarily be the case for your database.

DELETE FROM Attributes WHERE AttrTypeID = 6 AND LemmaID IN (SELECT ID
FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE
AttrTypeID = 5 and TextValue = '9876'))
INSERT INTO Attributes SELECT 'DEF' AS TextValue, 6 as AttrTypeID, ID
AS LemmaID FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes
WHERE AttrTypeID = 5 and TextValue = '9876')
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Change user to "Joe" in termbase for records with client "DEF"
Before you execute this command, you will have to verify what AttrTypeID "client" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents client. In this example we
assume that this code is 6, but this will not necessarily be the case for your database.

UPDATE Relations SET UserNick = ' Joe' WHERE OrgLemmaID IN (SELECT ID
FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE
AttrTypeID = 6 AND TextValue = 'DEF'))

Change records with client "ABC" in termbase to client "DEF"
Before you execute this command, you will have to verify what AttrTypeID "client" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents client. In this example we
assume that this code is 6, but this will not necessarily be the case for your database.

UPDATE Attributes SET Textvalue='DEF' WHERE AttrTypeID=6 AND
Textvalue='ABC'

Change records with subject "123" in termbase to subject "456"
Before you execute this command, you will have to verify what AttrTypeID "subject" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents subject. In this example we
assume that this code is 5, but this will not necessarily be the case for your database.

UPDATE Attributes SET Textvalue='456' WHERE AttrTypeID=5 AND
Textvalue='123'

Change termbase records marked as American English to British English
UPDATE Lemmas SET SubLang=2 WHERE Lang = 9 AND SubLang = 1

Déjà Vu X2

525

526

COMMANDS TO UPDATE RECORDS IN THE PROJECT FILE

Prevent translation project records containing "ABC" in Standard Spanish from being sent
to the translation memory
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.
For commands involving any field for which the language code is part of the field name
(such as Status_xxxx or Target_xxxx) in projects, you will have to use a four- or five-digit language
ID that follows this formula: (Sublanguage * 1024) + Language, i.e., Standard Spanish
would be (1 * 1024) + 10 = 1034.
For a list of codes for field attributes, see "List of Codes for Field Attributes in Projects" on page 544.

UPDATE Pairs SET Status_1034 = Status_1034 + 2048 WHERE Target_1034
LIKE '*ABC*' AND ((Status_1034 \ 2048) MOD 2) <> 1

Change translation status of translation project records from fuzzy to progress status
locked
For a list of codes for field attributes, see "List of Codes for Field Attributes in Projects"
on page 544.

UPDATE Pairs SET Status_1034 = Status_1034 – 2 + 512 WHERE
((Status_1034 \ 2) MOD 2) = 1 AND ((Status_1034 \ 512) MOD 2) <> 1

SAVING SQL EXPRESSIONS
Once you have written or assembled a SQL expression, it is possible to save this for later use with
translation memories, termbases, or project files.
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You can view all your saved expressions under Tools> Options> SQL.

Within the same dialog you can also create SQL filters or statements, but the more typical way of
creating and saving them would be in the actual application itself.

CREATING AND SAVING A SQL STATEMENT
In our example, we’ll create and save a SQL statement for a translation memory.
1

With an open translation memory select Translation Memory> Execute SQL.
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2

Enter a valid SQL expression under SQL Statement.

3

You can see that the Save button is still disabled.

4

Enter a name under Statement Name.

5

The Save button is now activated. Click the button.

6

In the submenu under Translation Memory> Execute SQL you can now see the statement
listed under that name and you can execute it by selecting it.
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7

If you reopen the dialog under Tools> Options> SQL and select "Translation Memory" under
Database Type you can also see the new expression listed right there:

Creating saved statements for termbases and projects follows a similar pattern.

SAMPLE REGULAR EXPRESSIONS FOR EXPORT FROM TRANSLATION
MEMORY AND TERMBASE
The following regular expressions can be used in the Filtering Conditions window of the Termbase/
Translation Memory Export Wizards (see p. 438 and p. 496) to export only a subset of your
databases into one of the supported formats. After you have entered or copied and pasted the
expressions into the provided text field, you should make sure that you validate them by selecting
the Validate button below the text field.
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Export records belonging to project 1234567 from translation memory
PrjID=1234567

Export records of subject "123" from translation memory
Subject='123'

Export records of subject "123" from termbase
Before you execute this command, you will have to verify what AttrTypeID "subject" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents subject. In this example we
assume that this code is 5, but this will not necessarily be the case for your database.

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 5 and
TextValue = '123')

Export records of client "987" from translation memory
Client='987'

Export records of client "987" from termbase
Before you execute this command, you will have to verify what AttrTypeID "client" has
in your termbase. You can do that by opening the AttrTypes table within the termbase
with Microsoft Access. Look for the ID that represents client. In this example we
assume that this code is 6, but this will not necessarily be the case for your database.

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 6 and
TextValue = '987')

Export records of client "987" and subject "123" from translation memory
Client='987' AND Subject='123'
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Export records of client "987" and subject "123" from termbase
Before you execute this command, you will have to verify what AttrTypeIDs "client" and
"subject" have in your termbase. You can do that by opening the AttrTypes table within
the termbase with Microsoft Access. Look for the IDs that represents client and subject.
In this example we assume that the codes are 5 and 6, but this will not necessarily be
the case for your database.

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 6 and
TextValue = '987') AND ID IN (SELECT LemmaID FROM Attributes WHERE
AttrTypeID = 5 and TextValue = '123')

Export translation memory records entered on or after December 21, 2009
ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/2009#)

Export termbase records entered on or after December 21, 2009
ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #12/21/
2009#) OR ID IN (SELECT DstLemmaID FROM Relations WHERE Datestamp >=
#12/21/2009#)

Export translation memory records entered on December 21, 2009
ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/2009# AND
Datestamp<#12/22/2009#)
Because the date field also contains a time value, you have to add lower and upper
boundaries.

Export termbase records entered on December 21, 2009
ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #12/21/
2009# AND Datestamp<#12/22/2009#) OR ID IN (SELECT DstLemmaID FROM
Relations WHERE Datestamp >= #12/21/2009# AND Datestamp<#12/22/2009#)
Because the date field also contains a time value, you have to add lower and upper
boundaries.
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Export translation memory records entered between January 1, 2010, and January 31,
2010
ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #1/1/2010# AND
Datestamp<#2/1/2010#)

Export termbase records entered between January 1, 2010, and January 31, 2010
ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #1/1/2010#
AND Datestamp<#2/1/2010#) OR ID IN (SELECT DstLemmaID FROM Relations
WHERE Datestamp >= #1/1/2010# AND Datestamp<#2/1/2010#)

Export translation memory records entered on December 21, 2009, between 12 pm and
3 pm
ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/2009 11:00#
AND Datestamp<#12/21/2009 15:00#)

Export termbase records entered on December 21, 2009, between 12 pm and 3 pm
ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #12/21/
2009 11:00# AND Datestamp<#12/21/2009 15:00#) OR ID IN (SELECT
DstLemmaID FROM Relations WHERE Datestamp >= #12/21/2009 11:00# AND
Datestamp<#12/21/2009 15:00#)

Export all translation memory records in U.S. English starting with "ABC"
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

ID IN (SELECT ID FROM Sentences WHERE Lang = 9 AND SubLang = 1 AND
Sentence LIKE 'ABC*')

Export all termbase records in U.S. English starting with "ABC"
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*'
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Export all termbase records in U.S. English containing "ABC"
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

ID IN (SELECT ID FROM Sentences WHERE Lang = 9 AND SubLang = 1 AND
Sentence LIKE '*ABC*')

Export all termbase records in U.S. English containing "ABC"
For a list of language and sublanguage codes, see "List of Language and Sublanguage
Codes" on page 534.

Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*'

Export all translation memory records from User "Joe"
ID IN (SELECT ID FROM Sentences WHERE UserNick = 'Joe')

Export all termbase records from User "Joe"
ID IN (SELECT OrgLemmaID FROM Relations WHERE UserNick = 'Joe') OR ID
IN (SELECT DstLemmaID FROM Relations WHERE UserNick = 'Joe')
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LIST OF LANGUAGE AND SUBLANGUAGE CODES
The following tables provide you with a list of codes for the languages and sublanguages used in
Déjà Vu X2 Professional that can be used in SQL commands and filtering expressions.
For commands involving any field for which the language code is part of the field name
(such as Status_xxxx or Target_xxxx) in projects, you will have to use a four- or five-digit
language ID that follows this formula: (Sublanguage * 1024) + Language, i.e.,
Standard Spanish would be (1 * 1024) + 10 = 1034.
Language

Decimal Code

Afrikaans

54

Albanian

28

Amharic

94

Arabic

1

Armenian

43

Assamese

77

Azeri

44

Basque

45

Belarusian

35

Bengali

69

Bosnian

26

Bulgarian

2

Burmese

85

Catalan

3

Cherokee

92

Chinese

4

Croatian

26

Czech

5

Danish

6
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Language

Decimal Code

Divehi

101

Dutch

19

Dzongkha

81

Edo

102

English

9

Estonian

37

Faeroese

56

Farsi

41

Filipino

100

Finnish

11

French

12

Frisian

98

Fulfulde

103

Gaelic

60

Galician

86

Georgian

55

German

7

Greek

8

Guarani

116

Gujarati

71

Hausa

104

Hawaiian

117

Hebrew

13

Hindi

57

Hungarian

14
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Language

Decimal Code

Ibibio

105

Icelandic

15

Igbo

112

Indonesian

33

Inuktitut

93

Italian

16

Japanese

17

Kannada

75

Kanuri

113

Kashmiri

96

Kazakh

63

Khmer

83

Konkani

87

Korean

18

Kyrgyz

64

Lao

84

Latin

118

Latvian

38

Lithuanian

39

Macedonian

47

Malay

62

Malayalam

76

Maltese

58

Manipuri

88

Marathi

78
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Language

Decimal Code

Moldavian

24

Mongolian

80

Nepali

97

Neutral

0

Norwegian

20

Oriya

72

Oromo

114

Papiamentu

121

Pashto

99

Polish

21

Portuguese

22

Punjabi

70

Rhaeto Romanic

23

Romanian

24

Russian

25

Sami

59

Sanskrit

79

Serbian

26

Sindhi

89

Sinhalese

91

Slovak

27

Slovenian

36

Somali

119

Sorbian

46

Spanish

10
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Language

Decimal Code

Sutu

48

Swahili

65

Swedish

29

Syriac

90

Tajik

40

Tamazight

95

Tamil

73

Tatar

68

Telugu

74

Thai

30

Tibetan

81

Tigrigna

115

Tsonga

49

Tswana

50

Turkish

31

Turkmen

66

Ukrainian

34

Urdu

32

Uzbek

67

Venda

51

Vietnamese

42

Welsh

82

Xhosa

52

Yi

120

Yiddish

61
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Language

Decimal Code

Yoruba

106

Zulu

53

Sublanguage

Decimal Code

Neutral

0

Default

1

Sys Default

2

Arabic Saudi Arabia

1

Arabic Iraq

2

Arabic Egypt

3

Arabic Libya

4

Arabic Algeria

5

Arabic Morocco

6

Arabic Tunisia

7

Arabic Oman

8

Arabic Yemen

9

Arabic Syria

10

Arabic Jordan

11

Arabic Lebanon

12

Arabic Kuwait

13

Arabic UAE

14

Arabic Bahrain

15

Arabic Qatar

16

Azeri Latin

1

Azeri Cyrillic

2

Bengali India

1
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Sublanguage

Decimal Code

Bengali Bangladesh

2

Chinese Traditional

1

Chinese Simplified

2

Chinese Hong Kong

3

Chinese Singapore

4

Chinese Macau

5

Croatian Standard

1

Croatian Bosnia

4

Dutch Standard

1

Dutch Belgium

2

English United States

1

English United Kingdom

2

English Australia

3

English Canada

4

English New Zealand

5

English Ireland

6

English South Africa

7

English Jamaica

8

English Caribbean

9

English Belize

10

English Trinidad

11

English Zimbabwe

12

English Philippines

13

English Indonesia

14

English Hong Kong

15

Déjà Vu X2

540

Digging In—Advanced Topics

Sublanguage

Decimal Code

English India

16

English Malaysia

17

English Singapore

18

French Standard

1

French Belgium

2

French Canada

3

French Switzerland

4

French Luxembourg

5

French Monaco

6

French West Indies

7

French Reunion

8

French Congo DRC

9

French Senegal

10

French Cameroon

11

French Cote D'Ivoire

12

French Mali

13

French Morocco

14

French Haiti

15

French North Africa

57

Gaelic Scotland

1

Gaelic Ireland

2

German Standard

1

German Switzerland

2

German Austria

3

German Luxembourg

4
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Sublanguage

Decimal Code

German Liechtenstein

5

Greek Standard

1

Greek Alternative

2

Italian Standard

1

Italian Switzerland

2

Kashmiri Pakistan

1

Kashmiri South Asia

2

Korean Standard

1

Korean Johab

2

Lithuanian Standard

1

Lithuanian Classic

2

Malay Standard

1

Malay Brunei

2

Mongolian Cyrillic

1

Mongolian Mongolian

2

Nepali Nepal

1

Nepali India

2

Norwegian Bokmål

1

Norwegian Nynorsk

2

Portuguese Standard

2

Portuguese Brazil

1

Punjabi India

1

Punjabi Pakistan

2

Romanian Standard

1

Romanian Moldova

2
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Sublanguage

Decimal Code

Russian Standard

1

Russian Moldova

2

Serbian Latin

2

Serbian Cyrillic

3

Sindhi India

1

Sindhi Pakistan

2

Spanish Standard

1

Spanish Mexico

2

Spanish Modern Sort

3

Spanish Guatemala

4

Spanish Costa Rica

5

Spanish Panama

6

Spanish Dominican Republic

7

Spanish Venezuela

8

Spanish Colombia

9

Spanish Peru

10

Spanish Argentina

11

Spanish Ecuador

12

Spanish Chile

13

Spanish Uruguay

14

Spanish Paraguay

15

Spanish Bolivia

16

Spanish El Salvador

17

Spanish Honduras

18

Spanish Nicaragua

19
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Sublanguage

Decimal Code

Spanish Puerto Rico

20

Spanish United States

21

Spanish Latin America

57

Swedish Standard

1

Swedish Finland

2

Tamazight Berber

1

Tamazight Latin

2

Tigrigna Ethiopia

1

Tigrigna Eritrea

2

Tibetan Tibet

1

Tibetan Dzongkha

2

Urdu Standard

1

Urdu India

2

Uzbek Latin

1

Uzbek Cyrillic

2

LIST OF CODES FOR FIELD ATTRIBUTES IN PROJECTS
MATCH TYPES
Normal = 0
Exact = 1
Fuzzy = 2
Assembled = 4
Propagated = 8
AutoPropagated = 16
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SEGMENT STATUS
Finished = 256
Locked = 512
Pending = 1024
Stop = 2048
For the status, Déjà Vu X2 Professional uses the OR operator to combine the desired
components. For example, pending and locked is 1024 OR 512 which equals 1536.
To find the correct result using the OR operator, you can use the scientific view of the
Windows calculator (under Start> Programs> Accessories> Calculator)

WARNINGS
MultipleMatches = 65536
RenumberedMatch = 131072

ERRORS
WrongCodes = 16777216
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THE MENU COMMANDS AND TOOLBAR ICONS
Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

File Menu
New

Ctrl+N

Creates a project file, translation
memory, termbase, or SGML/XML
filter.

Open

Ctrl+O

Opens an existing project file,
translation memory, termbase, or
SGML/XML filter.

Close

Closes an open project file, translation
memory, termbase, or SGML/XML
filter.

Import

Imports a satellite project, a lexicon, or
an External View. It also gives access to
the Advanced Project Explorer.

You cannot import a source file
with this command.
Export

Exit

Exports a Pack & Go project, an
External View, a satellite project, a
lexicon, a project-specific subset of the
translation memories or termbases, or
the completed translation project.
Alt+F4

Closes the application.

Undo

Ctrl+Z

Undoes an unlimited amount of
actions.

Redo

Ctrl+Y

Redoes the previously undone action.

Cut

Ctrl+X
-orShift+Del

Cuts the selected text and sends it to
the clipboard.

Copy

Ctrl+C
-orCtrl+Insert

Copies the selected text and sends it to
the clipboard.

Edit Menu
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Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

Paste

Ctrl+V
-orShift+Insert

Pastes the content of the clipboard at
the mouse insertion point.

Delete

DEL

Deletes the selected text.

Select All

Ctrl+Shift+A

Selects all text within one cell.

Find

Ctrl+F

Searches for a specified character
string within the project or file.

Find Next

F3
-orShift+F4

Continues with the search for a
specified character string within the
project or file.

Replace

Ctrl+H

Replaces a specified character string
with another specified character string.

Change Case

Shift+F3

Changes the case of the selected text.

Join Segment

Ctrl+J

Joins the current segment with the
next.

Split Segment

Ctrl+I

Splits the current segment in two at the
mouse insertion point.

Segment Status

F6

Opens the Segment Status submenu,
which allows you to change the status
of a segment.

Comments

Opens the Comments submenu.

Navigate

Opens the Navigate submenu, which
gives you access to commands to
navigate within your project.

Insert Menu
AutoText>
AutoText

Ctrl+Shift+F3

Expands the preceding segment if
defined as AutoText.
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Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

AutoText>
Add Selection
to AutoText

Opens Add AutoText entry dialog for
the current target segment or
highlighted record within the target
segment.

AutoCorrect>
Add Selection
to AutoCorrect

Opens Add AutoCorrect entry dialog
for the current target segment or
highlighted record within the target
segment.

Populate>
Current
Language

Alt+F5

Copies all segments from source into
empty target cells in current language.

Populate>
Current
Segment

F5

Copies current source segment to
target.

Current
AutoSearch
Portion

Ctrl+R

Copies currently highlighted portion
from AutoSearch window to insertion
point in target cell.

Current
AutoSearch
Segment

Ctrl+E

Copies currently highlighted segment
from AutoSearch - Segments window
to insertion point in target cell.

View Menu
Project
Explorer

Opens the Project Explorer.

Advanced
Project
Explorer

Opens the Advanced Project Explorer.

Properties
Window

F4

Opens the Properties window

AutoSearch

Opens the AutoSearch window

Sort

Opens the Sort submenu to sort the
project alphabetically or naturally.
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Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

Filter

Opens the Filter submenu to filter the
project based on a selection in the
source or target column.

Toolbars

Opens the Toolbars submenu to open
or close the various toolbars.

Translation
Menu
Pretranslate

Ctrl+p

Pseudotranslation

Pretranslates the project in any one or
all languages within the project or the
current file.
Pretranslates the project with "dummy"
special characters of the particular
target language.

Scan

Ctrl+S

Scans for matches for the current
segment or selection in the translation
memory(s).

Scan with
Wildcards

Ctrl+Shift+S

Opens a windows that allows a scan
for matches in the translation
memory(s) with the help of wildcards.

Lookup

Ctrl+L

Looks for matches for the current
segment or selection in the
termbase(s).

Lookup with
Wildcards

Ctrl+Shift+L

Opens a windows that allows to look
for matches in the termbase(s) with the
help of wildcards.

Assemble

Ctrl+A

Assembles the current segment from
portions out of the lexicon, the
termbase(s), and the translation
memory(s).

Translate with
Google
Translate

Ctrl+G

Translates the current segment with the
help of the machine translation engine
Google Translate.

Add Pair to
Lexicon

F10

Adds current pair or current selection
in source and target to the lexicon.
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Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

Add Pair to
Translation
Memory

F12

Adds current pair or current selection
to the assigned translation memory.

Add Pair to
Termbase

F11

Adds current pair or current selection
in source and target to the assigned
termbase.

Propagate

Opens the Propagate submenu which
allows you to propagate the translation
of the current segment within the
current file or the complete project.

QA Menu
Batch QA
Validation

Ctrl+Q

Performs a batch process for all
enabled quality assurance processes.

Batch
Terminology
Validation

Ctrl+T

Performs a batch process to validate
terminology for inconsistencies
between the translation in the project
and the content in the lexicon, TMs,
and termbases.

Check
Terminology

Ctrl+F7

Jumps to the next segment with
terminology inconsistencies between
the translation in the project and the
content in the lexicon, TMs, and
termbases.

Check
Numerals

Ctrl+Shift+F7

Checks for inconsistencies between
the numbers in the source and target
fields.

Check
Embedded
Codes

Ctrl+Shift+F8

Checks for inconsistencies between
the embedded codes in the source and
target fields.

Fix Embedded
Codes

Ctrl+F8

Inserts the embedded codes found in
the current source segment at the end
of the current target segment.

Check Missing
Spaces

Checks for inconsistencies between
the spaces at the end of the segment in
the source and target fields.
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Command
Name
Next Multiple
Match

Keyboard
Shortcut
Ctrl+F3

Toolbar
Icon

Action
Jumps to the next segment with a
multiple match.

Next
Unfinished
Match

Jumps to the next segment with an
unfinished fuzzy match.

Next Pending
Match

Jumps to the next segment that is
marked as pending.

Next
Commented
Segment

Jumps to the next segment with a
comment.

Next Duplicate
Segment

Jumps to the next segment with a
duplicate segment.

Next Segment
in SQL Filter

Jumps to the next segments of a stored
SQL filter.

Next Warning

Ctrl+Shift+Q

Jumps to the next segment with a QA
warning

Delete All QA
Warnings

Deletes all QA warnings.

Accept All
Multiple
Matches

Accepts all multiple matches.

Project Menu
Import All
Exported
Translated
Project
Send Project to
Translation
Memory

Alt+F12

Adds the current or all files and the
current or all languages of the project
to the assigned translation memory.
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Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

Add

Opens the Add submenu with access
to the various items that can be
imported into the project.

Remove

Removes the item from the project that
is selected in the Project Explorer.

Rename

Renames the item in the project that is
selected in the Project Explorer.

(Re) Import

Imports or reimports the currently
opened file of the item in the project
that is selected in the Project Explorer.

Export
Translated File

Imports the currently opened file or
the file in the project that is selected in
the Project Explorer.

Lock File

Locks the currently opened file or the
file in the project that is selected in the
Project Explorer.

Unlock File

Unlocks the currently opened file or
the file in the project that is selected in
the Project Explorer.

Find Duplicate
Segments

Opens the Find Duplicate Segments
dialog with options to detect
duplicates in source and/or target
segments.

Unmark
Duplicate
Segments

Unmarks any segments that were
previously marked as duplicates.

Execute SQL

Opens the Execute SQL dialog in
which you can enter any SQL
commands to manage your projects,
translation memories, or termbases.

Properties

Opens the Project Properties dialog
with access to general, languages,
filters, user, and databases
configuration options for the current
project.
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Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

Lexicon Menu
Build Lexicon

Opens the Build dialog to generate a
lexicon.

Remove Entries

Opens the Remove lexicon entries
dialog to remove records from a
lexicon.

Resolve with
Translation
Memory

Leverages the content from the
associated translation memories to
translate lexicon records.

Resolve with
Termbase

Leverages the content from the
associated termbases to translate
lexicon records.

Resolve with
DeepMiner

Leverages the content available
through the DeepMiner feature to
translate lexicon records.

Send to
Translation
Memory

Opens the Send to Translation
Memory dialog to send lexicon records
to the associated translation memories.

Send to
Termbase

Opens the Send to Termbase dialog to
send lexicon records to the associated
termbase(s).

Users Menu
Login

Opens the User Login dialog to log in
to the current project.

Logout

Logs the current user out of the current
project.

You do not have to log out to
log in under a different user
name.
Tools Menu
Spelling

F7

Checks the spelling of the target in the
current language in the current or all
files.
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Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

Word Count

Ctrl+W

Opens the Word Count dialog with
several options to count words and
characters in the current or all files.

Analyze

Ctrl+Shift+W

Opens the Analysis dialog with options
for project analysis, including internal
repetition and number of translation
memory matches.

Character Map

Ctrl+K

Opens the Windows Character Map.

User Interface
Language

Opens the User Interface Language
dialog to change the language of the
program.

Convert

Imports Déjà Vu 2 or 3 termbases and
memory databases.

Compact

Compacts a project, satellite,
translation memory, termbase, or
SGML/XML filter.

Repair

Repairs a project, satellite, translation
memory, or termbase.

Options

Opens the Options dialog with access
to general, delimitation, spelling,
subject, client, AutoText and display
options.

Customize

Opens the Customize dialog with
access to several options to customize
the appearance of menus and toolbars.

Window Menu
New
Horizontal Tab
Group

Arranges tabs in a horizontal manner.

New Vertical
Tab Group

Arranges document windows in a
vertical manner.
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Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

Close All
Windows

Closes all open windows.

Reset Windows
Layout

Resets the layout of all tabs and
windows to the default setting.

Help Menu
Contents

Opens the HTML Help system.

Index

Opens the index of the HTML Help
system.

Search

Opens the search feature of the HTML
Help system.

Activate

Opens the Activation dialog for
activating a non-dongle.secured
version of Déjà Vu.

About

Displays Déjà Vu version and build
information as well as copyright
information.
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TRANSLATION MEMORY-SPECIFIC MENU COMMANDS
Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

File Menu
Import

Imports an external database in a
variety of formats or opens the
Alignment Wizard with access to Déjà
Vu’s alignment feature.

Export

Exports to an external database in a
variety of formats and gives access to
filtering functions.

Database Menu
Properties

Opens the Translation Memory
Properties dialog with access to general
and user configuration options.

TERMBASE-SPECIFIC MENU COMMANDS
Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

File Menu
Import

Imports an external glossary in a variety
of formats.

Export

Exports to an external glossary in a
variety of formats and gives access to
filtering functions.

Database Menu
Properties

Opens the Termbase Properties dialog
with access to general, user, relations,
attributes, and categories options.

SGML/XML FILTER-SPECIFIC MENU COMMANDS
Command
Name

Keyboard
Shortcut

Toolbar
Icon

Action

File Menu
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Command
Name

Keyboard
Shortcut

Import

Toolbar
Icon

Action
Imports an SGML or XML file or data
from another SGML/XML filter file.

Edit Menu
Delete All Tags
and Attributes

Deletes all tags and attributes from the
SGML/XML filter file.

Delete All
Entities

Deletes all entities from the SGML/
XML filter file.

Delete All
Examples

Deletes all examples from the SGML/
XML filter file.

THE KEYBOARD SHORTCUTS
The following pages contain a complete list of keyboard shortcuts that are available by default
within Déjà Vu X2 Professional. It is important to keep in mind, however, that all keyboard
shortcut associations can be reconfigured. For more information on this, see "Keyboard Shortcuts"
on page 25.
Command Name

Keyboard Shortcut

Open File

Ctrl+O

New File

Ctrl+N

Exit Déjà Vu X2

Alt+F4

Help

F1

Copy

Ctrl+C or Ctrl+Ins

Copy All Codes

Alt+F8

Copy Next Code

F8 or Ctrl+D

Delete

Del

Delete Codes

Ctrl+Space

Delete Codes and Text

Ctrl+Space

Paste

Ctrl+V or Shift+Insert

Undo

Ctrl+Z
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Command Name

Keyboard Shortcut

Redo

Ctrl+Y

Select All

Ctrl+Shift+A

Find

Ctrl+F

Find Next

F3 or Shift+F4

Replace

Ctrl+H

Select All

Ctrl+Shift+A

Pretranslate

Ctrl+P

Assemble

Ctrl+A

Translate with Google Translate

Ctrl+G

Scan

Ctrl+S

Scan with Wildcards

Ctrl+Shift+S

Lookup

Ctrl+L

Lookup with Wildcards

Ctrl+Shift+L

Check Embedded Codes

Ctrl+Shift+F8

Fix Embedded Codes

Ctrl+F8

Check for Multiple Exact Matches

Ctrl+F3

Check Terminology (Single Segment)

Ctrl+Shift+T

Check Terminology Batch

Ctrl+T

Find Next Number Mismatch

Ctrl+Shift+F7

Batch QA Validation

Ctrl+Q

Find Next Terminology Mismatch

Ctrl+F7

Change Case

Shift+F3

Expand AutoText entry

Ctrl+Shift+F3

Display Code

Shift+F6
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Command Name

Keyboard Shortcut

Do Not Send to Translation Memory

Ctrl+Shift+D

Split Segments

Ctrl+I

Join Segments

Ctrl+J

Swap Current and Next Words

Ctrl+Shift+N

Swap Previous and Current Words

Ctrl+Shift+B

Lock/Unlock Segments

Ctrl+Shift+K

Pending

Ctrl+Shift+P

Reset Segment Status

Ctrl+Shift+U

See in Context

F6

Analyze

Ctrl+Shift+W

Character Map

Ctrl+K

View Properties

F4

View Project Explorer

Ctrl+Alt+L

Spelling

F7

Word Count

Ctrl+W

Go to the Beginning of Table

Ctrl+PgUp

Go to the End of Table

Ctrl+PgDn

Go to Next Segment

Ctrl+DownArrow

Go to Next Segment (No AutoFeatures)

Alt+RightArrow

Go to Next Segment (Overwrite Propagated
Segments)

Alt+Ctrl+DownArrow

Go to Next Untranslated Segment

Alt+DownArrow

Go to Previous Segment

Ctrl+UpArrow

Go to Previous Segment (no AutoFeatures)

Alt+LeftArrow
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Command Name

Keyboard Shortcut

Go to Previous Untranslated Segment

Alt+UpArrow

Go to Next Portion (AutoSearch)

Ctrl+Shift+DownArrow

Go to Next Segment (AutoSearch - Segments)

Alt+Shift+DownArrow

Go to Previous Portion (AutoSearch)

Ctrl+Shift+UpArrow

Go to Previous Segment (AutoSearch Segments)

Alt+Shift+UpArrow

Insert AutoSearch Portion (Insert)

Ctrl+1...n

Insert AutoSearch Portion (Overwrite)

Ctrl+Shift+1...n

Insert Current AutoSearch Portion (Insert)

Ctrl+R

Insert Current AutoSearch Portion (Overwrite)

Ctrl+Shift+R

Insert Current AutoSearch Segment (Insert)

Ctrl+E

Insert Current AutoSearch Segment (Overwrite)

Ctrl+Shift+E

Populate All Languages

Ctrl+Alt+F5

Populate Current Language

Alt+F5

Populate Current Segment

F5

Populate Current Segment (Insert)

Ctrl+F5

Propagate in Current File

F9

Propagate in Current File (Overwrite)

Shift+F9

Propagate to All Files

Alt+F9

Propagate to All Files (Overwrite)

Alt+Shift+F9

Delete Comment

Ctrl+Shift+M

Add Comment

Ctrl+M

Next Bookmark

F2

Previous Bookmark

Shift+F2
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Command Name

Keyboard Shortcut

Toggle Bookmark

Ctrl+F2 or Ctrl+B

Add Pair to Lexicon

F10

Add Pair to Termbase

F11

Add Pair to Termbase (No Prompt)

Shift+F11

Add Pair to Translation Memory

F12

Add Project to Translation Memory

Alt+F12

GLOSSARY
Advanced Project Explorer
A Windows Explorer-like interface from which you can import, export, or delete any supported file
or folder in and out of your project. The Explorer is also accessed from within the main
Déjà Vu X2 Professional interface.

alignment
Alignment is the process by which existing )source and (translated) )target documents are
matched up to build or add to a )translation memory.

alphabetic order
Refers to the order of )source )segments within a )project file. In alphabetic order, segments
are sorted by alphabet, as opposed to the )natural order, where they are sorted according to
their occurrence in the )source text.

antonym
A word with the opposite meaning (compare )synonym).

assemble
When )scanning does not find a )match, you can ask Déjà Vu X2 Professional to assemble a
translation from smaller pieces found in the project )lexicon, )termbases, and the )translation
memories (in this order if the similarity and other properties are equal).
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attribute
In HTML, SGML, and XML, an attribute is a definition within a )tag that may or may not have to
be translated. A well-known translatable example is the alt attribute within an <IMG> tag (<IMG
alt="Atril Software" border=0 src="/atril.jpg">).

AutoAssemble
The process in which Déjà Vu X2 Professional automatically )assembles a translation from
smaller pieces that can be found in the project )lexicon, )termbase, and )translation memory
(in this order). You can activate AutoAssemble and its options under Tools> Options>
Environment.

AutoCorrect
AutoCorrect is comparable to the AutoCorrect option of Microsoft Word. Its purpose is to correct
common spelling mistakes (for instance, "segement" to "segment" or "Deja Vu" to "Déjà Vu"). See
also )AutoText.

AutoPropagate
The process in which Déjà Vu X2 Professional automatically )propagates a translation to the
same segment within the )project file. You can activate AutoPropagate under Tools> Options>
Environment.

AutoSearch
The process in which Déjà Vu X2 Professional automatically )scans the )translation memories
for the current segment, and searches the translation memories, )termbases, and the project
)lexicon for any portions of the segment. You can activate AutoSearch and its options under
Tools> Options> Environment.

AutoSend
The process in which Déjà Vu X2 Professional automatically sends a finished )segment pair to
the )translation memory once you are done with the translation. You can activate AutoSend
under Tools> Options> Environment.

AutoText
AutoText is comparable to the AutoText option of Microsoft Word. Its purpose is to save typing
effort by expanding abbreviations into longer text (for instance, "DV" to "Déjà Vu"). See also
)AutoCorrect.
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AutoWrite
AutoWrite suggests content from your databases as you type. The suggestions will be displayed
right underneath your cursor. You only have to press the Enter button to accept.

batch processes
Procedures that process many files simultaneously. This is one of the core competencies of
Déjà Vu X2 Professional.

bookmarks
Déjà Vu X2 Professional allows you to set a bookmark to mark a position in a project so that you
can later easily locate certain segments.

case sensitive
The ability to distinguish between uppercase (capital) and lowercase (small) letters. Programs or
features that distinguish between uppercase and lowercase are said to be case sensitive. For
instance, if you enter atril to search for Atril in a case-sensitive feature, the program would not find
it.

CAT
CAT (Computer-Aided Translation) is a term used to classify a wide variety of software tools that
are employed to assist translators in their work, either in consistency, speed, or simply workload.
Some definitions include machine translation tools in the CAT category, while others consider CAT
to be exactly equivalent to translation memory tools.

comments
Comments are fields in the source or target segment to which you can add comments or questions
for your own or someone else’s review.

date stamp
A date stamp in a database record is the field that defines the date on which the record was
created or modified (compare )time stamp).

Déjà Vu X2

564

Glossary

DeepMiner
The unique DeepMiner analyzes the attached databases and comes up with sub-segment matches
to give you every last bit of information from the databases and allow you to enhance Déjà Vu X’s
fuzzy match repair.

delimitation rules
Delimitation rules are the rules by which Déjà Vu X2 Professional determines how text in a
specific language should be segmented. You can change or add default delimitation rules so that
they correspond to your specific language and the style of the author of your source documents.
The delimitation rules allow you to specify for each language what rules are to be used as well as
the exceptions to these rules. You can access the delimitation rules by selecting Tools> Options>
Delimiters.

delimiter
A punctuation character or group of characters that separates two pieces of data, or marks the
beginning or end of a piece of data. Déjà Vu X2 Professional uses delimiters in defining
)delimitation rules and in database import and export processes.

demo mode
You can work with Déjà Vu X2 Professional’s demo mode, but with some restrictions that make it
impossible to use in an actual production process.

dockable
Dockable windows are windows that align themselves with the edge of another interface element,
usually a window or a pane. In Déjà Vu X2 Professional, dockable windows can be placed
anywhere on the desktop. See also )tool windows.

Document window
A window that has to stay within the main window and is subject to the commands in the Window
menu. In Déjà Vu X2 Professional this includes all the main grids, including )project files,
)termbases, )translation memories, )Pack & Go packages, and )SGML/XML filter. See also
)tool window.

dongle
Déjà Vu X2 Professional employs a hardware key that acts as a protection device. The dongle has
to be connected to either your )parallel port or )USB port to fully activate the software.
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DTD
Document Type Definition file used by SGML and XML to define mark-up languages.

embeddable tags
An embeddable tag in Déjà Vu X2 Professional’s SGML/XML filter is a tag that can appear in the
middle of a segment which should not be split before or after this tag. For example, the <B> and
<I> tags in HTML (which specify bold and italic attributes) are embeddable, while the <P> tag
(which specifies a paragraph change) is not.

embedded code
When working with file types other than plain text, Déjà Vu X2 Professional only displays
translatable text—everything else is hidden. However, in )formats such as HTML, FrameMaker,
or Word, formatting information is often embedded within a )segment, such as a particular word
in bold, cursive, or small caps. Because Déjà Vu X2 Professional cannot automatically decide
which formatting belongs to which word, it lets the translator decide where to place this formatting
information. These are "embedded codes." If you have created a Déjà Vu X2 Professional project
for HTML, for example, you will probably have noticed that many segments contain embedded
codes such as {142} or {835}.

exact match
An exact )match (also: perfect match) is the perfectly identical equal match of a stored )source
)segment in the translation memory (often ignoring any formatting information that may be
stored with it) with the segment being sought.

External View
The External View format is a format specifically created for proofing or checking unresolved issues
outside of Déjà Vu X2 Professional. This allows you to export translated and commented rows
into a Word, HTML, Trados RTF or XLIFF format in which proofing can be performed and
outstanding questions can be answered.
The main benefit of these formats is that they can be used across platforms and thus even by
people who could not install a copy of Déjà Vu X2 Professional.
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extractable attributes
While most SGML attributes are not translatable, some may be translatable, and must therefore be
extracted. For example, the <IMG> tag in HTML (which inserts an image into the text) has the
ALT=“[alternate text for the image]” attribute, which specifies the text to display if
the browser cannot load the image. This text should be translated, so the attribute is extractable.

extractable text
Extractable text between tags refers to text between certain SGML/XML tags that should be
extracted, i.e., translated, or not. Users have the option to define this property in Déjà Vu X2
Professional’s SGML/XML filter.

format
Format is the term that is used to describe different file formats, such as Word, HTML, or
FrameMaker.

format filters
Déjà Vu X2 Professional uses different rules to separate non-translatable code and translatable
text for different )formats. These rules are sometimes referred to as format filters.

fuzzy match
A fuzzy match is a )source segment that only partially matches the segment being sought.

guaranteed match
A guaranteed match is an )exact match for which Déjà Vu X2 Professional has also checked that
the surrounding segments match, thus greatly increasing the likelihood of its accuracy.

hard return
A hard return, also called carriage return or paragraph marker, is an actual symbol inserted into
text that separates one paragraph from the next, usually inserted by the Return or Enter key. In
most programs you can view the hard return as the symbol "¶" (compare )soft return).

lemma
A word or phrase.
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lexicon
The )project file’s lexicon is an optional project-internal list of all the source language words or
phrases present in the project—in other words, an index of all terms and phrases. Once you have
translated this list, it will be used by Déjà Vu X2 Professional as the primary glossary for your
project. You can build and manage the lexicon by selecting Project> Lexicon.

lookup
Refers to search processes in the )termbases. See also )scan.

machine translation
MT (machine translation, often called automatic translation) systems are those that use linguistic
information about the languages being translated to automatically generate translations.

match
A match is a bilingual record of a segment or term whose source is identical or similar to the
)source in the )project file.

natural order
In Déjà Vu X2 Professional, the natural order refers to the original order of segments in the
)source document (compare )alphabetic order).

ODBC
Open DataBase Connectivity is a standard database access method developed by Microsoft
Corporation. The goal of ODBC is to make it possible to access any data from any application,
regardless of which database management system (DBMS) is handling the data. ODBC manages
this by inserting a middle layer, a database driver, between an application and the DBMS. The
purpose of this layer is to translate the application's data queries into commands that the DBMS
understands. For this to work, both the application and the DBMS must be ODBC-compliant—
that is, the application must be capable of issuing ODBC commands and the DBMS must be
capable of responding to them.

parallel port
Also called printer port. An interface for connecting an external device such as a printer. On PCs,
the parallel port uses a 25-pin connector and is used to connect printers, computers, and other
devices. Déjà Vu X2 Professional connects a )dongle to the parallel or )USB port to activate
the program.
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pending
Déjà Vu X2 Professional allows you to mark questionable rows as pending so that you or
someone else can come back at a later time to finish or review these rows.

perfect match
See )exact match.

populate
A process by which either a single segment or all segments of one language pair are copied over
from )source to )target in the )project file. The populate commands are available from the
Insert menu.

pretranslate
The process in Déjà Vu X2 Professional that allows you to )batch leverage the content of your
databases—translation memory(s), termbase(s), and (optionally) the lexicon—against your
)source files.

primary window
A window type to which you can assign a distinct font. Includes the )project files, )translation
memories, or )termbases (the primary windows). See also )secondary window.

Pack & Go packages
Pack & Go packages are highly compressed exports from project files that are ideal for the
transmission of Déjà Vu X2 Professional data. The Pack & Go feature is available as a stand-alone
feature for the transfer of complete projects, or as part of the satellite creation for the transfer of
even smaller bilingual satellite projects.

Project Explorer
In a project file, a small pane on the right of your screen that displays all the files in your project so
you can easily switch from one file to the next.

project file
Also called translation file. The .dvprj file that contains all )source files and the )lexicon, and in
which all translation processes are performed.
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propagate
The process by which Déjà Vu X2 Professional applies a translation to the same or similar
segments within the project file after you have translated a segment. The propagate options are
accessible through the Translation menu. See also )AutoPropagate.

Properties window
A window with import-specific options that appears when selecting files for import in the
)Advanced Project Explorer.

Pseudotranslation
Pseudotranslation is a process in which a "dummy" translation with target-language-specific
characters is performed and the length of the target text is increased by about 20% of the source.
This is done to allow for some functional testing on the exported file in its original format.

reflexive
One of the three most basic relationships in a relational database model (compare )symmetric
and )transitive). A reflexive relationship is a relationship that is valid for itself. For example, a
translation relation cannot be reflexive, because a term is usually not translated with the very same
term. A synonym relation is reflexive, however, because every term is also a synonym of itself. An
antonym by definition cannot be reflexive, because a term cannot be its own opposite.

regular expressions
Any legal combination of symbols that represents a value and that you can employ to
communicate with certain features of an application. Each programming language and application
has its own rules for what is legal and illegal. The scripting language that Déjà Vu X2 Professional
uses is VBScript. For more information on VBScript, see the MSDN library at http://
msdn.microsoft.com/library.

satellite files
A satellite file is an export from a project file that contains only one source and one target language
(as opposed to a full project file, which typically consists of the source language plus a number of
target languages) with all the information needed by the translator. This information can exclude
the formatting and image code, thus significantly reducing the file size and making it easier to
transmit. A satellite file restricts the translator from performing any task that would have an effect
on all the target languages, such as deleting files, splitting/joining rows, editing the source, or
locking/unlocking rows.
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scan
Refers to search processes in the translation memories. See also )lookup.

secondary window
A window type to which you can assign a distinct font. Includes the AutoSearch, )lookup, or
)scan windows. See also )primary window.

security
Security settings define user roles with different levels of access in Déjà Vu X2 Professional. The
three major different roles are project owner, administrator, and various levels of language users.
Project owners have access to all possible functions, administrators do not have the ability to
disable the project security features, and users have different levels of language-specific sets of
rights.

Segment Selector
The second of three record selectors in the )selector row in a )project file. You can use the rows
selector to filter and display only certain kinds of rows, e.g., )exact match

selector row
The row with the three record selection fields on the top of a project file. See )Text/Record
Locator, )satellite files, and )Target Language Selector.

segment
Any segment that is delimited by either a punctuation mark (such as a full stop or a question mark)
or by any other means of separation (such as the end of a paragraph, heading, or table cell).

SGML
SGML stands for the Standardized General Markup Language. It is the result of generalizing and
then standardizing a number of Rich Text Formats (RTF) developed for word processing software
on personal computers by the International Organization for Standardization (ISO) in 1986.
SGML is actually a metalanguage used to define mark-up languages. The definitions are called
Document Type Definitions or DTDs.
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SGML/XML filter
A file used when translating files that follow the )SGML definition. Because each SGML file or
group of SGML files is unique, a unique filter must be created for each of them. You can do that by
having Déjà Vu X2 Professional either analyze the SGML files or read the )DTD file.

soft return
A marker that forces a line break without starting a new paragraph, usually inserted by a key
combination such as Shift+Enter (compare )hard return).

source
Refers to the language or segment that is being translated. See also )target.

SQL
Structured Query Language is the most commonly used language to communicate with databases.

symmetric
One of the three most basic relationships in a relational database model (compare )reflexive and
)transitive). In a symmetric relationship, the relationship of A to B is also true of B to A. This is the
classical translation relationship: if term A is the translation of term B, then term B is also the
translation of term A. Synonym and antonym relations are symmetric relationships as well.

synonym
A word with the same or similar meaning (compare )antonym)

tag
A tag is an element in )SGML, )XML, or HTML that allows for the structuring of the content,
page layout, text formatting, insertion of images, etc. Tags are typically enclosed in <angled
brackets>. Internal tags, such as the <b>bold<\b> tag, are embedded in segments, whereas
external tags, such as the <p>paragraph<\p> tag, are located outside segments.

target
The target language or segment in which the translation is being conducted. See also )source.
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Target Language Selector
The third of three record selectors in the )selector row in a )project file. You can use the
selector to switch between the different )target languages that you may have in your project.

templates
Files in XML format with the extension .dvtdt (Déjà Vu termbase template) that are located in the
\Templates folder within your Déjà Vu X2 Professional installation directory (by default
C:\Program Files\Atril\Deja Vu X\Templates on an English Windows installation).
These files define what kind of relations, attributes, and categories your termbase will have.

termbase
Multilingual files that contain pairs of terms or short expressions (source and target) which you
have added. Each pair is associated by additional information that is freely configurable.

Text/Record Locator
The first of three record selectors in the )selector row in a )project file. You can use the selector
to enter the number of the project line you would like to jump to (in the )natural order), or any
combination of letters at the beginning of the segment that you would like to jump to (in
)alphabetic order).

TMX
Translation Memory eXchange is an XML-based standard for data exchange between memory
databases.

tool window
Windows that are freely )dockable, i.e., that can be placed anywhere outside the main window
on your desktop and be subject to the standard docking features. In Déjà Vu X2 Professional,
these windows include the )format, the )AutoSearch window, the )Properties window, or any
of the toolbars. See also )Document window.

time stamp
A time stamp in a database record is the field that defines at what time the record was created or
modified (compare )date stamp).
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transitive
One of the three most basic relationships in a relational database model (compare )symmetric
and )reflexive). In a transitive relationship, the relationship from A to B and A to C is the same as
that of B to C. Translations from language A to B are not transitive (the German translation of the
English term "file" can be either "Datei" or "Akte"; however, "Datei" is not the translation of "Akte"),
nor are synonyms (though "square" is the synonym for both "four-sided figure" and "plaza," "plaza" is
not a synonym for "four-sided figure") or—by the same logic—antonyms.

translation memory
The files that store all previously translated segments (segments, headings, cell content, bullet
points, etc.) in source and target. This file is multilingual, i.e., it can have several target languages.

wildcard
A special symbol that stands for one or more characters. Used to widen the scope of searches in
)scan processes.

XML
XML—eXtensible Markup Language—has been developed by the World Wide Web Consortium
as an alternative to HTML, which was not sophisticated enough for the creation of interactive
content, and SGML, which proved to be too complex for web applications. Much like SGML, XML
is a metalanguage to enable users to create their own markups in Document Type Definition
(DTD) files.

Unicode
A standard for representing characters as integers. Because it is possible to represent all characters
of all known languages with Unicode, there is no need for different character sets between
languages anymore. Déjà Vu X2 Professional deals with two different Unicode encoding
schemes, UTF-8 and UTF-16.
UTF-8 is an 8-bit encoding scheme. Most characters from Western-language alphabets are all
encoded using a single byte, whereas characters for other languages are encoded using 2, 3, or
even 4 bytes. UTF-8 therefore produces compact documents for Western languages, but for other
languages, documents tend to be half as large as they would be if they used UTF-16.
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UTF-16, a 16-bit encoding scheme, is large enough to encode all the characters from all the
alphabets in the world. It uses 16-bits for most characters, but includes 32-bit characters for
ideogram-based languages like Chinese. A Western-language document that uses UTF-16 will be
twice as large as the same document encoded using UTF-8. But documents written in most Asian
languages will be far smaller using UTF-16.

USB
Universal Serial Bus is an external bus standard that supports data transfer rates of 12 Mbps. A
single USB port can be used to connect up to 127 peripheral devices, such as mice, modems,
keyboards, and )dongles.
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Filter 550
Find 548
Find Duplicate Segments 553
Find Next 548
Fix Embedded Codes 551
Import 547, 553, 557, 558
Import All 552
Index 556
Insert Current AutoSearch Portion 549
Insert Current AutoSearch Segment 549
Join Segments 548
Lock File 553
Login 554
Logout 554
Lookup 550
Lookup with Wildcards 550
Navigate 548
New 547
New Horizontal Tab Group 555
New Vertical Tab Group 555
Next Commented Segment 552
Next Duplicate Segment 552
Next Multiple Match 552
Next Pending Match 552
Next Segment in SQL Filter 552
Next Unfinished Match 552
Next Warning 552
Open 547
Options 555
Paste 548
Populate All Languages 549
Populate Current Language 549

Pretranslate 550
Project Explorer 549
Properties 553, 557
Properties window 549
Pseudotranslation 550
Redo 547
Reimport 553
Remove 553
Remove Entries 554
Rename 553
Repair 555
Replace 548
Reset Windows Layout 556
Resolve with Termbase 554
Resolve with Terminology Database 554
Resolve with Translation Memory 554
Scan 550
Scan with Wildcards 550
Search 556
Segment Status 548
Select All 548
Send Project to Translation Memory 552
Sort 549
Spelling 554
Split Segments 548
Toolbars 550
Translate with Google Translate 550
Undo 547
Unlock File 553
Unmark Duplicate Segments 553
User Interface Language 555
Word Count 555
commands
SGML/XML filter-specific 557
termbase-specific 557
translation memory-specific 557
Comment
icon 253
comment
delete 255
delete all 255
edit 255
review 254
Comments
command 548
comments
add 252
definition 564
use 252
view all rows with comments 254
Word 304
common Windows functions 229
communicating
with databases 105
Compact
command 555
compact
project file 136
reasons 136
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satellite file 136
SGML filter file 136
termbase 136
translation memory 136
compact database 136
complete project
select 59
view 59
compound words
spelling option 238
concept
lexicon 377
concordance search. See scan
conditional change
dictionary 241
conditional change-preserve case
dictionary 241
configuration access
security restriction 273
Configure
command 557
Confirm Fuzzy Propagation
dialog 199
confirmation dialog
delete files 75
consistency checks
embedded codes 122
numbers 120
spaces 122
terminology 120
translations for duplicate source 123
Contents
command 556
context view 210
definition 211
format limitations 211
contracted words
spelling option 237
control leading and trailing symbols
option 213
conversion
case 213
decimal 213
punctuation marks 213
spaces 213
conversions 211
acronyms 211
embedded codes 211
numbers 212
options 212
settings 212
Convert
command 555
convert Déjà Vu 2/3
termbase 482
Convert Hard to Soft Spaces
FrameMaker import 315
Convert v2.x/3.x Memory Database
dialog 417

Convert v2.x/3.x Terminology Database
dialog 482
Copy
command 547
keyboard shortcut 558
copy
all segments 214
AutoSearch record 109
embedded codes 206, 207, 208
single segments 214
standard features 213
Copy All Codes
command 207
keyboard shortcut 558
uses 207
Copy Next Code
command 207
keyboard shortcut 558
CopyFlow
special discounts 327
count
characters 279
codes 279
words 279
create
External View 263
new dictionary 242
project 85
project file 85
create on a template
project 91
project file 91
creating
translation memory 400
Criter
template 457
Ctrl+DownArrow
AutoAssemble 60
AutoPropagate 60
AutoSend 60
current file
status bar 51, 59
current record
position 51
current row
check terminology mismatch 119
indicator 30
custom dictionaries 238
Customize
command 555
dialog 26, 27
customize
keyboard shortcuts 26
toolbars 27
Cut
command 547
cut
standard features 213
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D
Database
menu 557
database formats
source file 80
database lookups
options 138
Databases
tab (Project Properties dialog) 261, 405, 468
databases
adding additional information 174
adding records 111
automatically communicating with 105
challenge of translation 311
compact utility 136
data exchange 136
feeding 111
fuzziness setting 138
lookup 139
Microsoft Jet 135
minimum score 139
newer matches 139
overview 135
performance 135
repair utility 136
scan 139
sending text 169
SQL 136
TMX import 136
date last exported
file details 76
date last imported
file details 76
date modified
file details 76
date stamp 174
definition 564
field in databases 174
decimal conversion 213
DeepMiner
glossary 565
various uses 153
DeepMiner and assemble 155
DeepMiner Engine
explanation 152
default font 56
definition
bookmarks 564
embeddable tags 566
External View 566
extractable attributes 567
extractable tags 567
ODBC 568
Pack & Go packages 569
pending 569
satellite files 570
security 571
Unicode 574
USB 575

UTF-16 574
UTF-8 574
Déjà Vu
toolbox 10
Déjà Vu 2/3
terminology database import 475
translation memory conversion 417
translation memory import 411
Déjà Vu 3
import clients 181
import sentence delimiters 218
import subjects 192
Déjà Vu user group 17
Déjà Vu X2
analysis features 277
new features 19
Déjà Vu X2 alignment file 21
Déjà Vu X2 codes. See embedded codes
Déjà Vu X2 nterface 21
Déjà Vu X2 project files 21
Déjà Vu X2 SGML/XML filter 21
Déjà Vu X2 termbases 21
Déjà Vu X2 translation features 135
Déjà Vu X2 translation memory 21
Déjà Vu X2 workflow 77
Déjà Vu X2’s quality assurance feature 114
Delete
command 548
keyboard shortcut 558
delete
all embedded codes 208
comment 255
embedded codes 208
single embedded code 208
whole segment 208
delete all
comments 255
Delete All Entities
command 558
Delete All Examples
command 365, 558
Delete all pairs previously sent from this project
command 171
Delete All QA Warnings
command 552
Delete All Tags and Attributes
command 558
Delete all Terminology Warnings
command 118
Delete Codes
command 208
keyboard shortcut 558
Delete Codes and Text
keyboard shortcut 558
Delete Comment
keyboard shortcut 561
delete data
AutoSearch window 173
delete files 75
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confirmation 75
satellite files 262
security restriction 273
with Advanced Project Explorer 75
deleting term
termbase 501
delimitation
incorrect 218
sentences 215
delimitation rules
definition 565
delimiter
definition 565
Delimiters
tab (Options dialog) 216
demo mode
definition 565
desktop publishing formats
source file 80
Dictionaries
dialog 240
dictionaries
add existing 243
add to from AutoSearch window 38
add words 239
automatic change 240
automatic change-preserve case 241
conditional change 241
conditional change-preserve case 241
create 242
custom 238
default path 242
default setting 239
definition 238
exclude 241
ignore 241
spell checking 238
use of new 243
userdic.tlx 240
dictionary
export 247
import 244
digits
in propagate 197
Display
tab (Options dialog) 57
Display Code
command 209
keyboard shortcut 559
display portions from tranlation memory
command 35
Do Not Send
command 172
remove status 172
symbol 172
Do Not Send to Translation Memory
keyboard shortcut 560
dockable
definition 565

docking
disable 53
tool window 53
document window
definition 51, 565
Window menu 52
documentation
related 17
dongle
definition 565
dongle. See Getting Started Guide
doubled words
spelling option 237
down one screen
move 61
dragging files
Project Explorer 82
DTD
definition 566
use in SGML 355
use in XML 355
DTP formats
source file 80
duplicate rows
displaying 124
indicator 41
duplicate segments
unmark 125
Duplicates Only view
translation memory 399
Dutch
user interface language 23

E
Edit
menu 547, 558
menu options 23
edit
comment 255
edit box
translating in 31
edit mode 30
switch into 31
edit source
satellite files 262
security restriction 273
Edit Term
dialog 501
edit vs. selection mode 30
editing phase 114
editing term
termbase 500
embeddable tag
SGML/XML 355
embeddable tags
definition 566
Embedded Code
dialog 209
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embedded code
definition 566
joining/splitting segments 220
embedded codes 202
across formats 204
across tags 204
assemble 150
automatically copying all 207
automatically fixing 207
consistency checks 122
conversions 211
copying 206
copying automatically 207
definition 202
deleting 208
deleting all 208
deleting single 208
drawbacks of modifying 210
example 202
in propagate 197
manually copying 208
modifying 209
moving 206
moving from source to target 208
positioning 205
problems when reversing 205
protection 209
relative positioning 205
relevance 202
safety features 206
encoding
HTML 335
InDesign 330
PageMaker 324
SGML/XML 341
text files 332
end of file
jump to 61
end rule. See sentence delimitation
English
user interface language 22
entire project
view 59
entities
adding for SGML/XML filter 367
Entities and Characters (SGML/XML)
tab 366
Environment
tab (Options dialog) 35, 105
Eurodicautom
template 456
exact match
definition 566
Excel
description of export 442, 491
file formats 307
import options 307, 309
installation requirements 307
joining lines 308

location of original files 307
splitting lines 308
termbase export 490
termbase import 475
translation memory export 435
translation memory import 411
v. 95 vs. later versions 435, 490
Excel 2003 and below
support 307
exclude
dictionary 241
exclude files
folder import 69
Exclude Strings Heuristically
command 345
Execute SQL
command 527, 553
submenu 528
execute SQL
security restriction 273
existing project file
select 81
existing translation
aligning 79
import 79
Exit
command 547
Exit Déjà Vu X2
keyboard shortcut 558
Expand AutoText
keyboard shortcut 559
Explorer. See Advanced Project Explorer
Explorer. See Project Explorer
Export
command 547, 557
export 130
entire folder 72
files from project 130
folder structure 75, 132, 134
from lexicon 382
selecting several items 72
spelling dictionary 247
export data
security restriction 273
Export External View
dialog 263
export files 72
with Advanced Project Explorer 72
with menu command 131, 132
Export Finished Translation
command 132
export folder 75, 132, 134
export for proofing 129
Export Options
dialog 74, 131, 133
export options 74
BIF 352
FrameMaker 317
HTML 131, 133, 335
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SGML/XML 131, 133, 341
TagEditor 352
TMX 354
TTX 352
Word 302
export path
file details 76
Export Project
command 131
Export source comments as conditional text
command 317
Export source comments as Office comments
command 303
Export source comments as pop-up text
command 335
Export target comments as conditional text
command 318
Export target comments as Office comments
command 303
Export target comments as pop-up text
command 336
Export Translated File
command 553
Exported Translated Project
command 552
exporting
prompt for mising spaces 132
exporting data
termbase 488
translation memory 434
Exposable Markers
FrameMaker import 315
external databases
Access database 78
Déjà Vu 2/3 memory database 78
Déjà Vu X2 translation memory 78
Excel format 78
formats 78
IBM TM2 78
origin 78
SDLX 78
text files 78
TMX 78
Trados Workbench 78
external glossaries
Access 79
Déjà Vu 2/3 terminology databases 79
Déjà Vu X2 termbases 79
Excel files 79
formats 79
MultiTerm 79
origin 79
text files 79
External View
creating 263
definition 262, 566
export segments with comments 265
export translated segments 268
merge options 271

purposes 262
reimport 270
External Views 262
extractable attribute
SGML/XML 356
extractable attributes
definition 567
extractable tags
attributes 355
definition 567
extractable text 362
SGML/XML 355
extractable text in SGML/XML
nested tags 355

F
features
translation 135
field results
import in Word 301
File
menu 547, 557
file details
Advanced Project Explorer 76
date last exported 76
date last imported 76
date modified 76
export path 76
name 76
size 76
source path 76
type 76
file extension
filter association 290
individual relationship with filter 294
Trados Word 351
file filter
individual choice 294
file formats
Access 311
C/C++ 344
embedded codes 204
Excel 307
FrameMaker 313
GNU gettext 346
Help content 332
HTML 333
IBM TranslationManager 347
InDesign 327
Interleaf 331
Java 344
Java properties 342
OpenOffice.org 310
overview 289
PageMaker 320
plain text 332
PO/POT 346
PowerPoint 306
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QuarkXpress 324
RC 342
RTF 305
SGML/XML 338
StarOffice 310
text 332
TMX 353
Trados TagEditor 351
Trados Word 349
working with different 289
file ID 174
field in databases 174
file management 80
File menu 23
options 23, 24
files
align 419
compacting and repairing 136
import 81, 83
Filter
command 550
in Properties pane 295
translation memory 397
filter
select rows by 62
status 40
filter association
change 290
filter by selection
benefits 130
Filter Definition File
select 339
SGML/XML import 339
Filter on Selection
command 63
filter on selection
clear 63
editing 63
Filter Options
dialog 298
filtering conditions
termbase export 496
translation memory export 438, 446
Filters
tab (Options dialog) 291
tab (Project Properties dialog) 291, 297
Find
command 548
dialog 230
keyboard shortcut 559
find
features 230
use 230
Find Duplicate Segments
command 553
dialog 123, 399
translation memory 399
Find Next
command 231, 548

keyboard shortcut 559
Find Next Number Mismatch
keyboard shortcut 559
Find Next Terminology Mismatch
keyboard shortcut 559
finished row
symbol 40
first scan for whole segments
options 151
Fix Embedded Codes
command 551
keyboard shortcut 559
fixing
embedded codes 207
folder
import 82
folder import
exclude files 69
folder structure
import 82
font
change 56
default 56
set 56
Font Mapping 316
font size
change 56
Fonts
dialog 58
fonts
changing in FrameMaker 316
format
definition 567
format filter
individual choice 294
format filters
definition 567
formats
embedded codes 204
external glossaries 79
source files 80
working with different 289
Found Source
Scan Results dialog 141
Found Target
Scan Results dialog 141
FrameMaker
.fm vs. .mif 313
change bars 320
Convert Hard to Soft Spaces 315
converting .fm to .mif 314
export options 317
Exposable Markers 315
file formats 313
font mapping 316
Ignore Automatic Numbering 315
Ignore Cross-Reference Definitions 315
Ignore Text on Master Page 315
Ignore Variable Definitions 315
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import options 315
soft returns 219
support through version 10 313
tips and tricks 320
use of Ignore options in book 320
French
user interface language 23
French bracket codes. See embedded codes
full word count 277
functionality testing
Pseudotranslation 202
fuzziness
recommended setting 139
fuzziness setting
adjusting 138
fuzzy match
definition 567
percentage bar 40
fuzzy match repair
with machine translation 162

G
General
tab (Options dialog) 138, 151, 176, 212
tab (Project Properties dialog) 178, 189, 261
tab (Termbase Properties dialog) 461
German
user interface 23
Global Font Replacement
dialog 317
glossaries
Access 79
Déjà Vu 2/3 terminology databases 79
Déjà Vu X2 termbases 79
Excel files 79
MultiTerm 79
text files 79
glossary 562
Advanced Project Explorer 562
alignment 562
alphabetic order 562
antonym 562
assemble 562
attribute 563
AutoAssemble 563
AutoCorrect 563
AutoPropagate 563
AutoSearch 563
AutoSend 563
AutoText 563
AutoWrite 564
batch processes 564
case sensitive 564
CAT 564
comments 564
date stamp 564
DeepMiner 565
delimitation rules 565

delimiter 565
demo mode 565
dockable 565
document window 565
dongle 565
DTD 566
embedded code 566
exact match 566
format 567
format filters 567
fuzzy match 567
guaranteed match 567
hard return 567
lemma 567
lexicon 568
lookup 568
machine translation 568
match 568
natural order 568
parallel port 568
perfect match 569
populate 569
pretranslate 569
primary window 569
Project Explorer 569
project file 569
propagate 570
Properties window 570
Pseudotranslation 570
regular expressions 570
scan 571
secondary window 571
Segment Selector 571
segments 571
SGML 571
SGML/XML filter 572
soft return 572
source 572
SQL 572
symmetric 572
synonym 572
tag 572
target 572
Target Language Selector 573
template 573
termbase 573
Text/Record Locator 573
time stamp 573
TMX 573
tool window 573
transitive 574
translation memory 574
wildcard 574
XML 574
glossary for clients
lexicon 97
GNU gettext
definition 346
file formats 346
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Go to Next Portion (AutoSearch)
keyboard shortcut 561
Go to Next Segment
keyboard shortcut 560
Go to Next Segment (AutoSearch - Segments)
keyboard shortcut 561
Go to Next Segment (no AutoFeatures)
keyboard shortcut 560
Go to Next Segment (Overwrite)
keyboard shortcut 560
Go to Next Untranslated Segment
keyboard shortcut 560
Go to Previous Portion (AutoSearch)
keyboard shortcut 561
Go to Previous Segment
keyboard shortcut 560
Go to Previous Segment (AutoSearch - Segments)
keyboard shortcut 561
Go to Previous Segment (no AutoFeatures)
keyboard shortcut 560
Go to Previous Untranslated Segment
keyboard shortcut 561
Go to the Beginning of Table
keyboard shortcut 560
Go to the End of Table
keyboard shortcut 560
Google Translate
machine translation engine 161
security 161
graphics
in PowerPoint 307
Greek
enabling support for 87
guaranteed match
definition 567

H
hard return
definition 567
hard returns
PowerPoint 307
sentence delimitation 219
Hebrew
enabling support for 87
Help
keyboard shortcut 558
menu 556
Help content
definition 332
file formats 332
sample 333
Help formats
source file 80
Help menu 25
options 25
hidden text
ignore in Word 301
hide column headers

command 37
hierarchy
subjects 187
Highlight text in exported files
command 303, 318, 336
HTML
customized filter 334
editor 338
encoding 335
export options 131, 133, 335
file formats 333
Ignore Strings in Script 334
import options 333
missing images 338
special characters 335
tips and tricks 338
Unicode 335
hyphenated words
spelling option 238

I
IBM TranslationManager
file formats 347
translate 348
untranslated segment file 348
ignore
dictionary 241
Ignore Automatic Numbering
FrameMaker import 315
Ignore Cross-Reference Definitions
FrameMaker 315
Ignore Exact Matches
Trados import option 349
Ignore Hidden Text
import option for Word 301
use 301
ignore Internet addresses
spelling option 237
ignore numbers
spelling option 237
Ignore Red Text
Excel import option 308
Ignore Strings in Script
HTML import 334
Ignore Text in Single Quotes
C/C++/Java import 344, 345
Ignore Text on Master Page
FrameMaker import 315
Ignore Variable Definitions
FrameMaker import 315
IIF
template 457
ILOTerm
template 457
images
HTML 338
Import
command 547, 553, 557, 558
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import
.tlx dictionaries 244
external file into lexicon 388
folder 82
folder structure 82
selecting several items 65
spelling dictionary 244
subfolder 82
text spelling dictionaries 244
Import All
command 552
import data
security restriction 273
Import DV3 Settings
dialog 182, 193, 224, 228
Import External View
dialog 270
Import Field Results
Word import option 301
import files 64, 81, 83
with Advanced Project Explorer 64
import folders 68
with Advanced Project Explorer 68
import of glossaries
Access 79
Déjà Vu 2/3 terminology databases 79
Déjà Vu X2 termbases 79
Excel files 79
MultiTerm 79
text files 79
import options
Access 311
apply specific 295
BIF 352
C/C++/Java 344
Excel 307, 309
FrameMaker 315
HTML 333
New Project Wizard 89
PowerPoint 306
project-wide settings 296
RTF 305
SGML/XML 339
TagEditor 352
TMX 353
Trados 349
TTX 352
importing data
into termbase 474
into translation memory 409
importing databases
Access database 78
Déjà Vu 2/3 memory database 78
Déjà Vu X2 translation memory 78
Excel format 78
IBM TM2 78
SDLX 78
text files 78
TMX 78

Trados Workbench 78
importing glossaries
preparing 79
InDesign
encoding 330
export a story 327
file formats 327
tagged text file 327
Index
command 556
index
lexicon 377
Indic languages
enabling support for 87
indicator
current row 30
duplicate rows 41
indicator bars
change color 42
individual translation files
display 59
select 59
Insert
menu 548
insert
current target with source 214
Insert AutoSearch Portion (Insert)
keyboard shortcut 561
Insert AutoSearch Portion (Overwrite)
keyboard shortcut 561
Insert Current AutoSearch Portion
command 549
Insert Current AutoSearch Portion (Insert)
keyboard shortcut 561
Insert Current AutoSearch Portion (Overwrite)
keyboard shortcut 561
Insert Current AutoSearch Segment
command 549
Insert Current AutoSearch Segment (Insert)
keyboard shortcut 561
Insert Current AutoSearch Segment (Overwrite)
keyboard shortcut 561
Insert menu 23
options 23
insert text for failed portions
option 152
pretranslation 102
installation. See Getting Started Guide
installing Déjà Vu. See Getting Started Guide
installing dongle. See Getting Started Guide
integrated development environment 51
interface
Déjà Vu X2 21
project 22
Interleaf
ASCII files 331
file formats 331
save as ASCII file 331
internal codes. See embedded codes
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inter-project
analysis 284
intra-project analysis 284
Italian
user interface language 23

J
Japanese
enabling support for 87
Java
file formats 344
Java files
definition 344
Java Properties
sample 342
Java properties
definition 342
file formats 342
Jet engine 135
join lines
Excel 308
Join Segments
command 219, 548
keyboard shortcut 560
join segments
satellite files 262
security restriction 273
joining segments 218, 219
embedded code 220
reasons 218
jump to
previous segments 60
previous untranslated segment 60
untranslated segment 60
jump to next segment
no status change 60

K
keyboard shortcuts 25
access to Déjà Vu X2 features 25
add new 26
customize 26
list of 558
modify 26
Korean
enabling support for 87

L
language
selecting in project 50
language mapping
BIF 352
TMX 353
TTX 352
language selector 50
language support
enabling 87

languages
available for spell check 125
display order 87
select 87
switch user interface 22
vs. sub-languages 87
leading symbols 213
lemma
definition 567
levels
user access 273
Lexicon
menu 554
sub-menu 24
lexicon
automatically resolve with databases 99
Build command 97
change sorting 378
concept 97
create 97
current language 380
current vs. all files 98
definition 97, 377, 568
export 382
frequency (Freq) 99
generating 97
glossary for clients 97, 378
importing external file 388
in comparison to other databases 97
language 380
manual translation 100
manually add entries 379
new concept 377
number of words 99
open from Project Explorer 99
optional workflow component 97
reasons for adding entries 379
removal options 100
remove entries 100, 387
remove rows 100
resolve with databases 100
resolve with terminbases 380
resolving the translation memories 379
resolving with databases 379
send to terminbase 381
sending data 172
sending text 169
sending to translation memories 381
sorting options 378
translate 99
translating with other databases 98
useful vs. useless entries 98
uses 378
vs. terminbase 378
lexicon export
into text format 383
supported formats 383
Lexicon Export Wizard 383
lexicon import
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supported formats 389
uses 388
Lexicon Import Wizard 388
Lexicon menu 24
LibreOffice
support 310
limit to current record selection
option 171
lines
moving 60
switching 60
load
Microsoft Office spell checker 128
local drive
Advanced Project Explorer 63
Locate Segment
translation memory 396
Locate Term
termbase 485
locating term
termbase 499
location of source files 80
Lock
symbol 173
lock
group of segments 173
unlock segments 173
Lock File
command 553
lock segments
satellite files 262
security restriction 273
Lock Strings Heuristically
command 345
Lock vertical scrolling in project view
command 61
Lock/Unlock Segments
keyboard shortcut 560
locked row
symbol 40
locked segments
and propagate 198
export into External View 265
view 173
Locking Segments
command 173
log in
project 273
repeat 274
termbase 273
translation memory 273
log out
project 274
termbase 274
translation memory 274
Login
command 554
login name 273
Logout

command 554
Lookup
command 550
keyboard shortcut 559
lookup
database 139
definition 139, 568
termbase 139, 144
with wildcards 146
with word stems 146
Lookup with Wildcards
command 550
keyboard shortcut 559

M
Machine Translation 160
usage 160
machine translation
definition 568
for assemble 165
for fuzzy match repair 162
Macintosh
change code page 324
macros disabled
Word 304
main interface
translation grid 29
main sentence
in translation memory 414
manual
convention 16
how to use 9
index 10
menu commands 16
notes 16
overview 9
path names 16
related documentation 17
sample text 16
tips 16
user interface controls 16
manual assemble 149
manual propagate 198, 199
difference to AutoPropagate 198
manually adding records
termbase 471
manually resize
windows 54
mapping
fonts 316
marking segments as pending 251
match
definition 568
maximum number of words
lexicon 98
memory databases. See translation memory
menu
Database 557
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Edit 23, 547, 558
File 23, 547, 557
Help 25, 556
Insert 23, 548
Lexicon 24, 554
Project 24, 552
QA 24, 551
Tools 25, 554
Translation 24, 550
Users 24, 554
View 24, 549
Window 25, 555
menu bar 23
Merge
translation memory 398
Merge External View Data
dialog 271
merge segments
security restriction 273
merging
termbase 501
Microsoft Access. See Access
Microsoft Excel. See Excel
Microsoft Jet
databases 135
Microsoft Office spell checker 236
loading 128
Microsoft Word 2003 and below
support 300
MIF Font Mapping
tab (Project Properties dialog) 316
minimize options 56
minimum score 139
recommended setting 139
missing spaces
prompt at export 132
QA command 122
mode
edit 30
edit vs. selection 30
selection 61
model
workflow 77
modify
embedded codes 209
sentence delimitation rules 216
modify data
AutoSearch window 173
modifying term
termbase 500
monitor
working with several 52
mouse
move 61
move
beginning of file 61
context menu 61
embedded codes 206, 208
end of file 61

lines 60
mouse 61
screen up and down 61
scrollbar 61
wheelmouse 61
moving around
project file 59
MS Office 2007 and 2010
support 309
MS Word
word counts 284
multiple exact matches 104
multiple matches
accept all 104

N
name
file details 76
natural order 38
definition 568
switch to alphabetic order 39
Navigate
command 548
nested tags
extractable text in SGML/XML 355
network drive
Advanced Project Explorer 63
New
command 547
New Dictionary
dialog 242
new feature
analysis 20
new features
overview 19
New File
dialog 85, 94, 356, 368, 401, 420, 452
keyboard shortcut 558
new files
import into old vs. new projects 172
New Horizontal Tab Group
command 555
new project
create 85, 91
New Project Wizard 86, 95
no import options 89
New SGML/XML Filter Wizard 357, 369
New Termbase Wizard 453
New Translation Memory Wizard 402
New Vertical Tab Group
command 555
newer matches
databases 139
Next Bookmark
dialog 250
keyboard shortcut 561
Next Commented Segment
command 552
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Next Duplicate Segment
command 552
Next Multiple Match
command 552
Next Pending Match
command 552
next segment
jump to 60
Next Segment in SQL Filter
command 50, 552
Next Unfinished Match
command 552
Next Warning
command 552
nickname. See user
Non-translatable Notes
WinHelp example 302
WinHelp files 301
Word import option 301
notes
import option for PowerPoint 306
non-translatable in Word 301
OpenOffice.org/StarOffice 310
number conversions
limitations 212
number of characters
RC files 343
status bar 51
number of records
termbase 449
translation memory 407
numbers
consistency checks 120
conversions 212
in propagate 197
numerical listing
clients 177

O
ODBC
definition 568
description of export 442, 491
ODBC Import Options
dialog 312
Office 2007 and 2010
support 309
Office 2007/2010
filter-specific option 309
Office Proofing Tools
reload 128
Office spellchecking dictionaries
locating 245
Open
command 547
Open Document
support 310
Open File

keyboard shortcut 558
open files
access from selector bar 60
Open XML
support 309
opening
alignment file 429
translation memory 400
OpenOffice 2 and 3
support 310
OpenOffice.org
file formats 310
OpenOffice.org/StarOffice
notes 310
record changes 310
use AutoFormat 310
option catalogs
managing 55
Options
command 555
options
import 295
minimize 56
spelling 235
options for pretranslation 102
order
alphabetical 39
natural 38
overview
databases 135
manual 9
overwriting
pretranslation 103

P
Pack & Go Export Progress
dialog 258
Pack & Go Import Wizard 260
Pack & Go packages 257
create 257
definition 257, 569
open 258
return 262
size reduction 258
translate 261
uses 257
PageMaker
encoding 324
export a story 320
file formats 320
re-import the story 323, 329
tagged text file 320
tips and tricks 324
working with double-byte languages 324
working with Mac files 324
parallel port
definition 568
partial matches
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fuzzy setting 139
Paste
command 548
keyboard shortcut 558
paste
standard features 213
Pending
keyboard shortcut 560
pending
definition 569
mark segments 251
pending symbol 251
pending, mark as
benefits 130
perfect match
definition 569
performance
databases 135
phonetics
spelling option 238
plain text
file formats 332
PO/POT
file formats 346
populate
all segments 214
definition 214, 569
one vs. all segments 215
overwrite 215
single segments 214
Populate All Languages
command 549
keyboard shortcut 561
Populate Current Language
command 549
keyboard shortcut 561
Populate Current Segment
command 214, 215, 387
keyboard shortcut 561
Populate Current Segment (Insert)
keyboard shortcut 561
populating
all target languages 215
Portions found window. See AutoSearch - Portions
position indicator 343
position of characters
status bar 51
position of current record
status bar 51
Power Scan 142
use 142
PowerPoint
check for graphics 307
file formats 306
import options 306
installation requirements 306
location of original files 306
prepare files 307
soft returns 219

tips and tricks 307
PowerPoint 2003 and below
support 306
preparing glossaries for import 79
preprocessed files
source files 80
presentation formats
source file 80
Pretranslate
command 550
dialog 102
keyboard shortcut 559
pretranslate
definition 569
pretranslation
accept only exact matches 102
assemble from portions 102
benefits 101
check for inconsistent terminology 103
DeepMiner 153
definition 101
insert text for failed portions 102
options 102
overwriting 103
process 101
Use DeepMiner Engine 102
Use Machine Translation 102
pretranslation phase 101
prevent row
sending to translation memory 172
Previous Bookmark
dialog 251
keyboard shortcut 561
previous segment
jump to 60
previous untranslated segment
jump to 60
primary window 57
definition 569
Process notes
import option for PowerPoint 306
Process Slide Master
import option for PowerPoint 307
Project
menu 552
project
analysis 284
associate termbases 467
associate translation memories 405
project building phase 81
Project Explorer 32
command 549
definition 32, 569
differences from Advanced Project Explorer 63
navigating the project 63
selecting files to view 59
switching with Advanced Project Explorer 24
Project Explorer view 82
project file 21
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compact 136
create 85
create on a template 91
definition 569
moving around 59
reading 114
reading a hard copy 114
reading in Déjà Vu X2 114
repair 137
Project From Template
command 94
project glossary
lexicon 377
project ID 174
field in databases 174
on General tab 178, 189
project interface 22
Project menu 24
options 24
project name
specify 86
Project Templates
dialog 92
project toolbar 26
proofing
export into original format 129
proofing in Déjà Vu X2
pros and cons 130
proofing in original format
pros and cons 129
propagate 197
AutoPropagate 198
definition 197, 570
manually 199
manually to all files 200
overwrite 198
Propagate in Current File
command 199
keyboard shortcut 561
Propagate in Current File (Overwrite)
keyboard shortcut 561
Propagate to All Files
command 200
keyboard shortcut 561
Propagate to All Files (Overwrite)
keyboard shortcut 561
propagation
differences between different modes 198
propagation. See propagate
Properties
command 553, 557
dialog (New Project Wizard) 294
pane (Project Explorer) 294, 296
properties files. See Java properties
Properties window 65, 70, 82
command 549
definition 570
in Advanced Project Explorer 70
in Project Explorer 65, 82

protect
segments 173
Pseudotranslate
dialog 201
Pseudotranslation 200
and double-byte languages 200
command 550
definition 570
functions of 200

Q
QA
menu 551
QA menu 24
options 24
quality assurance features 114
quality assurance phase 114
QuarkXPress
batch export .xtg files 327
CopyFlow 327
export .xtg file 324
file formats 324
re-import .xtg file 325
Tag file 324
working with Mac files 327
QuarkXpress
tips and tricks 327
QuickSilver. See Interleaf

R
range of rows
select 62
RC
file formats 342
RC files
character count 343
converting quotes 343
copyright note 343
definition 342
sample 343
tips and tricks 343
reading the project file
different methods 114
readme file 17
rearrange windows 51
record
jumping to specific 60
record changes
OpenOffice.org/StarOffice 310
record locator 38
red text
ignore in Excel 308
Redo
command 233, 547
keyboard shortcut 559
redo
perform 232
reflexive relation
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definition 463
regular expressions
definition 570
for filtering export from termbase 529
for filtering export from translation memory 529
Reimport
command 553
related documentation
readme 17
user group 17
website 17
Relations
tab (Termbase Properties dialog) 462
relations
defining for termbase 462
reload
Office Proofing Tools 128
Remove
command 553
translation memory 397
remove
duplicate segments indicator 125
sentence delimitation rule 217
status indicators 45
Remove Entries
command 554
Remove lexicon entries 100
Remove lexicon rows
dialog 387
Rename
command 553
renumbered matches 278
Repair
command 555
repair
project file 137
reasons 137
satellite file 137
termbase 137
translation memory 137
repair database 136
repairing installation. See Getting Started Guide
repairing of fuzzy matches
DeepMiner 153
reparing of fuzzy matches
example 153
Replace
command 231, 548
dialog 231
keyboard shortcut 559
replace 231
features 230
Require Ctrl-key to Insert AutoSearch portions
command 110
reset
status indicators 45
Reset Segment Status
keyboard shortcut 560
Reset Windows Layout

command 556
resize
windows 54
Resolve Lexicon
dialog 380
Resolve with Termbase
command 554
Resolve with Terminology Database
command 554
Resolve with Translation Memory
command 554
resource files. See RC
RESX files
support 345
RESX-Specific Import Options 345
review
comment 254
review features 249
Rich Text Format. See RTF
rows selector 40
RTF
file formats 305
import options 305
Microsoft standard 305
non-Microsoft versions 305
security settings 305
RTF import options. See Word
rules
delimitation 215
Russian
enabling support for 87
user interface language 23

S
satellite file
compact 136
repair 137
satellite files 262
definition 262, 570
restrictions 262
security options 262
vs. project files 262
save 233
project 233
SQL expressions 526
SQL statement 49
Scan
command 550
keyboard shortcut 559
scan
database 139
definition 139, 571
navigate matches 141
translation memories 140
translation memory 139, 140
with wildcards 142
with word stems 142
Scan Results
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dialog 140
Scan with Wildcards
command 550
keyboard shortcut 559
sci files
support 310
script-based files 333
scrollbar
move 61
Search
command 556
search
features 230
termbase 144
with wildcards 142, 146
search and replace 231
termbase 500
secondary window 57
definition 571
security
definition 571
security features
in Déjà Vu X2 273
limitations to translation user 273
security options
satellite files 262
security restriction
configuration access 273
delete files 273
edit source 273
execute SQL 273
export data 273
import data 273
join segments 273
lock segments 273
merge segments 273
split segments 273
See in Context
command 210
keyboard shortcut 560
Segment Highlight Options
dialog for FrameMaker export 318
dialog for HTML export 336
dialog for Word export 303
segment pairs
duplicates in translation memory 169
overwriting in translation memory 169
Segment Selector
definition 571
Duplicate Segments 124
segment selector
view pending rows 252
Segment Status
command 548
segmentation rule. See sentence delimitation
segments
definition 571
delete whole 208
joining 218, 219

locking 173
mark as pending 251
protecting 173
splitting 218, 219
Segments Found window. See AutoSearch - Segments
select
all rows 62
all rows downwards 62
all rows upwards 62
existing project file 81
languages 87
range of rows 62
rows by filtering 62
rows by status 62
SQL 46
Select All
command 548
keyboard shortcut 559
Select Location of "New Pack & Go Package"
dialog 258
select rows 61
in selection mode 61
Select SQL
dialog 46, 399, 503
Select User Interface Language
dialog 22
selection mode 30, 61
moving in the project 61
switch into 30, 61
selection vs. edit mode 30
selector row 38
selector rows
language selector 50
rows selector 40
text/record locator 38
Send Lexicon to Terminbase
dialog 382
Send Lexicon to Translation Memory
dialog 381
Send Project to Translation Memory
command 552
dialog 171
sending data
lexicon 172
termbase 172
sentence delimitation 215, 217
alignment 426
Asian languages 218
common abbreviations 215
common rules 215
correcting errors 219
definition 215
differing punctuation between languages 216
exceptions 215, 216
modify rules 216
non-Western punctuation systems 218
remove rule 217
symbols and definition 217
sentence delimiters

Déjà Vu X2 598

import from Déjà Vu 3 218
sentence pairs
overwriting in translation memory 172
sentence scan 140
separate sentences. See sentence delimitation
set font 56
settings.dvset file
changing location 176
setup. See Getting Started Guide
SGML
definition 338, 355, 571
filter file 21
how to recognize 339
support 339
SGML filter
create from SGML file 356
SGML filter file
compact 136
SGML filter files
creating 355
maintaining 355
SGML/XML
defining the filter 341
definition of attributes 355
definition of tags 355
encoding 341
export options 131, 133, 341
extractable attribute 356
extractable text 355
file formats 338
Filter Definition File 339
import options 339
special characters 341
tips and tricks 341
SGML/XML attributes
extracted 365
SGML/XML filter
adding data 375
convert Déjà Vu 2/3 filter 375
create from DTD 368
definition 21, 572
delete examples 365
import from Déjà Vu 2/3 filter 375
SGML/XML tags
embedded 363, 364
Shared settings location
option 176
shortcuts
keyboard 25
SilvaTerm
template 457
simple word count 277
single translation files
select 59
size
file details 76
slide master
import option for PowerPoint 307
soft return

definition 572
soft returns
FrameMaker 219
PowerPoint 219, 307
sentence delimitation 219
software development formats
source file 80
Sort
command 549
sort alphabetically
benefits 130
sort by status
benefits 130
Sort Lexicon
toolbar 378
sort order
switch 39
termbase 499
sorting
lexicon 378
Sought Source
Scan Results dialog 141
Source
Terminology Lookup dialog 145
source
definition 572
source files
database format 80
desktop publishing format 80
file management 80
formats 80
Help format 80
location 80
network 80
originating application 80
preprocessed files 80
presentation format 80
selecting in New Project Wizard 89
software development formats 80
spreadsheet format 80
tagged formats 80
word processing formats 80
source language
termbase interface 484
source path
file details 76
Source Sentence in Context
dialog 211
source view. See context view
spaces
consistency checks 122
missing at export 132
Spanish
user interface language 23
special characters
HTML 335
SGML/XML 341
specific record
jumping to 60

Déjà Vu X2 599

specify
project name 86
spell check
Déjà Vu X2’s spell checker 126
of non-supported languages 126
with Microsoft Word 127
spell check with Word
condition 127
spell checker
Microsoft Office 236
spell checking 125
dictionaries 238
integrated languages 125
options 126
termbase 503
translation memory 432
Spell Checking Options
dialog 432, 503
Spelling
command 554
keyboard shortcut 560
tab (Options dialog) 236
spelling
options 235
spelling dictionary
export 247
import 244
spelling option
allow accented capital 237
case sensitive 237
doubled words 237
ignore Internet addresses 237
ignore numbers 237
split compound words 238
split contracted words 237
split hyphenated words 238
strip possessives 238
suggest phonetics 238
suggest split words 238
suggest typographical 238
uncapitalized words 237
use the Microsoft Office spell checker 236
words in capitals 237
words that begin with a capital letter 237
words with digits 237
words with embedded capital letters 237
split compound words
spelling option 238
split contracted words
spelling option 237
split hyphenated words
spelling option 238
split lines
Excel 308
Split Segments
command 219, 548
keyboard shortcut 560
split segments 219
satellite files 262

security restriction 273
split words
spelling option 238
splitting segments 218
embedded code 220
reasons 218
spreadsheet formats
source file 80
SQL
access to databases 136
definition 572
tab in Options dialog 527
SQL command
delete data from termbase 511
delete data from translation memory 511
update records in the project file 522, 523, 526
update records in the termbase 522, 523, 526
update records in the translation memory 522, 523,
526
SQL expressions
save 526
SQL select 46
termbase 503
translation memory 399
SQL Statement
record locator 42
view 46
SQL statement
save 49
standard toolbar 26
StarOffice
file formats 310
Statistics
tab (Termbase Properties dialog) 450
tab (Translation Memory Properties dialog) 408
statistics
translation memory 407
statisticstermbase 449
status
select rows by 62
tooltip 42
status bar 50
number of characters 51
position of current record 51
position of cursor 51
shortcut to automated options 51
stacked 50
status filter 40
status indicator
assembled segments 107
AutoPropagate 199
reference 42
review 42
status indicator bar 40
status indicators
remove 45
reset 45
strip possessives
spelling option 238
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subfolder
import 82
subject
add to list of subjects 190
assigning to records 188
definition 175
delete 195
find 195
modify 193
purpose 175
search 195
storing settings 176
Subjects
tab (Options dialog) 187
subjects 174
associated codes 188
hierarchical listing 187
import from Déjà Vu 3 192
managing 197
non-numeric codes 187
preset list 187
relevance 197
relevance of hierarchy 188
select for project 189
sub-languages
matching hierarchy 87
suggest phonetics
spelling option 238
suggest split words
spelling option 238
suggest typographical
spelling option 238
Swap Current and Next Words
keyboard shortcut 560
Swap Previous and Current Words
keyboard shortcut 560
switching lines 60
sxc files
support 310
sxw files
support 310
symbol
Do Not Send 172
finished row 40
Lock 173
locked row 40
pending 251
Warning 206
wrong codes 41
symbols
sentence delimitation 217
symmetric
definition 572
symmetric relation
definition 463
synonym
add to termbase 484
definition 572

T
tabbed interface 54
tag
definition 572
TagEditor
export options 352
import options 352
TagEditor. See Trados TagEditor
tagged formats
source files 80
tags (SGML/XML)
definition 355
Tags and Attributes (SGML/XML)
tab 362, 373
Target
Terminology Lookup dialog 145
target
definition 572
Target Language Selector
definition 573
TBX
template 457
teamwork features
benefits 257
template
create project with 91
Template Name
dialog 459
Templates
command 91
templates
assigning 457
creating 458
defining in wizard 455
definition 456, 573
Eurodicautom 456
termbases 456
termbase
add terms 112
adding additional information 174
adding non-translation records 484
adding records 112, 470
adding translation records 470
All Rows view 503
associate with project 467
compact 136
convert Déjà Vu 2/3 482
create 88
create as stand-alone file 451
create with New Project Wizard 88
creating 451
defining attributes 464
defining categories 466
defining relations 462
definition 21, 573
deleting term 501
editing 499
editing term 500
exporting data 488

Déjà Vu X2 601

filtering the export 496
fuzziness setting 138
importing data 474
importing glossaries 79
Locate Term 485
locating term 499
lookup 139, 144
manually adding records 471
merging 501
modifying term 500
opening 449
options to create 451
remove from project 468
search and replace 500
select 88
select with New Project Wizard 88
sending data 172
sending text 169
sort order 499
spell checking 238, 503
SQL select 503
standard fields 478
statistics 449
supported export formats 489
supported import formats 475
templates 456
views 503
termbase attributes
considerations 113
Termbase Export Wizard 489
Termbase Import Wizard 474
termbase interface
source language 484
Termbase Properties
dialog 461
termbase records
specifications 113
Termbase Templates
dialog 458, 459
termbases
creating and maintaining 449
terminology
consistency checks 120
terminology consistency checks 114
terminology database
repair 137
search 144
Terminology Lookup
dialog 145
terminology mismatch
check current row 119
Termite
template 457
text
description of import 442, 491
file formats 332
text area
translating in 31
text box

translating in 31
text boxes
Word 305
text expansion
and Pseudotranslation 201
text files
encoding 332
termbase import 475
translation memory import 411
text locator 38
Text/Record Locator
definition 573
text/record locator 38
Thai
enabling support for 87
support on Windows 201
third-part glossaries
Déjà Vu X2 termbases 79
third-party databases
Access database 78
Déjà Vu 2/3 memory database 78
Déjà Vu X2 translation memory 78
Excel format 78
formats 78
IBM TM2 78
import in translation memory 78
SDLX 78
text files 78
TMX 78
Trados Workbench 78
third-party glossaries
Access 79
Déjà Vu X2 termbases 79
Excel files 79
formats 79
import in termbase 79
MultiTerm 79
origin 79
text files 79
tile horizontally
windows 54
tile vertically
windows 54
time stamp 174
definition 573
field in databases 174
tips and tricks
FrameMaker 320
HTML 338
PageMaker 324
PowerPoint 307
QuarkXpress 327
RC 343
SGML/XML 341
Trados Word 351
Word 304
TIS
template 456
TMX
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definition 573
description of import 436
export options 354
file formats 353
import options 353
language mapping 353
source and target 353
translation memory export 436
translation memory import 411
use as a translation format 353
vs. Trados export 436
Toggle Bookmark
keyboard shortcut 562
tool window
closing 54
definition 51, 52, 573
disable docking 53
docking 52
tool windows
tabbed interface 54
toolbar 26
project 26
Sort Lexicon 378
standard 26
Toolbars
command 550
toolbars
configurable 21
create new 27
customize 27
customize view 28
toolbox
Déjà Vu 10
Tools
menu 554
Tools menu 25
options 25
tooltip
status 42
track changes
Word 304
Trados
import options 349
vs. TMX export 436
Trados RTF. See Trados Word
Trados TagEditor
file formats 351
Trados Word
configure file extension 351
file formats 349
fuzzy matches 349
installation requirements 349
location of original file 351
Segment Unknown Sentences 351
split/join sentences 351
tips and tricks 351
Trados Workbench
description of import 436
Trados Workbench databases

translation memory export 435
translation memory import 411
TradosTagEditor
fuzzy matches 351
XTranslated units 351
trailing symbols 213
transitive
definition 574
transitive relation
definition 463
Translate with Google Translate
command 161, 550
keyboard shortcut 559
Translation
menu 550
translation features
Déjà Vu X2 135
translation grid 29
automatic resizing 30
translation memories
creating and maintaining 395
translation memory 21
Add 397
adding additional information 174
adding records manually 112
All Rows view 398
associate with project 405
compact 136
create 88
create with New Project wizard 88
creating 400
creating as stand-alone file 401
definition 21, 574
Duplicates Only view 399
exporting data 434
Filter 397
filtering the export 438, 446
Find Duplicate Segments 399
fuzziness setting 138
importing data 409
importing databases 78
interface 395
Locate Segment 396
manually sending data 169
Merge 398
opening 400
options to create 400
prevent sending row 172
Remove 397
remove from project 405
repair 137
scan 139, 140
select 88
select with New Project Wizard 88
send portion of sentence 170
send project options 171
send whole project 170
sending data 169
sending text 169
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spell checking 238, 432
SQL select 399
standard fields 414
statistics 407
supported export formats 435
supported import formats 410
write attribute 112
Translation Memory Export Wizard 434
Translation Memory Import Wizard 410
translation memory interface
source language 395
target language 396
Translation menu 24
options 24
translation phase 104
translation user
nine levels 273
usage limitations 273
translation workflow 77
TranslationManager. See IBM TranslationManager
translations for duplicate source
consistency checks 123
Transref website 17
TTX
export options 352
import options 352
language mapping 352
type
file details 76
type of project
on General tab 178, 189
typographical
spelling option 238

U
UDC. See Universal Decimal Classification
uncapitalized words
spelling option 237
Undo
command 232, 547
keyboard shortcut 558
Unfilter
command 63
unfilter
filter on selection 63
Unicode
definition 574
HTML 335
uninstalling Déjà Vu. See Getting Started Guide
Universal Decimal Classification 187
Unlock File
command 553
unlock segments 173
unmark
duplicate segments indicator 125
Unmark Duplicate Segments
command 553
Unterm

template 457
untranslated segment
jump to 60
up one screen
move 61
USB
definition 575
Use DeepMiner Engine
pretranslation 102
Use DeepMiner engine
command in Options dialog 159
command in Pretranslate dialog 160
Use Machine Translation
command in Options dialog 162
command in Pretranslate dialog 163
pretranslation 102
Use Machine Translation for whole segments
command 164
use the Microsoft Office spell checker
spelling option 236
user 174
field in databases 174
user access
levels 273
user dictionaries. See dictionaries
user group
Déjà Vu 17
user interface
Déjà Vu X2 21
project 22
switch language 22
User Interface Language
command 555
User Login
dialog 274
user name 273, 274
default Windows logon 51
in databases 51
user types 10
beginner 10
convert 11
power user 12
upgrader 11
userdic.tlx
dictionary 240
Users
menu 554
Users menu 24
options 24
UTF-16
definition 574
UTF-8
definition 574

V
Vietnamese
support on Windows 201
View
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menu 549
view
All Files 59
context 210
SQL Statement 46
View menu 24
options 24
View Project Explorer
keyboard shortcut 560
View Properties
keyboard shortcut 560
views
termbase 503
Vintars
template 457

W
Warning
symbol 206
What’s new
AutoWrite 19
DeepMiner 19
look and feel 19
multi-file, multi-format alignment 19
new analysis features 20
new External View formats 19
new file types 20
new machine translation feature 19
new QA features 19
project templates 20
store and reuse SQL commands 20
wheelmouse
move 61
wildcard
definition 574
wildcards
client search 185
lookup with 146
scan with 142
subject search 196
Window
menu 555
window
primary 57
secondary 57
Window menu 25
options 25
Window Type
option 57
windows
rearrange 51
Windows functions
common 229
Windows logon
user name 51
wizard
New Project 86, 95
Word

character spacing 304
comments 304
duplicated text in text boxes 305
export options 302
macros 304
security setting 304
tips and tricks 304
track changes 304
use AutoFormat 305
Word Count
command 555
dialog 280
keyboard shortcut 560
word count 279
save in external file 282
word count modules
simple vs. full 277
word counts
according to MS Word 284
word processing formats
source file 80
word stems
lookup 146
scan 142
words in capitals
spelling option 237
words that begin with a capital letter
spelling option 237
words with digits
spelling option 237
words with embedded capital letters
spelling option 237
workflow
editing and QA phase 114
editing phase 114
export phase 130
phases 77
preparation phase 78
pretranslation 101
project building phase 81
quality assurance phase 114
suggestions 77
translation phase 104
workflow phase
preparation 78
write attribute
destination database 112
wrong codes
symbol 41

X
XML
definition 574
XML filter
create from XML file 356
XML filter files
creating 355
maintaining 355
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