Déjà Vu X2 COM+ Server
Installation and Configuration Guide
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Before you start
There are some things that you should take into account and prepare for before you attempt to install and
configure the Déjà Vu X2 COM+ Server for deployment in your organization:


The COM+ Server and the Déjà Vu X2 application must not be installed on the same computer. They
interfere with one another and will render each other inoperable. The correct setup is to set aside a
computer to act as a server, which will store the shared databases and run the COM+ Server, while
the translators each run Déjà Vu X2 on their own computers.



The COM+ Server should only be installed in Server editions of Windows (2003, 2008, etc.). While it
is possible to install it in consumer editions (e.g. Vista and 7), the consumer editions of Windows
have certain limitations compared to the server editions that will limit the COM+ Server’s
functionality.



The COM+ Server requires a Windows shared folder on the server computer (more in the next
section). This share must be accessible with Read and Write access from the client computers and
by the users who will use Déjà Vu X2 on these computers. If your network is configured in such a
way that a shared folder on the server cannot be accessed from the clients, the COM+ Server
cannot work.
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Déjà Vu X2 COM+ Server Installation:
In order for the Déjà Vu X2 COM+ Server to work correctly, you must prepare the server computer before
installing the COM+ Server. The necessary steps are described in this section.

Windows Server 2003 specific configuration
On Windows Server 2003 and 2003 R2, enable the option Enable network COM+ Access in Control Panel >
Add or Remove programs > Add/Remove Windows Components > Application Server.

Windows Server 2008 specific configuration
On Windows Server 2008 and 2008 R2, go to Control Panel > Programs and Features > Turn Windows
features on or off, and in the Server Manager window that appears, make sure that the Application Server
role is installed and that its COM+ Network Access role service is installed. (If you are using a firewall other
the OS’s own, read this article to find which ports must be enabled; if you use Windows Firewall but find that
the Com+ Server is not accessible, check the Windows Firewall rules to make sure the necessary ones were
enabled)

If all the computers are in a Domain
If the computer that will run the COM+ Server and the computers that will run the clients are members of an
Active Directory Domain, the setup process before installing the COM+ Server is made significantly simpler.
The following describes what you have to do the configure your server to run the Déjà Vu X2 COM+ Server if
it is a member of an AD Domain.

Folder and shares configuration
Create and share a new folder to store the Translation Memories and Termbases. The shared folder should
have the following share and security permissions:


Share (in the Share tab of the folder properties, click on Advanced Sharing):
o

Select the name of the Windows/Active Directory user group that corresponds to the
translators (e.g. TranslatorsGroup), and give this group “Full control” access rights. This
group should be created on the domain controller and should contain all the users that need
access to the shared folder. If no such group exists, then select “Everyone” security principal
and give it “Full control” access rights.
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o



Give the Network Service account (on the local server – not a domain account) “Full control”
access rights:

Security (in the Security tab of the folder properties):
o

Select the name of the Windows/Active Directory user group that corresponds to the
translators (e.g. TranslatorsGroup), and give this group “Full control” access rights. This
group should be created on the domain controller and should contain all the users that need
access to the shared folder. If no such group exists, then select “Everyone” security principal
and give it “Full control” access rights.

o

Give the Network Service account (on the local server – not a domain account) “Full
control” access rights.

Installation of the Déjà Vu X2 COM+ Server component
Install the Déjà Vu X2 COM+ Server component. The Déjà Vu X2 COM+ Server component is downloadable
from http://www.atril.com/__demos/Setup.COM+.exe.
Set the COM+ permissions on the server so that clients can access the shared databases using the Déjà Vu
X2 COM+ Server application:


Go to Administrative Tools>Component Services and then to Console Root>Component
Services>Computers, right click on My Computer and select the Properties menu option. Go to the
COM Security tab and add the following permissions under Launch and activation permissions>Edit
Limits:
o

For the translator user group (e.g. TranslatorsGroup): Remote activation, Remote launch
(use the built-in Everyone account if this group does not exist).
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If the computers are in a Workgroup
Setting up a server and several client computers to work with the Déjà Vu X2 COM+ Server is similar to what
is done when you are setting them up in a Domain. However, since there is no central AD Controller to
handle authentication you must configure each computer to recognize the user accounts of the users
involved so that both the clients and the server will be able to talk to each other.

Setting up the user accounts
In a normal setup, you will have several client computers connecting to a single server, and each client will
have a single user logged into their local user account, and the Déjà Vu X2 COM+ Server running in the
server computer under a local user account.
In order for the server to accept connections from the clients and to communicate with them, the Server
computer must recognize the users that are attempting to connect to it. If there is no central AD Controller to
handle authentication, this is achieved by making sure that there are local user accounts in the server with
the same name and password as the local user accounts being used in the clients.
Similarly, each client computer must have a local user account with the same name and password as the
user account being used on the server to run the Déjà Vu X2 COM+ Server, so that the client computers will
be able to communicate with the COM+ Server correctly.
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Folder and shares configuration
Deactivate Simple File Sharing
Window’s Simple File Sharing feature prevents windows from transmitting user credentials when attempting
to read from or write to a shared location, which makes it impossible for the sort of authentication required by
Déjà Vu X2 and the COM+ Server to work. Therefore it is necessary to deactivate this in all the computers
that will be involved in the sharing of databases, that is, the server where shared databases are stored, and
the computers running Déjà Vu X2.
To deactivate Simple File Sharing on the server computer:
1. Click the Start button.
2. Select Control Panel.
a. In Windows Server 2003, select Appearance and Themes.
b. In Windows Server 2008 and above, select Appearance and Personalization.
3. Select Folder Options.
4. Select the View tab.
5. Scroll to the bottom of the Advanced settings: list.
a. In Windows Server 2003, clear the Use simple file sharing (Recommended) check box.
b. In Windows Server 2008 and above, clear the Use Sharing Wizard (Recommended) check
box.
6. Click OK.
7. Close all windows.

Creating and configuring the shared folder
Create and share a new folder to store the Translation Memories and Termbases. The shared folder should
have the following share and security permissions:


Share (in the Share tab of the folder properties, click on Advanced Sharing):
o

Select the account Everyone and give it “Full control” access rights. If you prefer a more
granular setup, you can add the individual client user accounts and grant “Full control”
access rights to each of them.
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o



Give the user account used to run the Déjà Vu X2 COM+ Server “Full control” access rights:

Security (in the Security tab of the folder properties):
o

Select the account Everyone and give it “Full control” access rights. If you prefer a more
granular setup, you can add the individual client user accounts and grant “Full control”
access rights to each of them.

o

Give the user account used to run the Déjà Vu X2 COM+ Server “Full control” access rights.

Setting up COM Security
Set the COM+ permissions on the server so that clients can access the shared databases using the Déjà Vu
X2 COM+ Server application:


Go to Administrative Tools>Component Services and then to Console Root>Component
Services>Computers, right click on My Computer and select the Properties menu option. Go to the
COM Security tab and add the following permissions under Launch and activation permissions>Edit
Limits:
o

For the Everyone account set: Remote activation, Remote launch (if you prefer a more
granular setup, you can add the client user accounts individually and set the necessary
permissions for each).
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Installation and configuration of the Déjà Vu X2 COM+ Server component
Install the Déjà Vu X2 COM+ Server component. The Déjà Vu X2 COM+ Server component is downloadable
from http://www.atril.com/__demos/Setup.COM+.exe.
By default, the installer configures the Déjà Vu X2 COM+ Server component to be run by the Network
Service account. If the server and the client computers are not part of an AD Domain this will not work, since
the client computers will net recognize the Network Service account of the server as a valid user. Therefore,
you must configure the Déjà Vu X2 COM+ Server to be run by a different user account. To do so on the
server:
1. Open the Component Services window.
2. Access Console Root>Component Services>Computers>My Computer>COM+ Applications.
3. Right-click on the Déjà Vu X2 COM+ Server application and select Properties.
4. Select the Identity tab.
5. Check the This user: checkbox.
6. Type the name and the password of the user account that should run the Déjà Vu X2 COM+ Server:

7. Click on OK.
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Installing and configuring the Client:
You can install the client application, Déjà Vu X2, on the client computers using the installer for the latest
version, available from our website: http://www.atril.com/__demos/Setup.exe
After the application is installed you must set COM Security permissions in each client computer so the
server can call-back the Déjà Vu X2 Workgroup clients.

If the computers are in a Domain
To set the COM Security permissions:


Go to Administrative tools>Component services, and then to Console Root>Component
Services>Computers, right click on My Computer and select the Properties menu option. Go to the
COM Security tab and add the following permissions under Access Permissions>Edit Default:
o

For the server (specify the machine name of the server where the Déjà Vu X2 COM+ Server
is installed, e.g. COMPLUS$): Remote access. (When specifying the account for which to
set the permissions, you may need to click on Object Types and check the Computers entry
in order to be able to enter a machine name.)

If the computers are in a Workgroup
Deactivate Simple File Sharing
Window’s Simple File Sharing feature prevents windows from transmitting user credentials when attempting
to read from or write to a shared location, which makes it impossible for the sort of authentication required by
Déjà Vu X2 and the COM+ Server to work. Therefore it is necessary to deactivate this in all the computers
that will be involved in the sharing of databases, that is, the server where shared databases are stored, and
the computers running Déjà Vu X2.
To deactivate Simple File Sharing on the client computer:
1. Click the Start button.
2. Select Control Panel.
a. In Windows Server 2003, select Appearance and Themes.
b. In Windows Server 2008 and above, select Appearance and Personalization.
3. Select Folder Options.
4. Select the View tab.
5. Scroll to the bottom of the Advanced settings: list.
c. In Windows Server 2003, clear the Use simple file sharing (Recommended) check box.
d. In Windows Server 2008 and above, clear the Use Sharing Wizard (Recommended) check
box.
6. Click OK.
7. Close all windows.

Configuring COM Security permissions
To set the COM Security permissions:


Go to Administrative tools>Component services, and then to Console Root>Component
Services>Computers, right click on My Computer and select the Properties menu option. Go to the
COM Security tab and add the following permissions under Access Permissions>Edit Default:
o

Add the user account that is being used to run the Déjà Vu X2 COM+ Server on the server
computer. If this account does not exist on the client you must create following the
instructions in the section Setting up the user accounts. For this account enable: Remote
access.

Now the client computers should be able to work with Déjà Vu X2 Workgroup sharing Translation Memories
and Termbases (not projects) using the Déjà Vu X2 COM+ Server component installed on the server.
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